AutoIt: Einleitung: Einstieg

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Was wird benötigt?[Bearbeiten]

Der Compiler[Bearbeiten]

Angefangen hatte die Programmierung mit Assembler. Sie gilt offiziell als erste Programmiersprache. Auf Grundlage dessen wurden immer neuere Programmiersprachen entwickelt dessen Syntax viel einfacher für den Menschen zu lesen ist. Jedoch versteht der Computer diese für uns verständliche Sprache nicht. Glücklicherweise existiert für diesen eine eigene Sprache, die Maschinensprache. Die Maschinensprache ist jedoch, für uns Menschen, sehr schwierig zu lesen und das Programmieren in dieser ist sehr aufwendig. Aus diesem Grund wurden die Compiler ins Leben gerufen. Sie übersetzen unseren Quelltext in die Maschinensprache. Jede Programmiersprache muss demnach einen Compiler besitzen damit der geschriebene Code auch für den Computer lesbar wird.

Die Entwicklungsumgebung[Bearbeiten]

Da sich der Quelltext nicht von alleine schreibt wird auch ein Editor benötigt. Jeder beliebige ASCII Editor kann genutzt werden um einen Programmcode zu verfassen. Jedoch kann dies bei größeren Projekten nach einiger Zeit sehr unübersichtlich werden. Aus diesem Grund wurden spezielle Editors für ein oder mehrere Programmiersprachen geschrieben. Diese beinhalten meist praktische Features wie Syntax Highlights und Codevervollständigungen. Diese Editors nennt man in der EDV Integrierte Entwicklungsumgebung oder kurz einfach nur IDE. Diese sind zwar nicht zwingend notwendig um Programme zu entwickeln, es wäre aber definitiv von Vorteil. Deswegen liefern viele Entwickler zu ihrem Compiler auch gleich eine passende IDE mit.

Speziell für AutoIt[Bearbeiten]

Für AutoIt gibt es ein Softwarepaket welches eine abgespeckte Version der SciTE (die IDE für AutoIt) sowie den Compiler beinhaltet. Darüber hinaus existiert eine erweiterte SciTE. Es wird empfohlen die erweiterte SciTE ebenfalls zu installieren, da stetig aktuelle Updates für diese veröffentlicht werden. Beide können auf der offiziellen AutoIt Website heruntergeladen werden:

  1. Softwarepaket
  2. Erweiterte SciTE

Die SciTE[Bearbeiten]

Eine neue Datei anlegen[Bearbeiten]

In AutoIt wird der Quelltext auch Skript genannt. Ein Skript besitzt die Dateiendung *.au3. Es gibt nun verschiedene Möglichkeiten eine neue Skript Datei anzulegen. Eine Möglichkeit ist es, die SciTE zu öffnet und unter dem Menüeintrag [File => New] eine neue Datei zu öffnen. Danach kann diese Datei mit [File => Save] abgespeichert werden. Eine weitere Möglichkeit ist es auch diese über das Kontextmenü zu erstellen. Dafür wird in einem Ordner die rechte Maustaste gedrückt und dann der Eintrag [Neu => AutoIt v3 Script] ausgewählt.

Eine Skript Datei bearbeiten[Bearbeiten]

Sofern bei der Installation die Standardeinstellungen nicht verändert wurden öffnet ein Doppelklick eine Skript Datei nicht. In diesem Fall kann die Datei über die SciTE [File => Open...] oder über das Kontextmenü (dazu ein Rechtsklick auf die Datei machen) mit dem Eintrag [Edit Script] geöffnet werden.

Eine Skript Datei ausführen[Bearbeiten]

Um die Skript Datei auszuführen (um beispielsweise das geschriebene Programm zu testen) kann in der SciTE die Taste [F5] gedrückt werden. Alternativ lässt sich dies auch über den Menüeintrag [Tools => Go] erreichen. Weiter besteht die Möglichkeit, die Datei über das Kontextmenü mit dem Eintrag [Run Script] zu starten. Sofern bei der Installation die Einstellungen nicht verändert wurden reicht jedoch ein Doppelklick auf die Datei aus.

Einstellungen ändern[Bearbeiten]

Unter dem Menüeintrag [Tools => SciTE Config] oder mit dem Tastenkürzel [Strg + 1] lassen sich die Einstellungen für die SciTE verändern. Im Tab [General 1] kann auch das Verhalten bei einem Doppelklick auf eine Skript Datei verändert werden. Ist diese unter [Explorer .au3 File Setting] auf [Edit] gestellt, so öffnet sich die Skript Datei in der SciTE. Bei der Einstellung [Run] hingegen wird diese ausgeführt.

Hello World[Bearbeiten]

Traditionell wird für den Einstieg in eine Programmiersprache ein sogenanntes „Hello World“ Programm geschrieben. Dieses Programm öffnet nur ein kleines Fenster mit dem Schriftzug „Hello World“. In AutoIt lässt sich diese Aufgabe in nur einer einzigen Zeile bewältigen:

MsgBox(0, '', 'Hello World')

Bei „MsgBox“ handelt es sich lediglich um eine Funktion. Ähnlich wie in der Mathematik können an die Funktion Parameter (oder Werte) übergeben werden. Mithilfe der Parameter lässt sich das Verhalten und/oder das Aussehen des Fensters beeinflussen. Die Bezeichnung „MsgBox“ steht für den AUfruf der Funktion „Message Box“ und bekommt als Parameter <Flag zum Bestimmen der Tasten>, <Überschrift>, <Nachrichtentext>.