Blender Dokumentation: Referenz: Weight Paint Mode

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Referenz: Mesh Menü
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Metaobjekte


Diese Seite bezieht sich auf Blender vpre2.43

Der Weight Paint-Modus dient zum Erstellen und Bearbeiten von Vertex-Gruppen. Dabei kann ein Vertex nicht nur Mitglied in einer oder mehreren Gruppen sein, sondern innerhalb einer Gruppe unterschiedliches Gewicht - also unterschiedlichen Einfluss auf das Ergebnis - haben.

Abbildung 1: Auswahl des Weight Paint-Modus.

Vertexgruppen werden zu folgenden Zwecken eingesetzt:

  • zur Gruppierung von Vertices beim Modellieren, bspw. um eine Auswahl zu speichern.
  • um den Softbody-Effect einzuschränken.
  • um Partikel-Emission einzuschränken.
  • um die Zuordnung Mesh->Bone festzulegen, also welche Teile des Meshes von welchem Bone bewegt werden.

Sie erreichen den Weight Paint Modus aus dem Objekt-Modus eines Mesh-Objektes mit Strg-Tab oder über das Mode-Menü in der Werkzeugleiste des 3D-Fensters (Abbildung 1).

Abbildung 2: Ein Objekt im Weight Paint-Modus.

Im Weight Paint-Modus werden die Objekte - wenn noch keine Gruppe mit Weights erstellt wurde - in einer blauen Farbe dargestellt (Abbildung 2). Die Farbe visualisiert das Weight jedes Vertex der aktuell aktiven Gruppe. Ein Vertex in Blau kann also entweder mit einem Weight von "0" zur aktiven Gruppe gehören, zu einer anderen Gruppe gehören, oder noch keiner Gruppe zugeordnet sein.

Sie weisen den Weight jedes Vertex nun durch Bemalen mit einer Farbe zu. Gehört ein Vertex noch nicht zur aktuellen Gruppe, wird er automatisch zur Gruppe hinzugefügt, auch wenn Sie ihn mit einem Weight von "0" bemalen. Die Zuordnung von Farbe und Gewicht ist in Abbildung 3 dargestellt.

Abbildung 3: Das den Weights entsprechende Farbspektrum.

Im Weight Paint-Modus malen Sie auf das Objekt so wie mit einem Pinsel. Die Farbe beeinflusst nur die Vertices, wenn Sie versuchen eine Fläche oder eine Kante zu bemalen, hat das keinen Effekt. Für den Pinsel gibt es ein eigenes Werkzeug-Panel in den Editing-Buttons.

Blender3D FreeTip.gif

Überlebenswichtige Tips fürs Weight-Painting:

  • Drücken Sie F im Weight Paint-Modus um den Select-Modus zu aktivieren. Hier können Sie zu bemalende Flächen auswählen und Vertices und Faces wie im Edit-Modus verstecken.
  • Im Weight Paint-Modus können Sie mit Alt-B einen Clipping Border aufziehen. Damit legen Sie den sichtbaren Ausschnitt des 3D-Fensters fest, und nur in diesem kann gemalt werden. Erneutes drücken von Alt-B schaltet den Clipping Border wieder aus.
  • Stellen Sie Soft auf dem Paint-Panel aus. Mit Soft erreichen Sie den gewünschten Zielwert erst nach mehrmaligem Übermalen. Insbesondere das Übermalen mit dem Wert "0" ist dadurch fast unmöglich.



Paint-Panel[Bearbeiten]

Abbildung 4: Das Paint-Panel in den Editing-Buttons.

Sie können Weight in den feinsten Nuancen auftragen. Normalerweise braucht man das allerdings gar nicht, denn oft kommt man mit nur wenigen Weight-Abstufungen aus: 0, 1/4, 1/2, 3/4, 1.

Die Werkzeuge auf dem Paint-Panel sind sehr ausgefeilt. Die am häufigsten gebrauchten Einstellungen sind in Fettdruck hervorgehoben:

  • Weight: Das ist der jeweilige Weight mit dem gemalt werden soll. Die Button-Reihe darunter stellt fünf feste Werte für die schnelle Auswahl zur Verfügung. Um Farbe aufzutragen, müssen Sie klicken, die LMT festhalten und die Maus bewegen. Um erneut Farbe auf die gleichen Vertices aufzutragen, müssen Sie erneut klicken.
  • Opacity: Mit dem Opacity-Regler und den zugehörigen Buttons stellen Sie die Deckkraft des Pinsels ein.
  • Size: Die Größe des Pinsels in Pixeln.
  • Spray: Normalerweise müssen Sie zum mehrmaligen Farbauftrag mehrmals mit der linken Maustaste klicken. Leider funktioniert Spray nicht wie eine normale Sprühdose, Sie müssen die Maus immer noch mehrmals über dem Vertex bewegen.
  • Mix/Add/...: Die Auftragungsmodi für den Weight. Die meisten Modi dürften selbsterklärend sein.
    • Mix: Ersetzt den alten Wert. Das ist die Standardeinstellung.
    • Filter: Ich habe keine Ahnung, Ergänzungen sind sehr erwünscht.
  • All faces: Mit dieser Einstellung malen Sie tatsächlich mit dem gesamten angezeigten Pinselradius. Ist das aus, bemalen Sie nur Vertices, auf deren zugehörigen Flächen sich der Cursor befindet. Bei verwinkelten Meshes kann es sinnvoll sein, diese Option auszustellen. Sonst werden u.U. Vertices bemalt, die zwar in Blickrichtung nahe nebeneinander liegen, im Mesh aber weit voneinander entfernt sind.
  • Vertex Dist: Mit Vertex Dist bemalen Sie nur Vertices, die sich tatsächlich unter dem Pinsel befinden. Ist die Option aus, bemalen Sie alle Vertices die zu einer vom Pinsel berührten Fläche gehören, auch wenn keiner der Vertices tatsächlich unter dem Pinsel ist. Das kann in dichten Meshes mit vielen Vertices Sinn machen. In dünnen Meshes mit Surbsurfing werden Sie diese Option nicht ausschalten wollen.
Abbildung 5: Ein Pinsel mit der Option Soft.
  • Soft: Der aufgetragene Weight hängt vom Abstand zur Mitte des Pinsels ab, daher erreichen Sie den eingestellten Zielwert erst durch mehrmaliges Übermalen, oder durch Malen mit dem Zentrum des Pinsels. Wollen Sie mit dem Weight "0.000" malen - was insbesondere beim Skinning unabdingbar ist - ist das mit der Option Soft kaum zu erreichen. Stellen Sie Soft daher in der Regel aus.
  • Normals: Waagerecht zur Ansicht stehende Vertices werden stärker bemalt, als senkrecht stehende.
  • Vgroup: Es werden nur Vertices bemalt, die bereits zur bestehenden Vertexgruppe gehören. Sie können also zunächst schnell Vertexgruppen erstellen, und die Feinarbeit mit Weight-Painting erledigen.
  • X-mirror: Dies ist beim Skinning interessant. Haben Sie ihre Bones nach der Links/Rechts-Konvention benannt und das Mesh ist symmetrisch, erstellt Blender automatisch für den gespiegelten Bone die gespiegelte Vertexgruppe mit dem entsprechenden Weight. Sie müssen bei einem symmetrischen Modell die Vertexgruppen nur auf einer Seite erstellen. Gibt es keine symmetrische Gruppe, wird symmetrisch in der gleichen Gruppe gemalt.
  • Wire: Zeigt den Wireframe des Objektes zusätzlich an. Beim Subsurfacing wird aber zuviel angezeigt, bei dichten Meshes zu wenig. Benutzen Sie besser den Select-Modus (siehe unten).
  • Clear: Entfernt alle Vertices aus der aktiven Vertexgruppe. Sonst müssten Sie erst in den Edit-Modus wechseln, alle Vertices der Gruppe auswählen, auf Remove klicken und wieder zurück in den Weight Paint-Modus wechseln.

Werkzeuge[Bearbeiten]

Insbesondere bei etwas komplizierteren Meshes ist es fast unmöglich, verwinkelte Stellen zu erreichen, und nur die gewünschten Vertices zu bemalen. Auch ist es manchmal schwer zu beurteilen, wo die Vertices eigentlich sitzen. Aber mit dem Select-Modus wird das ganz einfach.

Abbildung 6: Select-Menü im Weight Painting-Modus.
  • Drücken Sie F im 3D-Fenster. Sie befinden sich nun im Select-Modus (Abbildung 6).

Der Select-Modus hat viele Vorteile, die das Weight Painting sehr erleichtern.

  1. Es wird das Originalmesh angezeigt, auch wenn SubSurfacing aktiv ist. Die zu bemalenden Vertices sind erkennbar. Um den Weight auch im Select-Modus erkennen zu können, müssen Vertexfarben vorhanden sein (Editing Buttons->Mesh Panel->VertCol->Make).
  2. Nur auf ausgewählten Flächen wird gemalt.
  3. Sie können auwählen:
    • RMT: einzelne Flächen
    • A: alle Flächen
    • Alt-B: Blockauswahl
    • B-B: Auswählen durch aufmalen
    • Strg-L: Verlinkte Flächen
    • Im Select-Menü: Flächen mit gleichem UV, außerdem die Auswahl umkehren.
  4. Sie können ausgewählte Flächen mit H verstecken, mit Alt-H wieder sichtbar machen (Abbildung 7).


Abbildung 7a: Störende Flächen ausgewählt...
Abbildung 7b: ... und mit H unsichtbar gemacht.

Eine weitere Möglichkeit den zu bearbeitenden Bereich einzuschränken ist der Clipping Border.

  • Drücken Sie Alt-B und ziehen Sie mit der Maus einen rechteckigen Bereich auf. Alles andere im 3D-Fenster wird dann ausgeblendet.

Allerdings werden auch Vertices bemalt, die an nur teilweise sichtbaren Flächen beteiligt sind. Das kann dazu führen, dass Sie am Rand unsichtbare Vertices bemalen.

Abbildung 8: Anzeige der Gruppen, zu denen ein Vertex gehört.
  • Mit Shift-LMT werden alle Gruppen angezeigt, denen die Vertices einer Fläche angehören. Sie können in dem erscheinenden Pop-UP Menü zwischen den Gruppen wechseln (Abbildung 8).


Abbildung 9: Weight Paint Properties Panel im 3D-Fenster.
  • Im 3D-Fenster können Sie das Weight Paint Properties Panel mit N anzeigen lassen, müssen dann also zur Auswahl des Weights nicht immer in die Editing Buttons wechseln.



Skripte im Paint-Menü[Bearbeiten]

  • Weight Gradient: Erstellt einen weichen Verlauf zwischen zwei Gebieten mit unterschiedlichem (oder gleichem) Weight (Abbildung 3). Bemalen Sie erst die Endpunkte mit dem gewünschten Weight, aktivieren dann das Script und klicken zunächst um den Anfangspunkt zu setzen, dann den Endpunkt.
  • Scale Weight: Erhöht/verringert den Weight der schwersten Vertices auf einen einstellbaren Wert. Alle übrigen Vertices werden entsprechend mitskaliert, Vertices mit einem Weight von "0" behalten diesen natürlich. Dabei wird der Weight von Vertices in mehreren Gruppen berücksichtigt, der relative Abstand der Gruppen zueinander behalten.
  • Grow/Shrink Weight: Vergrößert/Verkleinert den Bereich der gepainteten Vertices (wie beim Auslaufen von Farben).
  • Clean Weight: Entfernt alle Vertices, die weniger als einen bestimmten Weight-Wert haben, aus der aktiven Gruppe. Wenn sich die Vertices nur in einer Gruppe befinden, können sie optional in der einen Gruppe belassen werden.

Weight-Painting für Bones[Bearbeiten]

Dies ist vermutlich die am häufigsten gebrauchte Anwendung des Weight-Painting.

  • Wenn Sie ein Objekt durch eine Armature verformen lassen wollen, und den entsprechenden Armature Deform-Modifier erstellt haben, bringen Sie die Armature in den Pose-Modus.
  • Wählen Sie nun das Objekt aus und wechseln in den Weight Paint-Modus.
  • Mit RMT wählen Sie einen Bone aus.
  • Wenn Sie nun auf dem Mesh malen, wird automatisch eine Vertexgruppe für den Bone erstellt, und die bemalten Vertices dort eingetragen.
  • Haben Sie ein symmetrisches Mesh und eine symmetrische Armature, können Sie die Option X-Mirror benutzen, um automatisch die spiegelsymmetrischen Gruppen erstellen zu lassen.

Um zwischen zwei Bones zu überblenden, bemalen Sie einfach die Vertices am Gelenk mit jeweils vollem Gewicht beider Bones. Blender verrechnet dann das Gewicht beider Gruppen. Häufig genügt es, wenn Sie mit vollem oder mit einem Gewicht von "0" malen.

Links[Bearbeiten]

Die englischsprachige Vorlage dieses Textes.

<<<Zurück

Referenz: Mesh Menü

Inhaltsverzeichnis
Glossar
Weiter>>>

Metaobjekte