Blender Dokumentation: UV-Editor und Face Select 2.37a

Aus Wikibooks
Zur Navigation springen Zur Suche springen
<<<Zurück
Solide und hohle Glasgegenstände
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Suzanne mit UV-Mapping


Diese Seite bezieht sich auf
Blender v2.37a
Von dieser Seite gibt es eine
aktuellere Version

UV-Mapping ist eine Möglichkeit, zweidimensionale Bildtexturen auf dreidimensionale Modelle zu projizieren. Es kann benutzt werden um Texturen auf willkürliche und komplexe Formen wie menschliche Köpfe oder Tiere anzuwenden. Diese Texturen sind oft gemalte Bilder, die mit Programmen wie Gimp, Photoshop oder Ihrem bevorzugten Bildbearbeitungsprogramm erstellt wurden.

Prozedurale Texturen, wie sie in den vorigen Kapiteln vorgestellt wurden, sind eine schöne Möglichkeit um ein Modell zu texturieren. Das beste daran ist dass sie immer 'passen'. Zweidimensionale Bilder werden nicht immer auf dreidimensionale Formen passen. Prozedurale Texturen zu erzeugen ist relativ einfach und sie sind ein schneller Weg zu guten Ergebnissen.

Es gibt aber auch Fälle in denen diese Art von Textur nicht gut genug ist. Die Haut auf einem menschlichen Kopf zum Beispiel wird nie genau richtig aussehen wenn sie prozedural generiert wird. Falten an einem Kopf oder Kratzer an einem Auto erscheinen nicht an zufälligen Stellen sondern hängen von der Form des Modelles und seiner Verwendung ab. Von Hand gemalte Bilder geben dem Künstler die völlige Kontrolle über das Endergebnis. Anstatt mit ein paar numerischen Schiebereglern herumzuprobieren können Künstler jeden Punkt auf der Oberfläche kontrollieren. Das bedeutet mehr Arbeit, führt aber am Ende zu besseren Bildern.

Eine UV-Map wird benutzt um einem Polygon in einem Modell einen Teil eines Bildes zuzuweisen. Jede Vertex eines Polygons bekommt zweidimensionale Koordinaten zugewiesen, die bestimmen welcher Teil des Bildes für das Polygon verwendet wird. Diese zweidimensionalen Koordinaten heißen UV-Vertices oder kurz UVs (vgl. XYZ Koordinaten in 3D). Der Vorgang zum Erstellen der UV-Map heißt 'unwrap' (auseinanderfalten), da es einem Auseinanderfalten des Meshes auf eine zweidimensionale Fläche entspricht.

Blender3D FreeTip.gif

UV-Mapping ist auch sehr wichtig für Blenders Game Engine oder jedes andere Spiel. Es ist der de facto Standard um einem Modell Texturen zuzuweisen; fast jedes Modell, das man in Spielen findet, benutzt UV-Texturen.


Der UV-Editor[Bearbeiten]

UV-Mapping wird in Blender mit dem UV-Editor-Fenster und einem speziellen Modus im 3D-Fenster ausgeführt, der Face Select Mode [Flächenauswahlmodus] genannt wird. Der UV-Editor erlaubt Ihnen Texturen direkt auf die Faces eines Meshes zu projizieren.

Jedes Face kann individuelle Texturkoordinaten und ein individuelles Bild erhalten und kann auch mit Vertexfarben kombiniert werden, um die Textur heller oder dunkler zu machen oder ihr eine Farbe zu geben.

Mit dem UV-Editor werden jedem Face des Meshs zwei weitere Eigenschaften hinzugefügt:

  • Vier UV Koordinaten - Diese Koordinaten definieren wie ein Bild oder eine Textur auf das Face projiziert wird. Es sind zweidimensionale Koordinaten, deshalb werden sie UV genannt, um sie von den XYZ Koordinaten zu unterscheiden.
  • Eine Verknüpfung zu einem Bild - Jedes Face in Blender kann eine Verknüpfung zu einem anderen Bild haben. Die UV-Koordinaten definieren wie dieses Bild auf das Face projiziert wird. Dieses Bild kann gerendert oder in Echtzeit angezeigt werden.

Ein 3D-Fenster muss im Face Select Mode sein, um dem aktiven Meshobjekt Bilder zuweisen oder UV-Koordinaten ändern zu können.

Abbildung 1: Der Flächenauswahlmodus im Menübutton in der Titelleiste des 3D Fensters

Fügen Sie zuerst ein Meshobjekt in Ihre Szene ein und wechseln Sie dann in den Flächenauswahlmodus indem Sie UV Face Select in Modusmenü auswählen (Abbildung 1) oder F drücken.

Ihr Mesh wird jetzt mit Hilfe des Z-Buffers dargestellt. Wenn Sie in die texturierte Ansicht umschalten (Alt Z, wird auch potato mode genannt) werden Sie Ihr Mesh in weiß dargestellt sehen, da diesen Faces im Moment noch keine Bilder zugewiesen sind. Sie können die Art der Darstellung der Faces mit den Draw Edges [Kanten zeichnen] und Draw Faces [Flächen zeichnen] Buttons im UV Calculation Panel im Editing Kontext (F9) beeinflussen. Wenn Draw Edges aktiv ist werden alle Faces umrahmt dargestellt. Wenn Draw Faces aktiv ist werden ausgewählte Faces mit einem leichten Pinkstich dargestellt.

Wenn Sie A drücken werden alle Faces des Meshs ausgewählt und von gestrichelten Linien umgeben. Sie können Faces mit RMT oder der Rahmenauswahl (B) im 3D Fenster auswählen. Wenn Sie Probleme haben die gewünschten Faces auszuwählen können Sie auch direkt aus dem Face Select Mode in den Edit Mode wechseln und dort mit den bekannten Methoden die gewünschten Faces auswählen. Sobald Sie den Edit Mode verlassen sollten die Faces ausgewählt sein die auch dort ausgewählt waren.

Blender3D FreeNote.gif

Die Auswahl im Edit Mode wird nur mit der Auswahl im Face Select Mode synchronisiert, wenn Sie im zuletzt genannten Tab drücken und so in den Edit Mode wechseln, sonst nicht. Durch diese Synchronisierung wird Ihre Auswahl im Edit Mode durch die Auswahl überschrieben, die der Face Select Mode vorgibt.


Nur ein Face ist aktiv. Oder mit anderen Worten: Das Bildfenster (Image Window) zeigt nur das Bild des aktiven Face. Wie in Blender üblich wird mit RMT ausgewählt und das zuletzt ausgewählte Face ist das aktive.

Abbildung 2: 3D-Fenster und UV-Editor/Bildfenster

Ändern Sie ein Fenster zum UV-Editor/Bildfenster indem Sie Shift F10 drücken. Hier können Sie Bilder laden (Image>>Open), die schon geladenen Bilder durchsuchen und noch vieles mehr.

Wenn ein Bild im Face Select Mode geladen wird oder Sie ein schon geladenes aus der Liste auswählen bekommen automatisch alle ausgewählten Faces dieses Bild zugewiesen. Sie können das sofort im 3D-Fenster sehen wenn Sie in der texturierten Ansicht sind.


Unwrapping Werkzeuge[Bearbeiten]

Im 3D Fenster können Sie im Face Select Mode U drücken, dadurch wird ein Menü angezeigt mit dem Sie UV-Koordinaten für die ausgewählten Flächen berechnen können (Abbildung 3). Dieser Vorgang heißt unwrap [auseinanderfalten] da das Mesh dafür intern auf eine zweidimensionale Fläche auseinandergefaltet wird. Sie können den unwrap Vorgang auch vom UV Calculation Panel in den Edit Buttons starten. Dieses Panel bietet auch bessere Kontrolle über die Entfaltung.

Abbildung 3: Das UV-Berechnungsmenü

Die verfügbaren UV Mapping Optionen sind:

  • Cube - kubisches Mapping
  • Cylinder, Sphere - zylindrisches/kugelförmiges Mapping, vom Mittelpunkt der ausgewählten Faces aus berechnet
  • Bounds to 1/8, 1/4, 1/2, 1/1 - UV-Koordinaten werden orthogonal aus der Richtung berechnet, die vom aktuellen 3D-Fenster vorgegeben wird, und dann auf die gewünschte Bildfläche skaliert.
  • Standard 1/8, 1/4, 1/2, 1/1 - Jedes Face erhält die standardmäßigen quadratischen UV-Koordinaten, die dann auf die gewünschte Größe skaliert werden.
  • From Window - UV-Koordinaten werden so wie im aktuellen 3D-Fenster dargestellt berechnet.
  • LSCM - UV-Koordinaten werden mit der LSCM Methode berechnet. Sie sollten diese Methode zusammen mit markierten Schnittkanten verwenden. Weitere Erklärungen zu LSCM folgen später in diesem Kapitel.
Blender3D FreeNote.gif

Wenn Sie Bounds oder Window aus dem UV Calculation Panel aufrufen ändert Blender den Cursor zu einen Pfeil mit Fragezeichen. Damit müssen Sie in das 3D-Fenster klicken welches Blender als Ausgangspunkt für die Projektion verwenden soll. Wenn Sie diese Methoden aus dem UV Calculation Menü aufrufen verwendet Blender automatisch das aktuelle Fenster.


Im UV Calculation Panel (Abbildung 4) können Sie die Einstellungen für das Mapping und die Darstellung des Meshs im Face Select Mode verändern.

Wenn View Aligns Face [Ansicht von vorne] aktiv ist werden Cylindrical und Spherical von der aktuellen Ansicht beeinflusst. Blender geht dann davon aus dass der Zylinder bzw. die Kugel von vorne sichtbar ist und die Pole in der Ansicht oben und unter sind. Der Zylinder/die Kugel wird dann auf der gegenüberliegenden Seite 'aufgeschnitten'.

Size oder Radius definieren jeweils die Größe der UV-Map, wenn Sie Cube oder Cylinder verwenden.

Abbildung 4: Das UV Calculation Panel

Wenn VA Top (View Aligns Top [Ansicht von oben]) aktiv ist geht Blender davon aus dass die aktuelle Ansicht von oben auf das Objekt schaut. Der Schnitt ist dann fast der selbe wie bei View Aligns Face von vorne. Polar ZX und Polar ZY bewirken in diesem Modus noch eine zusätzliche Drehung der Koordinaten.

Wenn Al Obj aktiv ist hängt die UV-Map von der Drehung des Objekts ab.

Draw Edges und Draw Faces aktivieren die Darstellung von Edges und Faces im 3D Fenster während das Mesh im Face Select Mode ist. Ausgewählte Faces werden dann mit einem transparenten Pink (oder der Farbe des Themas) dargestellt, ähnlich wie im Edit Mode. Die Darstellung der Schnittkanten in Edit Mode und Face Select Mode kann mit Draw Seams an- oder abgeschaltet werden. Auch die Farbe der Schnittkanten kann in den Themenoptionen eingestellt werden.


UV-Koordinaten bearbeiten[Bearbeiten]

Im UV-Editor sehen Sie die ausgewählten Faces, repräsentiert durch gelbe oder violette Punkte die durch gestrichelte Linien verbunden sind. Sie können hier die selben Techniken wie im Edit Mode verwenden, also auswählen, bewegen, drehen, skalieren und so weiter. Wenn das Schloss in der Titelleiste eingeschnappt ist werden Sie Ihre Änderungen auch in Echtzeit im 3D-Fenster sehen können. Skalieren und verschieben kann auch auf die X oder Y Achse beschränkt werden, indem Sie X bzw. Y drücken oder auch MMT klicken. Auch das Proportional Editing Tool ist verfügbar und funktioniert so wie bei Meshes im Edit Mode. Vertices im UV-Editor können mit H versteckt und mit Alt H wieder sichtbar gemacht werden, genau wie im Edit Mode.

Es gibt mehrere Auswahlmodi für den UV-Editor. Da ein Vertex im UV-Editor einmal für jedes Face gezeichnet wird, zu der er gehört, ist es manchmal schwer zu sagen ob man den selben Vertex auswählt oder nicht.

Wenn Stick UVs to Mesh Vertex (im Select Menü) aktiv ist, wird RMT nicht nur einen UV-Vertex auswählen, sondern auch alle anderen die zum selben Mesh Vertex gehören. Sie können diesen Modus auch verwenden, wenn er nicht im Menü aktiviert ist, indem Sie Strg gedrückt halten während Sie einen Vertex auswählen.

Stick Local UVs to Mesh Vertex arbeitet auf die gleiche Weise, allerdings werden nur Vertices ausgewählt, die 'verbunden' sind, das heißt dass sie maximal fünf Pixel von dem zuerst ausgewählten Vertex entfernt sein dürfen. Sie können diesen Modus auch verwenden, wenn er nicht im Menü aktiviert ist, indem Sie Shift gedrückt halten während Sie einen Vertex auswählen.

Diese beiden Optionen können mit Strg C bzw. Shift C an- und ausgeschaltet werden.

Wenn Active Face Select aktiv ist wird durch RMT ein Face ausgewählt und als aktiv definiert. Diese Option kann mit C an- und ausgeschaltet werden.

Für jede dieser drei Optionen wird ein spezielles Symbol links unten im UV-Editor angezeigt. Hinweis: Die beiden erstgenannten Optionen können mit der letztgenannten kombiniert werden, aber nicht miteinander.

Unlink Selection [Auswahl trennen] entfernt alle UV-Vertices aus der Auswahl die nicht zu ganz ausgewählten Faces gehören. Wie der Name andeutet ist das besonders nützlich um die Auswahl abzutrennen und irgendwohin zu bewegen. Diese Funktion wird mit Alt L aufgerufen.

Select Linked UVs [verbundene UVs auswählen] arbeitet ähnlich wie Select Linked in der 3D-Ansicht. Diese Funktion wählt alle Vertices aus die mit den derzeit ausgewählten 'verbunden' sind. Im Unterschied zur 3D-Ansicht sind Vertices im UV-Editor implizit verbunden, das heißt sie gelten als verbunden wenn sie höchstens fünf Pixel voneinander entfernt sind. Diese Funktion wird mit L aufgerufen.

Abbildung 5: Stitch und Limit Stitch

Verschiedene Teile einer UV-Karte können mit V vernäht werden wenn die UV-Vertices am Rand jeweils der selben Mesh Vertex entsprechen. Der Stitch Befehl kann auch unregelmäßige Kanten vernähen, wählen Sie einfach mit Stick UVs to Mesh Vertex die Vertices am Rand aus oder halten Sie beim Auswählen Strg gedrückt um auch die anderen übereinstimmenden Vertices auszuwählen.

Limit Stitch arbeitet auf die selbe Weise. Der Unterschied ist dass nur UVs vernäht werden die innerhalb eines bestimmten Radius liegen. Die maximale Entfernung ist standardmäßig 20 Pixel. Der Vorteil gegenüber Stitch ist in Abbildung 5 klar zu sehen: die UV-Map der Röhre wird nur da vernäht wo es sinnvoll ist.

Sie können mit dem Weld Befehl (W) auch UV-Vertices zusammenschweißen, die nicht dem selben Mesh Vertex entsprechen. Außerdem können Sie mit diesem Befehl die ausgewählten Vertices auf einer gemeinsamen Achse platzieren (Align X oder Align Y).


Abbildung 6: Menü im UV Editor

In der Titelleiste des UV Editors (Abbildung 6) geben die Menüs Zugang zu diesen und weiteren Funktionen.


Abbildung 7: Vertexfarben passen die Textur an

Einige Tips:

  • Drücken Sie R im 3D-Fenster, es erscheint ein Menü welches Ihnen erlaubt UV-Koordinaten zu drehen.
  • Manchmal ist es notwendig, Bilddateien auf der Festplatte zu verschieben. Danach können Sie die Option Replace... [ersetzen] verwenden um Blender mitzuteilen, wohin Sie das Bild verschoben haben. Blender ersetzt dann automatisch alle veralteten Vorkommen des Bildes (zum Beispiel in Materialien) durch die neue Version.
  • Sie können den Face Select Mode und Vertex Paint auch gleichzeitig verwenden. Dann können nur ausgewählte Faces angemalt werden. Diese Möglichkeit ist besonders nützlich um Faces anzumalen als ob sie keine Vertices teilen würden. Beachten Sie bitte das Vertexfarben verwendet werden um Helligkeit oder Farbe der Bilder anzupassen.


LSCM Unwrap[Bearbeiten]

LSCM ist die Abkürzung von Least Squares Conforming Map [kleinste quadratische passende Karte]. Das ist eine fortschrittliche mathematische Methode um automatisch eine UV-Map zu erstellen und dabei Texturverformungen so gering wie möglich zu halten. Das funktioniert indem die Winkel möglichst unverändert beibehalten werden. Genau wie bei jeder anderen UV-Unwrap-Methode werden die Faces im Face Select Mode auseinandergefaltet. Aufrufen können Sie die Methode entweder mit U und Klick auf LSCM oder indem Sie auf LSCM Unwrap im UV Calculation Panel klicken.

Um ein Mesh mit LSCM korrekt auseinanderfalten zu können müssen Sie sicherstellen dass Ihr Mesh mit wenig Deformationen geglättet werden kann (auf Mathematisch: es sollte einer Scheibe ähneln). Das geschieht indem Sie Schnittkanten [Seams] definieren, das heißt Stellen an denen das Mesh aufgeschnitten wird. Sie müssen keine Kanten setzen wenn das Mesh zu einer Ebene auseinandergefaltet werden kann.

Im Edit Mode können ausgewählte Kanten mit Strg E als Schnittkante definiert und wieder gelöscht werden.

Abbildung 7: Ein Würfel mit Schnittkanten und die UV-Map nach LSCM

Oft kann ein Mesh nicht als eine Gruppe entfaltet werden, sondern muss in mehrere Gruppen aufgeteilt werden. Diese werden von LSCM dann einzeln entfaltet und im UV-Editor so platziert dass sie sich nicht überschneiden. Um die Auswahl von Gruppen zu erleichtern verwenden Sie Select Linked (Strg L) im Face Select Mode, das wird alle Faces auswählen die nicht durch Schnittkanten vom aktiven Face getrennt sind. Auf diese Art können Sie eine Gruppe von Faces auswählen indem Sie ein Face dieser Gruppe wählen und Select Linked ausführen.

Um das Ergebnis weiter zu verbessern können UV-Vertices im UV-Editor an einer bestimmten Position festgepinnt werden. Wenn LSCM dann ausgeführt wird bleiben diese UV-Vertices an ihrem Platz und die neu erzeugte UV-Map wird sich an die festgepinnten UV-Vertices anpassen. Ausgewählte UV-Vertices können im UV-Editor mit P festgepinnt und mit Alt P wieder gelöst werden. Festgepinnte UV-Vertices werden rot dargestellt. Wenn Sie im UV-Editor E drücken wird LSCM nur für die sichtbaren Flächen ausgeführt, dadurch kann es aber zu Überlappungen kommen sodass Sie das Ergebnis wahrscheinlich manuell bearbeiten müssen.

Texture Paint[Bearbeiten]

Sobald Sie ein Bild im UV-Editor geladen haben können Sie es im Texture Paint Modus bearbeiten, das heißt Sie können das Bild in Blender anmalen. Im UV-Editor können Sie im View Menü View Paint Tool aufrufen, es erscheint dann ein Panel wo Sie die Größe [Size], die Deckkraft [A bzw. Opacity] und die Farbe des Pinsels einstellen können. Wenn Sie im 3D-Fenster zeichnen erscheint das Panel stattdessen im Editing Kontext. Im Moment gibt es nur einen Standardpinsel, aber die Bereitstellung weiterer Pinsel ist in Arbeit.

Blender3D FreeNote.gif

Auch wenn Blender nicht die Funktionalität einer Software wie Gimp anbietet hat diese Funktion doch einen Vorteil: Sie können die Textur direkt auf dem dreidimensionalen Mesh zeichnen und so zumindest eine gute Vorlage für die spätere Bearbeitung schaffen. Natürlich können Sie die Textur auch im UV-Editor anmalen. Beachten Sie dabei bitte dass Texture Paint für die 3D-Ansicht und für den UV-Editor separat angeschaltet werden muss, wobei Sie wiederum auch beide gleichzeitig eingeschaltet haben können.


Alle Änderungen werden sofort angezeigt, falls sich das Modell in der texturierten Ansicht befindet. Die bearbeitete Textur wird aber nicht gespeichert bis Sie Blender dazu auffordern. Verwenden Sie dazu das Image Menü im UV-Editor. Die Option Replace wird das Bild speichern und das Original ersetzen, die Option Save öffnet das bekannte 'Datei speichern' Fenster damit Sie die Datei unter einem anderen Namen speichern können.


Wenn Sie im UV-Editor zeichnen kann die Option Draw Shadow Mesh natürlich sehr hilfreich sein damit Sie wissen welchen Teil der Textur Sie gerade anmalen.

Rendern und UV-Koordinaten[Bearbeiten]

Sogar ohne den Flächen ein Bild zuzuweisen kann man Texturen unter Zuhilfenahme der UV-Koordinaten rendern. Dazu wid der UV Button im Panel Map Input in den MaterialButtons (F5) verwendet.

Wenn Sie auch die zugewiesene Bildtextur rendern wollen, benutzen Sie eine Image-Textur, deren Map Input auf UV gestellt wurde.

Alternativ können Sie den TexFace Button in den Materialeigenschaften aktivieren, um die UV-Textur zu rendern. Dann wird die UV-Textur auch im 3D-Fenster sichtbar. Kombinieren Sie das mit der VertexCol Option, um Vertexfarben zu verwenden.

Links[Bearbeiten]

Die englischsprachige Vorlage dieses Textes
What is UV-Mapping?

<<<Zurück

Solide und hohle Glasgegenstände

Inhaltsverzeichnis
Glossar
Weiter>>>

Suzanne mit UV-Mapping