Concrete5: Einführung: Installation/Aufrüsten: Systemvoraussetzungen

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Damit Concrete5 sauber auf dem System der Wahl läuft, sind folgende Voraussetzungen nötig:

  • PHP 5.1.x, mit folgenden eingebundenen Erweiterungen:
    • 'GD' Unterstützung (normalerweise enthalten) und die MySQL Erweiterung zu PHP (mysql_connect, etc...). Diese ist standardmäßig auch eingebunden.
    • 'SimpleXML' Unterstützung(normalerweise enthalten)
    • Suchindizierung durch 'Lucene' (ein optionales aber integriertes Feature) setzt voraus, dass die 'mbstring' Erweiterung korrekt in PHP und 'iconv' installiert ist.
  • Python 2.2 (wird nur bei Verwendung von HTMLDiff benötigt, das zum Vergleich verschiedener Seitenversionen verwendet wird.)
  • MySQL 4.1 oder höher.
  • Falls concrete5 in einer anderen Sprache als Englisch angezeigt werden soll, wird das 'gettext' Plugin benötigt.




Wikibooks buchseite.svg Zurück zu 'Installation/Aufrüsten' | One wikibook.svg Hoch zu 'Inhaltsverzeichnis' | Wikibooks buchseite.svg Vor zu 'Installation'