Java Enterprise: Einrichten der Entwicklungsumgebung

Aus Wikibooks
Zur Navigation springen Zur Suche springen
Nuvola apps bookcase 1.svg Die Enterprise Edition Gnome-mime-application-x-dvi.svg Einrichten der Entwicklungsumgebung

Eclipse und Glassfish[Bearbeiten]

Wie man Eclipse installiert, wird bereits hier beschrieben. Eclipse kann hier heruntergeladen werden. Empfohlen wird "Eclipse IDE for Java EE Developers".

Hier kann man den Glassfish Applikationsserver herunterladen. Nachdem der Glassfish Server installiert ist, können wir zur eigentlichen Einrichtung kommen. Nach dem Start von Eclipse wird der Welcome Screen angezeigt. Hier kann man auf "Go to the workbench" klicken um zur IDE zu gelangen.

Um Glassfish aus der IDE starten zu können und um JEE Projekte erstellen zu können, sollte das Glassfish Plugin installiert werden. Um es zu installieren, kommt man über "Help -> Install new Software" zum Install Dialog. In die Combobox trägt man die Download Site für das Plugin ein. Aktuell ist dies http://dlc.sun.com.edgesuite.net/glassfish/eclipse/helios/ (GlassFish Eclipse Update Site for the Helios release (Eclipse 3.6)). Wichtig ist, die Checkbox bei "Group Items by Category" zu deselektieren. Danach kann man die Checkbox "Oracle Glassfish Server Tools" aktivieren und zweimal mit "Next" bestätigen. Nach dem Bestätigen der Lizenzbestimmungen wird das Plugin installiert. Um die Installation abzuschliessen fordert Eclipse zu einem Neustart der IDE auf.

Glassfish einrichten[Bearbeiten]

Sollte die View "Servers" noch nicht geöffnet sein, kann man dies über "Window -> Show View -> Other" erreichen. In das obige Filter Textfeld kann man Server eingeben. Die View "Servers" erscheint nun im unteren Fenster. Über das Kontextmenü (mit der rechten Maustaste) und "New -> Server" gelangt man in den "New Server" Dialog. Wenn das Glassfish Plugin korrekt installiert ist, kann man "GlassFish Server Open Source Edition 3 (Java EE 6)" auswählen und den Dialog mit "Next" bestätigen. Im nächsten Dialog muss man die JRE und das Installationsverzeichnis des Glassfish Servers angeben. Hier sollte man ein JDK auswählen. Sollte keines verfügbar sein, kann man über den Klick auf "Installed JRE Preferences" eines hinzufügen. Das Verzeichnis des Glassfish Servers ist unter Windows standardmässig: C:\glassfishv3\glassfish. Im Folgenden Dialog wird man zur Eingabe des Administrator Passwortes aufgefordert (seltsamerweise nicht in ein Passwortfeld). Durch bestätigen mit "Next" gelant man zum "Add and Remove" Dialog. Dieser Dialog ist nach einer Neuinstallation leer, da noch keine JEE- oder WebProjekte verfügbar sind, die man dem Server hinzufügen könnte. Über Finish ist die Einrichtung des Glassfish Servers in Eclipse zunächst abgeschlossen.

In der Servers View sollte nun der eingerichtete Server sichtbar sein. Über das Kontextmenü kann man den Server starten. Eclipse wechselt während des Starts in die "Console - View" und wenn der Server fertig gestartet ist erscheint hier die Meldung "Befehl start-domain wurde erfolgreich ausgeführt." Um die Admin Konsole zu öffnen, wechselt man in die "Servers - View" und klickt im Kontextmenü "Glassfish -> View Admin Console". Im Standardfall wird die Adminkonsole im Eclipse eigenen Browser geöffnet. Sie ist aber in jedem anderen Browser auch über http://localhost:4848/ erreichbar. In der Konsole selbst kann man über die linke Navigationsleiste die verschiedenen Einstellungen betrachten oder verändern. Über den Klick auf "Enterprise Server" gelangt man zu einer Übersicht des Glassfish Application Servers. Hier finden sich allgemeine Informationen wie zum Beispiel das Konfigurationsverzeichnis oder die verwendeten Ports. Unter dem Menüpunkt "Applikationen" können fertige Enterprise Anwendungen auch über die Admin Konsole bereitgestellt werden. Der Menüpunkt Ressourcen lässt den Administrator die Verbindung zu einer Datenbank einstellen oder JNDI konfigurieren. Der Punkt "Konfiguration" beinhaltet die meisten Einstellungen wie zum Beispiel die JVM Optionen oder die EJB Container Einstellungen.

Glassfish konfigurieren[Bearbeiten]

JDBC Verbindungspool einrichten[Bearbeiten]

Ein JDBC Verbindungspool wird beispielsweise für die Java Persistence Api benötigt. Wenn der Applikationsserver diesen Dienst zur Verfügung stellt, fällt später die Konfiguration eines JPA Projektes leichter.

Um den Verbindungspool einrichten zu können benötigt der Glassfish Server den MySQL JDBC Treiber. Diesen kann man unter MySQL Connector J herunterladen. Entpacken Sie das Archiv und kopieren Sie die JAR Datei in das Glassfish Library Verzeichnis (C:\glassfishv3\glassfish\lib). Jetzt können Sie den Server starten und die Admin Konsole unter http://localhost:4848/ öffnen.

Abbildung 1: Konfigurationsansicht in der Glassfish Admin Konsole


Wählen Sie in der Admin Konsole auf der linken Seite im Baum den Punkt "Ressourcen" , danach den Unterpunkt "JDBC" und danach "JDBC Verbindungspools" aus. Nachfolgend wird die Erstellung beispielhaft für einen MySQL Verbindungspool erläutert. Klicken Sie auf der rechten Seite "Neu..." und tragen Sie für den Poolnamen "MySQL" ein. Für den Ressourcentyp wählen Sie aus der Combobox den Eintrag "javax.sql.ConnectionPoolDataSource" aus. Wählen Sie dann Ihren Datenbankhersteller (In unserem Fall MySQL). Um diesen Schritt abzuschliessen klicken Sie auf "Weiter".

Wenn der Glassfish Server den Treiber gefunden hat, ergänzt er automatisch den Klassennamen der Datenquelle mit "com.mysql.jdbc.jdbc2.optional.MysqlConnectionPoolDataSource".


Folgende Einträge müssen Sie nun vornehmen:

Feld Eintrag
DatabaseName test
User root
Password Passwort für MySQL
URL jdbc:mysql://localhost:3306/test
Url jdbc:mysql://localhost:3306/test
ServerName MySQLServer

Achtung: Es ist kein Schreibfehler, dass URL und Url vorhanden ist. Sie müssen beide Einträge vornehmen. Wenn Sie alle Einträge vorgenommen haben, können Sie auf "Speichern" klicken. Anschliessend können Sie einen Ping absetzen. Wenn dieser erfolgreich war, ist ihr JDBC Verbindungspool korrekt eingerichtet.

JDBC Ressource einrichten[Bearbeiten]

Damit die Datenbank auch im JNDI Directory zu finden ist, tragen wir sie dort ein. Ein Klick auf "JDBC"->"JDBC Ressourcen" listet Ihnen auf der rechten Seite die bereits vorhandenen Einträge auf. Klicken Sie auf "Neu..." und tragen Sie folgende Werte ein:

Feld Eintrag
JNDI-Name jdbc/mysql
Poolname MySQL (der gerade erstellte Verbindungspool)
Beschreibung optional

Klicken Sie anschliessend auf "OK". Damit ist die DB auch im JNDI Verzeichnis eingetragen.

Netbeans und Glassfish[Bearbeiten]

Unter http://netbeans.org/downloads/ kann man die Alternative Netbeans IDE herunterladen. Dabei ist der Glassfish Server bereits enthalten und kann mitinstalliert werden. Weil die Erläuterung der Beispiele in beiden Umgebungen zu umfangreich wäre, beschränkt sich dieses Buch auf Eclipse.

Weitere Applikationsserver[Bearbeiten]

Eine Auflistung von Applikationsservern kann im Wikipedia Artikel Java Enterprise nachgelesen werden.