Benutzer:Toni Grappa/ Objekte einfügen

Aus Wikibooks
Zur Navigation springen Zur Suche springen
Abbildung 1: Ein Würfel im Objekt-Modus.

So fügen Sie ein neues Objekt ein:

  • über das Add-Menü in der Werkzeugleiste des User Preferences-Fensters The Blender User Preferences Icon.png (das User Preferences-Fenster befindet sich in der Standardeinstellung am oberen Bildschirmrand über dem 3D-Fenster) oder
  • über die "Werkzeugkiste": SpaceAdd (also zunächst Space drücken, dann den Menüpunkt Add auswählen)

Eingefügte Objekte haben bestimmte Eigenschaften:

  • Neue Objekte werden mit ihrem Schwerpunkt am 3D-Cursor eingefügt Blender 3D-cursor.png. Setzen Sie also eventuell vorher den 3D-Cursor auf die gewünschten Koordinaten.
  • Objekte werden im Objekt-Modus eingefügt (Abb. 1) und an den globalen Koordinaten ausgerichtet, unabhängig von der Ansicht im 3D-Fenster.
  • Objekte werden in den aktiven Layer eingefügt.


Blender3D FreeDifficulty.gif

Blender greift nicht auf die Zwischenablage des Betriebssystems bzw. Fenstermanagers zu. Objekte lassen sich deswegen nicht über Copy in einem Blendfile kopieren und mit Paste in eine andere Datei einfügen.



Blender3D FreeNote.gif

Hinweis für Umsteiger aus anderen 3d Programmen Die Parameter der Grundkörper können nach dem Einfügen nicht mehr interaktiv verändert werden.



Der Unterschied zwischen dem Objekt-Modus und dem Edit-Modus[Bearbeiten]

Blender3D object edit.png

Im Objekt-Modus können Sie ein Objekt im Ganzen verschieben, drehen und skalieren. Im Edit-Modus haben Sie Zugriff auf die Feinstruktur des Objektes und können durch das Verschieben, Löschen und Hinzufügen von Vertices [Datenpunkten], Edges [Kanten] und Faces [Flächen] die Form des Objektes gezielt verändern.

Abbildung XX: Die Mode-Auswahl

Der Unterschied zwischen dem Objekt-Modus- und Edit-Modus vermittelt sich zuerst über das unterschiedliche Aussehen der Objekte. Wenn Sie ein Objekt ausgewählt haben, wechseln Sie mit der Mode-Auswahl in der Werkzeugleiste des 3D-Fensters (Abb. XX) oder mit TAB in den Edit-Modus und Sie erkennen den Aufbau des Objektes aus Vertices, Edges und Faces. Durch erneutes drücken von TAB oder wieder mit der Mode-Auswahl wechseln Sie zurück in den Objekt-Modus.


Abbildung 1: Das Objektzentrum ist der Referenzpunkt des Objektes. Auf ihn beziehen sich Position, Drehung und Skalierung des Objektes.

Wenn Sie einen Würfel einfügen, erhalten Sie ein Objekt (Objektdatenebene) und zugehörige Meshdaten (Meshdatenebene).

  • Der kleine lila Punkt in der Mitte des Objekts repräsentiert die Objektdaten, insbesondere den Ort des Objektes. Im Objekt-Modus haben Sie Zugriff auf diese Daten.
  • Wechseln Sie in den Edit-Modeus ist stattdessen die Meshdatenebene aktiv, visualisiert durch die Vertices, Edges und Faces.

Arbeiten im Objekt- und Edit-Modus[Bearbeiten]

  • Es macht einen großen Unterschied, ob Sie Daten im Edit- oder Objekt-Modus löschen. Befinden Sie sich im Edit-Modus, markieren alle Vertices und löschen diese, haben Sie nur die Meshdaten gelöscht, aber nicht die Objektdaten. Sie erhalten auf der visuellen Ebene ein Objekt ohne sichtbare Meshdaten, nur noch der kleine, unscheinbare Referenzpunkt ist übrig, aber Sie haben nicht «Nichts» und selbst die Meshdatenebene ist nicht gelöscht, sie enthält nur keine Daten.
  • Bewegen (drehen, skalieren) Sie ein Objekt im Objekt-Modus, verändern Sie nur die Daten des Referenzpunktes. Die Meshdatenebene bleibt davon unberührt und ändert seine Position relativ zum Referenzpunkt nicht. Transformieren Sie ein Objekt im Edit-Modus verändern Sie die Position der Meshdaten, aber die Objektdaten (Referenzpunkt) bleiben unberührt. Es werden also die Meshdaten relativ zur Position des Referenzpunktes verändert, was sich bei Transformationen im Objekt-Mode dann deutlich bemerkbar machen kann [Link].
  • Befinden Sie sich im Edit-Modus eines Meshobjektes, z.B. eines Würfels, arbeiten Sie auf der Meshdatenebene. Es ist nun vollkommen einsichtig, dass Sie in die Meshdatenebene bspw. keine Kurvendaten einfügen können und wenn Sie in dieser Situation die Werkzeugkiste (Space-Add) aufrufen, werden Ihnen konsequenter Weise nur Meshobjekte zum Einfügen angeboten.

Kopieren, Einfügen, Verlinken[Bearbeiten]

  • Um ein Objekt zu kopieren, verwenden Sie Object → Duplicate (Shift - D). Sie erhalten eine Kopie, die Sie in allen Parametern frei gestalten können.
  • Mit Object → Duplicate Linked (Shift - Alt - D) erhalten Sie eine Kopie (Instanz), die Sie in wesentlichen Parametern nicht mehr frei gestalten können. Verändern Sie das Original, ändert sich die Kopie.
  • Um Eigenschaften von einem Objekt auf ein anderes zu übertragen, markieren Sie mindestens zwei Objekte. Das zuletzt ausgewählte ist das aktive Objekt. Mit Object → Copy Attributs (Strg - C) öffnet sich ein Menü mit Eigenschaften (abhängig, ob sich das aktive Objekt im Edit- oder Objekt-Modus befindet), die auf das/die anderen Objekte übertragen werden.
  • Mit Object → Make Links (Strg - L) werden Datenblöcke neu verknüpft. Das aktive Objekt «überträgt» z.B. seine Materialien auf andere Objekte. Auf einer visuellen Ebene sieht es so aus, als würde das Material von «einem auf das andere Objekt kopiert», die tatsächlich Prozesse hängen jedoch mit Blenders Datenstruktur zusammen und deswegen muss in diesem Fall von Verlinkung gesprochen werden.
  • Um Objekte aus einer Datei in eine andere zu übertragen, muss die Funktion File → Append verwendet werden ( siehe Append ). Mit Strg - C können Sie keine Objekte von einem in das andere Blendfile kopieren (!).
  • Halten Sie die Maus über einen Button mit Zahlenangaben (markieren ist nicht nötig), können Sie die Zahlenwerte mit Strg - C kopieren und in ein anderes Zahlenfeld mit Strg - V einfügen.