Blender Dokumentation: Boolean-Modifier

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Bevel-Modifier
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Build-Modifier


Diese Seite bezieht sich auf
Blender v2.49
Archiv-Version(en) verfügbar für:
2.40, 2.37a
Abbildung 1: Was man besser nicht von Hand modelliert: Ein Würfel, drei extrudierte Buchstaben und drei mal Difference.

Boolsche Operationen helfen dann weiter, wenn ein Mesh zu umständlich zu modeln ist, sich aber leicht als Kombination mehrerer Grundobjekte erstellen lässt. Boolsche Operationen auf Meshobjekten sind prinzipbedingt problematisch:

  • Das resultierende Mesh ist teilweise sehr komplex, und kann nur schlecht nachbearbeitet werden.
  • Die Ausgangsobjekte müssen geschlossen sein, also eine geschlossene Oberfläche aufweisen.

Man kann eine boolsche Operation auch ohne Modifier anwenden (Object->Boolean Operation), dann und nur dann werden die Materialien vom einen auf das andere Objekt übernommen (so wie in Abb. 1).


Verwendung des Modifier-Panels[Bearbeiten]

Abbildung 2: Boolean Modifier
 1  Modifier hinzufügen und Typ auswählen
 2  Auswahl der boolschen Operation
 3  Objektname des zweiten Objektes
 4  Modifier permanent anwenden
 5  die Bildschirmdarstellung der Boolschen Operationen ausschalten

Wenn Sie das zweite Objekt auf einen anderen, ausgeblendeten Layer verschieben, können Sie das Ergebnis direkt beurteilen. Sind die Objekte komplex, kann die Bildschirmdarstellung lange dauern. Blenden Sie dann die Bildschirmdarstellung im 3D-Fenster aus.

Boolsche Operationen[Bearbeiten]

Blender3D boolscheoperationen übersicht.png
Difference

Zieht das zweite Objekt vom ersten ab. Hierbei sollten sie darauf achten in welcher Reihenfolge sie die Objekte selektieren, denn das aktive Objekt (das zuletzt ausgewählte) wird vom markierten Objekt (erste Objekt) abgezogen.

Union

Erzeugt ein neues Objekt, das das gesamte Volumen beider Objekte enthält. Wie sie in dem Bild sehen können wurde die Kugel dem Volumen des Würfels hinzugefügt.

Intersect

Erzeugt ein neues Objekt, das die Schnittmenge beider Volumina beinhaltet.


Boolean Tools-Menü[Bearbeiten]

Abbildung 4: Boolean Tools-Menü

Alternativ zur Anwendung des Modifier-Panels können Sie das Boolean Tools-Menü verwenden (Abb. 4).

  1. Wählen Sie zwei Meshobjekte aus.
  2. Rufen Sie das Menü entweder über Object->Boolean Operation oder mit W auf.

Bei den ersten drei Menüpunkten wird jeweils ein neues Objekt erzeugt, wobei die Materialien und Texturen der Ausgangsobjekte erhalten bleiben. Die Originalobjekte werden nicht verändert.


<<<Zurück

Bevel-Modifier

Inhaltsverzeichnis
Glossar
Weiter>>>

Build-Modifier