Blender-Handbuch: Lasst uns Gus ansehen

Aus Wikibooks
Zur Navigation springen Zur Suche springen
<<<Zurück
Das Grundgerüst bauen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Material und Texturen für Gus


Diese Seite bezieht sich auf Blender v2.5

Wir nähern uns der ersten Bildberechnung (dem sog. Rendering), aber wir müssen noch einige Dinge einstellen.

Abbildung 1: Layer 1 und 10 sichtbar machen.

Der Layer mit der Kamera und der Lampe muss sichtbar gemacht werden, denn Objekte werden nur auf sichtbaren Layern gerendert.

  • Klicken Sie im Object-Modus mit Shift-LMT bei den Layer Buttons den Button rechts oben an, das ist Layer 10 (Abb.1)

Dies macht die Objekte auf Layer 10 sichtbar, in diesem Fall die Kamera und die Lampe, die wir dorthin verschoben hatten.

Blender3D FreeNote.gif

Aktiver Layer

Der zuletzt ausgewählte Layer ist der aktive, in diesen werden neue Objekte eingefügt. Alle neuen Objekte werden von nun an also in Layer 10 eingefügt.


  • Stellen Sie den 3D-Manipulator wieder auf den "Bewegen"-Modus (Pfeil).
  • Wählen Sie die Kamera aus (RMT) und verschieben Sie sie ungefähr an (x=7, y=-10, z=7).
Abbildung 2: Das Transform Properties Panel
Blender3D FreeTip.gif

Ort und Rotation festlegen

Sie können numerische Werte für den Ort und die Rotation eingeben, wenn Sie mit View->Properties (oder N) das Properties Panel aufrufen und dort die entsprechenden Felder ausfüllen (Abb. 2). Wenn das Panel offen ist, können Sie die Position des Objektes immer kontrollieren, während Sie es mit der Maus verschieben.


Die Kamera nachzuführen kann bei einer Animation sehr aufwendig sein. Es gibt aber eine Funktion, mit der man ein Objekt immer auf ein anderes ausrichten kann, ein sog. TrackTo Constraint [Zeige Auf-Bedingung]. Mit den nächsten beiden Schritten erzeugen wir einen solchen Constraint.

  • Stellen Sie sicher, dass die Kamera ausgewählt ist. Wählen Sie als zweites Gus mit Shift-RMT aus.

Die Kamera sollte dunkler, Gus heller Orange erscheinen. Die Reihenfolge ist hier wichtig, sonst folgt Gus der Kamera, statt die Kamera Gus.

  • Wählen Sie Object->Track und wählen Track To Constraint.

Damit wird die Kamera gezwungen Gus zu folgen und immer auf ihn zu zeigen. Egal wie die Kamera auch bewegt wird, sie wird nun immer auf Gus zeigen.

Constraints [Zwangsbedingungen] sind eine wichtige Funktion bei der Animation in Blender, weil sie viele Animationsaufgaben erleichtern und automatisieren. To Do: Link muss angepasst werden.

In Abbildung 3 sind Top-, Front-, Seiten- und Kameraansicht gezeigt. Eine solche Ansicht erhalten Sie schnell mit View->Toggle Quad View.

Abbildung 3: Kameraposition im Verhältnis zu Gus

Jetzt müssen wir den Boden erzeugen, auf dem Gus steht.

  • Fügen Sie eine Plane (Ebene) hinzu (Add->Mesh->Plane).
Blender3D FreeNote.gif

Edit Mode und Object Mode

Es ist wichtig das neue Objekt im Object Mode hinzuzufügen. Sonst wäre das neu erstellte Objekt Teil des vorherigen Objektes, so wie wir es bei Gus Kopf gemacht haben. Neu eingefügte Objekte zeigen mit der Z-Achse immer nach oben und werden am Ort des 3D-Cursors eingefügt (wie bereits erwähnt).


  • Wechseln Sie zur Frontansicht (Num-1) ...
  • ...und bewegen die Ebene hinunter zu Gus Füßen.

Haben Sie zwischendurch in die Kameraansicht geschaltet, befindet sich Blender unter Umständen in der perspektivischen Ansicht (Zentralperspektive, Linien laufen im Unendlichen zusammen). Das erschwert das exakte Positionieren von Objekten. Schalten Sie dann über das View-Menü wieder zurück in die orthogonale Ansicht View->Orthografic.

  • Wechseln Sie zur Kameraansicht (Num-0) und skalieren (S) Sie die Ebene, bis die Grenzen der Ebene im Kamerabild nicht mehr zu sehen sind.

Die Bildgrenzen werden deutlich durch den abgedunkelten Bereich in der Kameraansicht angedeutet.

Es werde Licht![Bearbeiten]

  • In der Ansicht von oben (Num-7) wählen Sie die vorhandene Lampe aus und bewegen sie auf die andere Seite der Kamera, z.B. auf (x=-9, y=-10, z=7).
  • Im Properties-Fenster wählen Sie bitte Object Data aus, wenn das nicht schon automatisch geschehen ist.

Blender3D Gus-LampObjectData-2.54.png

Dummerweise ändert sich das Icon für Object Data, wenn sich der Objekttyp ändert, also nicht irritieren lassen, wenn Ihr Fenster etwas anders aussieht.

Abbildung 5: Einstellungen für das Spotlight. Nur ein Teil der Einstellungen für die Lampe ist gezeigt.
  • Unter den Lamp-Einstellungen wählen Sie Spot um die Lampe zu einem Spotlicht zu machen.
  • Klicken Sie auf den weißen Kasten über "Energy" und ändern Sie die Farbe auf ein helles Gelb (R=1, G=1, B=0.9).
  • Klicken Sie auf Buffer Shadow unter Shadow.

Buffer-Schatten [Buffer Shadow] kann viel schneller berechnet werden als Raytracing Schatten, daher verwenden wir ihn hier. Es gibt dann auch gleich vier verschiedene Berechnungsmethoden für Buffer-Schatten. Classic-Halfway ist eine gute Wahl für die meisten Anwendungsgebiete, deshalb ist dieser Schattentyp auch voreingestellt.

  • Setzen Sie den Wert von ClipEnd: auf 100, Samples: auf 4 und Soft: auf 8 (Abb. 5).

Damit erreichen wir, dass der Schatten leicht weichgezeichnet wird. ClipEnd gibt an, wie weit der Schatten reicht.

  • Das Spotlight soll Gus genauso folgen wie die Kamera, daher zunächst die Lampe auswählen (RMT), dann Gus (Shift-RMT). Object->Track->, im erscheinenden Popup-Menü Track To Constraint wählen.

Jetzt fügen wir eine zweite Lampe hinzu, die genau am gleichen Ort ist wie der Spot.

  • Setzen Sie den Cursor auf den Spot. Wählen Sie die Lampe aus (RMT). Drücken Sie Shift-S->Cursor to Selected.
  • In der Ansicht von oben fügen Sie mit Add->Lamp->Hemi eine Hemi Lampe hinzu. Die Energie der Hemi Lampe stellen Sie auf 0.6. (v2.76b: Die Energie der Hemi-Lampe beträgt nur 0.06, mit einer Energie von 0.6 sind fast keine Schatten vorhanden.)


Blender3D FreeTip.gif

Zwei Lampen?

Eine Lampe genügt praktisch nie, um eine auch nur annähernd vernünftige Beleuchtung zu erzeugen. Im wirklichen Leben kommt das Licht immer von vielen Richtungen, da jeder einzelne Gegenstand zu einer Lichtquelle werden kann. Sie erfahren mehr über dieses extrem wichtige Thema im Kapitel Licht To do: Link muss angepasst werden.


Beinahe fertig für die erste Bildberechnung.

Ein erstes Bild[Bearbeiten]

Abbildung 7: Das Render Panel. Nur der obere Teil des Panels ist sichtbar.
  • Im Properties-Fenster wählen Sie nun die Render-Einstellungen aus. Bei Dimensions tragen Sie als Resolution die Bildgröße von X:640 und Y:480 ein (Abb. 7).

Weiter unten bei Output sehen Sie das Verzeichnis und das Format (voreingestellt ist PNG) in dem die Bilddateien abgelegt werden. Bei Performance können Sie die Anzahl der Threads (bzw Anzahl der benutzten Prozessoren Ihres Systems) ändern, wenn Sie nichts ändern versucht Blender die Anzahl der Prozessoren in Ihrem System zu erkennen, und entsprechend viele parallele Berechnungen durchzuführen.

  • v2.5: Drücken Sie nun bei Render den Image Button. v2.76b: Drücken Sie nun bei Render den Render Button.

Weitere Möglichkeiten um zu Rendern sind: einfach F12 drücken, oder Render->Render Image im Window-Header des Info-Windows, also an der oberen Bildschirmkante. Das Ergebnis (Abb. 8) ist noch ziemlich schwach. Wir benötigen verschiedene Materialien und viele Details an der Figur.

Abbildung 8: Ihr erstes Bild. Glückwunsch!

Sie befinden sich nun im Image Editor-Fenster. Gerenderte Einzelbilder werden nicht von alleine gespeichert, das machen Sie im Image Editor über Image->Save As Image (oder mit F3).

  • Kehren Sie mit F11 (alternativ Render->Show/Hide Render View) zur ursprünglichen Ansicht zurück.

Wenn Sie es noch nicht getan haben wäre jetzt der richtige Zeitpunkt die Datei zu speichern. Das können Sie über das File->Save Menü tun. Oder drücken Sie Strg-S. Blender wird Sie warnen, wenn Sie eine existierende Datei überschreiben wollen.

Blender speichert außerdem die Blend-Datei automatisch in das temporäre Verzeichnis ihres Systems. In der Voreinstellung geschieht das alle fünf Minuten. Der Dateiname ist eine Zahl (z.B. "7659.blend"). Wenn Sie eine automatisch gespeicherte Datei öffnen, können Sie so unerwünschte Änderungen zurücknehmen.

Blender3D FreeTip.gif

Rettung

Sollten Sie Blender versehentlich geschlossen haben ohne zu speichern, holen Sie über File->Recover Last Session die zuletzt bearbeitete Datei wieder aus dem Orkus.





<<<Zurück

Das Grundgerüst bauen

Inhaltsverzeichnis
Glossar
Weiter>>>

Material und Texturen für Gus