Blender-Handbuch: Material und Texturen für Gus

Aus Wikibooks
Zur Navigation springen Zur Suche springen
<<<Zurück
Lasst uns Gus ansehen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Rigging Gus


Diese Seite bezieht sich auf Blender v2.5

Material für den Körper[Bearbeiten]

Abbildung 1: Das Material-Panel und ein erstes "GingerBread" Material.
Abbildung 2: Das Textur-Panel und einige Einstellungen der "GingerTex"-Textur

Das Material von Gus[Bearbeiten]

Jetzt werden wir Gus ein schönes Keks-Material verpassen.

  • Wählen Sie Gus aus.
  • Wechseln Sie in die Material Ansicht. Blender3D Materialbutton 2.54

Das Material für Gus ist ziemlich langweilig, da es einfach grau ist.

  • Als erstes fügen wir ein neues Material, durch drücken des + New-Button, hinzu. (Der graue Kasten über dem Button enthält eine Übersicht über alle vom Objekt verwendeten Materialien. Wenn Ihr Objekt bereits ein Material besitzt, können Sie dieses einfach ändern.)
  • Die Bezeichnung Material für das Material ändern wir auf "GingerBread". Klicken Sie dazu in das Namensfeld (gelb umrahmt in Abbildung 1) und tippen Sie den neuen Namen ein.
  • Verändern sie die voreingestellten Werte so wie in Abbildung 1 dargestellt (alle zu ändernden Werte in Abb. 1 sind gelb umrahmt), um ein erstes Rohmaterial zu erhalten (Die Farbwerte sind R:0.738 G:0.474 B:0.220). Das Bild in dem Preview Panel dient der Vorschau auf das Material.


Die Oberflächentextur von Gus[Bearbeiten]

Das Material besitzt noch keine Textureinstellungen.

  • Wechseln Sie in die Texture Ansicht. Blender3D Texturbutton 2.54
  • Fügen Sie eine neue Textur über den +-Button hinzu.
  • Nennen Sie die Textur "GingerTex" (wieder mit LMT ins Feld klicken).
  • Aus der Auswahlliste der Texture Types wählen Sie Stucci. Setzen Sie alle Parameter wie in Abb. 2 dargestellt. Die Einstellungen Stucci befinden sich evtl. weiter unten in der Einstellungsliste als auf dem Bild.

Hier soll einfach nur eine gewisse Unregelmäßigkeit erzeugt werden, die genauen Einstellungen spielen gar keine so große Rolle.

  • Wählen Sie den Bereich Influence (Abb. 3).

In dem Influence-Panel stellt man ein, welche Auswirkungen eine Textur auf das Material haben soll.

  • Deaktivieren Sie Color und aktivieren Sie Normal. Den Normal Schieberegler stellen Sie auf 0.75 (Abb. 3).

Dadurch wird die Stucci Textur zu einer sogenannten Bumpmap. Es sieht dann so aus, als hätte die Oberfläche von Gus Erhöhungen und Vertiefungen - eben so, wie ein Keks aussehen sollte.

  • v2.76b: Die Stucci-Einstellungen für die Bump-Map haben sich geändert. Stellen Sie Size auf 0.001 und Normal auf 0.1.

Jetzt fügen wir eine zweite Textur hinzu.

  • Wählen Sie in der Übersicht das leere Feld unter GingerTex und klicken Sie erneut auf den +-Button um eine zweite Textur einzufügen.
  • Nennen Sie diese neue Textur "Grain".
  • Als Textur-Typ wählen Sie wieder Stucci, diesmal allerdings mit Hard Noise und einer Noise Size von 0.020.
  • Diese Textur soll nur den Intensity Parameter beeinflussen. Jetzt wie in Abb. 4., den Blending Mode auf Add stellen und Var auf 0.4.

In Abb. 4 habe ich die relevanten Panel zusammengestellt. Intensity beeinflusst die Helligkeit des Materials.

Der Fußboden[Bearbeiten]

Der Fußboden bekommt ein einfaches, dunkelblaues Material nach den Einstellungen aus Abb. 5.

  • Wählen Sie den Fußboden aus. Der Fußboden hat noch kein Material.
  • Wechseln Sie in die Material-Ansicht.
  • Klicken Sie auf den +-Button (Add a new Material slot).
  • Ändern Sie die Einstellungen des Materials entsprechend Abb. 5, also den Namen und die Farbe.

Es ist jetzt wieder eine gute Gelegenheit ihre Datei zu speichern. Rendern Sie ein Bild und schauen Sie sich die verschiedenen Materialien an. Beobachten Sie die Wirkung der verschiedenen Texturen. Der Haken hinter dem Texturnamen (Abb. 2, 3, 4,) kann eine Textur temporär deaktivieren.



Abbildung 3: Das Textur-Panel und die weiteren Einstellungen der "GingerTex"-Textur (Ergänzung zu Abb. 2).


Abbildung 4: Das Textur-Panel und die Einstellungen der zweiten ("Grain"-)Textur.


Abbildung 5: Das Material-Panel und die Einstellungen für das Material "Ground".


Und wo sind die Augen und Drops Knöpfe? Die fügen wir nun hinzu.

Augen[Bearbeiten]

  • Schalten Sie in die Wireframe Ansicht (mit dem Draw Type-Menü in der Werkzeugleiste des 3D-Fensters).

Ich habe den 3D-Transformmanipulator für die Ansichten teilweise ausgeschaltet.

  • v2.5: Platzieren Sie den 3D-Cursor ungefähr in die Mitte von Gus Kopf. Sie befinden sich in einem 3D-Programm, also müssen Sie den Cursor in mindestens zwei Ansichten platzieren. Teilen Sie dazu das Fenster und wählen eine Frontansicht und eine Seitenansicht. Sie teilen das Fenster, indem Sie ganz rechts oben in der Ecke des Ansichtsfenster das Dreieck wählen und nach links ziehen. In diesem Duplikat des 3D View-Fensters brauchen wir die Werkzeugleiste nicht. Diese kann man über das Menü View->Tool Shelf oder T ausblenden. Um diese Ansicht wieder zu entfernen wählt man die Ecke des linken 3D View-Fensters und zieht es komplett über das rechte 3D View-Fenster. Wenn Sie möchten können Sie auch die QuadView-Ansicht (View->Toogle Quad View, Strg+Alt+Q) verwenden.

Die genaue Position von Objekten ist leichter einzuschätzen, wenn Sie die orthographische Ansicht benutzen (View->Orthographic, Num 5). Um den Cursor genau auszurichten können Sie wieder das Snap-Menü verwenden. (Shift-S, Cursor->Grid setzt den Cursor auf den nächstgelegenen Gitternetzpunkt).

  • v2.76b: Der 3D-Cursor wird auf das nächstgelegene Objekt platziert, wenn Sie mit LMB in das 3D-Fenster klicken (Einstellung: User Preferences->Interface->Cursor Depth). Platzieren Sie den 3D-Cursor in der Front-Ansicht ungefähr in die Mitte von Gus Kopf.

Wir werden nun die Augen als eigenständige Objekte hinzufügen. Achten Sie darauf, dass Sie sich beim Hinzufügen von neuen Objekten im Object Mode befinden.

  • Fügen Sie eine Kugel hinzu (Add->Mesh->UVSphere). Die Kugel hat die Werte 'Segments: 32 und Rings: 16, die die Detailliertheit der Kugel angeben. Die voreingestellten 32 sind viel zu viel, stellen Sie beide Werte auf 16. Sie finden das Einstellungspanel "Add UV Sphere" im linken Bereich unter den Object Tools.
Abbildung 6: Angriffspunkt für Rotation und Skalierung auf den 3D-Cursor setzen (Pivot-Menü)

Zunächst werden wir die Kugel in allen drei Raumrichtungen kleiner skalieren. (Sie können alternativ auch über das Einstellungspanel "Add UV Sphere" die Größe ändern.)

  • Skalieren Sie die Kugel klein (S-Taste, Strg beim Skalieren drücken) auf einen Faktor von 0.1 in allen drei Raumrichtungen. (Alternativ können Sie den Skalierungswert auch über die Tastatur eingeben.)
  • Dann wechseln Sie in die Seitenansicht Num 3.
  • Skalieren Sie nur noch in Y-Richtung (S-Y, Strg beim Skalieren drücken) um den Faktor 0.5.
  • Zoomen Sie ein bisschen in die Szene hinein (Num-+ oder MR oder Strg-MMT).
  • Bewegen Sie die Kugel ein bißchen, so dass sie halb aus dem Kopf herausschaut. Dazu können Sie den Tranformmanipulator einsetzen (auf den grünen Pfeil klicken und verschieben) oder mit G-Y die Bewegungsrichtung auf die globale Y-Achse beschränken.
  • Zurück in die Vorderansicht (Num 1), bewegen (G) Sie die Kugel nun zur rechten Seite an die Stelle, wo Gus Auge sitzen soll.

Nun werden wir das Auge kopieren und spiegelbildlich im Gesicht von Gus platzieren. Für den Körper hatten wir einen Mirror Modifier benutzt, damit Sie auch noch eine andere Methode kennenlernen, werden Sie das Auge "von Hand" kopieren.

  • Wählen Sie den Eintrag 3D Cursor im Pivot-Menü des Headers des 3D-Fensters (Abb. 6).

Der 3D-Cursor befindet sich noch in der Mitte von Gus-Kopf. Er wird gleich als Spiegelpunkt dienen.

Blender3D FreeTip.gif

Pivot Point (Bezugspunkt)

Skalieren, Rotieren und andere Mesh Änderungen beziehen sich immer auf einen bestimmten Bezugspunkt. Das kann die Cursorposition, das Zentrum des Objektes, das Schwerezentrum des Objektes, das Zentrum der Bounding Box, das Schwerezentrum mehrerer ausgewählter Objekte oder das zuletzt ausgewählte Objekt sein (Abb. 6). Der Button der so aussieht wie ein Fadenkreuz, wählt den Cursor als Bezugspunkt aus.



Abbildung 7: Gus Kopf nach dem Hinzufügen der Augen.
  • Wechseln Sie in den Edit-Modus. Alle Vertices des Auges sind ausgewählt.
  • Drücken Sie Shift-D, um alle ausgewählten Vertices, Edges und Faces zu kopieren. Die neu erzeugten Objekte befinden sich im Bewegungsmodus (Grab Mode), drücken Sie Esc, um diesen Modus zu beenden, ohne die Vertices tatsächlich zu bewegen.
  • Wählen Sie Mesh->Mirror->X-Global um entlang der X-Achse zu spiegeln und bestätigen Sie die Position mit der Bestätigen-Taste.

Gus Kopf sollte jetzt so aussehen wie in Abbildung 7.

Blender3D FreeTip.gif

Teile des Meshes als eigenes Objekt abtrennen

Wenn Sie sich doch mal mit dem Edit- und dem Object Modus beim Hinzufügen eines Mesh-Objektes vertun, kein Problem. Wählen Sie die gewünschten Vertices aus und drücken P für Separate. Dann wird ein neues Objekt aus diesen Vertices erstellt.




Mund[Bearbeiten]

Abbildung 8: Mesh Tools Panel (zusammengeschnitten)
  • Wechseln Sie in den Objekt-Modus (Tab).
  • Fügen Sie eine neue Kugel hinzu und skalieren und bewegen Sie sie wie vorhin das Auge, allerdings sollte die Kugel insgesamt etwas kleiner sein als die Augen.
  • Bewegen Sie die neue Kugel an die Stelle, an der Gus Mund anfangen soll (Abb. 9, links).
  • Wechseln Sie in den Edit-Modus.
  • An der Stelle der Object Tools befindet sich nun ein Panel mit Mesh Tools (linker Bildschirmrand). Die Buttons zur Steuerung des Spin Werkzeuges.
  • Drücken Sie Spin (Abb. 8). Stellen Sie nun unter den Mesh Tools im Spin Panel bei Steps: 3 ein und bei Degrees: 90 (standard). Das erzeugt drei Kopien auf einem 90 Grad Bogen, dessen Zentrum am Cursor liegt. Das Ergebnis sollte so aussehen wie das rechte Bild in Abb. 9. Sie haben auch die Möglichkeit die Mittelpunkt Position über die Center-Einstellungen im Spin-Panel zu ändern.

Falls die nun erzeugten Kopien nicht wie im Bild ausgerichtet sind, bedenken Sie dass der Bezugspunkt der 3D-Marker ist.

Blender3D Gus Kopf 2.54.png
Abbildung 9: Gus Mund wird mit SpinDup erzeugt.



Die Knopfleiste[Bearbeiten]

Abbildung 10: Gus Modell ist fertig.

Sie sind jetzt vermutlich in der Lage, drei weitere von diesen Ellipsoiden anzufertigen, die Gus' Knöpfe darstellen sollen.

  • Beenden Sie den Edit-Modus.
  • Erzeugen Sie zuerst einen Knopf, drücken Shift-D um eine Kopie anzufertigen und verschieben die Kopie wie in Abb. 10 gezeigt.
  • Erzeugen Sie den dritten Knopf, indem Sie den zweiten kopieren.



Das übrige Material[Bearbeiten]

Abbildung 11: Das Material hat zwei Benutzer.

Augen, Mund und Knöpfe bekommen jeweils ein eigenes Material. Die Augen werden "schokoladig", der Mund soll aus weißem Zucker bestehen. Die Knöpfe sollen rot, weiß und grün werden. Da der Mund und der mittlere Knopf aus weißem Zucker bestehen sollen, sollen sie natürlich das gleiche Material erhalten.


Abbildung 12a: Achten Sie insbesondere auf die Zahlen neben dem Materialnamen und ...

Die Materialien sind sehr ähnlich. Daher benutzen wir ein Material und "kopieren" dieses Material auf das nächste Objekt. Dieses Kopieren funktioniert in Blender etwas anders, als Sie es vermutlich gewohnt sind.

  • Wählen Sie die Augen aus und erstellen Sie das Material Choccolate:
    • RGB: 0.3/0.18/0.0
    • Diffuse Intensity: 0.5
    • Specular Intensity: 1.0
    • Hardness: 255
  • Wählen Sie nun den Mund aus. Der Mund trägt noch kein Material.
  • Klicken Sie auf dem Links and Pipeline-Panel auf den Doppelpfeil neben dem Add New-Button.
  • Wählen Sie das Material Choccolate aus.


Wie Sie nun auf dem Material-Panel sehen können, hat das Material zwei Benutzer (Abb. 11). Das Material ist also nicht kopiert worden, sondern mit zwei Objekten verlinkt. Ändern wir jetzt das Material, würde es sich auf allen verlinkten Objekten ändern. Das ist in diesem Fall unerwünscht, daher muss aus dem verlinkten Material eine echte Kopie gemacht werden (ein sog. Single User).

  • Klicken Sie auf die kleine "2" neben dem Materialnamen und eine Kopie des Materials wird angelegt.

Das Material heißt jetzt Choccolate.001.

  • Benennen Sie das Material in White Sugar um, und ändern Sie folgende Einstellungen:
    • RGB: 1.0/1.0/1.0
    • Diffuse Intensity: 0.9
    • Specular Intensity: 0.9


Blender3D FreeTip.gif

Verlinken statt Kopieren

Diese Vorgehensweise zum Kopieren von Objekten ist typisch in Blender. Zunächst wird etwas verlinkt, also an mehreren Stellen benutzt. Das ist sehr praktisch, spart es doch überflüssigen Speicherplatz und ermöglicht die nachträgliche Veränderung von vielen Objekten auf einmal. Benötigen Sie dann eine eigenständige Kopie, wird die Verlinkung aufgehoben, und durch eine echte Kopie ersetzt. Dieser Vorgang heißt in Blender "Make Single User". Auf diese Weise lassen sich viele Objekte mit dem gleichen Material versehen, 3D Objekte können in vielen Szenen gleichzeitig benutzt werden, lassen sich aber trotzdem noch nachträglich ändern usw.


Abbildung 12b: ...neben der Textur. Zwei Objekte tragen das Material, zwei Materialien benutzen die Textur. Aber drei Objekte tragen die Textur!

Wie oben beschrieben, erzeugen Sie weitere Materialien:

  • Wählen Sie den obersten Knopf aus.
  • Verlinken Sie zum Material White Sugar.
  • Erzeugen Sie einen Single User.
  • Bennen Sie das Material in Red Sugar um.
  • Ändern Sie die Farbe auf rot.
  • Verfahren Sie genauso für den untersten Knopf, der soll aber grün werden (Green Sugar).
  • Wählen Sie für den mittleren Knopf das Material White Sugar aus der Menüliste aus. Dieser Knopf bleibt weiß.

Dieses Material soll noch die Grain-Textur von dem Keks-Material erhalten. Bei den Texturen kann man ebenfalls vorhandene Texturen durch Menüauswahl einem Kanal zuweisen, aber die Textur hat ja auch noch Materialeinstellungen. Diese Materialeinstellungen müssen ebenfalls übertragen werden. Diesen Vorgang werde ich schrittweise beschreiben:

  1. Wählen Sie den Körper von Gus aus (RMT).
  2. Wählen Sie im Texture-Panel die Grain-Textur aus (LMT).
  3. Klicken Sie (LMT) auf den "schwarzen Pfeil nach unten" und wählen Sie Copy Texture Slot Settings (siehe Bild unten).
  4. Wählen Sie den Mund aus (RMT).
  5. Wählen Sie den ersten Texturkanal aus.
  6. Klicken Sie (LMT) auf den "schwarzen Pfeil nach unten" und wählen Sie Paste Texture Slot Settings (siehe Bild unten).
Kopieren von Textureinstellungen.


Das Material White Sugar sollte dann insgesamt so aussehen wie in Abb. 12a, b.


Abbildung 13: Gus mit Material

Nachdem wir alle Materialien erzeugt und zugewiesen haben, sollten wir mal wieder ein Bild rendern. Das Ergebnis sollte so ähnlich aussehen wie in Abb. 13.

Wenn Sie wollen, können Sie ihr Bild nun speichern. Drücken Sie dazu bei offenem Render-Fenster F3. Benennen Sie die Datei und klicken Sie auf Save As Image. Die Dateiendung wird automatisch angehängt.

  • Mit F11 geht es zurück in die vorherige Ansicht.
Blender3D FreeTip.gif

Dateitypen

In den Render buttons im Format-Panel stellen Sie das gewünschte Dateiformat ein. Sie können nur in dem Format speichern, in dem Sie auch gerendert haben.



Die erste Hälfte dieser Einführung ist nun beendet, unsere Figur ist fertig. In der nächsten Hälfte der Einführung bringen wir Gus das Laufen bei.



<<<Zurück

Lasst uns Gus ansehen

Inhaltsverzeichnis
Glossar
Weiter>>>

Rigging Gus