Blender Dokumentation: Extrude

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Das Mesh erweitern
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Knife Tools


Diese Seite bezieht sich auf
Blender v2.46RC1
Archiv-Version(en) verfügbar für:
2.37a

Extrude[Bearbeiten]

Mit Hilfe von Extrude "ziehen" sie zusätzliche Flächen, Kanten oder Punkte aus einem Mesh.

Es handelt sich dabei um eines der wichtigsten Werkzeuge bei der Modellierung. Auf diese Weise können Sie beispielsweise mit einem einfachen Rechteck anfangen und nach und nach ein Gesicht modellieren. Auch wenn der Prozess an sich recht intuitiv ist, werden die Prinzipien hinter Extrude [austoßen, extrudieren] im Nachfolgenden ausführlich erläutert.

Anleitung[Bearbeiten]

Abbildung 1: Extrude Button im Mesh Tools Panel
Blender3D FreeNote.gif

Extrude funktioniert nur im Edit Mode



Extrude kann auf verschiedene Weisen aufgerufen werden:

  • durch Drücken von E
  • mit Space->Edit->Extrude
  • mit Mesh->Extrude
  • durch Anklicken von Extrude auf dem Mesh Tools-Panel in den Editing Buttons (F9)

Markieren Sie ein oder mehrere Vertices (Punkte), Kanten oder auch Flächen - eben den Bereich des Meshes, den Sie extrudieren möchten. Rufen Sie dann Extrude auf.


Abbildung 2: Unterschied zwischen Only Edges und Only Vertices bei einer Plane

Das erscheinende Menü hängt davon ab, ob Sie sich im Vertex-, Edge- oder Face-Selection Modus befinden, sowie von Ihrer Auswahl. Wir besprechen hier die Optionen für den Vertex-Selection Modus, für die anderen Modi gilt entsprechendes.

  • Wenn Sie ausschließlich Vertices ausgewählt haben die nicht miteinander verbunden sind, erscheint kein Menü, weil es dann nur eine Möglichkeit gibt (nämlich Only Vertices).
  • Wenn Sie verbundene Vertices ausgewählt haben, können Sie zwischen Only Vertices und Only Edges wählen (Abb. 2).
  • Haben Sie eine zusammenhängende Fläche ausgewählt, kommt die Option Region hinzu.
  • Haben Sie mehrere zusammenhängende Flächen ausgewählt, kommt die Option Individual Faces hinzu.


Abbildung 3: Die verschiedenen Methoden bei einer Sphere - im Uhrzeigersinn: Region, Individual Faces, Only Edges
  • Region: Kopiert alle Vertices, Kanten und Flächen. Erscheint nur, wenn zwischen den ausgewählten Vertices eine Fläche aufgespannt ist. (Abb. 3)
  • Individual Faces: Jede Fläche wird entlang der Flächennormalen extrudiert. Nur wenn mehrere Flächen ausgewählt wurden.
  • Only Edges: Die zwischen den alten Vertices aufgespannte Fläche wird nicht kopiert, es entstehen aber neue Flächen zwischen den alten Kanten und den neuen Kanten.
  • Only Vertices: Es werden nur die Vertices kopiert, aber keine Flächen.


Nachdem Sie die gewünschte Option ausgewählt haben, befinden Sie sich automatisch im Bewegungsmodus [Grab mode], so dass die neu erstellten Teile des Objekts sofort mit der Maus bewegt werden können. Mit LMT-Klick schließen Sie die Aktion ab.

Blender3D FreeDifficulty.gif

Aktion abbrechen

Sie können den Vorgang abbrechen, wenn Sie die Maus aus dem Popup-Menü heraus bewegen. Haben Sie aber bereits neue Vertices erzeugt und brechen jetzt mit Esc ab, bleiben die neuen Vertices erhalten. Dadurch entstehen doppelte Vertices und damit doppelte Flächen, die zu vielen unschönen Fehlern führen können. Machen Sie daher dann auf jeden Fall die letzte Aktion rückgängig mit Strg-Z.





Tutorial: Ein Schwert[Bearbeiten]

Die Klinge[Bearbeiten]

  • Starten Sie Blender und löschen Sie den Standard-Würfel (X).
  • Stellen Sie sicher, dass Sie sich in der Draufsicht befinden (View->Top).
  • Erstellen Sie einen Kreis mit acht Vertices. (Leertaste->Add->Mesh->Circle, im Feld Vertices 8 eintragen.)
  • Blender befindet sich im Object Mode. Wechseln Sie zum Bearbeiten nun mit Tab in den Edit Mode.
  • Bewegen Sie die Vertices so, dass sie der Anordnung in Abb. 4 entsprechen.
    • Mit G bewegen Sie die jeweils markierten Vertices. (Zum Markieren mit RMT anklicken.)
    • Mit Strg erreichen Sie, dass sich die markierten Vertices beim Bewegen in festen Schritten bewegen.
    • Mit Shift-S lassen Sie die Vertices ggfs. nachträglich auf dem Grid einrasten.
Abbildung 4: Verformter Kreis. Das wird der Klingenquerschnitt.
  • Wählen Sie alle Vertices aus (A) und skalieren Sie sie mit S herunter, so dass die Form in zwei Einheiten des Gitters passt. Wechseln Sie in die Frontansicht (View->Front).


Die Form, die wir gerade erstellt haben, ist der Querschnitt der Klinge. Mit Extrude werden wir nun die ganze Klinge in ein paar einfachen Schritten erstellen.

Abbildung 5: Die Klinge
  • Stellen Sie sicher, dass alle Vertices ausgewählt sind. Drücken sie E
  • Wählen Sie im erscheinenden Pop-Up Menü die Option Only Edges.
  • Wenn Sie nun die Maus bewegen, sehen Sie, dass Blender die Vertices dupliziert hat. Außerdem wurden die ursprünglichen Vertices mit den neuen durch Flächen und Kanten verbunden.
  • Bewegen Sie die neuen Vertices um 30 Einheiten nach oben, während Sie die Bewegung mit Strg in Rasterschritten ablaufen lassen. Klicken Sie dann LMT um die neue Position zu bestätigen und skalieren Sie die Vertices mit S etwas kleiner (Abb. 5).


  • Drücken Sie nochmal E, um das obere Ende der Klinge zu extrudieren. Anschließend bewegen Sie die Vertices um fünf Einheiten nach oben.
Abbildung 6: Specials Menü. Remove Doubles
  • Um die Klinge in einem einzelnen Vertex enden zu lassen, skalieren Sie die oberen Vertices auf 0.000 herunter indem Sie Merge auf dem Mesh Tools-Panel (Abb. 1) klicken.

Blender wird Ihnen mitteilen, dass von acht Vertices sieben gelöscht wurden (Abb. 7).

Die Klinge ist fertig!

Abbildung 7: Die Klinge ist fertig.


Der Griff[Bearbeiten]

  • Verlassen Sie den Edit Mode (Tab) und bringen die Klinge auf einen anderen Layer (M->Layer auswählen). Blender3D LayerAuswahl.png
  • Erstellen Sie eine UVSphere (Leertaste -> Add -> Mesh -> UVSphere) mit 16 Segmenten und 16 Ringen.
  • Wechseln Sie wieder in den Edit Mode und deselektieren Sie anschließend alle Vertices mit A.
  • Benutzen Sie Box Select (B), um die obersten drei Ringe zu markieren, die Sie danach mit X->Vertices löschen. (Abb. 8).
Abbildung 8: UVSphere für den Griff. Die markierten Vertices sollen entfernt werden.
Abbildung 9: Die erste Extrusion für den Griff
  • Markieren Sie den obersten Vertices-Ring (z. B. wieder mit B) und extrudieren Sie ihn. Bewegen Sie den Ring um vier Einheiten nach oben und skalieren Sie ihn etwas größer (Abb. 9), dann extrudieren Sie weiter um jeweils vier Einheiten, so dass, wenn Sie den letzten Ring wieder etwas kleiner machen, die Form eines Griffes entsteht (Abb. 10).
Abbildung 10: Der vollständige Griff
  • Blenden Sie den Layer mit der Klinge ein. (z. B. mit Shift + Nummer des Layers)
  • Verlassen Sie den Edit Mode und skalieren und bewegen Sie den Griff so, dass er zur Klinge passt.
  • Bringen Sie den Griff auf den gleichen Layer wie die Klinge (M->Layer auswählen), und blenden den Layer mit Griff und Klinge wieder aus.


Der Handschutz[Bearbeiten]

Abbildung 11: Der vollständige Handschutz

Inzwischen sollten Sie sich an die Abfolge extrudieren >bewegen >skalieren gewöhnt haben. Versuchen Sie einfach mal, damit einen schönen Handschutz zu modellieren. Fangen Sie mit einem Würfel an, und extrudieren Sie die verschiedenen Seiten einige Male, skalieren Sie wann immer es nötig ist. Sie sollten in der Lage sein, etwas wie in Abbildung 11 gezeigt zu erstellen. Die Kanten habe ich am Schluss noch etwas abgeflacht mit Leertaste -> Edit -> Edges -> Bevel.


Nach dem Texturieren sieht das Schwert so aus:

Abbildung 12: Das fertige Schwert, mit Material und Texturen

Wie Sie sehen können, ist Extrude ein sehr mächtiges Werkzeug, welches ihnen das Modellieren von relativ komplexen Objekten in sehr kurzer Zeit ermöglicht (das ganze Schwert wurde in weniger als einer halben Stunde erstellt). Wenn Sie das extrudieren >bewegen >skalieren-Prinzip einmal verinnerlicht haben, wird Ihnen das Modellieren mit Blender wesentlich leichter fallen.

Blender3D FreeTip.gif

Die Richtung, in der extrudiert wird, kann auf eine Achse beschränkt werden. Dazu nach der Auswahl, was extrudiert werden soll (Region, Faces...), zusätzlich auf X, Y oder Z drücken.

Um beim Extrudieren gleichzeitig zu Skalieren, zusätzlich auf S drücken. Das kann auch mit der Einschränkung der Bewegungsrichtung kombiniert werden.


Für technisch Interessierte: Erläuterung des Algorithmus[Bearbeiten]

  1. Der Algorithmus sucht den äußeren Edge Loop aller zum Extrudieren ausgewählten Flächen. Normalerweise sieht er Kanten, die zu zwei oder mehr ausgewählten Flächen gehören, als intern an, und damit nicht als Teil des Loop
  2. Die Kanten im Edge Loop werden in Flächen umgewandelt
    • Wenn die Kanten im Edge Loop nur zu einer Fläche des gesamten Meshs gehören, werden alle ausgewählten Flächen dupliziert und mit den neu erstellten Flächen verbunden. Zum Beispiel werden Rechtecke in diesem Schritt zu Würfeln.
    • Andernfalls werden die markierten Flächen mit den neu erstellten Flächen verbunden, aber nicht dupliziert. Das verhindert unerwünschte Flächen innerhalb des entstehenden Meshs. Diese Unterscheidung ist extrem wichtig, da es ständig eine kohärente, abgeschlossene Kontruktion bei der Verwendung von Extrude sicherstellt.
  3. Kanten, die nicht zu ausgewählten Flächen gehören und einen "offenen" Edge Loop darstellen, werden dupliziert, und eine neue Fläche wird zwischen der neuen und der ursprünglichen Kante erstellt.
  4. Einzelne Vertices, die nicht zu einer markierten Kante gehören, werden dupliziert, und eine neue Kante wird zwischen den beiden erstellt.

Links[Bearbeiten]

<<<Zurück

Das Mesh erweitern

Inhaltsverzeichnis
Glossar
Weiter>>>

Knife Tools