Blender Dokumentation: Image Browser

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Dateien laden und speichern
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Background Image


Diese Seite bezieht sich auf Blender v2.46

Übersicht[Bearbeiten]

Der alte Image Browser wurde mit Version 2.46 rundumerneuert. Das Ziel war hierbei zum einen eine größere Stabilität zu erreichen und zum anderen die Grundlagen dafür zu legen, dass File- und Imagebrowser in (hoffentlich) naher Zukunft komplett zusammengelegt werden können. Der Image Browser ist nun auch in der Lage, neben den normalen Bildern Vorschaubilder von Materialien, Texturen, World und Lampen anzuzeigen, allerdings beschränkt auf die Anzeige von Bildern im aktuell geöffneten Blendfile.

Abbildung1: Der Image Browser


Den Image Browser aufrufen[Bearbeiten]

Mit Strg-F1 wird der Image Browser aufgerufen. Eine zweite Möglichkeit besteht darin, mit Strg-LMT auf den Load Button für Bilder zu klicken, der auf der Benutzeroberfläche in folgenden Zusammenhängen auftaucht:

  • Load Image in den Texture Buttons [ F6 > Texture Typ Image > Load]
  • Um Hintergrundbilder zu laden [ View > Background Images > Load]
  • Im Image Node in den Composite Nodes [Add > Input > Image > Load New]
  • In den Scene Buttons, um ein Backbuffer Bild zu laden [ F10 > Panel Output > Open File select ]
  • Im UV/Image Editor [ Menü Image > Open Image]
  • Wenn in einem Blendfile so viele Materialien vorhanden sind, dass in der Materialvorschau »Data Browse« angezeigt wird, kann der Image Browser ebenfalls mit Strg-LMT auf den Button »Data Browse« aufgerufen werden.
  • Im VideoSequenceEditor kann der Image Browser nicht aufgerufen werden!

Anzeigeoptionen[Bearbeiten]

Standardmäßig werden alle Ordner und Dateien im Image Browser angezeigt. Allerdings kann die Ansicht auf bestimmte Dateitypen eingeschränkt werden, wenn der Button unter Abb. 2  1  aktiviert ist. Es erscheinen dann neue Buttons, mit denen die unterschiedlichen Filetypen ausgewählt werden. (Mehrfachselektionen sind möglich). Ist die Funktion deaktiviert, sind die zusätzlichen Buttons nicht sichtbar. In Abb. 2 ist der Aktivierungsbutton mit  1  bezeichnet, in Abb.1 und Abb.5 jedoch mit  15 .

Abbildung 2: Selektive Anzeige verschiedener Filetypen


  1. Aktiviert das Untermenü
  2. Image-Dateien
  3. Blender-Dateien
  4. Movie-Dateien
  5. Python-Dateien
  6. Font-Dateien
  7. Sound-Dateien
  8. Text-Dateien
  9. Nur die Ordner werden angezeigt

Anzeigeoptionen für Bilder[Bearbeiten]

Abbildung 3: Vorschaufenster für Bilder

Ist der Image Browser geöffnet, werden kleine Thumbnails von den vorhandenen Bildern gezeigt. Diese Ansicht kann nicht verändert werden. Allerdings besteht die Möglichkeit ein etwas größeres Vorschaufenster mit B zu öffnen, dass sich über die Thumbnails legt. Immer, wenn Sie nun ein Bild mit LMT anklicken, wird es im Vorschaufenster angezeigt.

Datenansicht im aktuellen Blendfile[Bearbeiten]

Abbildung 4: Vorschaubilder für Materialien, Bilder, Wordhintergründe und Lampen

Die große Neuerung mit Version 2.46 besteht darin, dass Vorschaubilder für Materialien, Bilder, World und Lampen des gerade geöffneten Blendfiles (!) im Browser angezeigt werden, allerdings in einem anderen Modus, der mit Strg-F4 geöffnet wird.

Die Vorschaubilder werden normalerweise erst dann berechnet, wenn Sie im Image Browser angezeigt werden müssen, was unter Umständen lange dauern kann. Deswegen besteht die Möglichkeit, Vorschaubilder mit einer Größe von 96 x 96 px mit den Blendfiles abzuspeichern. Da dies die Filegröße signifikant erhöhen kann, ist diese Möglichkeit optional.

In den Voreinstellungen unter »Auto Save« finden Sie den Button »Save preview Images« und »Recent files«, mit dem Sie die Anzahl der Vorschaubilder, die höchstens abgespeichert werden, bestimmen können. »Save preview Images« ist in den ursprünglichen Settings deaktiviert. Wenn Sie möchten, dass »Save preview Images« immer aktiviert ist, müssen Sie die Benutzereinstellungen mit aktiviertem Button einmal mit Strg-U abspeichern.

Lesezeichen setzen[Bearbeiten]

Ist Button  13  aktiviert, wird links im Browserfenster eine Lesezeichenleiste angezeigt. Mit einem Klick auf  3  wird der aktuelle Pfad als Lesezeichen hinzugefügt. Sie löschen einen Eintrag, indem Sie den Cursor über den Eintrag halten und X drücken.


Referenz[Bearbeiten]

Abbildung 5: Der Image Browser

 1  Aktuelle Pfadangabe

 2  Auswahl der Partition oder gerade benutzter Ordner

 3  Lesezeichen des aktuellen Pfades hinzufügen

 4  Lesezeichenleiste

 5  Aktualisiert die Ansicht des Ordnerinhalts.

 6  In das nächst höhere Verzeichnis wechseln

 7  Fenster auswählen

 8  Vollbildmodus

 9  Alphabetische Sortierreihenfolge

 10  Nach Dateiendung sortieren

 11  Nach Abspeicherdatum sortieren

 12  Nach Datengröße sortieren

 13  Lesezeichen ein- / ausblenden

 14  Versteckt Dateien, deren Namen mit einem Punkt anfangen (Unix-typisch)

 15  Filtereinstellungen für die Anzeige der Daten

 16  Der Pfad zu einer Datei wird relativ zur blend-Datei gespeichert.

 17  Die Daten werden an die bestehende Datei angehängt

 18  Die Daten werden (nur) an die bestehende Datei verlinkt

 19  Die eingefügten Objekte werden automatisch selektiert und zu aktiven Objekten. Alle anderen bisher selektierten Objekte werden deselektiert.

 20  Die Objekte werden in den aktiven Layer eingefügt. Sind mehrere Layer angeschaltet, ist der aktive Layer derjenige, der zuletzt aktiviert wurde. Wenn Sie also z.B. die Layer 1, 2 und 6 in dieser Reihenfolge angeschaltet haben, wird das Objekt auf Layer 6 eingefügt. Leider gibt es keine optische Rückmeldung darüber, welcher Layer eigentlich der "zuletzt aktivierte" ist. Deswegen empfiehlt es sich, einmal M zu drücken und die Layerposition so genau zu erfahren.

 21  Fügt das Objekt an der Position des Cursors ein.

Tastaturkürzel[Bearbeiten]

  • Pfeil nach oben / nach unten Nach oben / unten scrollen
  • Pos1 An den Anfang der Liste wechseln
  • End An das Ende der Liste wechseln
  • ESC Den Image Browser verlassen
  • . Die Inhalte des Verzeichnisses aktualisieren
  • A Alles selektieren
  • P Auf das Parent Verzeichnis wechseln
  • MMT Daten aktiv machen und gleichzeitig auswählen
  • LMT Das Verzeichnis öffnen oder Daten aktivieren
  • RMT Daten nur aktiv machen aber noch nicht auswählen
  • MausRadIm Verzeichnis auf und ab scrollen.

Erweiterungen, die für die Zukunft geplant sind[Bearbeiten]

  • noch mehr Datenblöcke in die Vorschau aufnehmen (Meshes, Kurven...)
  • Image Browser und File Browser endgültig zusammenfassen
  • Materialien und Texturen auch über den Image Preview auswählen können
  • Zoomen für größere/kleinere Vorschauen

Links[Bearbeiten]

http://wiki.blender.org/index.php/Release_Notes/Notes246/Image_Browser

http://wiki.blender.org/index.php/User:Elubie/PreviewImageBrowser


<<<Zurück

Dateien laden und speichern

Inhaltsverzeichnis
Glossar
Weiter>>>

Background Image