Blender Dokumentation: Lasst uns Gus ansehen

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Das Grundgerüst bauen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Material und Texturen für Gus


Diese Seite bezieht sich auf
Blender v2.46
Archiv-Version(en) verfügbar für:
2.42, 2.37a

Wir nähern uns der ersten Bildberechnung (dem sog. Rendering), aber wir müssen noch einige Dinge einstellen.

Abbildung 1: Layer 1 und 10 sichtbar machen.

Der Layer mit der Kamera und der Lampe muss sichtbar gemacht werden, denn Objekte werden nur auf sichtbaren Layern gerendert.

  • Wechseln Sie in den Objekt-Modus (Tab), damit in der Werkzeugleiste des 3D-Fensters die Layer Buttons angezeigt werden.
  • Klicken Sie mit Shift-LMT bei den Layer Buttons den Button rechts oben an (Abb.1)

Das macht die Objekte auf Layer 10 sichtbar, das ist in diesem Fall die Kamera, die wir dorthin ja verschoben haben.

Blender3D FreeNote.gif

Aktiver Layer

Der zuletzt ausgewählte Layer ist der aktive, in diesen werden neue Objekte eingefügt. Alle neuen Objekte werden von nun an also in Layer 10 eingefügt.


  • Wählen Sie die Kamera aus (RMT) und verschieben Sie sie ungefähr an (x=7, y=-10, z=7). Das Verschieben wird mit der G-Taste gestartet. Wenn Sie nun die Strg-Taste halten, bewegt sich das Objekt in Schritten von 1 Blendereinheit.
Abbildung 2: Das Transform Properties Panel
Blender3D FreeTip.gif

Ort und Rotation festlegen

Sie können numerische Werte für den Ort und die Rotation eingeben, wenn Sie mit Object->Transform Properties das Transform Properties Panel aufrufen (N) und dort die entsprechenden Felder ausfüllen (Abb. 2). Wenn das Panel offen ist, können Sie die Position des Objektes immer kontrollieren, während Sie es mit der Maus verschieben.


Die Kamera nachzuführen kann bei einer Animation sehr aufwendig sein. Es gibt aber eine Funktion, mit der man ein Objekt immer auf ein anderes ausrichten kann, ein sog. TrackTo Constraint [Zeige Auf-Bedingung]. Mit den nächsten beiden Schritten erzeugen wir einen solchen Constraint.

  • Stellen Sie sicher, dass die Kamera ausgewählt ist. Wählen Sie als zweites Gus mit Shift-RMT aus.

Die Kamera sollte Magenta und Gus in Pink erscheinen. Die Reihenfolge ist hier wichtig, sonst folgt Gus der Kamera, statt die Kamera Gus.

  • Wählen Sie Object->Track->Make Track... und wählen TrackTo Constraint aus dem erscheinenden Popup Menü.

Damit wird die Kamera gezwungen Gus zu folgen und immer auf ihn zu zeigen. Egal wie die Kamera auch bewegt wird, sie wird nun immer auf Gus zeigen.

Constraints [Zwangsbedingungen] sind eine wichtige Funktion bei der Animation in Blender, weil sie viele Animationsaufgaben erleichtern und automatisieren.

In Abbildung 3 sind Top-, Front-, Seiten- und Kameraansicht gezeigt. Die Kameraansicht erhalten Sie mit Num-0.

Abbildung 3: Kameraposition im Verhältnis zu Gus

Jetzt müssen wir den Boden erzeugen, auf dem Gus steht.

  • Fügen Sie eine Plane (Ebene) hinzu (Space->Add->Mesh->Plane).
Blender3D FreeNote.gif

Edit Mode und Object Mode

Es ist wichtig, das neue Objekt im Object Mode hinzuzufügen. Sonst wäre das neu erstellte Objekt Teil des vorherigen Objektes, so wie wir es bei Gus Kopf gemacht haben. Neu eingefügte Objekte zeigen mit der Z-Achse immer nach oben und werden am Ort des 3D-Cursors eingefügt (wie bereits erwähnt).


  • Wechseln Sie zur Frontansicht (Num-1) ...
  • ...und bewegen die Ebene hinunter zu Gus Füßen. Benutzen Sie dabei Strg um die Bewegung nur in festen Schritten zu gestatten, dann steht Gus direkt auf der Ebene.

Haben Sie zwischendurch in die Kameraansicht geschaltet, befindet sich Blender unter Umständen in der perspektivischen Ansicht (Zentralperspektive, Linien laufen im Unendlichen zusammen). Das erschwert das exakte Positionieren von Objekten. Schalten Sie dann über das View-Menü wieder zurück in die orthogonale Ansicht View->Orthografic.

  • Wechseln Sie zur Kameraansicht (Num-0) und skalieren (S) Sie die Ebene, bis die Grenzen der Ebene im Kamerabild nicht mehr zu sehen sind.

Die Bildgrenzen werden durch die äußeren schwarzen, gestrichelten Linien in der Kameraansicht angedeutet.

Es werde Licht![Bearbeiten]

  • In der Ansicht von oben (Num-7) wählen Sie die vorhandene Lampe aus und bewegen sie auf die andere Seite der Kamera, z.B. auf (x=-9, y=-10, z=7).
  • Wechseln Sie in die Lamp Buttons im Shading Context (F5). Blender3D GusLampButtons.png
  • Im Preview Panel drücken Sie auf Spot um die Lampe zu einem Spotlicht zu machen. Ändern Sie die Farbe auf ein helles Gelb (R=1, G=1, B=0.9).
  • Klicken Sie Buf. Shadow auf dem Shadow and Spot Panel an.

Buffer-Schatten [Buffered Shadow] kann viel schneller berechnet werden als Raytracing Schatten, daher verwenden wir ihn hier. Es gibt dann auch gleich drei verschiedene Berechnungsmethoden für Buffer-Schatten. Classic-Halfway ist eine gute Wahl für die meisten Anwendungsgebiete.

  • Stellen Sie die Berechnungsmethode des Buffer-Schatten von Classical auf Classic-Halfway.
  • Setzen Sie den Wert von ClipEnd: auf 100, Samples: auf 4 und Soft: auf 8 (Abb. 5).

Damit erreichen wir, dass der Schatten leicht weichgezeichnet wird. ClipEnd gibt an, wie weit der Schatten reicht.

  • Das Spotlight soll Gus genauso folgen wie die Kamera, daher zunächst die Lampe auswählen (RMT), dann Gus (Shift-RMT). Object->Track->Make Track..., im erscheinenden Popup-Menü TrackToConstraint wählen.

Fügen Sie eine zweite Lampe an genau dem gleichen Ort wie dem Spot hinzu.

  • Setzen Sie den Cursor auf den Spot. Dazu wählen Sie die Lampe aus, falls sie nicht schon sowieso ausgewählt ist. Drücken Sie Shift-S->Cursor->Selection.
  • In der Ansicht von oben fügen Sie mit Space->Add->Lamp->Hemi eine Hemi Lampe hinzu. Die Energie der Hemi Lampe stellen Sie auf 0.6 (Abbildung 6).
Abbildung 5: Einstellungen für das Spotlight. Nur ein Teil der Panels für die Lampe ist gezeigt.
Abbildung 6: Einstellungen für das Hemilight. Nur ein Teil der Panels ist gezeigt.
Blender3D FreeTip.gif

Zwei Lampen?

Eine Lampe genügt praktisch nie, um eine auch nur annähernd vernünftige Beleuchtung zu erzeugen. Im wirklichen Leben kommt das Licht immer von vielen Richtungen, da jeder einzelne Gegenstand zu einer Lichtquelle werden kann. Sie erfahren mehr über dieses extrem wichtige Thema im Kapitel Licht.


Beinahe fertig für die erste Bildberechnung.

  • Wechseln Sie in die Render buttons im Scene Kontext.
  • Im Format Panel stellen Sie die Bildgröße auf 640x480.

Sie können darunter erkennen, dass Blender in der Voreinstellung Jpeg-Einzelbilder rendert. Wenn Sie nun auf das Output-Panel schauen finden Sie dort ein Auto-Icon, daneben die Angabe Threads. In Abb. 7 steht dort eine 2. Blender versucht die Anzahl der Prozessoren in Ihrem System zu erkennen, und entsprechend viele parallele Berechnungen durchzuführen. Sie können die Anzahl an Threads aber auch per Hand einstellen.

Abbildung 7: Die Render Buttons. Nur ein Teil der Panele ist gezeigt.
Abbildung 8: Ihr erstes Bild. Glückwunsch!
  • Drücken Sie nun den RENDER Button oder F12.

Das Ergebnis (Abb. 8) ist noch ziemlich schwach. Wir benötigen verschiedene Materialien und viele Details an der Figur.

Blender3D FreeTip.gif

Speichern

Wenn Sie es noch nicht getan haben wäre jetzt der richtige Zeitpunkt die Datei zu speichern. Das können Sie über das File->Save Menü tun. Oder drücken Sie Strg-W. Blender wird Sie warnen, wenn Sie eine existierende Datei überschreiben wollen.

Blender speichert die Blend-Datei automatisch in das temporäre Verzeichnis ihres Systems. In der Voreinstellung geschieht das alle fünf Minuten. Der Dateiname ist eine Zahl (z.B. "7659.blend"). Wenn Sie eine automatisch gespeicherte Datei öffnen, können Sie so unerwünschte Änderungen zurücknehmen.

Sollten Sie Blender über Alt-F4 oder über den Fenster-Button geschlossen haben, fragt Blender nicht nach ob Änderungen gespeichert werden sollen. Über File->Recover Last Session holt man die zuletzt bearbeitete Datei wieder aus dem Orkus.

Gerenderte Einzelbilder werden nicht von alleine gespeichert, das machen Sie über File->Save Rendered Image (oder mit F3).



<<<Zurück

Das Grundgerüst bauen

Inhaltsverzeichnis
Glossar
Weiter>>>

Material und Texturen für Gus