Blender Dokumentation: Das Grundgerüst bauen

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Aufwärmphase
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Lasst uns Gus ansehen


Diese Seite bezieht sich auf
Blender v2.46
Archiv-Version(en) verfügbar für:
2.42, 2.40, 2.37a

Abbildung 1: Würfel im Edit Mode

Zunächst wechseln wir die Blickrichtung auf den Würfel. Im Moment schauen Sie von oben auf den Würfel (YX-Ansicht). Die jeweilige Ansicht wird links unten im 3D-Fenster durch ein kleines, farbiges Achsenkreuz angezeigt.

  • Schalten Sie in die ZX-Ansicht durch View->Front.

Sie haben sicher schon bemerkt, dass neben vielen Menübefehlen auch das jeweilige Tastenkürzel steht, in diesem Fall NumPad1.

Unser zu erstellendes Pfefferkuchenmännchen werden wir "Gus" nennen. Unsere erste Aufgabe ist der Körper von Gus, den wir jetzt aus dem Würfel erstellen. Dabei werden wir nur eine Seite tatsächlich modellieren, die andere Seite wird Blender für uns automatisch erzeugen.

Den Würfel müssen wir zum Bearbeiten in den Edit Mode bringen, ein Modus in dem die Eckpunkte [Vertices, Sing. Vertex] des Würfels frei im Raum platziert werden können.

  • Drücken Sie die Tab-Taste oder wechseln Sie mit dem Mode-Auswahlmenü in der Werkzeugleiste des 3D-Fensters auf Edit Mode.

Alle Vertices aus denen der Würfel aufgebaut ist, sind ausgewählt (ausgewählt = gelb, nicht ausgewählt = pink) (Abb. 1).


  • Im unteren Fensterbereich sollten bereits die Editing Buttons zu sehen sein, überprüfen Sie, ob in der Werkzeugleiste der richtige Button aktiviert ist (Abbildung 2). Ist das nicht der Fall, drücken Sie F9 oder klicken Sie den Button an.
Abbildung 2: Der Button für die Editing Buttons

Die Editing-Buttons enthalten eine Fülle von verschiedenen Funktionen und Einstellungsmöglichkeiten, erfreulicherweise benötigt man meistens zum Arbeiten nur eine kleine Auswahl der Funktionen. Für den Rest gibt es dieses Handbuch.



  • Klicken Sie einmal auf den Subdivide-Button im Mesh Tools Panel (Abbildung 3).


Abbildung 3: Die Editing Buttons. Für das Bild wurden die Panels etwas anders angeordnet.


Abbildung 4: Der unterteilte Würfel

Jede Seite des Würfels wurde jetzt mit einem weiteren Vertex unterteilt (Abbildung 4).

  • Drücken Sie die A-Taste, um die Auswahl aufzuheben (oder wählen Sie Select->Select/Deselect All).

Bedenken Sie, dass Tastaturbefehle nur in aktiven Fenstern funktionieren. Ein Fenster ist aktiv, wenn sich der Mauszeiger darin befindet. Die Vertices werden nun pink dargestellt (nicht ausgewählt).


Auswahl des Wireframe Modus

Im 3D-Fenster kann ein Objekt in verschiedenen Voransichtsmodi [Draw Types] dargestellt werden, z.B. als Drahtgitter [Wireframe] oder massiv [Solid]. In der Voreinstellung werden die Objekte massiv [Solid] dargestellt, der Voransichtsmodus [Draw Type] soll aber jetzt gewechselt werden.

Wir wollen im sogenannten "Drahtgittermodus" [Wireframe] weiterarbeiten.

  • Klicken Sie dazu auf das Auswahlfeld für den Draw Type in der Werkzeugleiste des 3D-Fensters, und wählen Sie dort Wireframe aus (Auswahl des Wireframe Modus).


  • Drücken Sie die B-Taste (Border Select), oder wählen Sie Select->Border Select aus dem Menü. Am Mauszeiger sind graue Linien zu sehen. Bewegen Sie den Mauszeiger über die linke obere Ecke des Würfels, halten Sie LMT gedrückt und ziehen mit der Maus ein Rechteck über alle Vertices links der Mittellinie. Lassen Sie die Maustaste los.

Diese Arbeitsschritte zum Auswählen der Vertices sind in den folgenden Bildern noch einmal dargestellt.


Blender3D FreeTip.gif

Border Select

Häufig sind bei einem Objekt Vertices hinter anderen Vertices versteckt, so wie in diesem Fall. Der unterteilte Würfel hat 26 Vertices, von denen man nur 9 sehen kann, da die anderen hinter den vorderen liegen.

Ein normaler RMT wählt nur einen der Vertices aus, Border Select wählt im Wireframe-Modus alle Vertices aus. Sie haben daher in diesem Fall 9 Vertices ausgewählt, obwohl Sie nur drei gelbe Vertices sehen können.

Oben rechts über dem 3D-Fenster finden Sie die Angabe Ve: 9/26. Die erste Zahl gibt die Anzahl an ausgewählten Vertices an, die zweite Zahl die Anzahl an Vertices im Objekt (solange Sie sich im Edit-Modus befinden).


Abbildung 5: Border Select


Abbildung 6: Löschen der Vertices im Edit Mode
  • Drücken Sie jetzt die X-Taste und wählen Sie Vertices, um die ausgewählten Vertices zu löschen (Abb. 6).


Blender3D FreeTip.gif

Undo und Redo [Rückgängig machen/Wiederherstellen]:

Falls Sie sich mal beim Bearbeiten vertun sollten: Blender besitzt eine Funktion, um Bearbeitungsschritte rückgängig zu machen (Undo). Entweder drücken Sie Strg-Z/⌘-Z, oder verwenden Mesh->Undo History (Alt-U). Dort können auch mehrere Schritte auf einmal rückgängig gemacht werden.

Mit Mesh->Redo Editing (Strg-Shift-Z/⌘-Shift-Z) können Sie die Änderungen wieder herstellen (Redo).

Durch Esc brechen Sie eine noch nicht bestätigte Aktion ab und kehren zu dem vorherigen Zustand des Meshes zurück.



Das Mesh mit der Extrude-Funktion Schritt für Schritt aufbauen[Bearbeiten]

  • Wählen Sie die Vertices oben rechts mit Border Select aus (Abbildung 7, links). Sie sehen von vorne nur zwei Vertices, ausgewählt haben Sie aber sechs Vertices.
  • Drücken Sie zum Extrudieren die E-Taste und wählen Sie im Extrude Menü Region, um die Auswahl zu verlängern.


Dabei werden neue Eckpunkte und Flächen erschaffen, die Sie nun bewegen können. Extrudieren Sie eine Region - so wie in diesem Fall - erscheint eine Linie, die die Richtung der Extrusion festlegt. Bewegen Sie die Maus nach rechts, sehen Sie die neu erschaffenen Vertices.

Möchten Sie stattdessen in eine beliebige Richtung - also schräg - bewegen, müssen Sie zunächst die Festlegung der Bewegungsrichtung mit einem Klick auf MMT (also der mittleren Maustaste) aufheben. Mit einem weiteren Klick auf MMT legen Sie die Bewegungsrichtung wieder fest. Halten Sie MMT gedrückt und bewegen die Maus im Kreis, können Sie zwischen den verschiedenen Achsen wechseln. Um zum ungerichteten Bewegen zurückzukehren muss MMT nochmal geklickt werden. Alternativ kann die X-Taste gedrückt werden, um die Auswahl in X-Richtung zu bewegen. Dasselbe für die Y-Taste für die Y-Richtung oder die Z-Taste für die Z-Richtung.


Jetzt erschaffen Sie Arme und Beine für Gus.

  • Bewegen Sie die Auswahl mit den neuen Vertices insgesamt 1,5 Kastenlängen nach rechts. Wenn Sie dabei Strg drücken, werden die Vertices in festen Schritten bewegt. Das erleichtert das genaue Positionieren. Alternativ kann auch einfach 1.5 und danach Enter eingegeben werden.
  • Klicken sie LMT, um die Aktion abzuschließen.
  • Wiederholen Sie die Aktion mit einer halben Kastenlänge wie in Abbildung 7 gezeigt.
Abbildung 7: Erzeugen von Gus Arm in 3 Schritten



Abbildung 8: Der halbe Körper ist fertig.

Gus hat jetzt einen linken Arm (sein Kopf schaut Sie an).

  • Heben Sie die Auswahl auf (A).
  • Jetzt erschaffen Sie das linke Bein auf demselben Weg, indem sie die unteren Vertices auswählen. Versuchen Sie etwas zu erzeugen, was Abbildung 8 ähnelt. Sie müssen mit MMT die Einschränkung der Bewegungsrichtung aufheben, damit Sie die Vertices schräg positionieren können.


Blender3D FreeNote.gif

Ellenbogen und Knie

Wir benutzen das Extrude-Werkzeug dreimal, um das Bein zu erzeugen. Um den Ellenbogen haben wir uns nicht gekümmert. Aber wir brauchen später ein Knie, damit Gus laufen kann!



Blender3D FreeTip.gif

Sich überlagernde Vertices

Wenn Sie extrudieren und beim Bewegen Esc drücken, um die Bewegung abzubrechen, bleiben die extrudierten Vertices erhalten. Diese nehmen dann genau die gleiche Position ein wie die Vertices, aus denen sie erzeugt wurden. Sie können die neuen Vertices natürlich noch verschieben oder rotieren, solange sie ausgewählt sind. Um das Extrudieren vollständig rückgängig zu machen, wählen Sie zunächst alle Vertices aus, und benutzen dann Rem Double(s) im Mesh Tools Panel (oder W,6).


Rem Doubles arbeitet nur mit den ausgewählten Vertices, daher müssen Sie zunächst alle Vertices auswählen, bevor Sie die Funktion anwenden.

Wenn eine Fläche beim Rendern seltsam aussieht (z.B. grieselig), sollten Sie immer die Möglichkeit in Betracht ziehen, dass Sie doppelte Vertices in Ihrem Modell haben.



Mit dem Mirror-Modifier eine Meshhälfte spiegeln[Bearbeiten]

Abbildung 9: Mirror Modifier hinzufügen.
  • Klicken Sie auf dem Modifiers-Panel in den Editing Buttons auf Add Modifier (Abb. 9) und wählen Sie dort den Mirror Modifier aus.

Wenn Sie das Modifiers-Panel nicht sehen können, verschieben Sie mit der MMT das Buttonfenster nach links.

Gus wird entlang der X-Achse gespiegelt, so dass Sie nun das Ausgangsmesh und das gespiegelte Mesh im 3D-Fenster sehen. Verändern Sie das Ausgangsmesh, werden alle Änderungen an der gespiegelten Kopie übernommen. Wenn Sie später näheres zur Anwendung dieser wichtigen Technik wissen möchten, lesen Sie den Abschnitt Spiegelsymmetrische Objekte.


Gus benötigt einen Kopf. Auch dieser soll aus einem Würfel entstehen. Um den Würfel an der richtigen Stelle einzufügen, muss zunächst der 3D-Cursor an die richtige Stelle gebracht werden.


Blender3D FreeTip.gif

Den Cursor positionieren

Um den Cursor an eine bestimmte Stelle auf dem Gitter zu setzen, klicken Sie möglichst nahe an diesen Punkt (LMT). Drücken Sie Shift-S, um das Snap-Menü aufzurufen. Die Auswahl Cursor->Grid setzt den Cursor auf den Gitternetzpunkt. Cursor->Selection setzt den Cursor auf das ausgewählte Objekt. Die anderen Einträge bewegen das ausgewählte Objekt.


Abbildung 10a: Einen Kopf hinzufügen
  • Bewegen Sie den Cursor, so dass er sich exakt ein Kästchen über dem Körper von Gus befindet (Abbildung 10a, links).
  • Fügen Sie einen neuen Würfel ein (Leertaste->Add->Cube).
  • Klicken Sie auf den blauen Pfeil (den 3D-Transform Manipulator) und bewegen Sie mit diesem die neu eingefügten Vertices ungefähr ein drittel Kästchen nach unten (Abbildung 10a, rechts).
Abbildung 10b: Der halbierte Kopf, vorbereitet für SubSurf.

Durch den Mirror-Modifier ist die - von uns aus gesehen - linke Hälfte des Kopfes allerdings doppelt vorhanden. Dadurch entstehen sich überlagernde Flächen. Berechnet man später ein Bild, gibt es daher unter Umständen schwarze Flecken. Um den Kopf zu halbieren, ihn nach dem nächsten Schritt aber trotzdem kugelförmig zu halten, muss man ein bißchen tricksen.

  • Skalieren Sie den Würfel um den Faktor 0.71. Dazu drücken Sie zunächst S, und geben dann die Zahl 0,71 über die numerische Tastatur ein.
  • Unterteilen Sie den Kopf einmal (diesmal über das Specials-Menü mit w->Subdivide, Sie können aber auch wieder den Knopf in den Editing-Buttons benutzen).
  • Wenden Sie die Funktion To Sphere an. Im Menü: Mesh->Transform->To Sphere. Durch Bewegen des Mauscursors änderen Sie die Stärke, mit der diese Funktion angewendet wird. Links in der Werkzeugleiste des 3D-Fensters können Sie die Änderung dieses Faktors beobachten. Stellen Sie den Faktor auf 1.00 durch das Bewegen des Mauscursors nach außen. LMT schließt die Aktion ab.
  • Heben Sie die Auswahl auf (A).
  • Wählen Sie die neun Vertices auf der linken Seite des Kopfes aus (z.B. wieder mit Border Select), und löschen Sie diese (Entf).

Der Kopf sollte jetzt im 3D-Fenster so aussehen wie in Abb. 10b.

Oberfläche abrunden und glätten[Bearbeiten]

Um Gus eine weiche, organische Form zu verpassen, setzen wir einen sogen. Subsurf-Modifier (Subdivision Surfaces) ein.

Abbildung 11: SubSurface Einstellungen
  • Klicken Sie im Modifier-Panel auf Add Modifier und wählen Subdivision Surf.
  • Erhöhen Sie den Wert für Levels auf 2 (Abb. 11).
  • Beenden Sie den Edit Mode und wechseln Sie von der Anzeige des Drahtgittermodells in den Solid Mode (Draw Mode).

Wenn Sie mit dem Model fertig sind (im "Object-Mode") müssen Sie beim Mirror-Modifier mit Apply die beiden Hälften zu einem Mesh machen (In neueren Blender-Versionen nötig!).

Jetzt können Sie sich schon eine gute Vorstellung von unserem Modell machen (Abbildung 12, links). Man erkennt noch die einzelnen Flächen, aus denen Gus aufgebaut ist.

  • Um die Übergänge weich verlaufen zu lassen, drücken Sie den SetSmooth Button im Link and Materials-Panel im Button-Fenster.

Gus hat nun eine glatte Oberfläche (Abbildung 12, rechts).

Abbildung 12: Gus mit SubSurf Modifier (links) und nach Anwendung von Set Smooth (rechts)
Blender3D FreeNote.gif

SubSurfacing

SubSurfacing ist ein fortgeschrittenes Modelling-Werkzeug. Es verfeinert dynamisch ein vorgegebenes grobes Netz aus Vertices. Die Form des Objektes ist immer noch durch die äußeren Vertices vorgegeben, aber gerendert wird das feine Mesh. Benutzen Sie stets möglichst wenig Vertices zur Kontrolle von SubSurfaces, und stellen sie den SubSurface Level nicht auf 6. Wenn Sie später näheres zur Anwendung dieser wichtigen Technik wissen möchten, lesen Sie den Abschnitt Subdivision Surfaces.


Blender3D FreeTip.gif

Ansichtssachen

Um mit 3D-Objekten vernünftig arbeiten zu können, ist es wichtig sich im virtuellen Raum frei bewegen zu können. Daher gibt es zu diesem Thema auch eine eigene Seite: Navigation im dreidimensionalen Raum. Hier die allerwichtigsten Befehle:

  • Klicken und Halten von MMT im 3D-Fenster rotiert die Ansicht wenn Sie die Maus bewegen.
  • Scrollen des Mausrades zoomt ein oder aus. Haben Sie kein Mausrad, verwenden Sie die Plus- bzw. Minustasten auf der numerischen Tastatur.
  • Shift-MMT verschiebt die Ansicht.
  • Mit dem "Fadenkreuz/Rettungsring-Cursor" und der 'LMT' bestimmen sie 1. den Ort zum einfügen neuer Objekte und 2. mit der Taste "C" das "Center/ Zentrum" der Ansicht im 3D-Fenster!


Entlang einer Achse skalieren[Bearbeiten]

Gus ist noch ein wenig rundlich und soll abgemagert werden.

  • Wechseln Sie in die Seitenansicht mit Num-3.
  • Wechseln Sie wieder in den Edit Mode (Tab-Taste).
  • Zurück in die Drahtgitteransicht [Wireframe] (Z-Taste).
  • Wählen Sie alle Vertices mit A aus (Abbildung 13, links).
Abbildung 13: Gus mit eingeschränkter Skalierung verschlanken.
  • Drücken Sie S und bewegen die Maus leicht in horizontaler Richtung.
  • Klicken Sie MMT, um die Skalierung auf eine Achse einzuschränken. Wenn Sie die Maus nun auf Gus zubewegen wird er dünner, behält aber die gleiche Höhe und Breite. In der Werkzeugleiste des 3D Fenster wird der Skalierungsfaktor und die Achse angezeigt, an der skaliert wird. Im 3D Fenster ist die Achse an der skaliert wird, farbig markiert (hier in grün, weil es sich um die Y-Achse handelt).
  • Drücken und halten Sie Strg. Der Skalierungsfaktor ändert sich nun nur noch in diskreten Schritten von 0.1. Skalieren Sie Gus hinunter auf 0.2, bestätigen Sie die Änderung mit LMT.
  • Kehren Sie zur Frontansicht (Num-1) und Solid mode (Z-Taste) zurück, dann schauen Sie ihn sich noch einmal von allen Seiten an. Er ist viel besser so!
Blender3D FreeTip.gif

Alternativ hätten wir zur Skalierung auch die 3D Transform Widgets einsetzen können.



<<<Zurück

Aufwärmphase

Inhaltsverzeichnis
Glossar
Weiter>>>

Lasst uns Gus ansehen