Blender Dokumentation: Spiegelsymmetrische Objekte

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Objekte glätten
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Subdivision Surfaces


Diese Seite bezieht sich auf
Blender v2.44
Archiv-Version(en) verfügbar für:
2.42a, 2.37a

Spiegelsymmetrische Objekte[Bearbeiten]

Bei radiärsymmetrischen (Wagenrad, Qualle), drehsymmetrischen (Vase, Glocke) oder translationssymmetrischen (Gartenzaun, Schienenschwellen) Objekten ist es günstig, zuerst die Grundstruktur zu modellieren und sie dann als letzten Schritt mit SpinDup oder einem anderen geeigneten Befehl zu duplizieren (z.B. Array-Modifier).

Spiegelsymmetrische Objekte werden am sinnvollsten mit dem Mirror-Modifier erzeugt. Man erstellt nur die eine Hälfte eines Objektes, die zugehörige andere Hälfte wird automatisch erstellt. Die Vorgehensweise bei der Arbeit mit einem Mirror-Modifier ist folgende:

  • Man aktiviert für ein Mesh-Objekt den Mirror-Modifier und erstellt die eine Hälfte des Objektes.
  • Man erstellt Seams für das UV-Mapping.
  • Am besten erstellt man jetzt auch die UV-Map selbst, insbesondere wenn diese ebenfalls spiegelsymmetrisch ist.
  • Riggen und Skinnen erledigt man ebenfalls mit dem Mirror-Modifier, wenn man ohne Vertexgruppen und nur mit Envelopes arbeitet, kann man den Mirror-Modifier sogar belassen.
  • Man erstellt weitere Vertexgruppen, z.B. für Partikel.

Ob man den Mirror-Modifier jetzt anwenden muss oder nicht, hängt davon ab, ob man mit Vertexgruppen arbeiten muss und/oder Partikel benötigt. Partikeleffekte funktionieren nicht auf der gespiegelten Mesh-Seite, daher muss man bei der Benutzung von Partikeln (z.B. für Haare) den Mirror-Modifier permanent machen [Apply]. Seams, UV-Koordinaten und Vertexgruppen bleiben dabei erhalten und werden auf die andere Seite gespiegelt.

Bedienung[Bearbeiten]

Abbildung 1: Ein Beispiel für einen Mirror Modifier.
  • Der Mirror Modifier spiegelt entlang der lokalen X, Y oder Z-Achse des Objektes. (Eine Spiegelung entlang der X-Achse bedeutet eine Spiegelung an der Y-Z-Ebene.)
  • Dann werden nahe beieinanderliegende Vertices verschmolzen [merge].
  • Die Entfernung zu verschmelzender Vertices ist mit dem Merge Limit Parameter einstellbar. Man erhält auch ohne die permanente Anwendung des Modifiers eine glatt anschließende, spiegelsymmetrische Kopie.
  • Do Clipping verhindert, dass die Vertices des Ausgangsmeshes durch die Spiegelebene bewegt werden können. Sind Objekt und Kopie miteinander verbunden, können Sie mit eingeschaltetem Clipping nicht getrennt werden. Das ist sehr hilfreich, wenn man Vertices direkt auf der Symmetrieebene platzieren will.
  • Wenn Sie mit dem Model fertig sind können Sie entweder mit Apply die beiden Hälften zu einem Mesh machen oder es so lassen, um es später noch bearbeiten zu können.
  • Mirror U/V bezieht sich auf die UV-Koordinaten des gespiegelten Meshes. Man kann damit beiden Seiten unterschiedliche UV-Texturen verpassen (siehe unten für ein Beispiel).

Falls die Spiegelung mit dem Mirror-Modifier nicht die gewünschten Ergebnisse bringt, müssen zuerst die lokalen Achsen des Objektes an den globalen Achsen neu ausgerichtet werden. Dies geschieht über den Menüpunkt Object -> Clear/Apply -> Apply Size/Rotation. Dies ist sowieso sehr zu empfehlen, insbesondere wenn Sie das Objekt später animieren möchten. Auf der Seite Object Mode kann man auch mehr zu globalen und lokalen Koordinaten erfahren.

Anwendungsbeispiel[Bearbeiten]

Abbildung 2: Ausgangsvertices unseres Objektes.
Abbildung 3: Subsurf angeschaltet. Die Vertices erreichen nicht mehr die Symmetrieachse.
Abbildung 4: Mirror Modifier im Stack unter SubSurf. Die Linienzüge ergänzen sich nicht.
Abbildung 5: Mirror Modifier im Stack über Subsurf.
Abbildung 6: Do Clipping erleichtert das Zusammenfügen von Vertices.
  • Erstellen Sie in der Frontansicht (View->Front) eine Ebene (Add->Mesh->Plane). Sie ist der Ausgangspunkt für die eine Hälfte unseres Objektes. Sagen wir sie ist die linke Hälfte des Objektes, für uns also in der Frontansicht auf der rechten Seite. Die Mirror-Achse ist die X-Achse.
  • Bewegen Sie das Mesh (Netz) im Edit Mode, sodass es vollständig rechts von der Mittellinie ist.
  • Entfernen Sie eine Kante und verschieben Sie die Vertices so wie in Abbildung 2.

Für organische Modelle benötigen wir den Subsurf Modifier.

  • Fügen Sie den Subsurf-Modifier auf dem Modifiers Panel im Editing Kontext (F9) hinzu.
  • Schalten Sie den Cage-Modus für den Subsurf-Modifier an. Sie sehen in Abbildung 3, dass der Linienzug nun nicht mehr die Mittellinie (die Symmetrieebene) erreicht.
  • Fügen Sie nun den Mirror Modifier hinzu. Schalten Sie auch für ihn den Cage Modus an.

Die Linien sind nicht miteinander verbunden (Abbildung 4). Das ist meistens nicht das, was wir wollen. Mirror Modifier und Subsurf Modifier müssen vertauscht werden.

  • Verschieben Sie den Mirror Modifier vor den Subsurf Modifier.

Da der Mirror Modifier nun zuerst angewendet wird, und der Merge Limit nicht null ist, werden die beiden mittleren Vertices verschmolzen (Abbildung 5).

Um die Figur nun unten zu schließen, kann man sehr gut den Do Clipping Button benützen. Es ist sonst etwas schwierig, beim Zusammenführen der unteren Vertices genau die Stelle zu treffen, an der sie vom Merge Limit erfasst werden. Mit Do Clipping geht das automatisch. In Abbildung 6 habe ich nur einige Vertices zur rechten Seite hinzugefügt. Führt man den letzten Vertex bei eingeschaltetem Clipping in Richtung Mittellinie, werden die beiden Vertices vereinigt, und die Form ist geschlossen. Solange das Clipping eingeschaltet ist, kann man sie auch nicht wieder trennen, die Figur also nicht öffnen.

Ein komplexeres Beispiel[Bearbeiten]

Das Mesh für das folgende Beispiel wurde freundlicherweise von Sascha Kozacenko zur Verfügung gestellt.

Abbildung 7: Die eine Hälfte des Meshes ist fertig.

In Abbildung 7 sehen Sie die eine Hälfte des Meshes eines Drachens. Subsurf ist eingeschaltet. Fügt man den Mirror Modifier hinzu, wird das Mesh (fast) passgenau ergänzt. Nur am Mund und am Horn des Drachens gibt es kleine Unregelmäßigkeiten.


Abbildung 8: Der Mirror Modifier ist noch nicht perfekt eingestellt.

Die Lücken an der Lippe lassen sich beseitigen, wenn man den Subsurf und den Mirror Modifier vertauscht, d.h. den Mirror Modifier vor dem Subsurf Modifier anwendet. Die Vertices des Horns liegen nicht ganz genau auf der Mittellinie. Das Merge Limit muss behutsam soweit erhöht werden, bis alle Vertices verschmolzen sind (aber bitte nicht zu viele).


Abbildung 9: So soll das Ergebnis aussehen!
Abbildung 10: Das Modell des Drachen.



Verbinden von Armature und Mesh[Bearbeiten]

Abbildung 11: Das Amature-Panel am Ende der Bearbeitungsschritte.
  • Nachdem das Mesh fertig ist, fügt man eine Armature ein und erstellt die eine Hälfte der Armature. Dabei ist es wesentlich, dass die Bones nach dem Links/Rechts-Schema benannt werden, also z.B. Schulter.L, Arm.L, Hand.L usw.
  • Wählen Sie im Edit-Modus alle entsprechend benannten Bones aus ( 1 ) und duplizieren (Armature->Duplicate) Sie sie. Sie können die neuen Bones einfach irgendwohin verschieben.
  • Die duplizierten Bones sind noch ausgewählt. Im Armature-Menü finden Sie den Befehl Flip Left & Right Names, damit ändern Sie die Namen der duplizierten Bones in das entsprechende rechte bzw. linke Pendant ( 2 ).
  • Auf dem Armature-Panel wählen Sie X-Axis-Mirror (Abbildung 11).
  • Wählen Sie wieder die Ausgangsbones aus und drücken G, brechen die Aktion aber mit Esc ab. Die duplizierten Bones springen an den richtigen Platz ( 3 ).
  • Da wir hier zunächst mit Envelopes skinnen wollen, aktivieren Sie noch die Option Envelope auf dem Armatures Panel (Abbildung 11, im 3D-Fenster  4 ).
Abbildung 12: Die linke Seite einer Armature auf die rechte Seite kopieren.

Nun verbinden wir das Mesh mit der Armature wie üblich (Verbinden von Armature und Mesh).

  • Wechseln Sie mit der Armature in den Pose-Modus.
  • Wählen Sie zunächst das Mesh aus, dann mit Shift-RMT die Armature.
  • Drücken Sie Strg-P->Make Parent To->Armature. Im folgenden Dialog wählen Sie dann Create Vertex Groups?->Don't create groups.
  • Machen Sie die Armature parent deform zu einem echten Modifier, indem Sie auf Make Real klicken (Abbildung 13a).
  • Vertauschen Sie nun die Position von Armature- und Mirror-Modifier (Abbildung 13b).
Abbildung 13a: Modifier-Panel für das Mesh.
Abbildung 13b: Und mit echtem Armature-Modifier.

Mit Hilfe der Envelopes können Sie nun das Mesh animieren. Wenn die Envelopes zum Animieren genügen, sind wir hier fertig. Alle Änderungen an Mesh und Armature werden auf die jeweils andere Seite dynamisch übertragen. Vermutlich kommt aber irgendwann der Punkt, an dem Sie doch Vertexgruppen benutzen wollen. Ich werde hier nicht auf die Erstellung von Vertexgruppen oder das Umwandeln von Envelopes in Vertexgruppen eingehen, da diese Dinge in der Dokumentation ausreichend beschrieben sind.

Kopieren der Vertexgruppen[Bearbeiten]

  • Entfernen Sie den Mirror-Modifier. Ihr Mesh ist nur noch zur Hälfte zu sehen.
  • Definieren Sie die gewünschten Vertexgruppen wie üblich.
Blender3D FreeTip.gif

Jetzt kommt der Trick. Das Mesh wird im Objekt-Modus kopiert, und an dem neuen Objekt die Vertex-Gruppen umbenannt.


  • Wechseln Sie mit dem Mesh in den Objekt-Modus.
  • Duplizieren (Object->Duplicate) Sie das Mesh, und brechen mit Esc den Bewegungsmodus ab.
  • Spiegeln Sie das Objekt (Object->Mirror). Spiegeln Sie an der gleichen Achse, die Sie vorher am Mirror-Modifier eingestellt hatten, in dem Beispiel wäre das X Local.
  • Benennen Sie die Vertexgruppen um (z.B. von L nach R).
  • Wählen Sie zunächst das kopierte Objekt aus, dann mit Shift-RMT das ursprüngliche Objekt.
  • Verbinden Sie die beiden Objekte (Object->Join Objects).

Jetzt noch die letzten Aufräumarbeiten.

  • Wechseln Sie in den Edit-Modus, wählen alle Vertices aus und verschmelzen die Vertices an der Mittellinie (Mesh->Vertices->Remove Doubles).
  • Richten Sie die Flächennormalen gleichmäßig aus (Mesh->Normals->Recalculate Outside).

Damit haben Sie jetzt ein vollständig geriggtes und mit Vertexgruppen versehenes Objekt.

Mirror UV[Bearbeiten]

Damit die Option Mirror U/V klar werden, ein Beispiel:

Abbildung 14a: UV-Map. Links im 3D-Fenster das Original des Meshes, rechts die gespiegelte Kopie. Daneben das Bild im UV/Image-Editor.
Abbildung 14b: Option Mirror U aktiviert. Die UV-Map der gespiegelten Seite benutzt die Textur auf der rechten Seite, erfreulicherweise seitenrichtig. Auf dem Feld an der rechten Stirnseite steht die römische I, genauso orientiert wie die arabische 1 auf der anderen Seite.
Abbildung 14b: Mirro U und Mirror V aktiviert. Die UV-Kooridnaten der gespiegelten Seite sind um 180° gedreht.

Links[Bearbeiten]

Die englischsprachige Dokumentation der alten linked Duplicate Methode

<<<Zurück

Objekte glätten

Inhaltsverzeichnis
Glossar
Weiter>>>

Subdivision Surfaces