Blender Dokumentation: Material und Texturen für Gus

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Lasst uns Gus ansehen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Rigging


Diese Seite bezieht sich auf
Blender v2.46
Archiv-Version(en) verfügbar für:
2.42, 2.37a

Material für den Körper[Bearbeiten]

Jetzt werden wir Gus ein schönes Keks-Material verpassen.

  • Wählen Sie Gus aus.
  • Wechseln Sie in den Shading Kontext (F5).

Das Material für Gus ist ziemlich langweilig, da es einfach grau ist.

  • Die Bezeichnung Material für das Material ändern wir auf "GingerBread". Klicken Sie dazu in das Feld MA: und tippen Sie den neuen Namen ein.
  • Verändern sie die voreingestellten Werte so wie in Abbildung 1 dargestellt, um ein erstes Rohmaterial zu erhalten. Das Bild auf dem Preview Panel dient der Vorschau auf das Material.
Abbildung 1: Das Material buttons Window und ein erstes "GingerBread" Material. Die Panel wurden anders angeordnet, damit sie alle auf das Bild passen.

Das Material besitzt Textureinstellungen, den Einstellungen ist aber noch keine Textur zugeordnet.

  • Wechseln Sie in die Texture buttons (klicken Sie auf Blender3D TextureButton.png).
  • Nennen Sie die Textur "GingerTex" (wieder mit LMT ins Feld klicken).
  • Aus der Auswahlliste der Texture Types wählen Sie Stucci. Setzen Sie alle Parameter wie in Abb. 2.
Abbildung 2: Die Texture buttons mit einer Stucci Textur.

Hier soll einfach nur eine gewisse Unregelmäßigkeit erzeugt werden, die genauen Einstellungen spielen gar keine so große Rolle.

  • Kehren Sie zurück in die Material buttons (F5)
  • Holen Sie das Map To-Panel nach vorne (Abb. 1 ganz rechts unten, das hintere der drei Panels).

Auf dem Map To-Panel stellt man ein, welche Auswirkungen eine Textur auf das Material haben soll.

  • Stellen Sie Col aus und Nor an. Den Nor Schieberegler stellen Sie auf 0.75 (Abb. 3).

Dadurch wird die Stucci Textur zu einer sogenannten Bumpmap. Es sieht dann so aus, als hätte die Oberfläche von Gus Erhöhungen und Vertiefungen - eben so, wie ein Keks aussehen sollte.

Abbildung 3: Die Textureinstellungen in den Material buttons für die Stucci Textur.

Jetzt fügen wir eine zweite Textur hinzu.

  • Klicken Sie auf den zweiten Texturkanal (einer von den leeren Buttons auf dem Texture Panel). Klicken Sie auf Add New.
  • Nennen Sie diese neue Textur "Grain". Diese Textur soll nur den Ref Parameter beeinflussen. Jetzt wie in Abb. 4 u.re., den Blending Mode auf Add stellen und Var auf 0.4.
  • Jetzt mit F6 in die Texture-Buttons wechseln, als Textur-Typ wählen Sie wieder Stucci, diesmal allerdings mit Hard Noise und einer Noise Size von 0.020.

In Abb. 4 habe ich die relevanten Panel zusammengestellt. Ref beeinflusst die Helligkeit des Materials.

Abbildung 4: Einstellungen für die Ref Map. Oben die Textur, unten die Materialeinstellungen.
Abbildung 5: Ein einfaches Material für den Fußboden.

Der Fußboden bekommt ein einfaches, dunkelblaues Material nach den Einstellungen aus Abb. 5.

  • Wählen Sie den Fußboden aus. Der Fußboden hat noch kein Material.
  • Wechseln Sie in die Material-Buttons.
  • Klicken Sie auf dem Links and Pipeline-Panel auf Add New.
  • Ändern Sie die Einstellungen des Materials entsprechend Abb. 5, also den Namen und die Farbe.

Es ist jetzt wieder eine gute Gelegenheit ihre Datei zu speichern. Rendern Sie ein Bild und schauen Sie sich die verschiedenen Materialien an. Beobachten Sie die Wirkung der verschiedenen Texturen. Der Haken vor dem Texturnamen (Abb. 4, ganz links) kann eine Textur temporär deaktivieren.

Und wo sind die Augen und Drops Knöpfe? Die fügen wir nun hinzu.

Augen[Bearbeiten]

  • Schalten Sie in die Wireframe Ansicht (mit dem Draw Type-Menü in der Werkzeugleiste des 3D-Fensters).

Ich habe den 3D-Transformmanipulator für die Ansichten teilweise ausgeschaltet.

  • Platzieren Sie den 3D-Cursor ungefähr in die Mitte von Gus Kopf. Sie befinden sich in einem 3D-Programm, also müssen Sie den Cursor in mindestens zwei Ansichten platzieren. Teilen Sie dazu das Fenster und wählen eine Frontansicht und eine Seitenansicht.

Die genaue Position von Objekten ist leichter einzuschätzen, wenn Sie die orthographische Ansicht benutzen (View->Orthographic). Achten Sie darauf, dass Sie sich beim Hinzufügen von neuen Objekten im Object Mode befinden.

  • Fügen Sie eine Kugel hinzu (Space->Add->Mesh->UVSphere). Sie werden nach der Anzahl der Segments: und Rings: gefragt, die die Detailliertheit der Kugel angeben. Die voreingestellten 32 sind viel zu viel, stellen Sie beide Werte auf 16.

Zunächst werden wir die Kugel in allen drei Raumrichtungen kleiner skalieren.

  • Skalieren Sie die Kugel klein (S-Taste, Strg beim Skalieren drücken) auf einen Faktor von 0.1 in allen drei Raumrichtungen.
  • Dann wechseln Sie in die Seitenansicht.
  • Skalieren Sie nur noch in Y-Richtung (S-Y, Strg beim Skalieren drücken) um den Faktor 0.5.
  • Zoomen Sie ein bißchen in die Szene hinein (Num-+ oder MR oder Strg-MMT).
  • Bewegen Sie die Kugel nach links, so dass sie halb aus dem Kopf herausschaut. Dazu können Sie den Tranformmanipulator einsetzen (auf den grünen Pfeil klicken und verschieben) oder mit G-Y die Bewegungsrichtung auf die globale Y-Achse beschränken.
  • Zurück in der Vorderansicht bewegen (G) Sie die Kugel zur rechten Seite an die Stelle, wo Gus Auge sitzen soll.


Abbildung 6: Angriffspunkt für Rotation und Skalierung auf den 3D-Cursor setzen (Pivot-Menü)

Nun werden wir das Auge kopieren und spiegelbildlich im Gesicht von Gus platzieren. Für den Körper hatten wir einen Mirror Modifier benutzt, damit Sie auch noch eine andere Methode kennenlernen, werden Sie das Auge "von Hand" kopieren.

  • Wählen Sie den Eintrag 3D Cursor im Pivot-Menü des Headers des 3D-Fensters (Abb. 6).

Der 3D-Cursor befindet sich noch in der Mitte von Gus-Kopf. Er wird gleich als Spiegelpunkt dienen.

Blender3D FreeTip.gif

Reference center (Bezugspunkt)

Skalieren, Rotieren und andere Mesh Änderungen beziehen sich immer auf einen bestimmten Bezugspunkt. Das kann die Cursorposition, das Zentrum des Objektes, das Schwerezentrum des Objektes, das Zentrum der Bounding Box, das Schwerezentrum mehrerer ausgewählter Objekte oder das zuletzt ausgewählte Objekt sein (Abb. 6). Der Button der so aussieht wie ein Fadenkreuz, wählt den Cursor als Bezugspunkt aus.



Abbildung 7: Gus Kopf nach dem Hinzufügen der Augen.
  • Wechseln Sie in den Edit-Modus. Alle Vertices des Auges sind ausgewählt.
  • Drücken Sie Shift-D, um alle ausgewählten Vertices, Edges und Faces zu kopieren. Die neu erzeugten Objekte befinden sich im Bewegungsmodus (Grab Mode), drücken Sie Esc, um diesen Modus zu beenden, ohne die Vertices tatsächlich zu bewegen.
  • Wählen Sie Mesh->Mirror->X-Global um entlang der X-Achse zu spiegeln.

Gus Kopf sollte jetzt so aussehen wie in Abbildung 7.

Blender3D FreeTip.gif

Teile des Meshes als eigenes Objekt abtrennen

Wenn Sie sich doch mal mit dem Edit- und dem Object Modus beim Hinzufügen eines Mesh-Objektes vertun, kein Problem. Wählen Sie die gewünschten Vertices aus und drücken P für Separate. Dann wird ein neues Objekt aus diesen Vertices erstellt. Drücken Sie STR+J im "Object Mode, passiert genau das Gegenteil mit join kreiren sie ein Objekt aus 2 Meshes.




Mund[Bearbeiten]

Abbildung 8: SpinDup Werkzeug
  • Wechseln Sie in den Objekt-Modus (Tab).
  • Fügen Sie eine neue Kugel hinzu und skalieren und bewegen Sie sie wie vorhin das Auge, allerdings insgesamt etwas kleiner.
  • Bewegen Sie die neue Kugel an die Stelle, an der Gus Mund anfangen soll (Abb. 9, links).
  • Wechseln Sie in den Edit-Modus.
  • In den Editing Buttons (F9) im Edit Modus befinden sich die Buttons zur Steuerung des Spin Werkzeuges. Stellen Sie Degr: auf 90, Steps: auf 3 und überzeugen Sie sich, dass der Button Clockwise gedrückt ist.
  • Drücken Sie SpinDup (Abb. 8). Ein kleines Fragezeichen erscheint am Mauscursor. Klicken Sie mit LMT in die Vorderansicht. Das erzeugt drei Kopien auf einem 90 Grad Bogen, dessen Zentrum am Cursor liegt. Das Ergebnis sollte so aussehen wie das rechte Bild in Abb. 9.

Falls die nun erzeugten Kopien nicht wie im Bild ausgerichtet sind, bedenken Sie dass der Bezugspunkt der 3D-Marker ist.

Abbildung 9: Gus Mund wird mit SpinDup erzeugt.

Die Knopfleiste[Bearbeiten]

Abbildung 10: Gus Modell ist fertig.

Sie sind jetzt vermutlich in der Lage, drei weitere von diesen Ellipsoiden anzufertigen, die Gus' Knöpfe darstellen sollen.

  • Beenden Sie den Edit-Modus.
  • Erzeugen Sie zuerst einen Knopf, drücken Shift-D um eine Kopie anzufertigen und verschieben die Kopie wie in Abb. 10 gezeigt.
  • Erzeugen Sie den dritten Knopf, indem Sie den zweiten kopieren.


Das übrige Material[Bearbeiten]

Augen, Mund und Knöpfe bekommen jeweils ein eigenes Material. Die Augen werden "schokoladig", der Mund soll aus weißem Zucker bestehen. Die Knöpfe sollen rot, weiß und grün werden. Da der Mund und der mittlere Knopf aus weißem Zucker bestehen sollen, sollen sie natürlich das gleiche Material erhalten.

Die Materialien sind sehr ähnlich. Daher benutzen wir ein Material und "kopieren" dieses Material auf das nächste Objekt. Dieses Kopieren funktioniert in Blender etwas anders, als Sie es vermutlich gewohnt sind.

  • Wählen Sie die Augen aus und erstellen Sie das Material Choccolate:
    • RGB: 0.3/0.18/0.0
    • Ref: 0.5
    • Spec: 1.50
    • Hard: 255
  • Wählen Sie nun den Mund aus. Der Mund trägt noch kein Material.
  • Klicken Sie auf dem Links and Pipeline-Panel auf den Doppelpfeil neben dem Add New-Button.
  • Wählen Sie das Material Choccolate aus.


Abbildung 11: Das Material hat zwei Benutzer.

Wie Sie nun auf dem Links and Pipeline-Panel sehen können, hat das Material zwei Benutzer (Abb. 11). Das Material ist also nicht kopiert worden, sondern mit zwei Objekten verlinkt. Ändern wir jetzt das Material, würde es sich auf allen verlinkten Objekten ändern. Das ist in diesem Fall unerwünscht, daher muss aus dem verlinkten Material eine echte Kopie gemacht werden (ein sog. Single User).

  • Klicken Sie auf die kleine "2" neben dem Materialnamen, und bestätigen Sie Single user.


Das Material heißt jetzt Choccolate.001.

  • Benennen Sie das Material in White Sugar um, und ändern Sie folgende Einstellungen:
    • RGB: 1.0/1.0/1.0
    • Ref: 0.9
    • Spec: 0.9
Blender3D FreeTip.gif

Verlinken statt Kopieren

Diese Vorgehensweise zum Kopieren von Objekten ist typisch in Blender. Zunächst wird etwas verlinkt, also an mehreren Stellen benutzt. Das ist sehr praktisch, spart es doch überflüssigen Speicherplatz und ermöglicht die nachträgliche Veränderung von vielen Objekten auf einmal. Benötigen Sie dann eine eigenständige Kopie, wird die Verlinkung aufgehoben, und durch eine echte Kopie ersetzt. Dieser Vorgang heißt in Blender "Make Single User". Auf diese Weise lassen sich viele Objekte mit dem gleichen Material versehen, 3D Objekte können in vielen Szenen gleichzeitig benutzt werden, lassen sich aber trotzdem noch nachträglich ändern usw.


Wie oben beschrieben, erzeugen Sie weitere Materialien:

  • Wählen Sie den obersten Knopf aus.
  • Verlinken Sie zum Material White Sugar.
  • Erzeugen Sie einen Single User.
  • Bennen Sie das Material in Red Sugar um.
  • Ändern Sie die Farbe auf rot.
  • Verfahren Sie genauso für den untersten Knopf, der soll aber grün werden (Green Sugar).
  • Wählen Sie für den mittleren Knopf das Material White Sugar aus der Menüliste aus. Dieser Knopf bleibt weiß.

Dieses Material soll noch die Grain-Textur von dem Keks-Material erhalten. Bei den Texturen kann man ebenfalls vorhandene Texturen durch Menüauswahl einem Kanal zuweisen, aber die Textur hat ja auch noch Materialeinstellungen. Diese Materialeinstellungen müssen ebenfalls übertragen werden. Diesen Vorgang werde ich schrittweise beschreiben:

  1. Wählen Sie den Körper von Gus aus (RMT).
  2. Wählen Sie im Texture-Panel die Grain-Textur aus (LMT).
  3. Klicken Sie (LMT) auf den Copy To Buffer-Button (Pfeil nach oben auf dem Texture-Panel) Blender3D CopyToFromBuffer.png.
  4. Wählen Sie den Mund aus (RMT).
  5. Wählen Sie den ersten Texturkanal aus.
  6. Klicken Sie (LMT) auf den Pastes From Buffer-Button (Pfeil nach unten).


Das Material White Sugar sollte dann insgesamt so aussehen wie in Abb. 12.


Abbildung 12: White Sugar. Achten Sie insbesondere auf die Zahlen neben dem Materialnamen und neben der Textur. Zwei Objekte tragen das Material, zwei Materialien benutzen die Textur. Aber drei Objekte tragen die Textur!


Abbildung 13: Gus mit Material

Nachdem wir alle Materialien erzeugt und zugewiesen haben, sollten wir mal wieder ein Bild rendern. Das Ergebnis sollte so ähnlich aussehen wie in Abb. 13.

Wenn Sie wollen, können Sie ihr Bild nun speichern. Drücken Sie dazu bei offenem Render-Fenster F3. Benennen Sie die Datei und klicken auf Save XXX, wobei XXX das Dateiformat angibt. Die Dateiendung wird automatisch angehängt.


Blender3D FreeTip.gif

Dateitypen

In den Render buttons (F10) im Format-Panel stellen Sie das gewünschte Dateiformat ein. Sie können nur in dem Format speichern, in dem Sie auch gerendert haben.


Die erste Hälfte dieser Einführung ist nun beendet, unsere Figur ist fertig. In der nächsten Hälfte der Einführung bringen wir Gus das Laufen bei.


<<<Zurück

Lasst uns Gus ansehen

Inhaltsverzeichnis
Glossar
Weiter>>>

Rigging