Blender Dokumentation: UV-Tutorial

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
UV-Mapping Einleitung
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
UV-Projektionsverfahren


Diese Seite bezieht sich auf Blender v2.46
Abb. 1: Eine typische Arbeitsumgebung für die UV-Abwicklung



In Abb. 1 sehen Sie eine Arbeitsumgebung, wie sie für die UV-Abwicklung geeignet ist.

Im 3D-Fenster sehen Sie das abzuwickelnde Objekt (linkes Fenster). Hier werden alle Vorarbeiten für die Abwicklung getroffen und gleichzeitig können Sie die zugewiesenen Bilder auf dem Objekt in einer Vorschauansicht betrachten. Der UV-Editor (rechtes Fenster) wird dazu benutzt, die Abwicklung weiter zu bearbeiten und den einzelnen Flächen Bilder zuzuweisen oder sie zu verändern.

Die Panels «UV Calculation» und «Texture Face» in den Editing Buttons [F9] enthalten Einstellungen für die Abwicklung des Meshes im UV Editor und für die Ansicht des Meshes im 3d View. Das Panel «Texture Faces» erscheint allerdings erst, wenn das Mesh UV-Koordinaten besitzt, also zumindest einmal abgewickelt wurde [Unwrap].

Einstiegstutorial[Bearbeiten]

Abb. 2: Das Endergebnis


In diesem Beispiel texturieren wir eine DVD-Hülle. Die dafür benötigten Bilder finden Sie unten auf der Seite im Abschnitt "Originalbilder".

  • Öffnen Sie eine neue Standardszene mit Strg-X und splitten den Bildschirm. Das rechte Fenster ändern Sie in die UV/Image Editor Ansicht.
Abb. 3: Die DVD Hülle mit selektierter Vorderseite
  • Öffnen Sie mit N im 3D-Fenster das Panel «Transform Properties» , wählen den Würfel im ObjectMode aus und geben unter ScaleX = 19, ScaleY = 13.5 und ScaleZ = 1.5 ein. Jetzt hat der Würfel die richtigen Proportionen und kann mit S so weit verkleinert werden, das er in der normalen Ansicht gut sichtbar ist.
Blender3D FreeDifficulty.gif

Die UV-Abwicklung erfolgt seit Version 2.46 im EditMode. Daher kann dort kein FaceSelect-Mode mehr ausgewählt werden. Es genügt stattdessen ein einfaches Drücken der U-Taste im EditMode, um das Mesh abzuwickeln.


  • Wechseln Sie in den EditMode mit Tab und dann in den FaceSelect-Mode Strg - Tab und wählen das obere Face des Meshes aus (Abb. 3).
Abb. 4: Das UV Calculation Menü mit allen Abwicklungsarten
  • Drücken Sie nun U und wählen den obersten Eintrag in der Liste – Unwrap.

Im UV/Image Editor erscheint ein kleines gelbes Quadrat.

  • Öffnen Sie im UV/Image Editor-Fenster das Menü «Image» und klicken mit gedrückter Strg Taste auf den Eintrag «open». Es öffnet sich der Image Browser. Hier wählen Sie das Bild, das die Vorderseite der Videohülle darstellt und bestätigen mit einem Klick auf den Button «Open Image».


Das Bild wird nun im UV/Image Editor angezeigt, allerdings noch nicht auf dem Mesh im 3d View. Dafür müssen Sie entweder

  • im 3D-Fenster in den Textured View wechseln

oder

  • in den Solid View wechseln und im View Properties-Panel Solid Tex aktivieren (Umsch - T)
Abbildung 4a: Einstellen des Draw Type.


Abb. 5: Das Bild um 90 Grad rotieren

In meinem Beispiel ist das Bild allerdings noch nicht richtig auf der Hülle platziert, sondern um 90 Grad im Uhrzeigersinn verdreht. Sie können diesen Fehler entweder im 3DView oder im UV/Image Editor korrigieren. Am einfachsten ist es in diesem Fall im 3DView. Drücken Sie mit dem Cursor im 3d View Strg - F und wählen im Menü den Eintrag «UV Rotate». Das Bild rotiert in der 3d Ansicht um 90 Grad. Möchten Sie in die Gegenrichtung rotieren, halten Sie beim Klicken auf UV Rotate die Umsch Taste gedrückt. Wiederholen Sie diese Aktion so oft, bis das Bild seine richtige Position erreicht hat. Bei dieser Aktion werden nicht die Vertices verschoben, sondern nur die UV-Textkoordinaten in Bezug auf das Bild.

Etwas aufwändiger ist in diesem Fall die Bearbeitung im UV/Image Editor, die in den nun folgenden Abschnitten erläutert wird.

Auswählen, Ansichten und visuelle Hilfsmittel[Bearbeiten]

Während im ersten Beispiel nur das Bild im Verhältnis zu den Texturkoordinaten gedreht wurde, müssen nun die Texturkoordinaten selbst transformiert werden, die Lage des Bildes hingegen bleibt unverändert. Deswegen möchten wir Ihnen zuerst einige grundlegende Arbeits- und Anzeigemethoden vorstellen, damit Sie die nötigen Transformation vornehmen können.

Auswählen und Transformieren im UV-Editor[Bearbeiten]

Die Funktionen "Auswählen" und "Transformieren" funktionieren im UV-Editor so wie im 3D-Fenster.

  • mit RMT wählen Sie einzelne Vertices oder Faces aus
  • mit A selektierten/deselektieren Sie alles
  • mit B wird die Rechteckauswahl aufgezogen
  • mit Strg - LMT starten Sie die Lassoauswahl
  • G S R aktivieren die bekannten Transformationen
  • mit H werden ausgewählte Vertices ausgeblendet, mit Alt - H eingeblendet

Ansichten und Bildschirmdarstellung[Bearbeiten]

In unserem Beispiel wurde nur eine einzelne Fläche abgewickelt. Dies dürfte aber eher eine Ausnahme bilden, weil normalerweise sehr viele Faces auf einmal dargestellt werden müssen. Um hierbei die Übersicht zu behalten gibt es einige nützliche Einstellungen, die Ihnen die Arbeit erleichtern.

Abb. 6: Sync UV and Mesh Selection. Links ohne Sync zwischen 3D- und UV/Image Edtitor Fenster, rechts mit Synchronisation.
  • Aktivieren Sie den Button Sync UV and Mesh Selection (falls nicht automatisch aktiv), dann werden im UV-Editor ausgewählte Vertices auch im 3D-Fenster ausgewählt und umgekehrt. Dies hat den Nebeneffekt, dass alle abgewickelten Faces im UV-Editor dargestellt werden, und nicht nur die gerade ausgewählten. Mit den beiden Buttons rechts daneben wird zwischen Vertex- und Faceselect-Modus umgeschaltet (Abb. 6).
  • Für die Darstellung der Edges und Faces im UV-Editor gibt es weitere Einstellungsmöglichkeiten. Öffnen Sie dafür unter View → View Properties das View Properties-Panel.
  • Aktivieren Sie im View-Menü die Option Update Automatically. Nehmen Sie Änderungen an der Projektion im UV-Editor vor, wird die Anzeige der Textur auf dem Mesh im 3D-View automatisch angepasst. Damit haben Sie eine Echtzeitkontrolle bei allen Transformationen.
  • Die Ansicht wird wie im 3D-View gezoomt. Mit NumPad . (Punkt) wird das aktive Face in der Mitte des UV-Editors dargestellt, mit Pos1 schalten Sie zurück in die Gesamtansicht.


Nach dieser langen Vorrede sind Sie nun endlich in der Lage, die Abwicklung im UV-Editor so zu bearbeiten, dass die Ansicht im 3D-View richtig ist.

  • Wählen Sie das Face im UV-Editor aus und rotieren es dort um 90 Grad. Halten Sie dabei die Strg Taste gedrückt, dreht sich die Auswahl nur in Rasterschritten. Beobachten Sie das Ergebnis in der Echtzeitvorschau im 3D-View. Falls nötig verschieben Sie einzelne Vertices so, dass die UV-Vertices genau an den Eckpunkten der Bildvorlage liegen.
  • Bearbeiten Sie nun die Rückseite und den Buchrücken der Schachtel nach den gleichen Prinzipien wie oben geschildert.

Ein neues Bild erzeugen[Bearbeiten]

Abb. 7: Für diese drei Seiten brauchen wir noch ein Bild.

Sind diese Arbeiten abgeschlossen, bleiben noch drei Schmalseiten übrig, die wir im nächsten Schritt texturieren müssen (siehe Abb. 7).

  • Selektieren Sie eine Seite, wickeln diese ab und wählen nun Image → New Alt - N. In dem erscheinenden Menü lassen Sie alle Einstellungen unverändert bis auf die Bildgröße. Setzen Sie diese auf 256 x 256 (px) und bestätigen mit Ok (Abb. 8).

Das Bild ist jetzt zwar angelegt, muss aber in einem zweiten Schritt gesondert abgespeichert werden.

  • Wählen Sie deswegen Image → Save as und speichern das Bild mit einem aussagekräftigen Namen ab.
Abb. 8: Einstellungen für die neue Textur.
  • Selektieren Sie nun nacheinander die restlichen, unbearbeiteten Faces, wickeln sie diese ab und weisen ihnen das gerade abgespeicherte Bild zu.

Wie groß eine Bildtextur sein muss, um auf dem Mesh sauber dargestellt zu werden hängt davon ab, wie groß diese Textur im abschließenden Renderbild sein soll. Als Sicherheitsfaktor nimmt man für das Original eine 1.5 bis 2fache Größe. Wenn das aufgebrachte Bild also im Render 200px groß ist, genügt eine Originalgröße zwischen 300 und 400px. Da es sich in diesem Fall um ein gleichmäßig schwarzes Bild handelt, treten aber selbst bei kleinen Größen keine Probleme auf.

Eigenschaften auf andere Faces kopieren[Bearbeiten]

Sie haben gerade jeder abgewickelten Seite das Bild jeweils in einem eigenen Arbeitsschritt zugewiesen. Bei der in diesem Beispiel geringen Anzahl von Flächen ist dieses Vorgehen vertretbar. Wenn es sich allerdings um viele Flächen (> 20) handelt, ist es empfehlswert, die Bilder den einzelnen Flächen per Copy Befehl zuzuweisen.

Die alternative Vorgehensweise wäre dann:

  • Markieren Sie alle drei Flächen und wickeln diese ab.
  • Weisen Sie der ersten Fläche das schwarze Bild zu.
  • Selektieren Sie nun im 3d-View die zweite, dritte und am Ende wieder die erste Fläche. Sie ist nun die aktive Fläche. Wählen Sie Strg - C und in dem erscheinenden Menü «Copy Face Selected» den Eintrag «Active Image». Das schwarze Bild wird den anderen Flächen automatisch zugeordnet.


Die Arbeiten im UV-Editor sind nun abgeschlossen, allerdings werden beim Rendern die aufgebrachten Bilder noch nicht dargestellt. Dafür muss im nächsten Schritt ein Material angelegt werden.

Materialien mit UV-Texturen anlegen[Bearbeiten]

Material mit der Einstellung Texface[Bearbeiten]

  • Wechseln Sie in die Material Buttons [F5], legen ein neues Material an (falls nicht standardmäßig vorhanden) und aktivieren im Panel Material den Button Texface.

Nun wird die Textur gerendert, allerdings ist diese Lösung beschränkt, da sich auf diese Weise nur Colormaps abbilden lassen. Diese Möglichkeit sollten Sie nur dann benutzen, wenn Sie mehr UV-Texturen als Materialindizes benutzen wollen, oder wie in unserem Fall jedem Face ein unterschiedliches Bild zuweisen möchten. Häufig wird man UV-Koordinaten auch für Normal-Maps oder Spec-Maps usw. verwenden wollen, daher ist eine andere Lösung günstiger.


Material mit der Einstellung UV[Bearbeiten]

Abb. 9 Alle Einzelbilder zu einem zusammen gefasst. Die einzelnen Flächen wurden neu abgewickelt und auf dem Bild platziert.

Entscheiden Sie sich für diese Methode, können Sie die Abwicklung und Bilder aus dem Beispiel «Texface» leider nicht mehr ohne weiteres verwenden, weil der Arbeitsablauf ein anderer ist. Der Vorteil dieser Methode liegt allerdings darin, dass nun auch Texturen für Aspekte wie z.B. Spec, Bump und Nor den UV-Koordinaten zugewiesen werden können. Die hier beschriebene Vorgehensweise wird in den überwiegenden Fällen Anwendung finden.

  • Öffnen Sie ein Bildbearbeitungsprogramm Ihrer Wahl und bringen Sie alle Einzelbilder in einem einzigen zusammen. Vergessen Sie dabei nicht, auch eine schwarze Fläche für Seiten der Hülle mit anzulegen.
  • Rufen Sie das Bild im UV/Image-Editor auf, wickeln die Flächen neu ab und verschieben die UV-Vertices auf die richtige Position. Eine mögliche Lösung sehen Sie in Abb. 9



Abb. 10: Die Image Textur wird angelegt
  • Falls noch nicht vorhanden, legen Sie eine neue Textur an und rufen das soeben erstellte Bild in den Texture Buttons als «Image» auf.
Abb. 11: Der Button UV muss aktiv, der Button Texface hingegen ausgeschalter sein
  • Die Einstellungen im Material müssen geändert werden, damit die UV Textur nicht mehr per «Texface» sondern über den Eintrag «UV» im Panel «MapInput» berechnet wird.(Abb. 11)
  • Deaktivieren Sie im Panel Material den Button Texface!
  • Wenn Sie nun F 12 drücken, wird das Modell mit der Textur gerendert.



Script verwenden[Bearbeiten]

Abb. 12: Das Script Consolidate into one image.

Anstatt das Bild von Hand zusammenzukopieren und die Abwicklung so vorzunehmen, dass nur ein Bild verwendet wird, können Sie diese Arbeit auch das Script Consolidate into one image erledigen lassen. Allerdings müssen Sie dafür eine aktuelle Python-Version installiert haben, wozu wir Sie an dieser Stelle nachdrücklich ermutigen möchten und was auch von der Blenderfoundation empfohlen wird.

  • Wechseln Sie einmal in den Object-Modus, dann wieder zurück in den Edit-Modus und markieren alle Faces mit A. Bei meinen Experimenten mit dem Script habe ich festgestellt, das dieses Vorgehen eingehalten werden muss, da es ansonsten zu Fehlermeldungen kommt. Das Script «Consolidate into one image» finden Sie im «Image-Menü».

In unserem Fall brauchen Sie die Defaultwerte nicht zu ändern. In anderen Anwendungen, wo die Bildqualität eine wichtige Rolle spielt, sollten Sie aber beachten, das die originalen Bilder auf das vorgegebene Format (zwangs)abgebildet und damit im Zweifelsfall verkleinert bzw. verzerrt werden. Ist nichts anderes angegeben, wird das Bild im gleichen Verzeichnis wie das Blendfile abgespeichert.

  • Wenn Sie auf OK drücken, startet die Berechnung und im UV Editor wird das fertige Bild angezeigt und die einzelnen Faces zugewiesen.
  • Legen Sie - wie weiter oben beschrieben - ein neues Material incl. Textur mit den entsprechenden Einstellungen an.


Abb. 13: Das Script-Ergebnis: alle Einzelbilder wurden zusammen gefasst.

Originalbilder[Bearbeiten]

Blender3D ruecken big bug.jpg
Blender3D vorderseite big bug.jpg
Blender3D rueckseite big bug.jpg
Blender3D huelle alles zusammen.jpg



<<<Zurück

UV-Mapping Einleitung

Inhaltsverzeichnis
Glossar
Weiter>>>

UV-Projektionsverfahren