GIMP/ Tutorials

Aus Wikibooks
Wechseln zu: Navigation, Suche
Tutorials

Dieser Teil gehört zum Buch „GIMP“.

Kurzinhalt: Hier findest du eine Liste von Tutorials, wird noch ausgebaut.

Rote Augen aus Bildern entfernen [Bearbeiten]

Personen, die in dunklen Räumen aufgenommen wurden, haben häufig rote Augen. Es gibt aus der Freeware-Szene zahlreiche Programme, mit denen es kein Problem ist, per Mausklick die rote Augenfarbe zu entfernen. Für GIMP 2.4 gibt es ebenfalls ein Skript, das automatisch die rote Augen entfernt. Sie finden es unter http://gimpguru.org/download/red-eye.scm. GIMP 2.6 liefert einen solchen Filter mit, den Sie über die Menüfolge Filter - Verbessern und Rote Augen entfernen erreichen. GIMP gibt als Schwellenwert die Zahl 50 vor. Im Regelfall können Sie diesen Wert übernehmen. Für ein besseres Ergebnis empfiehlt sich aber die manuelle Vorgehensweise.

  1. Ziehen Sie mit der Lupe Gimp lupe.png ein Rechteck im Bereich, in dem das rote Auge liegt, soweit auf, bis es Ihnen möglich ist, mit Hilfe des elliptischen Auswahlwerkzeugs Elliptische auswahl.png die Umrisse der Pupille auszuwählen.
  2. Mit dem Verschieben-Werkzeug Auswahl verschieben.png verschieben Sie die Auswahl solange, bis sie in der Mitte sitzt. Aktivieren Sie dazu in den Werkzeugeinstellungen des Verschieben-Werkzeugs die Option Auswahl transformieren (GIMP 2.4) oder Auswahl (GIMP 2.6).
    Auswahl transformieren.png
  3. Über die Funktion schnelle Maske (Umschalttaste+Q) können Sie Ihre Auswahl noch verfeinern. Wundern Sie sich nicht über die ungewöhnlichen Funktionen des Radierers, des Pinsels und des Stifts. Der Radierer ist dafür verantwortlich, neue Bereiche hinzuzufügen - im Gegensatz dazu entfernt der Pinsel und der Stift einzelne Pixel aus der Auswahl.
    Kanalmixer.png
  4. Nachdem Sie die rote Pupille ausgewählt haben, können Sie über den Kanalmixer den Rot-Anteil auf 10% verringern und den Grün- und Blau-Anteil auf die Werte 40% bis 50% erhöhen. Zu erreichen ist der Kanalmixer in GIMP 2.4 über Filter - Farben und in GIMP 2.6 über Farben - Komponenten.
  5. Um ein natürlicheres Erscheinungsbild zu erhalten, sollten Sie über Filter und Weichzeichnen den Gauß'scher Weichzeichner verwenden. Mit diesem Filter vermeiden Sie zu scharfe, unnatürliche Kanten.


Objekte freistellen [Bearbeiten]

Eine vor allem für Fotomontagen oft verwendete Technik ist das Freistellen von Objekten. Man wählt die Umrisse eines Objektes aus und entfernt den Hintergrund. Zum Auswählen von Bildbereichen gibt es mehrere Auswahlwerkzeuge - welches davon sich am besten eignet, richtet sich nach dem Ausgangsbild. Dieses Kapitel wird die Methoden und Werkzeuge anhand verschiedener Beispiele Schritt für Schritt vorstellen. Wir werden feststellen, dass gute Ergebnisse immer auch Handarbeit sind. Automatische Werkzeuge sind fürs Grobe hilfreich, für perfekte Ergebnisse muss meistens nachjustiert werden.

Die Auswahlwerkzeuge in GIMP

Rechteckige AuswahlElliptische AuswahlFreihändige AuswahlZauberstabMagnetische SchereVordergrundauswahlAuswahl nach Farbe

Die ersten sieben Werkzeuge im Werkzeugfenster sind zum Erzeugen und Bearbeiten von Auswahlen gedacht: Rechteckige Auswahl (R-Taste), Elliptische Auswahl (E-Taste), Freihändige Auswahl (F-Taste), Zauberstab (U-Taste), Magnetische Schere (I-Taste), Vordergrundauswahl und Auswahl nach Farbe (Shift + O). Das Pfadwerkzeug eignet sich ebenfalls zum Erstellen von Auswahlen, da jederzeit ein Pfad in eine Auswahl verwandelt werden kann und umgekehrt.

Mit Hilfe der ersten drei Werkzeuge und des Pfadwerkzeugs lassen sich manuelle Auswahlen erzeugen, die anderen sollen selbstständig Umrisse erkennen und Ihnen so die Arbeit erleichtern.

Modifizieren der Werkzeuge im Reiter „Werkzeugeinstellungen“

Jedes dieser Werkzeuge hat eigene Optionen, die sich im Fenster „Werkzeugeinstellungen“ jeweils anpassen lassen. Das Fenster befindet sich standardmäßig unter dem Werkzeugfenster, sie können es aber auch über das Menü „Dialoge“ erreichen.

Beispiel: Tierchen auf Apfel[Bearbeiten]

Ausgangsbild

Wir beginnen mit einem einfachen Beispiel. Einfach bedeutet in diesem Fall Kontrastreich (klarer Helligkeitsunterschied zum Hintergrund), einfarbiger Hintergrund und scharfes Objekt. Bei geringer  Schärfentiefe oder langer  Belichtungszeit ist ein Teil des Objektes unscharf, was das Freistellen deutlich schwieriger macht.

GIMP bringt eine kleine Hilfe für solche Situationen: Das Werkzeug zum Auswählen eines Bildumrisses Gimp-icon-umriss.png (I). Damit kannst du Punkte um das Objekt vorgeben, und dazwischen findet GIMP automatisch den Umriss, solange die Punkte nicht zu weit auseinander sind.

Beginnen wir also mit dem Freistellen. Lade dir das Ausgangsbild runter, öffne es in GIMP und speichere es als .xcf-Datei. Setze nun den ersten Punkt auf die Linie zwischen Tier und Apfelschale (ist übrigens ein Spartan), dann den zweiten etwas davon entfernt:


Erster Schritt


Nun geht es weiter. Wiederhole das, bis du um das ganze Tierchen bist. Achte dabei darauf, dass der Umriss zwischen zwei aufeinander folgenden Punkten möglichst gerade ist und keine extremen Spitzen hat, der Algorithmus würde sonst Fehler machen.

beinahe herum



Was aber nun, wenn das Werkzeug mal nicht genau gewählt hat? Kein Problem. Du kannst die Linien ziehen (ausser die, die mit dem letzten gemachten Punkt verbunden ist) und so einen neuen Punkt einfügen. Ziehe die Pfade, die falsch liegen, wieder zwischen Apfelschale und Tier.

Schlussendlich musst du, wenn du den Umriss wieder mit dem Anfangspunkt verbunden hast, das ganze in eine Auswahl verändern. Halt dazu zuerst die Taste Shift gedrückt und klicke dann auf das Tier. Nun ist das umrandete Tier zu einer Auswahl geworden.

Tier ausgewählt


Jetzt wird endlich freigestellt. Wähle den Hintergrund aus, indem du Ctrl-I drückst (Auswahl invertieren). Nun ist nicht mehr das Tier, sondern alles andere ausgewählt:

Vordergrund ausgewählt


Zuletzt drückst du Ctrl-X, um alles auszuschneiden.

Tier freigestellt


Weiterführung[Bearbeiten]

Ebenenmaske hinzufügen

Und jetzt? Das Bild sieht nicht besonders gut aus. Darum: Mit Ctrl-Z den letzten Schritt rückgängig machen. Die Auswahl haben wir noch. Dupliziere die Ebene im Ebenendialog über das Icon oder die rechte Maustaste. Falls du den Dialog nicht hast: Im «The GIMP»-Hauptfenster kannst du ihn unter Datei > Dialoge > Dock hinzufügen > Ebenen, Kanäle und Pfäde holen. Nun füge der oberen Ebene mit der Rechten Maustaste eine Ebenenmaske hinzu und verwende die Standardeinstellungen. Die Ebenenmaske ist nun aktiviert, das heisst, alles, was du zeichnest, kommt da drauf. Wenn du schwarz malst, wird der Bildteil transparent, mit weisser Farbe holst du ihn wieder.

Wir wollen nun alles andere unsichtbar machen, ausser dem Tier. Mit dem Füllwerkzeug oder per Shift-B füllst du die Auswahl, die wir immer noch von weiter oben haben. Achte darauf, dass du mit Schwarz malst! Mit x kannst du übrigens zwischen Vorder- und Hintergrundfarbe wechseln. Was geschieht? Nichts!

Doch. Das Vorschaubild der Ebenenmaske, die du übrigens auch sichtbar machen kannst, indem du bei gedrückter Alt-Taste darauf klickst, hat sich geändert; Der Umriss des Tieres ist zu sehen.

Wenn du auf das Auge bei der unteren Ebene klickst, kannst du diese verschwinden lassen. Dann siehst du auch die Auswirkungen: Bei der oberen Ebene ist der Hintergrund verschwunden. Mache die untere Ebene wieder sichtbar. Nun können wir mit den Ebenenmodi etwas herumspielen. Wir können zum Beispiel das Tier heller oder dunkler machen, den Hintergrund aber so belassen, wie er ist. Übrigens kannst du die Auswahl nun mit Shift-Ctrl-A löschen oder zuvor über das Menu mit Auswahl > In Kanal speichern in einem separaten Kanal sichern.

Wir machen das Tier nun etwas dunkler. Wähle als Modus im Ebenendialog Multiplikation und eine Deckkraft von 50 %. Der Unterschied:

Beispiel: Silberwurz[Bearbeiten]

Ausgangsbild

Die obere Technik ist mehr für einfache Beispiele. Bei komplexeren Objekten oder bei solchen mit unscharfem Rand versagt sie. Darum schauen wir nun weitere Techniken an.

Dupliziere zuerst die Ebene. So kannst du im Notfall immer noch auf das Original zurückgreifen. Wir wollen bei diesem Bild die Blüte ausschneiden und den Farbton korrigieren – aber nur den der Blüte. Füge der neuen Ebene wieder eine neue Ebenenmaske hinzu! Diesmal wählen wir als Modus, für den Pinsel, «Faser extrahieren», die Deckkraft wieder 50 %. Das dient vorerst nur dazu, dass wir überhaupt sehen, was wir ändern und was nicht. Das Bild sieht nun so aus:

Faser extrahieren, 50 %


Wähle als Werkzeug den Pinsel, über das Icon oder mit P. Wähle die Ebenenmaske an – sie bekommt einen weissen Rahmen. Ist er schwarz, ist die Ebene nicht aktiv und du zeichnest auf etwas anderes. Wir brauchen nur schwarz und weiss. Wähle die Vordergrundfarbe Schwarz. Der Pinsel sollte für diese Pflanze «weich» sein; Wähle den «Circle Fuzzy 7×7». Eventuell musst du den Pinsel-Dialog noch zuerst holen (Shift-Ctrl-B). Du kannst ihn an den Ebenendialog andocken, indem du ihn unter der Symbolleiste anfasst und unten an den Ebenendialog ziehst. Jetzt beginnen wir, den Rand der Pflanze zu malen. Du darfst dabei aber nicht genau in die Mitte zeichnen, sondern so, dass der äusserste Teil vom Pinsel dort ist, wo das Weiss der Blüte – die ja etwas «unscharf» ist – aufhört. Mit etwas Übung geht das ganz gut. Zoome genügend weit rein, damit du auch sauber arbeiten kannst! Du bist zudem schneller.

Die oberste Ecke habe ich hier umfahren:

Oberste Ecke


Mache das nun für die ganze Blüte. Denke daran: Wenn du zu viel schwarz gezeichnet hast, kannst du x drücken, um die Farbe zu wechseln, und korrigieren. Und je nachdem, wie unscharf der Blütenrand ist, musst du einen grösseren Pinsel nehmen; Im unteren Bereich wirst du ungefähr einen 13×13-Pinsel brauchen. Und verwende das Scrollrad, um zu scrollen! Mit gedrückter SHIFT-Taste (Hochstelltaste) kannst du horizontal scrollen, bei gedrückter CRTL-Taste (strg-Taste auf Dt. Tastatueren) vergrössern oder verkleinern. Vergiss nicht, dich zu vergewissern, dass die Deckkraft des Pinsels auf 100 % ist! Ich habe es vergessen. Am Schluss sollte alles etwa so aussehen:

Umrandete Blüte


Grüner Rahmen

Jetzt bearbeiten wir direkt die Ebenenmaske. Klicke bei gedrückter Alt-Taste auf das Vorschaubild der Ebenenmaske. Es bekommt einen grünen Rand, und du hast nun den Umriss der Blüte auf dem Bildschirm. Mit der gedrückten Ctrl-Taste kann man die Ebenenmaske übrigens auch deaktivieren; das Vorschaubild hat dann einen roten Rand.

Rahmen


Mit dem Füllwerkzeug füllen wir nun die Blüte aus. Da wegen dem weichen Rand des Pinsels ein zweiter Rand entsteht, auf der Innenseite der Blüte, müssen wir den noch schnell entfernen, am besten mit einem «harten» Pinsel (kreisrund). Aber das geht schnell. Wir bekommen das:

Rahmen


Und nachdem wir die Ebenenmaske wieder unsichtbar gemacht haben:

Das ist aber nicht das, was wir wollen. Momentan wirkt die Maske auf den Hintergrund, nicht auf die Blüte. Also Ebenenmaske wieder sichtbar machen. Mit der rechten Maustaste können wir die Farben invertieren (umkehren) über Ebene > Farben > Invertieren, dann die untere (Original-)Ebene unsichtbar machen mit einem Klick auf das Auge. Setze die Deckkraft wieder auf 100 % und wähle als Ebenenmodus «Normal». Nun haben wir die Blüte:


Freigestellte Blüte




Wikibooks-Hinweise
Druckversion des Buches GIMP/ Tutorials
  • Dieses Buch umfasst derzeit etwa DIN-A4-Seiten einschließlich Bilder (Stand: ).
  • Wenn Sie dieses Buch drucken oder die Druckvorschau Ihres Browsers verwenden, ist diese Notiz nicht sichtbar.
  • Zum Drucken klicken Sie in der linken Menüleiste im Abschnitt „Drucken/exportieren“ auf Als PDF herunterladen.
  • Mehr Informationen über Druckversionen siehe Hilfe:Fertigstellen/ PDF-Versionen.
  • Hinweise:
    • Für einen reinen Text-Ausdruck kann man die Bilder-Darstellung im Browser deaktivieren:
      • Internet-Explorer: Extras > Internetoptionen > Erweitert > Bilder anzeigen (Häkchen entfernen und mit OK bestätigen)
      • Mozilla Firefox: Extras > Einstellungen > Inhalt > Grafiken laden (Häkchen entfernen und mit OK bestätigen)
      • Opera: Ansicht > Bilder > Keine Bilder
    • Texte, die in Klappboxen stehen, werden nicht immer ausgedruckt (abhängig von der Definition). Auf jeden Fall müssen sie ausgeklappt sein, wenn sie gedruckt werden sollen.
    • Die Funktion „Als PDF herunterladen“ kann zu Darstellungsfehlern führen.
  • Autorenliste, sofern möglich
CC some rights reserved.svg
Heckert GNU white.svg

Dieser Text ist sowohl unter der „Creative Commons Attribution/Share-Alike“-Lizenz 3.0 als auch GFDL lizenziert.

Eine deutschsprachige Beschreibung für Autoren und Weiternutzer findet man in den Nutzungsbedingungen der Wikimedia Foundation.