GIMP/ Einführung

Aus Wikibooks
Zur Navigation springen Zur Suche springen
Einführung

Dieser Teil gehört zum Buch „GIMP“.

Kurzinhalt: Dieses Kapitel enthält Informationen, die entweder bereits vor dem Start von GIMP wichtig sind, oder aber jedenfalls vor dem eigentlichen Arbeitsbeginn. Wer schon Erfahrungen mit GIMP hat, wird dieses Kapitel in der Regel nicht lesen müssen.

Download und Installation [Bearbeiten]

Vorbemerkung[Bearbeiten]

Diese Seite beinhaltet Informationen zum Beschaffen (Download) und zum Installieren von GIMP sowie zu einigen Fragen, die unmittelbar damit zusammenhängen, etwa die Wahl der "richtigen" Version von GIMP, und gewisse Spezialfälle. Da GIMP auf einer sehr grossen Zahl Plattformen und auf sehr vielen, auch relativ "exotischen", Betriebssystemen läuft (oder irgendwie zum Laufen gebracht werden kann), ist es völlig unmöglich hier jedes Szenario zu beschreiben. Die Erfahrung zeigt aber, dass Nutzerinnen und Nutzer von relativ seltenen Betriebssystemen oder Konfigurationen meist ein recht hohes technisches Wissen haben (müssen), weshalb sie eher weniger Unterstützung für solche Fragen brauchen als durchschnittliche Anwenderinnen und Anwender. Es sei bemerkt, dass Personen, die GIMP bereits installiert haben und das Programm ohne "Zwischenfälle" starten können, diese Seite in der Regel nicht lesen müssen. Nicht auf dieser Seite beschrieben wird der Download und die Installation von Erweiterungen für GIMP.

GIMP beschaffen (downloaden) und installieren[Bearbeiten]

Grundregel[Bearbeiten]

Bei der Beschaffung von GIMP (und übrigens bei der Beschaffung von fast aller Software, die überhaupt online verfügbar ist) gilt ein einfacher Grundsatz: Der mit Abstand beste Weg ist der Download aus den offiziellen Quellen. Jede andere Beschaffungsart ist grundsätzlich schlechter oder riskanter oder sogar beides. Der Download aus nicht-offiziellen Quellen (Beispiele für solche Quellen sind im besseren Fall die Portale grosser Verlage von Computerzeitschriften, im schlechteren dubiose Anbieter mit unklaren Absichten) hat zum Beispiel oft den Nachteil, dass die angebotenen Dateien nicht original sind, sondern z. B. mit Werbematerial des Anbieters oder von Dritten "vermüllt" sind. Wenn es böse kommt, werden beim Download Schadprogramme aufs System geladen und unter Umständen sofort installiert. Weiter sind die angebotenen Versionen nicht immer aktuell, was eigentlich nur Nachteile hat. Dieselben Nachteile gelten im Prinzip auch für das Beschaffen von GIMP aus Offline-Quellen, insbesondere von DVDs, die zum Beispiel Zeitschriften oder Büchern beiliegen. Natürlich lädt man sich nicht mit jeder solchen fragwürdigen Beschaffung gerade die schlimmsten Schädlinge aufs System, aber die Wahrscheinlichkeit, dass zumindest eines der Probleme auftaucht, ist sehr gross. Letztlich ist der Download aus offiziellen Quellen nichts anderes als eine Vorsichtsmassnahme vor allerhand Ungemach.

Download und Installation von GIMP für Windows[Bearbeiten]

Für alle aktuell unterstützten Versionen von Windows (Windows Vista, Windows 7, Windows 8, Windows 8.1) steht unter der offiziellen Downloadseite von GIMP eine Installationsdatei zur Verfügung. Der Installer erkennt sogar selber, ob das System eine 32-Bit-Architektur oder eine 64-Bit-Architektur hat, und installiert automatisch die passende Version. Natürlich gäbe es Wege auf einem 64-Bit-System „nur“ die Version für 32-Bit-Systeme zu installieren, die durchaus laufen würde (das Umgekehrte gilt aber nicht!), doch besteht für so etwas kein vernünftiger Grund. Wenn Sie nicht wissen, welche der beiden Architekturen Ihr System hat, ist das somit – bezüglich der Installation von GIMP – egal. Es sei noch bemerkt, dass 32-Bit-Systeme aktuell (2017) nur noch sehr selten sind.

Es gibt noch Folgendes zu beachten: Die Download-Seite von GIMP versucht vorrangig eine so genannte Torrent-Datei anzubieten. Läd man diese herunter, läd man damit noch nicht GIMP herunter. Um sie für einen Download zu benutzen, bedarf es weiterer Software. Natürlich gibt es zahlreiche (auch kostenlose) Programme für Windows, die problemlos mit Torrent-Dateien umgehen können, aber für Einsteiger, die sich nicht „auch noch“ damit beschäftigen wollen, ist es empfehlenswert, direkt die installierbare Setup-.exe-Datei als Download zu wählen. Diese kann neben der Torrent-Datei ausgewählt werden. Ohne diesen Punkt hier zu sehr vertiefen zu wollen: Das Herunterladen über Torrent-Dateien ist eine fortschrittliche Download-Methode, die die Lasten der Downloadserver viel besser verteilt. Sie ist im Linux-Umfeld sehr verbreitet, im Windows-Umfeld aber noch nicht Standard. Deshalb haben gängige Linux-Distributionen meist gleich standardmässig einen so genannten Torrent-Client (ein Programm für den Umgang mit Torrent-Dateien bzw. für den Download mit dieser Methode) installiert, Windows jedoch nicht.

Die eigentliche Installation unter Windows erfordert nur wenige Benutzerinteraktionen. Der Installer verlangt Administratorrechte, und die Sprache von GIMP muss ausgewählt werden. GIMP erkennt übrigens die vermutlich richtige Sprache selber, sofern das verwendete Windows dieselbe Sprache hat, wie GIMP haben soll (das ist in nahezu allen Fällen so). Der eigentliche Installationsvorgang dauert kaum über zwei Minuten.

Download und Installation von GIMP für (Mac) OS X[Bearbeiten]

GIMP ist auch für alle aktuellen Versionen der Betriebssysteme (Mac) OS X erhältlich. Der Download erfolgt ebenfalls über die offizielle Downloadseite von GIMP. Da die Navigation auf der Downloadseite etwas eigenwillig gestaltet ist, sei noch der Hinweis gegeben, wie man zu GIMP für (Mac) OS X kommt: Man muss Show other downloads (etwa in der Mitte der Seite) anklicken, dann klappt eine reichhaltige Auswahl von Installationsdateien für andere Betriebssysteme als Windows auf. Unter GIMP for Mac OS X findet man das Gewünschte. Wie unter Windows (siehe oben) versucht die Downloadseite der Besucherschaft zunächst die Torrent-Datei schmackhaft zu machen. Wer noch keinen Torrent-Client auf seinem Apple-Rechner installiert hat und das auch nicht zuerst tun will, findet unter ...this link. die direkt ausführbare Installationsdatei.

Download und Installation von GIMP für Linux-Distributionen[Bearbeiten]

GIMP steht für zahlreiche (eigentlich alle) Linux-Distributionen zur Verfügung. Wegen der Vielfalt der Distributionen sind hier nur die wichtigsten Fälle beschrieben. Wer "exotische" Distributionen nutzt, muss unter Umständen zusätzliche Recherchen vornehmen oder GIMP selber kompilieren.

Ein erstes Szenario ist, dass GIMP sogar Teil der Standardinstallation ist, d. h. bei der Installation des Betriebssystem direkt mitinstalliert wird. Das war früher recht häufig, ist aber heute nicht mehr der Normalfall. Der Grund ist, dass die meisten üblichen Linux-Distributionen den Anspruch haben, dass das ganze Betriebssystem inklusiv aller standardmässig zu installierender Software auf einer DVD Platz hat. Da GIMP doch ein recht umfangreiches Programm ist (der Umfang ist aber der Funktionalität durchaus angemessen), ist GIMP bei vielen Distributionen sozusagen "von der DVD verbannt" worden. Falls GIMP dennoch direkt installiert wurde, muss man natürlich als Benutzerin oder Benutzer überhaupt nichts mehr unternehmen - ausser prüfen, welche Version von GIMP man hat.

Das häufigste Szenario ist, dass GIMP zwar nicht gerade direkt zusammen mit der Linux-Distribution installiert wird, aber Teil der offiziellen Paketquellen ist. In diesem Fall sind der Download und die Installation sehr einfach. Da der Download und das Installieren von (insbesondere offiziellen) Paketen zum Grundwissen für die Benutzung einer Linux-Distribution gehört, wird hier auf eine weiterführende Einführung verzichtet. Ein Problem muss aber angesprochen werden: Es ist leider nicht immer so, dass in den offiziellen Paketquellen die neuste Version von GIMP liegt. Es muss in dem Fall abgeschätzt werden, ob die vorhandene Version aktuell genug für eine zeitgemässe Verwendung ist. Mehr zu diesem Problem findet sich im Abschnitt Versionen von GIMP unten.

Wenn sehr seltene Linux-Distributionen verwendet werden, ist es möglich, dass GIMP überhaupt nicht in den Paketquellen vorhanden ist. Dennoch ist es möglich, GIMP auch auf solchen Betriebssystemen zu verwenden. Im einfacheren Fall ist es möglich, zumindest vorkompilierte Versionen von GIMP zu downloaden und dann zu entpacken und zu installieren. Dabei ist vorgängig natürlich unbedingt abzuklären, ob die angebotenen vorkompilierten Pakete zur fraglichen Linux-Distribution passen! Sogar wenn es nicht einmal vorkompilierte Pakete für eine besonders exklusive Linux-Distribution gibt, kann GIMP trotzdem installiert werden. In dem Fall muss zuerst der Quellcode von GIMP heruntergeladen werden. Dieser wird von GIMP als so genannte Tarballs angeboten und kann hier heruntergeladen werden. GIMP muss danach selbst kompiliert werden. Das Selberkompilieren von Software ist nicht ganz einsteigertauglich und grundsätzlich nicht Thema dieses Buches. Beispielsweise muss sichergestellt werden, dass das Zielsystem alle fürs Funktionieren von GIMP nötigen Pakete enthält bzw. diese müssen ggf. vorher ebenfalls heruntergeladen und kompiliert werden (eine Liste findet sich hier]. Bei der ganzen Angelegenheit handelt sich aber eigentlich um ein Scheinproblem: Wer solche "exotischen" Linux-Distributionen benutzt, wird (und muss) sich sowieso mit dem Thema Kompilieren beschäftigen. Das Szenario bezieht sich mehrheitlich auf Linux-Distributionen, die sowieso (als Ganzes) selber kompiliert werden (müssen).

Download und Installation der internen Hilfe[Bearbeiten]

GIMP verfügt als wichtiges Merkmal über eine sehr weit entwickelte interne Hilfe, die in mehreren Sprachen, seit Langem auch in Deutsch, angeboten wird. Diese Hilfe ist nicht automatisch Teil der Installation, sondern muss, bei Bedarf, zusätzlich installiert werden. Selbstverständlich kann GIMP in voller Funktionalität auch ohne die Installation dieser Hilfe benutzt werden. Insgesamt ist die zusätzliche Installation der Hilfe jedoch klar zu empfehlen, und zwar nicht einmal nur für Einsteigerinnen und Einsteiger (für die aber sowieso). GIMP hat die Eigenheit, dass viele Aufgaben auf mehr als eine Weise erledigt werden können (gar nicht so selten auf drei oder sogar noch mehr Arten!). Das gibt der Benutzerschaft natürlich eine enorme Freiheit in der Bedienung des Programms. Der Preis für diese enorme Vielfalt ist aber natürlich, dass das Programm halt schon sehr komplex aufgebaut ist. Deshalb ist es eine beträchtliche Erleichterung, mit der internen Hilfe schnell etwas nachschauen zu können, ohne Bücher oder Webseiten konsultieren zu müssen. Der Speicherbedarf der Hilfedatei von knapp 30 MB ist für heutige Systeme kein ernsthaftes Gegenargument mehr.

Im Unterschied zum Programm selber ist die interne Hilfe für jede der unterstützten Sprachen als eigenständige Datei vorhanden (dagegen wird ja bei der Installation des Programms die gewünschte Sprache erst im Rahmen der eigentlichen Installation gewählt, d. h. der Download enthält alle Sprachpakete). Dies muss beim Download beachtet werden, d. h. es muss die Datei oder das Paket der gewünschten Sprache heruntergeladen werden. Für Windows findet sich die interne Hilfe wieder auf der offiziellen Downloadseite von GIMP; GIMP nennt die interne Hilfe offiziell GIMP User Manual. Die Sprachen sind alphabetisch sortiert. Download und Installation sind selbsterklärend bzw. laufen problemlos durch. Die GIMP-Istallation wird automatisch erkannt; eine (an sich mögliche) manuelle Anpassung ist nur nötig, wenn GIMP in ein nicht standardmässiges Verzeichnis installiert wurde, was Privatanwendern aber ohnehin nicht zu empfehlen ist.

Etwas mühsamer ist leider der Download der internen Hilfe für (Mac) OS X: Es gibt derzeit kein offizielles Download-Angebot auf der GIMP-Download-Seite. Man muss sich hier mit einem Download über den nicht unumstrittenen Dienst Sourceforge behelfen, den Dritte zur Verfügung stellen. Die deutschsprachige interne Hilfe für GIMP unter (Mac) OS X ist hier zu finden. Allerdings ist die Wahrscheinlichkeit, sich für (Mac) OS X Schadsoftware aufs System zu laden, weit geringer als für Windows, so dass der Link trotz Vorbehalte empfohlen werden kann. Bisher sind keine konkreten Warnungen betreffend dieses Angebot bekannt. Jedenfalls ist allenfalls zusätzlich zum Download oder zur Installation vorgeschlagene Software unbedingt abzuwählen. Der Vorbehalt gilt ausdrücklich nur gegenüber dem Downloaddienst Sourceforge und nicht gegenüber der Privatperson, die den Download überhaupt erst ermöglicht. Zur Verfügung gestellt wird dieses Angebot von Simone Karin Lehmann, die die auf das Thema GIMP für (Mac) OS X spezialisierte Webseite Lisanet betreibt. Der Besuch dieser Webseite ist für Benutzerinnen und Benutzer von GIMP unter (Mac) OS X generell zu empfehlen, da hier oft Informationen zu GIMP unter (Mac) OS X veröffentlicht werden, die sonst nur schwer, und jedenfalls nicht in Deutsch, zugänglich sind.

Verhältnismässig einfach wiederum ist der Download und die Installation der internen Hilfe für Linux-Distributionen, sofern GIMP nicht gerade selber kompiliert wurde. Im häufigsten Szenario, wenn nämlich GIMP aus den offiziellen Paketquellen installiert wird, befindet sich das Paket für die interne Hilfe ebenfalls dort. Wie bei den anderen Betriebssystemen hat jede unterstützte Sprache ein eigenes Paket, so dass die gewünschte Sprache ausgewählt werden muss. Ist GIMP bereits vorinstalliert, muss unter Umständen die interne Hilfe trotzdem noch nachinstalliert werden. Anwender, die GIMP für ihre Linux-Installation selber kompiliert haben, können dasselbe selbstverständlich auch mit der internen Hilfe tun. Die Tarballs dafür können von hier heruntergeladen werden. Es ist auf Folgendes zu achten: Es stehen für GIMP 2.8 nur Tarballs zur Verfügung, die alle unterstützte Sprachen enthalten, nicht nur die gewünschte. Deshalb ist die Hilfe-Datei satte 150 MB schwer.

GIMP für weitere Betriebssysteme[Bearbeiten]

Android[Bearbeiten]

GIMP kann mit gewissen Einschränkungen auf dem Betriebssystem Android verwendet werden. Android ist ein Betriebssystem, das für Smartphones und Tablets existiert. Es ist zwar technisch gesehen ein Linux, jedoch keine (übliche) Linux-Distribution, weshalb Android faktisch ein eigenes Betriebssystem ist. Auf Smartphones ist Android heute (sogar mit Abstand) das häufigste Betriebssystem. Da das Arbeiten mit GIMP auf Smartphones wegen den relativ kleinen Displays sehr gewöhnungsbedürftig ist, ist GIMP auf Android noch wenig verbreitet. Allerdings gibt es Android nicht nur für Smartphones, sondern auch für Tablets. Auf diesen Geräten ist das Arbeiten mit GIMP zwar nicht ganz so bequem wie auf Systemen mit (noch) grösseren Monitoren, aber durchaus einigermassen produktiv möglich.

Um GIMP für Android zu installieren, muss man Zugang zum so genannten Playstore der Firma Google haben. Alternative Anbieter von Programmen ("Apps") für Android führen GIMP derzeit nicht. Allerdings haben die meisten Benutzerinnen und Benutzer von Android-Geräten sowieso einen solchen Zugang; die Einschränkung sei dennoch erwähnt. Es bedeutet zum Beispiel, dass GIMP für Android derzeit nur auf Android-Versionen installierbar ist, die von Google kommen. Die App heisst etwas überraschend GIMP Inkscape. Sie enthält nämlich nicht nur die Android-Version von GIMP, sondern integriert auch noch gleich das Vektorgrafikprogramm Inkscape. Da Inkscape nicht Thema dieses Buches ist, wird auf diesen Aspekt nicht weiter eingegangen. Der Speicherbedarf von (mindestens) 700 MB ist für Tablets zwar nichts ganz Aussergewöhnliches, für Smartphones freilich sehr hoch. Dieser Bedarf ist nicht einfach damit erklärt, dass die App mit GIMP und Inkscape gleich zwei zwar durchaus "wuchtige" Programme enthält. Vielmehr führt folgendes Problem zu diesem exorbitanten Speicherbedarf: Die Oberfläche des Betriebssystem Android ist technisch gar nicht in der Lage, die sehr komplexe "Fensterlandschaft" eines noch mit Inkscape verstärkten GIMPs darzustellen! Deshalb lädt diese App extra noch gleich eine zusätzliche Desktopumgebung auf das Android-betriebene Gerät, nämlich Xfce. Salopp ausgedrückt wird also für diese App zusätzlich noch ein weiteres halbes Betriebssystem mitinstalliert. Ob man das Ganze zumal auf Smartphones nicht doch eher für eine Spielerei hält, ist Ansichtssache. Sicher ist, dass man seinen Androiden mit dieser App ordentlich brummen lassen kann (vor dem Download empfiehlt es sich unbedingt abzuklären, was für Preiskonditionen man bei seinem Netzanbieter für den Datenverkehr hat - oder man weicht auf ein kostenloses WLAN aus!). Bis vor Kurzem konnte diese GIMP-Inkscape-App nicht auf externen Speicherkarten installiert werden was ihre reale Verfügbarkeit auf Tablets und ein paar wenige Smarthone-Modelle begrenzt hat, doch ist das inzwischen möglich. Die interne Hilfe ist für GIMP auf Android derzeit nicht installierbar.

iOS[Bearbeiten]

Für Geräte des Unternehmens Apple, die mit dem Betriebssystem iOS betrieben werden, ist GIMP nicht verfügbar. Mit iOS werden im Wesentlichen Apples Smartphones, die so genannten iPhones, sowie Apples Tablets, die so genannten iPads, betrieben. Das GIMP auf iOS nicht installierbar ist, hat natürlich keine technischen Ursachen - die Portierung von GIMP auf iOS wäre problemlos machbar -, sondern ist ein unternehmerischer Entscheid von Apple. Er betrifft nicht besonders GIMP, sonder alle Software, die unter einer Variante der GPL-Lizenz veröffentlicht wird. Apple ist für diesen Entscheid immer wieder heftig kritisiert worden; insbesondere wurde dem Konzern vorgeworfen, damit verhindern zu wollen, dass auf iOS-betriebenen Geräten Software installiert werden kann, die besser funktioniert oder mehr kann als Apple-eigene Programme. Bezüglich GIMP ist freilich zu sagen, dass dessen Verwendung auf iPhones wohl ohnehin nicht gerade naheliegend wäre, da die iPhones im Vergleich zu Smartphones anderer Anbieter und damit mit anderen Betriebssystemen, insbesondere mit Android, tendenziell kleinere Displays haben (fürs 2014 erschienene iPhone 6 gilt das aber nicht mehr uneingeschränkt, da es ein deutlich grösseres Display hat als die früheren Modelle). Selbst die Verwendung von GIMP auf Smartphones mit grossen Displays ist indes gewöhnungsbedürftig.

Deutlich schmerzlicher als der Ausschluss von GIMP vom iPhone ist allerdings, dass GIMP auch auf dem iPad nicht installiert werden kann. Tablets sind grundsätzlich durchaus für die Verwendung von GIMP geeignet, auch wenn das Arbeiten auf Geräten mit (noch) grösseren Monitoren für anspruchsvolle Bildbearbeitung sicher angenehmer ist. iOS ist mit einem momentanen (2015) weltweiten Anteil von 7 bis 10 Prozent an allen von internetfähigen Geräten verwendeten Betriebssystemen mit grossem Abstand das wichtigste, unter dem GIMP nicht installiert und verwendet werden kann. Hinter der Abwehrhaltung von Apple steckt an sich nicht eine grundlegende Ablehnung von Open-Source-Software - auf (Mac) OS X funktioniert GIMP ja einwandfrei -, sondern eine Ablehnung von GPL-lizenzierten Apps im Apple-eigenen App-Store. Es muss offen bleiben, ob Apple diese Politik auch in Zukunft aufrechterhält. Zum Schluss sei erwähnt, dass es unter Umständen möglich ist, GIMP auf einem iOS-betriebenen Gerät zu installieren, sobald das Gerät "gejailbreakt" ist oder wird. Darauf wird hier aber nicht eingegangen, da das Jailbreaken nicht Thema dieses Buches ist und für unbedarfte Anwender Risiken entstehen (und sei es nur, dass das Gerät dann nicht mehr korrekt funktioniert).

BSD-artige Betriebssysteme[Bearbeiten]

GIMP kann auf BSD-artigen Betreiebbsystemen installiert und verwendet werden. Für die beiden heute häufigsten BSD-artigen Betriebssysteme, FreeBSD und OpenBSD, werden von offizieller Seite aktuelle Versionen angeboten. Für FreeBSD ist GIMP auf dieser Downloadseite erhältlich. Auch die interne Hilfe, auch in deutscher Sprache, kann für GIMP unter FreeBSD installiert werden. Es sei noch erwähnt, dass wegen der engen Verwandtschaft von FreeBSD mit Linux (technisch heisst diese Verwandtschaft Binärkompatibilität) sogar die Verwendung von (ggf. selbst unter Linux) kompilierter GIMP-Versionen möglich ist. Für OpenBSD steht GIMP ebebfalls zur Verfügung, und zwar hier. Die interne Hilfe steht für OpenBSD nicht direkt zur Verfügung; möglich ist aber der Umweg übers Selberkompilieren. Die Installation von Software unter FreeBSD oder OpenBSD wird hier nicht weiter erklärt; insgesamt ist das Verfahren gewissen Vorgehensweisen unter Linux verwandt, wobei allerdings immer "höchstens" vorkompilierte Pakete verwendet werden (was unter Linux natürlich auch möglich, bei den verbreitesten Distributionen mit beliebter Software wie GIMP aber in der Regel nicht nötig ist - ausser man wolle eine aktuellere Version installieren, als die offiziellen Paketquellen enthalten). Wer FreeBSD oder OpenBSD nutzt, wird sich so oder so mit dem Umgang mit vorkompilierten Softwarepaketen beschäftigen müssen. Das Selberkompilieren von GIMP stellt auch unter FreeBSD und OpenBSD die Ausnahme dar, ist aber natürlich möglich. Auf andere BSD-artige Betriebssysteme als FreeBSD oder OpenBSD (es gibt noch etliche!) wird hier nicht eingegangen: Wer solche benutzt, wird auch GIMP installieren können.

Solaris-artige Betriebssysteme[Bearbeiten]

GIMP kann auf Solaris 11, der aktuellen Version dieses Betriebssystems von Oracle, installiert werden. Das Verfahren ähnelt sehr jenem für FreeBSD oder OpenBSD, was natürlich kein Zufall ist: Das Betriebssystem Solaris ist mit den BSD-artigen Betriebssystemen eng verwandt (noch enger als mit Linux). Die interne Hilfe ist nur über den Umweg des Selbstkompilierens installierbar.

Neben Solaris 11 existieren noch eine ganze Reihe von Abkömmlingen von Solaris, die als Solaris-artige Betriebssysteme bezeichnet werden können. Wegen den für Normalsterbliche geringfügigen technischen Unterschiede zu Solaris 11 ist anzunehmen, dass GIMP auf allen Solaris-artigen Betriebssystemen installiert werden kann (im Extremfall durch Selbstkompilieren).

GIMP Portable (nur Windows)[Bearbeiten]

Als portable Version eines Programms bezeichnet man eine Programmvariante, bei der das Programm zur Benützung nicht installiert werden muss, sondern "direkt", ohne Installation, benutzt werden kann. Portable Programmvarianten existieren aus technischen Gründen nur für Windows. Sozusagen alle heute aktuellen übrigen Betriebssyteme ausser Windows beruhen technikgeschichtlich auf Unix, und unter (in einem weiten Sinne) unixoiden Betriebssystemen ist es nicht in der Weise möglich Programme "ohne Installation" zu benützen. Auch von GIMP existiert für Windows seit Langem eine portable Version. Es ist zu betonen, dass diese nicht offiziell von der GIMP-Community angeboten wird. Anbieter ist vielmehr PortableApps unter John Haller. Allerdings wird das Angebot von GIMP wohlwollend betrachtet, und es sind keine Beschwerden gegen den Anbieter bekannt. PortableApps bietet noch viele andere Programme für Windows in portablen Varianten an. GIMP portable kann hier heruntergeladen werden.

Die portable Version von GIMP hat den Vorteil, dass so GIMP auch dann benutzt werden kann, wenn man auf einem bestimmten Windows-System GIMP nicht installieren will, oder dafür keine Berechtigung hat. Der Programmstart ist denkbar einfach: Man muss dazu nur die .exe-Datei anklicken, und das Programm startet. Häufig wird gesagt, dass portable Programmversionen solche sind, die ab einem USB-Stick gestartet werden. Das ist sicher ein häufiges Anwendungsszenario, aber technisch spielt es überhaupt keine Rolle, wo die .exe-Datei gespeichert ist. Man kann GIMP Portable durchaus auch auf eine interne Festplatte kopieren und von dort starten. Möglich ist sogar, die .exe-Datei auf eine beschreibbare CD oder DVD zu kopieren und von dort aus zu starten.

Auf den ersten Blick scheint GIMP Portable gegenüber der installierten Variante nur Vorteile zu haben, aber das trifft durchaus nicht zu. In Wirklichkeit gibt es etliche Einschränkungen zu gewärtigen. Dass die interne Hilfe mit GIMP Portable nicht benutzt werden kann, ist eher von untergeordneter Bedeutung. Vor allem aber ist es bei der Verwendung von GIMP Portable nicht möglich, dauerhafte Benutzerprofile anzulegen (GIMP Portable legt durchaus bei jedem Systemart ein solches Profil an, löscht es aber bei Programmende wieder). Das hat zur Folge, dass keine personalisierten Einstellungen des Programms (des Programms, nicht von bearbeiteten Bildern!) gespeichert werden können. Also muss man GIMP Portable entweder immer in der Standardkonfiguration nutzen, oder man muss seine bevorzugte Konfiguration nach jedem Programmstart neu einstellen. In der Praxis ist das recht lästig. Dazu nur ein Beispiel: GIMP startet in der Standardinstallation im sehr gewöhnungsbedürftigen Mehrfenster-Modus. Gerade Windows-Benutzer, zumal Einsteiger, bevorzugen nahezu immer den Einzelfenster-Modus. Verwendet man GIMP Portable, muss man das nach jedem Programmstart umstellen (oder sich an den Mehrfenster-Modus gewöhnen).

Insgesamt ist GIMP Portable ein durchaus interessanter "Notnagel", wenn man, z. B. unterwegs, mit GIMP arbeiten will und das Programm auf einem zur Verfügung stehenden System nicht installieren will oder darf. Als Dauerlösung taugt es für die Mehrheit der Benutzer nicht. Schliesslich sei noch folgender Legende widersprochen: Es hat sich irgendwie in manchen Köpfen festgesetzt, für die Installation von GIMP auf Netzwerken unter Windows sei GIMP Portable besser geeignet als die "normale" GIMP-Version für Windows. Das ist indes falsch. Wird GIMP Portable nämlich wie das "normale" GIMP installiert, funktioniert das Programm fehlerhaft. Das ist auch auf Windows-Netzwerken so.

Welche Version von GIMP verwenden?[Bearbeiten]

Wie viele Programme hat jede Version von GIMP eine Nummer. Bei GIMP besteht diese Versionnbummer aus drei Zahlen, die wie üblich mit Punkten voneinander abgetrennt sind. Die aktuellste Version ist seit August 2014 2.8.14 . Die ersten zwei Zahlen (aktuell also 2.8) bezeichnen dabei die Hauptversion, die letzte Zahl (aktuell 14) bezeichnet die Unterversion. Bei GIMP gibt es bei den ersten zwei Zahlen der Versionsnummer keine innere Hierarchie, d. h. man könnte die aktuelle GIMP-Hauptversion ebenso gut GIMP 28 nennen. Wie in der Software-Entwicklung üblich gilt auch bei GIMP, dass neue Funktionen und grössere Veränderungen der Programmoberfläche grundsätzlich nur von Hauptversion zu Hauptversion auf- oder vorgenommen werden. Dagegen unterscheiden sich Unterversionen im Prinzip nur durch erfolgte Fehlerkorrekturen oder kleine Anpassungen. Soweit die Theorie; in der Praxis ist es bei komplexen Programmen nicht bei jeder Änderung ganz eindeutig, ob "nur" ein Fehler behoben oder nicht doch schon eine weiter gehende Veränderung eingeführt wurde. Eine Besonderheit der Vergabe der Versionsnummern ist bei GIMP, dass bei der zweiten Zahl (aktuell also 8) zwischen geraden und ungeraden Zahlen wie folgt unterschieden wird: Gerade Zahlen sind stabilen Hauptversionen vorbehalten, mit ungeraden Zahlen dagegen werden immer unstabile Versionen (auch Entwicklerversionen genannt) bezeichnet. Die drei letzten stabilen Versionen vor dem aktuellen GIMP 2.8 waren also in chronologischer Reihenfolge 2.2 , 2.4 und 2.6 . Dagegen waren 2.3 , 2.5 und 2.7 Entwicklerversionen. Auch aktuell gibt es bereits seit Längerem eine unstabile Version, nämlich GIMP 2.9 .

Welche Version sollen Benutzer verwenden? Im Prinzip gilt: Wenn immer möglich die aktuellste stabile Version, also zur Zeit 2.8.14 . Von dieser Regel gibt es nur folgende kleine Ausnahme: Wird GIMP unter gewissen Linux-Distributionen verwendet, dann kann unter Umständen in Kauf genommen werden, nicht die aktuellste Unterversion zu verwenden. Die Wahrscheinlichkeit, ausgerechnet auf eine echte Fehlfunktion des Programms zu stossen, die dann in aktuelleren Unterversionen bereits gefixt wurde, ist nämlich, zumindest für Durchschnittsanwender, schon sehr klein. Linux-Distributionen, die GIMP in offiziellen Paketquellen anbieten, haben dort nicht immer die aktuellste Unterversion. Dies trifft gerade auf einige sehr populäre Distributionen zu, beispielsweise auf Mint und auf Ubuntu, und zwar auf alle Derivate dieser beiden sehr verbreiteten Distributionen. In dem Fall muss abgewogen werden, ob es tatsächlich die aktuellste Unterversion sein muss: Das bedeutet dann nämlich mindestens das Freischalten von nicht-offiziellen Paketquellen, was sorgfältig gemäss einschlägigen Anleitungen gemacht werden muss, da eine durcheinandergebrachte Paketquellenliste eine der (wenigen) Möglichkeiten ist, ein (solches) Linux-System nachhaltig zu ruinieren. In den weitaus meisten anderen Einsatzszenarien (GIMP unter Windows oder unter OS X, oder GIMP wird selbst kompiliert) gibt es schlicht keine Argumente für den Einsatz veralteter (Unter-)Versionen.

Ein Sonderfall muss aber noch angesprochen werden: Wie soll man sich verhalten, wenn eine neue Hauptversion erscheint, man aber GIMP bereits verwendet? Hierüber gibt es verschiedene Meinungen. Empfohlen wird meist ein Kompromiss: Der Wechsel auf die neuste Hauptversion sollte zwar innerhalb eines nicht allzu langen Zeitraums vollzogen werden (Richtwert: nach 6 bis 12 Monaten), aber nicht unbedingt früher. Abgesehen vom Faktor "Umgewöhnungszeit" (der nicht zu unterschätzen ist) ist es eine Erfahrungstatsache, dass ganz neue (Haupt-)Versionen unmittelbar nach dem Erscheinen noch gewisse, im dümmsten Fall sogar recht störende, Fehler aufweisen. Diese Beobachtung gilt für jede Software, nicht speziell für GIMP (übrigens sogar auch für neue Versionen von Betriebssystemen!), und ist auch keineswegs eine besondere Schwäche von Open-Source-Software. Wer allerdings neu einsteigt, liegt mit der aktuellsten Hauptversion richtig.

Abschliessend ist vom Einsatz von unstabilen Versionen auf Produktivsystemen (die mit einer ungeraden Zahl an zweiter Stelle der Versionsnummer) klar abzuraten. Solche Entwicklerversionen sind zum Testen und Ausprobieren neuer Funktionen und Veränderungen gedacht, nicht zum produktiven Einsatz. Es ist bei Entwicklerversionen ohne Weiteres möglich, dass die fragliche Unterversion regelmässig abstürzt oder beliebige andere Fehlfunktionen aufweist. Diese Tests werden insbesondere von der global vernetzten GIMP-Community durchgeführt, damit die Entwicklung von GIMP vorangetrieben werden kann. Natürlich ist es nicht etwa verboten, Entwicklerversionen aus Neugierde usw. auch als Normalsterbliche zu testen, aber für dieses Szenario legt man sich am besten eine vom Produktivsystem abgeschottete Testumgebung zu. Dies wird im vorliegenden Buch nicht weiter thematisiert. Das Nebeneinanderverwenden verschiedener Versionen von GIMP ist übrigens nicht unmöglich, erfordert aber je nach Betriebssystem zusätzliche Eingriffe bei der Installation, die hier nicht beschrieben werden.



Fenstermodus [Bearbeiten]

Grundsätzliches[Bearbeiten]

GIMP kann optisch auf zwei recht verschiedene Arten betrieben werden, nämlich im Einzelfenster-Modus oder aber im Mehrfenster-Modus. Die beiden verschiedenen Betriebsarten haben nichts mit dem Betriebssystem zu tun, unter dem GIMP betrieben wird, sondern sind eine echte Eigenheit des Programms. Ohne auf diesen Punkt weiter einzugehen, sei erwähnt, dass GIMP bis zur Hauptversion 2.6 nur im Mehrfenster-Modus betreiben werden konnte; die Einführung des Einzelfenster-Modus ist eine wesentliche Neuerung von GIMP 2.8 . Folgende Bemerkung ist wichtig: Mit der Funktionalität und den Möglichkeiten des Programms GIMP haben die beiden verschiedenen Fenstermodi nichts zu tun. Es ist einzig eine Frage der Art, wie die Programmoberfläche für die Benutzerschaft optisch dargestellt wird.

Da es eine Tatsache ist, dass die beiden Darstellungsweisen je eine (meist überzeugte) Anhängerschaft und Gegnerschaft haben, wird (nur) auf dieser Seite auf diese Frage eingegangen. Wer schon jetzt weiss, welcher Fenstermodus von ihr oder ihm gewählt wird, muss dieses Unterkapitel nicht lesen. Zudem sei schon jetzt der Hinweis gemacht, dass in diesem Buch für Abbildungen, ausser einmalig auf dieser Seite zwecks Anschaulichkeit, der Einzelfenster-Modus gewählt wird. Dies entspricht inzwischen auch mehrheitlich den Gebräuchen in der Literatur zu GIMP und ist primär dadurch bedingt, dass Abbildungen im Mehrfenster-Modus auf kleiner Lese-Fläche schwer verständlich sind. Dazu kommt noch, dass der Einzelfenster-Modus gerade für Einsteiger, und besonders für solche, die das Programm unter Windows verwenden, grundsätzlich intuitiver ist. Eine Wertung ist dies nicht. GIMP war historisch zuerst für die Verwendung unter Linux-Distributionen konzipiert, und die GIMP-Community hat sich sehr lange gesträubt, den Einzelfenster-Modus überhaupt zu implementieren. Eine Nachlese der Kämpfe um dieses Feature ist der Umstand, dass auch unter GIMP 2.8 der Mehrfenster-Modus die Default-Einstellung ist; wer den Einzelfenster-Modus will, muss das bewusst einstellen. Solange man nicht GIMP Portable verwendet, ist diese Einstellung allerdings nur ein einziges Mal, nämlich nach dem ersten Start des Programms, nötig.

Der Mehrfenster-Modus[Bearbeiten]

GIMP im Mehrfenster-Modus

GIMP startet per Default in den Mehrfenster-Modus. Gemeint ist damit, dass gewissermassen jeder "Teil" des Programms ein eigenes Fenster hat, die auf dem Bildschirm nicht zusammenhängen müssen (und das per Default auch gerade nicht tun). Die Zahl dieser Fenster ist sehr variabel, wobei allerdings ein Fenster, nämlich das so genannte Bildfenster, immer geöffnet sein muss. Das Schliessen dieses Bildfensters beendet das Programm (wenn noch ein Bild bzw. eine Datei geöffnet ist, fragt GIMP noch nach, ob es wirklich beendet werden soll; dieses Verhalten ist für komplexe Programme üblich). Standardmässig werden beim Start ausser dem Bildfenster noch zwei weitere Fenster geöffnet, nämlich links der Der Werkzeugkasten und rechts das das Dock Ebenen - Kanäle - Pfade - Journal. Hier ist noch folgende Bemerkung zur Terminologie der grafischen "Programmteile" angebracht: Man bezeichnet bei GIMP nur das erwähnte Bildfenster tatsächlich als Fenster, alle übrigen "Teile" heissen Docks. Deshalb müsste der Mehrfenster-Modus eigentlich "Bildfenster-Modus mit eventuell einem oder mehreren frei schwebenden Docks" heissen - das wäre zwar terminologisch korrekt, aber natürlich ein Wortmonster. Damit ist auch schon angetönt, dass der Anwender bezüglich Docks die völlige Freiheit hat: Man kann nämlich eines oder beide der standardmässig geöffneten Docks schliessen, oder natürlich auch andere Docks öffnen. Über ein Dutzend verschiedene Docks stehen bei GIMP zur Verfügung! Hier ist nicht der Ort, diese Docks einzeln vorzustellen; das geschieht erst in späteren Kapiteln. Hier geht es nur um die Konfiguration von GIMP hinsichtlich Fenstermodus. Neben dem beliebigen Schliessen und Öffnen können Docks ebenso beliebig verschoben oder bezüglich ihrer Grösse verändert werden. Das geschieht mit den für das verwendete Betriebssystem und die eingesetzte Hardware vorgesehenen Mitteln zur Fensterverwaltung; in der Regel werden solche Aktionen heute per Drag and Drop mit der Maus vollzogen.

Wie schon im oberen Abschnitt bemerkt ist der Mehrfenster-Modus für zwei grosse Gruppen von GIMP-Anwendenden sehr gewöhnungsbedürftig, nämlich erstens für Einsteigerinnen und Einsteiger und zweitens für Anwenderinnen und Anwender von GIMP unter Windows. Es sei aber ausdrücklich darauf hingewiesen, dass der Mehrfenster-Modus durchaus auch besondere Vorteile haben kann. Für ein Anwendungsszenario ist er geradezu prädestiniert: Nämlich für die Verwendung von GIMP auf Systemen mit mehreren Monitoren. Zwar sind auch heute noch solche Systeme bei Privatanwendern nicht der Normalfall. Bei professionellen Anwendern stehen aber heute bereits häufig mehrere Bildschirme zur Verfügung. Das erlaubt es im Mehrfenster-Modus zum Beispiel, verschiedene Docks auf verschiedene Monitore zu benutzen, unter Umständen durch verschiedene Benutzer. Dadurch sind für die Verwendung von GIMP im Profibereich sehr leistungsfähige Arbeitsumgebungen einrichtbar. Auf diese Aspekte geht das vorliegende Buch nicht ein; es sei erwähnt, dass die sich hierzu stellenden Konfigurationsprobleme an sich auch gar nichts mit GIMP zu tun haben, sondern mit der Konfiguration der eingesetzten Grafikkarte (bzw. vorab ihres Treibers) für die Verwendung mit mehreren Monitoren.

Der Einzelfenster-Modus[Bearbeiten]

Der Einzelfenster-Modus von GIMP

Wird GIMP im Einzelfenster-Modus betrieben (zum Einschalten desselben siehe nächster Abschnitt), dann verhält sich die Programmoberfläche wie die der meisten heute gebräuchlichen Programme. Alle Teile des Programms sind im Prinzip in einem Fenster. Standardmässig besteht die Programmoberfläche aus den vier Teilen Menüleiste, Bildfenster, Werkzeugkasten und dem Dock Ebenen - Kanäle - Pfade - Journal. Als Abschluss des Einführungskapitels wird die Programmoberfläche dann noch etwas detaillierter erklärt; die Detailerklärungen der vier Elemente (und vieler weiterer zuschaltbarer Docks) erfolgt dann aber erst im Kapitel Grundlegende Bildbearbeitung, da das nicht sinnvoll vom realen Gebrauch des Programms zu trennen ist. Es sei noch auf folgende terminologische Übereinkunft hinzuweisen: Es hat sich eingebürgert die Teile der Programmoberfläche unabhängig vom Fenstermodus immer gleich zu benennen, auch wenn eine Benennung manchmal sachlich nicht ganz zutreffend sein mag. Deshalb spricht man zum Beispiel immer vom Bildfenster, auch im Einzelfenster-Modus, obwohl da dieser Teil ja kein eigenes Fenster bildet und rein sachlich so etwas wie "Bildbereich" korrekter wäre. Auch die Docks heissen immer Docks, obwohl sie im Einzelfenster-Modus nicht in jedem Fall "angedockt", sondern manchmal eher ins (einzige) Fenster eingefügt werden.

Es gibt noch folgende Verwirrung im Einzelfenster-Modus bezüglich Docks: Es ist auch in diesem Modus möglich Docks sozusagen freischwebend zu halten. Der Unterschied zum Mehrfenster-Modus ist allerdings, dass an Stelle des "abgedockten" Docks nicht einfach "nichts" von der Programmfläche sichtbar ist, sondern dass das Einzelfenster die Fläche unter dem abgedockten Dock schliesst (oder "darunter" gar keine Leere besteht, wie man will). Es handelt sich im Einzelfenster-Modus bei abgedockten Docks eben nicht um völlig selbstständige Fenster, sondern mehr um verschiebbare Elemente, die auf dem Fenster verschoben werden. Das alles hat zur Folge, dass durchaus auch im Einzelfenster-Modus eine sehr weit gehende Konfiguration der Arbeitsumgebung einstellbar ist.

Ändern des Fenstermodus[Bearbeiten]

Bildfenster von GIMP im Mehrfenster-Modus, nach dem ersten Programmstart

Da das Ändern des Fenstermodus gerade bei Einsteigern oft das Erste ist, was sie in GIMP tun, und das mit echtem Arbeiten noch nichts zu tun hat, wird dieser Schritt bereits hier kurz erklärt. Auch wenn die Programmoberfläche ansonsten ja noch mit keinem Wort erklärt wurde, kann diese Umstellung ohne Weiteres ohne Kenntnisse von GIMP leicht vorgenommen werden.

GIMP hat wie viele moderne Programme (z. B. etwa Textverarbeitungsprogramme usw.) oben eine so genannte Menüleiste. Da GIMP per Default im Mehrfenster-Modus startet, muss noch erwähnt werden, dass sich diese immer oben im Bildfenster befindet, nicht in den Docks. Beim Erststart nach der Installation von GIMP befindet sich das querformatige Bildfenster (ungefähr) in der Mitte des Bildschirms und recht und links davon je ein hochformatiges Dock, die hier nicht weiter interessieren. Die Menüleiste befindet sich nicht ganz am oberen Rand des Bildfensters, sondern etwas darunter; ganz zuoberst ist der Fensterrahmen, der auch die offizielle Fensterbeschriftung GNU Image Manipulation Programm enthält. Die Menüleiste hat standardmässig 11 Einträge. Fürs Ändern des Fenstermodus brauchen wir den zweitletzten von links gezählt, der Fenster heisst. Wenn dieser Menüpunkt angeklickt wird, klappt ein Menü mit 7 Einträgen aus. Der letzte davon heisst Einzelfenster-Modus. Wird er angeklickt, wechselt GIMP automatisch und sofort (ohne Neustart des Programms!) in den Einzelfenster-Modus. Der Eintrag Einzelfenster-Modus bekommt ein Häckchen, wenn GIMP tatsächlich in diesem Fenstermodus betrieben wird. Es ist möglich, jederzeit - auch mitten in der Arbeit - auf analoge Weise den Fenstermodus zu wechseln; natürlich ist auch der Rückwechsel in den Mehrfenster-Modus jederzeit möglich, und auch der wird automatisch und sofort vollzogen. Das erwähnte Häckchen verschwindet dann wieder.

Standardmässig speichert GIMP diese (und übrigens auch alle übrigen) Einstellungen am Programm im Benutzerprofil des Programms, was bedeutet, dass GIMP beim nächsten Start bereits direkt in der zuletzt verwendeten Konfiguration startet. Diese "Speicherverhalten" bezüglich Programmeinstellungen lässt sich übrigens (wie nahezu alles an GIMP) auch ändern, was aber hier noch nicht erklärt wird, da das beschriebene Verhalten in der Regel, und jedenfalls für Einsteiger, wünschbar und sinnvoll ist. Einzig GIMP Portable kann dies aus technischen Gründen nicht, was zur Folge hat, dass dort entweder die Programmeinstellungen nach jedem Programmstart wieder eingestellt werden müssen, oder das Programm in den Standardeinstellungen genutzt werden muss.

Ein Problem muss noch erwähnt werden, das Einsteiger verwirren kann: Wenn das Bildfenster aus Platzgründen nicht in voller Breite auf dem Bildschirm dargestellt werden kann, "versteckt" GIMP in der Menüleiste Menüpunkte, und zwar von rechts beginnend. Deshalb kann es in einer solchen Konstellation vorkommen, dass der Menüpunkt Fenster, der ja der zweitletzte ist, gar nicht sichtbar ist. In dem Fall erscheint ganz rechts in der Menüleiste ein kleiner schwarzer, nach unten zeigender Pfeil. Wird er angeklickt, erscheinen alle "fehlenden" Menüpunkte, die aus Platzgründen nicht dargestellt werden konnten, in der Form einen Klappmenüs. Dann kann einfach Fenster angeklickt werden, und ab da kann die Änderung des Fenstermodus wie beschrieben eingestellt werden. - Es lässt sich nicht exakt vorhersagen, wann GIMP zu wenig Platz hat, um das Bildfenster in voller Breite darzustellen. Das hängt nämlich nur zum Teil von der Grösse des verwendeten Bildschirms ab. Auch andere Faktoren beeinflussen das, beispielsweise, welche Schriftgrösse für die Fensterbeschriftungen auf dem fraglichen System eingestellt ist. Solche Einstellungen lassen sich für alle heutigen Betriebssysteme bzw. Fensterverwaltungen einstellen; das ist aber ein anderes Thema. Das beschriebene Phänomen kann durchaus schon bei Bildschirmen unter 19 Zoll Durchmesser auftreten.



Überblick über die Programmoberfläche [Bearbeiten]

Vorbemerkung[Bearbeiten]

Zweck dieses Kapitels ist es, Einsteigern vor dem Beginn der eigentlichen Arbeit mit GIMP eine minimale Übersicht über die Programmoberfläche zu vermitteln. Das Kapitel beschränkt sich auf den Zustand der Programmoberfläche, wie er sich nach der Installation des Programms bzw. nach dem ersten Start präsentiert. Dieser Default-Zustand ist bereits für einen recht beachtlichen Teil der Funktionalität des Programms ausreichend, nämlich im Prinzip für die grundlegende Bildbearbeitung. Andere Konfigurationen der Programmoberfläche, insbesondere zusätzliche Docks, werden erst zu beschreiben, wenn sie tatsächlich verwendet werden, was in der Regel erst in der fortgeschrittenen Bildbearbeitung der Fall ist.

Im Rahmen dieses Kapitels kann es nicht darum gehen, die gesamte Funktionalität des Programms bzw. der Default-Programmoberfläche vollständig zu beschreiben. Es gilt das Prinzip, dass Funktionen erst dort erklärt werden, wo sie tatsächlich real zum Einsatz kommen. Alles andere entspricht nicht der Konzeption eines Lehrbuchs. Wer alle Funktionen kompakt nachschlagen will, ist mit der offiziellen und vollständig auf deutsch verfügbaren internen Hilfe von GIMP bestens bedient, so dass für eine solche handbuchartige Darstellung ohnehin kein Bedarf ist. Sinn dieses Kapitels ist nur, dass sich der Einsteiger rasch auf der komplexen Programmoberfläche zurechtfindet. Deshalb werden hier nur die, je nach Zählweise, vier bis sechs Hauptteile der Default-Oberfläche kurz beschrieben.

Die Menüleiste[Bearbeiten]

Menüleiste von GIMP

GIMP hat fast zuoberst, direkt unter dem Fensterrahmen (der kein eigentlicher Programmteil ist, sondern zur Fensterverwaltung des verwendeten Betriebssystems gehört) wie viele moderne Programme eine Menüleiste. Bei GIMP bietet diese 11 Menüs an, nämlich (von links nach recht): Datei, Bearbeiten, Auswahl, Ansicht, Bild, Ebene, Farbe, Werkzeuge, Filter, Fenster und Hilfe. Im Grossen und Ganzen hält sich GIMP bezüglich Art und sogar Reihenfolge der Menüs an heutige Gebräuche anderer verbreiteter Programme. Deshalb wird, wer bereits komplexe Programme einsetzt (etwa Textverarbeitungprogramme), durchaus einen recht grossen Wiedererkennungseffekt haben und sich dadurch etwas schneller in der Menüstruktur zurechtfinden. Es sei aber schon hier auf zwei tendenzielle Besonderheiten ("besonders" ist natürlich immer relativ) hingewiesen:

Erstens ist festzuhalten, dass die Menüstruktur von GIMP ausserordentlich stark ausdifferenziert ist. Schon nur die Zahl der Menüpunkte beläuft sich auf 5 bis 22 pro Menü, was bedeutet, dass schon nur gegen 200 (!) Menüpunkte vorhanden sind. Das ist aber noch längst nicht alles. Sehr viele Menüpunkte enthalten nämlich Untermenüpunkte, und zwar bis zu 25. Wenn ein Menüpunkt Untermenüpunkte enthält, ist dies durch einen kleinen nach rechts gerichteten Pfeil am rechten Ende der Schaltfläche des Menüpunkts erkennbar; auf blossen Überfahren mit der Maus werden die Untermenüpunkte angezeigt und sind dann anwählbar. Auch das ist aber nicht alles. Etliche Menü- und Untermenüpunkte lassen, wenn sie angewählt werden, eine zusätzliche, unter Umständen komplexe Schaltfläche (eigentlich manchmal schon eher echte Fenster) erscheinen, in denen (unter Umständen zahlreiche) weitere Einstellungen vorgenommen werden können. Menü- oder Untermenüpunkte mit solchen Möglichkeiten enden in der Beschriftung der fraglichen Schaltfläche mit drei Punkte (...). Bis ein Dutzend Konfigurationsmöglichkeiten (zudem sehr oft graduelle!) schon nur pro einzelner solcher Schaltfläche sind bei GIMP möglich. Konfigurieren, als ob es kein Morgen gäbe, ist somit bei GIMP möglich. Man muss dazu klar sagen, dass der Anspruch von GIMP, ein professionelles Bildbearbeitungsprogramm zu sein, dies erzwingt. Zeitgemässe Bildbearbeitung mit Profisoftware bedeutet, schier unbegrenzte Möglichkeiten zu haben, und ein Programm, das das bietet, hat automatisch eine entsprechend ausdifferenzierte Programmoberfläche. Der Einsteiger darf und soll ab solchem nicht erschrecken.

Eine zweite tendenzielle Besonderheit bezüglich Menü ist darin zu sehen, dass bei GIMP das Bedienkonzept herrscht, das wenn irgend möglich jeder Schritt auf mehr als eine Art durchgeführt werden kann, vorzugsweise nicht einmal nur auf zwei Arten, sondern sogar auf drei, nämlich entweder eben im Menü, oder aber grafisch (auf Docks), oder aber durch Tastenkürzel. Es ist heute zwar durchaus auch bei anderen komplexen Programmen üblich alternative Bedienkonzepte zu haben. Nur wenige Programme haben aber das Prinzip der mehrfachen Bedienungsmöglichkeiten so konsequent umgesetzt wie GIMP. Dies ermöglicht natürlich der Benutzerschaft eine grösstmögliche Wahlfreiheit bezüglich der Bedienung. Der Preis für ein solches Konzept ist freilich, dass dadurch die Programmoberfläche sehr komplex wird. - Es ist dem Benutzer überlassen, welche Bedienungsart(-en) er vorzieht. Einsteigern wird empfohlen, sich sowohl die Bedienung über die Menüs als auch die grafische Bedienung anzueignen und dann je nach gewünschter Aktion die einfachere oder schnellere Variante zu wählen. Die Bedienung über Tastenkürzel ist die Vorliebe einer klaren Minderheit, wobei aber auch gilt: Wer das beherrscht, arbeitet klar schneller als mit beiden anderen Bedienungsarten.

Das Bildfenster[Bearbeiten]

Das Bildfenster von GIMP, wenn keine Datei geöffnet ist

Das Bildfenster von GIMP ist so etwas wie der virtuelle Arbeitstisch zum Bearbeiten von Bildern. Das bedeutet, das hier immer das gerade aktuelle Bild angezeigt wird. Ist kein Bild geöffnet, ist das Bildfenster weitgehend leer; eine stilisierte Form des Maskottchens des Programm, das Wilber heisst, ist links im unteren Teil sichtbar. Das Bildfenster ist neben der Menüleiste der einzige Teil der Programmoberfläche, der nicht geschlossen werden kann (ausser natürlich, wenn man das ganze Programm beendet). Die im Einzelfenster-Modus eigentlich nicht ganz korrekte Benennung Bildfenster wurde bisher beibehalten, obwohl es sich in diesem Modus nicht um ein richtiges bzw. selbstständiges Fenster handelt.

Der Hauptzweck des Bildfensters ist das direkte Arbeiten an der da sichtbaren, geöffneten Bilddatei. Im Unterschied etwa zur Menüleiste verfügt das Bildfenster auf den ersten Blick nicht über eigene Optionen zum direkten "Eingreifen". Das ist indes falsch. Auch das Bildfenster, wie sozusagen alles an GIMP, hat durchaus auch grafisch zugängliche Einstellungsmöglichkeiten. Diese werden auf der entsprechenden Seite detailliert erklärt. Grundsätzlich gilt, dass für die grundlegende Bildbearbeitung in der Regel die Standardeinstellungen des Bildfensters ausreichen. Erst für fortgeschrittene Arbeiten sind hier Anpassungen nötig. In der Standardeinstellung füllt das Bildfenster den gesamten Raum von der Menüleiste bis fast an den unteren Rand der Programmoberfläche.

Das Doppeldock Werkzeugkasten - Werkzeugeinstellungen[Bearbeiten]

Das linke Doppeldock

Links vom Bildfenster wird standardmässig ein Dock geöffnet, das eigentlich (was aber für Einsteiger durchaus nicht sofort ersichtlich ist) ein Doppeldock ist. Der obere Teil des Docks (d. h. eigentlich das obere Dock) zeigt den so genannten Werkzeugkasten, der untere Teil die Werkzeugeinstellungen. Auf den Umstand, dass es sich beim Ganzen eigentlich um zwei Docks handelt, wird an dieser Stelle nicht im Detail eingegangen. Es genügt der Hinweis, dass man nicht nur das ganze Doppeldock schliessen oder anderswie manipulieren kann, sondern dass es auch möglich ist, nur den oberen oder sogar nur den unteren Teil des Doppeldocks offen zu halten. Da es für die gesamte grundlegende Bildbearbeitung empfehlenswert ist, die beiden per Default erscheinenden Doppeldocks unverändert zu lassen, wird der detaillierte Umgang mit der Konfiguration von Docks erst in der fortgeschrittenen Bildbearbeitung behandelt.

Inhaltlich ist das Doppeldock so aufgebaut, dass im oberen Dock alle zur Standardinstallation von GIMP gehörigen Werkzeuge grafisch als Schaltflächen mit Symbolen enthalten sind, während das untere die zum jeweils gerade angewählten Werkzeug gehörigen Einstellungen grafisch (oder anderswie) eingestellt werden können. Es ist immer genau ein Werkzeug angewählt, auch wenn das Doppeldock überhaupt nicht verwendet wird. Ein Ändern des ausgewählten Werkzeugs (durch blosses Anklicken) zeigt sofort, dass dann unten andere Werkzeugeinstellungen erscheinen. Die Arbeit mit den Werkzeugen gehört zu den grundlegenden Bildbearbeitungstechniken, steht dort aber nicht am absoluten Anfang. Es gibt durchaus Bildbearbeitungsschritte, die sogar ohne Werkzeuge auskommen.

Das Doppeldock Ebenen... - Pinsel...[Bearbeiten]

Das rechte Doppeldock

Rechts vom Bildfenster wird standardmässig ebenfalls ein Doppeldock geöffnet. Natürlich ist auch dieses Doppeldock entkoppelbar, so dass die beiden Teil-Docks einzeln geschlossen, verschoben oder sonstwie manipuliert werden können. Das rechte Doppeldock ist fast nicht vernünftig benennbar, was an folgender Besonderheit liegt: Beide Teil-Docks bestehen in Wirklichkeit noch je aus mehreren Docks, die übereinander gestapelt sind. In GIMP werde so "gestapelte" (Mehrfach-)Docks mit Reitern dargestellt. Das sind grafische Elemente, die bei übereinander liegenden grafischen Teilen dafür sorgen, dass immer nur gerade ein Teil aktiv (und tatsächlich sichtbar) ist. Reiter kennen auch einige andere komplexere Programme. Die Benennung des rechten Doppeldocks wird noch dadurch erschwert, dass die beiden Teil-Docks bzw. miteinander gar nichts zu tun haben; das ist ein Unterschied zum linken Doppeldock, wo das untere Teil-Dock mit den Werkzeugeinstellungen sich ja klar aufs obere mit dem Werkzeugkasten bezieht. Dass genau die im linken Doppeldock vorhandenen Teil- und Unter-Docks enthalten sind und nicht andere, ist teilweise etwas zufällig bzw. ein Ergebnis der langjährigen Entwicklung von GIMP. Zumindest das obere Teil-Dock ist allerdings insbesondere in der fortgeschrittenen Bildbearbeitung meist unverzichtbar. Fürs untere Teil-Dock gilt das nicht in dem Ausmass, aber es hat sich bewährt, dass Einsteiger die Standardkonfiguration der Programmoberfläche zunächst nicht abändern, weil diese Abänderungen ihrerseits nicht immer ganz trivial sind. Besser beschäftigt man sich am Anfang mit Bildbearbeitung statt (nur) mit GIMP.

Wenn das rechte Doppeldock dennoch vollständig bezeichnet werden müsste, würde es "Doppeldock Ebenen - Kanäle - Pfade - Journal -- Pinsel - Muster - Farbverläufe" oder so ähnlich heissen. Tatsächlich enthält das obere Teil-Dock eigentlich vier Docks, nämlich Ebenen, Kanäle, Pfade und Journal. insbesondere die Ebenen sind fundamental für jedes Verständnis von fortgeschrittener Bildbearbeitung. Die drei anderen Unter-Docks sind nicht ganz so fundamental, aber für sie gilt ebenfalls bzw. sogar erst recht, dass sie in die fortgeschrittene Bildbearbeitung gehören. Es lohnt sich aber wie erwähnt eigentlich nicht, nur deswegen das (Doppel-)Dock für grundlegende Bildbearbeitung zu schliessen. Eher ist ein Grund fürs Schliessen von Standardocks, dass (statt dessen) andere Docks verwendet werden sollen, und das ist ohnehin typischerweise erst in der fortgeschrittenen Bildbearbeitung der Fall. Das untere Teil-Dock besteht aus drei Unter-Docks, nämlich Pinsel, Muster und Farbverläufe. Im Unterschied zu den bisher erwähnten Docks geht es bei diesen Unter-Docks in der Regel nicht um Bildbearbeitung, sondern um die Verwendung von GIMP als Malprogramm. Das ist, wie einleitend schon bemerkt, nicht der Hauptfokus dieses Buches. Allerdings muss die Einschätzung dieser Docks wie folgt relativiert werden: Bildbearbeitung und Malen können selbstverständlich kombiniert werden, auch wenn faktisch bei den meisten Arbeiten das eine oder das andere im Vordergrund steht. Obwohl insgesamt die Unter-Docks des unteren Teil-Docks nicht im Zentrum der Arbeit mit GIMP im Sinne dieses Buches stehen, ist es, zumal für Einsteiger, unnötig dieses Unter-Dock zu schliessen.



Wikibooks-Hinweise
Druckversion des Buches GIMP/ Einführung
  • Dieses Buch umfasst derzeit etwa DIN-A4-Seiten einschließlich Bilder (Stand: ).
  • Wenn Sie dieses Buch drucken oder die Druckvorschau Ihres Browsers verwenden, ist diese Notiz nicht sichtbar.
  • Zum Drucken klicken Sie in der linken Menüleiste im Abschnitt „Drucken/exportieren“ auf Als PDF herunterladen.
  • Mehr Informationen über Druckversionen siehe Hilfe:Fertigstellen/ PDF-Versionen.
  • Hinweise:
    • Für einen reinen Text-Ausdruck kann man die Bilder-Darstellung im Browser deaktivieren:
      • Internet-Explorer: Extras > Internetoptionen > Erweitert > Bilder anzeigen (Häkchen entfernen und mit OK bestätigen)
      • Mozilla Firefox: Extras > Einstellungen > Inhalt > Grafiken laden (Häkchen entfernen und mit OK bestätigen)
      • Opera: Ansicht > Bilder > Keine Bilder
    • Texte, die in Klappboxen stehen, werden nicht immer ausgedruckt (abhängig von der Definition). Auf jeden Fall müssen sie ausgeklappt sein, wenn sie gedruckt werden sollen.
    • Die Funktion „Als PDF herunterladen“ kann zu Darstellungsfehlern führen.
  • Autorenliste, sofern möglich
CC some rights reserved.svg
Heckert GNU white.svg

Dieser Text ist sowohl unter der „Creative Commons Attribution/Share-Alike“-Lizenz 3.0 als auch GFDL lizenziert.

Eine deutschsprachige Beschreibung für Autoren und Weiternutzer findet man in den Nutzungsbedingungen der Wikimedia Foundation.