GIMP/ Grundlegende Bildbearbeitung/ Das Bildfenster

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Optionaler Ein-Fenster-Modus ab GIMP 2.8![Bearbeiten]

GIMP wird ab Version 2.8 einen vollständig implementierten Single-Window mode enthalten. Wer das nicht abwarten kann, kann jetzt schon die Entwicklerversion 2.7.1 ausprobieren, dort ist dieser schon in (unstabilen) Teilen enthalten. Zu finden ist dieser unter dem Menüpunkt "Fenster".

Das Bildfenster:[Bearbeiten]

Das Bild stellt das Bildfenster von GIMP dar, die blauen Zahlen und die roten Striche dienen nur der Erläuterung. Der Screenshot wurde unter Windows XP mit GIMP 2.2.15 erstellt.


Nachfolgend wird das Bildfenster anhand des obigen Bildes und den darin enthaltenen Markierungen erklärt.

Hinweis: Die Beschreibungen weichen eventuell geringfügig von Gegebenheiten in GIMP 2.4.x ab, helfe bitte mit die Unterschiede in den Text einzufügen.

  • 1: Von links nach rechts im roten Kasten: das * Sternchen bedeutet das seit dem letzten laden/speichern dieses Bildes bereits Veränderungen vorgenommen wurden. blingbling ist der Name des Bildes; wenn ein neues Bild erstellt wird heißt es vorerst einmal Namenlos, beim Speichern kann der Name dann geändert werden. .xcf stellt die Dateiendung, also das Grafikformat das zum Speichern verwendet wird, dar. Bei -1.0 handelt es sich um eine Nummer, die GIMP während einer Sitzung den Bildern gibt, in der Reihenfolge wie sie geöffnet wurden; in diesem Fall ist das verwendete Bild das erste dass in dieser Sitzung geöffnet wurde; wird noch ein Bild geöffnet erhält es die fortlaufend höhere Nummer, in diesem Fall wäre es dann -2.0. Durch diesen Teil: RGB wird der Farbraum des Bildes angegeben in dem es dargestellt werden kann, GIMP kann derzeit auch noch Graustufen-Bilder und Bilder mit indizierter Farbpalette ausgeben; RGB bedeutet Rot Grün Blau beziehungsweise Red Green Blue. ,11 Ebenen gibt an aus wie vielen Ebenen das Bild in diesem Moment besteht. 300x300 gibt an wie groß das Bild in Pixeln ist, also in der Reihenfolge 300 Pixel Breite und 300 Pixel Höhe.
  • 2: Mit den 2 schwarzen Dreiecken an den Linealen wird die Position des Mauszeigers angezeigt, zusammen mit 5 sehr praktisch.
  • 3: Die Lineale dienen der Orientierung, die linke obere Ecke des Bildes befindet sich immer bei den Maßstrichen und Koordinaten (siehe 5) 0,0.
  • 4: Dieser Schalter ist zum aktivieren/deaktivieren der schnellen Maske(Quickmask).
  • 5: Diese beiden Zahlen geben die Position des Mauszeigers (Cursor) in Koordinaten an, also im obigen Bild befindet sich der Mauszeiger bei den Koordinaten 90 Pixel Rechtswert und 87 Pixel Hochwert. Er wird in dem Bild nicht angezeigt, weil das Bild über die Snapshot-Funktion von GIMP erstellt wurde.
  • 6: Mit einem Klick auf den Pfeil öffnet sich ein Menu, in dem sich die Maßeinheit festlegen lässt, welche für die Unterteilung der Lineale und Angaben der Koordinaten verwendet werden soll. Allgemein lässt sich sagen, dass 'px' (Pixel) wohl die beste Einheit bei einem Rastergrafik-Programm wie GIMP ist, für Bilder die gedruckt werden sollen sind die anderen Einheiten eventuell hilfreich.
  • 7: Über das Menu, dass sich durch einen Klick auf den Pfeil neben 100% öffnet, lässt sich die Zoomstufe einstellen; bei einer Einstellung über 100% wird das Bild vergrößert auf dem Bildschirm dargestellt, um zum Beispiel um pixelgenaue Auswahlen anzufertigen. Bei einer Einstellung unter 100% wird das Bild dementsprechend verkleinert dargestellt. Für fast stufenloses Zoomen bietet sich eine Kombination des Mausrades mit einer beliebig zu belegenden Taste ([dynamische Tastaturkürzel])an , Standardeinstellung ist die Kombination 'Shift+Mausrad'. Wenn 'Shift' gedrückt wird, lässt sich durch Rollen des Mausrades die Ansicht vergrößern oder verkleinern, die Zoomstufen hängen nur von dem Mausrad ab.
  • 8: Die Statuszeile. Hier wird normal der Name der aktiven Ebene beziehungsweise Ebenenmaske oder des aktiven Kanals angezeigt. Bei der Verwendung des Pfadwerkzeugs werden hier kurze Hinweise zur Anwendung gegeben. Wird das Auswahlwerkzeug zum erstellen einer rechteckigen oder elliptischen Auswahl verwendet, wird in der Statuszeile die aktuelle Breite und Höhe der Auswahl angezeigt. Bei Anwendungen die längere Rechenzeit in Anspruch nehmen, wird der Fortschritt meistens in der Statuszeile grafisch dargestellt (zum Beispiel bei diversen Filtern).
  • 9: Mit diesem Scrollbalken lässt sich die Bildansicht horizontal verschieben durch ziehen des Balkens mit gedrückter Maustaste oder mit gedrückter [Strg]-Taste + Rollen des Mausrades (hierbei muss sich der Mauszeiger innerhalb des aktiven Bildfensters befinden).
  • 10: Lange und aufwendige Prozeduren lassen sich teilweise abbrechen wenn gewünscht, mit einem Klick auf den Abbrechen Knopf.
  • 11: Dieses Pfeilkreuz dient der schellen Navigation in der Bildansicht. Durch ein Klick auf das Kreuz und anschließend gehaltener linker Maustaste erscheint ein kleines Fenster mit einer Ansicht des Bildes, in der ein Rahmen anzeigt welcher Ausschnitt im Bildfenster jetzt dargestellt wird. Um einen anderen Ausschnitt zu wählen, wird einfach die Maus in dieser Miniaturansicht des Bildes an die gewünschte Stelle geschoben: der Rahmen bewegt sich dort hin und normaler Weise wird in Echtzeit der jeweilige Ausschnitt im Bildfenster dargestellt. Die Miniaturansicht verschwindet beim Loslassen der linken Maustaste automatisch wieder.
  • 12: Nummer 12 markiert die Hilfslinien in GIMP, die blau-schwarz gestrichelten Linien. Es gibt horizontale und vertikale Hilfslinien, welche mit gedrückter Maustaste aus den Linealen (3) in das Bild gezogen werden können (aus den Bereichen der Lineale, wo der Mauszeiger eine Pfeilform annimmt).Exakt Positioniert wird eine Hilfslinie durch Beobachtung der Mauszeiger-Koordinaten (5).
  • 13: Ebenen-Grenzen werden durch eine gelb-schwarz gestrichelte Umrandung dargestellt. Die Form einer Ebene ist stets rechteckig, was aber nicht bedeutet dass nur rechteckige Formen in einer Ebene existieren können, sondern lediglich dass der Teil der Ebene der keine Farbe enthält komplett durchsichtig ist. Es wird immer nur die Ebenen-Grenze der aktiven Ebene angezeigt.
  • 14: Eine Auswahl wird durch eine animierte, weiß-schwarz gestrichelte Linie dargestellt, die so genannten "laufenden Ameisen" oder "marching ants". In unserem Fall wurde eine Auswahl mit dem Ellipsen-Auswahl Werkzeug erstellt, die über die aktive Ebene hinausragt, was man auch daran erkennt dass die Ameisen außerhalb der Ebene weiß-grau dargestellt sind und sie "laufen" dort auch nicht.
  • 15: Wenn ein Pfad sichtbar gemacht ist, wird er mit einer durchgehenden, grauen Linie dargestellt.
  • 16: Ist das Gegenstück zu 9, also der Scrollbalken zum vertikalen verschieben der Bildansicht. Er lässt sich mit Rollen des Mausrades bei aktivem Bildfenster und darin positioniertem Mauszeiger verschieben.
  • 17: Die Pfeile dienen ebenfalls wie 9 und 16 dem Verschieben der Ansicht; durch drücken Maustaste auf einen Pfeil verschiebt sich die Ansicht in die entsprechende Richtung.
  • 18: Ein Klick mit der linken Maustaste auf dieses Lupensymbol bewirkt, dass wenn jetzt das Bildfenster verkleinert oder vergrößert wird, der Bildausschnitt genau der selbe bleibt und somit die Zoomstufe entweder kleiner oder größer wird, probiert es mal aus!
  • 20: Ein Klick auf den Pfeil öffnet ein Menu, das die selben Menupunkte und Menu-Unterkategorien enthält wie bei Nummer 19. Aber durch einen Klick auf eine gestrichelte Linie oben im Menu oder in einer der Unterkategorien, wird das gewählte Menu in ein eigenständiges Fenster verfrachtet; was zum Beispiel nützlich sein kann wenn im Vollbildmodus gearbeitet wird.

Die Menüs[Bearbeiten]

<<zurück zum Inhalt
Index: DateiBearbeitenAuswahlAnsichtBildEbeneWerkzeugeDialogeFilterScript-FuPython-Fu

Datei[Bearbeiten]

Dieses Menü enthält die Befehle zum Erstellen, Laden und Speichern von Bildern.

Neu (Strg + N)[Bearbeiten]

Wie im Werkzeugfenster.

Öffnen (Strg + O)[Bearbeiten]

Wie im Werkzeugfenster.

Als Ebene öffnen (Strg + Alt + O)[Bearbeiten]

Dieser Befehl öffnet eine Datei (Auswahl wie bei Öffnen) und fügt sie als neue, oberste Ebene in das aktuelle Bild ein.

Von Ort öffnen[Bearbeiten]

Wie im Werkzeugfenster.

Zuletzt geöffnet[Bearbeiten]

Wie im Werkzeugfenster.

Speichern (Strg + S)[Bearbeiten]

Speichert das Bild. Wenn bislang noch kein Dateiname für das Bild angegeben wurde, fragt GIMP nach, wo das Bild gespeichert werden soll.

Speichern unter... (Strg + Shift + S)[Bearbeiten]

Speichert das Bild an einem anderen als dem bisherigen Speicherort. GIMP arbeitet danach mit dem Bild an diesem Ort weiter.

Kopie speichern unter...[Bearbeiten]

Speichert eine Kopie des Bildes an einem zu wählenden Ort. GIMP arbeitet danach (im Gegensatz zu "Speichern unter...") aber mit dem bisherigen Bild an seinem bisherigen Speicherort weiter; die Kopie wird nicht mehr verändert.

Diese Funktion kann nützlich sein, um ein Bild, an dem Sie noch weiterarbeiten wollen, testweise in einem anderen Format zu speichern.

Als Vorlage speichern...[Bearbeiten]

Speichert das Bild als Vorlage, die Sie dann unter Datei > Neu... auswählen können.

Zurücksetzen[Bearbeiten]

Dieser Befehl lädt das Bild neu, macht also alle Änderungen seit der letzten Speicherung rückgängig. GIMP fragt Sie nochmals, bevor es den Befehl ausführt, da das Zurücksetzen nicht rückgängig gemacht werden kann.

Verschicken...[Bearbeiten]

Ermöglicht es, das Bild per E-Mail zu verschicken.

Schließen[Bearbeiten]

Schließt das Bildfenster. Wenn noch nicht gespeicherte Änderungen vorliegen, fragt GIMP nach, ob diese gespeichert werden sollen.

Beenden[Bearbeiten]

Wie im Werkzeugfenster.


Bearbeiten[Bearbeiten]

Dieses Menu enthält Befehle zum Arbeitsschritte rückgängig machen/wiederholen, kopieren/einfügen von Bildern/Bilteilen sowie Befehle zum löschen, füllen und nachziehen von einer Auswahl.

Rückgängig (Strg+z)

Mit diesem Befehl lassen sich fast alle Arbeitsschritte rückgängig machen.

Wiederholen (Strg+y)

Hiermit lassen sich rückgängig gemachte Aktionen wiederholen.

Journal

Das Journal listet alle Arbeitsschritte, auf die sich rückgängig machen lassen beziehungsweise wiederholbar sind. Der Journal-Dialog befindet sich normalerweise im Dock "Ebenen, Kanäle, Pfade...". Der Dialog enthält Vorschaubildchen der getätigten Aktionen und der Name der Aktion. Es lässt sich durch den Dialog scrollen und wenn ein Arbeitsschritt angeklickt wird, werden alle zeitlich nach diesem Schritt kommenden Aktionen rückgängig gemacht, beziehungsweise wird ein rückgängig gemachter Schritt ausgewählt und dadurch alle dazwischen liegenden Schritte wiederholt. Mit dem Schalter rechts unten im Dialog lassen sich alle Schritte bis auf den aktuellen aus dem Journal entfernen, sind somit dann nicht verfügbar für die Befehle "Rückgängig" und "Wiederholen"

Ausschneiden (Strg+x)

Schneidet die aktuelle Ebene beziehungsweise Auswahl aus und verschiebt diese in die Zwischenablage.

Kopieren (Strg+c)

Kopiert die aktuelle Ebene beziehungsweise Auswahl in die Zwischenablage.

Kopiere Sichtbares

Kopiert alle zu diesem Zeitpunkt sichtbaren Anteile des Bildes in die Zwischenablage.

Einfügen (Strg+v)

Fügt die Zwischenablage als schwebende Ebene in das Bild eine. Die schwebende Ebene lässt sich über das Menu Ebene in eine neue normale Ebene verwandeln, oder in der vor dem Einfügen aktiven Ebene einfügen (verankern).

In Auswahl einfügen

Entspricht "Einfügen", doch wird durch den Befehl Verankern nur der Teil der in der aktiven Auswahl sichtbar ist eingefügt.

Als neues Bild einfügen

Erzeugt ein neues Bild mit dem Inhalt der Zwischenablage.

Ablagen

Der Ablagen-Dialog enthält Bildinhalte die nur temporär für eine Sitzung gespeichert werden können, sie sind nach dem Beenden von GIMP nicht mehr verfügbar.

In Ablage ausschneiden
Schneidet die aktuelle Ebene beziehungsweise Auswahl aus und kopiert sie in die Ablage.
In Ablage kopieren
Kopiert die aktuelle Ebene/Auswahl in die Ablage.
Aus Ablage einfügen
Öffnet den Ablagen-Dialog. Dort lässt sich (wenn vorhanden) eine der Ablagen auswählen und durch die Schalter am unteren Rand des Dialogs einfügen; die Schalter entsprechen von links nach rechts den Befehlen: "Einfügen", "In Auswahl einfügen" und "Als neues Bild einfügen" auf die jeweilige Ablage bezogen. Der Schalter rechts unten löscht die ausgewählte Ablage.
Löschen (Strg+k)

Löscht den Inhalt der aktiven Ebene bzw. einer Auswahl innerhalb dieser Ebene.

Mit VG-Farbe füllen (Strg+,)

Füllt eine Ebene/Auswahl mit der derzeitigen Vordergrund-Farbe.

Mit HG-Farbe füllen (Strg+.)

Füllt eine Ebene/Auswahl mit der derzeitigen Hintergrund-Farbe.

Mit Muster füllen (Strg+;)

Füllt eine Ebene/Auswahl mit dem derzeitig aktiven Muster.

Auswahl nachziehen

Hiermit lässt sich eine Auswahl auf verschiedene Art und Weise nachzeichnen. Es öffnet sich ein Fenster in dem sich einstellen lässt, wie die Auswahl nachgezogen werden soll. Das Menu ist weitgehend selbsterklärend nur bei "Mit Hilfe eines Malwerkzeugs nachziehen" ist zu beachten, dass jeweils die aktuellen Werkzeugeinstellungen verwendet werden, also Farbe, Deckkraft, Verblassen, Modus und so weiter.

Pfad nachziehen

Entspricht "Auswahl nachziehen", nur auf den derzeit aktiven Pfad angewendet.


Auswahl[Bearbeiten]

In diesem Menu dreht sich alles um Auswahlen und Pfade.

Alles (Strg+A)

Wählt die gesamte aktive Ebene aus.

Aufheben (Strg+Umschalt+A)

Hebt die aktuelle Auswahl auf.

Invertieren (Strg+I)

Die aktive Auswahl wird umgekehrt, dass heißt, die Bereiche der Ebene die nicht ausgewählt waren sind nach dem Befehl ausgewählt und die restlichen Teile nicht.

Schwebend (Umschalt+Strg+L)

Schneidet die aktuelle Auswahl aus und fügt sie als schwebende Ebene dem Bild hinzu.

Nach Farbe (Umschalt+O)

Mit diesem Auswahlwerkzeug lassen sich Auswahlen aus einem bestimmten Farbbereich erzeugen mit einem einfachen Klick auf die gewünschte Farbe im Bild. In den Werkzeugeinstellungen lässt sich der Schwellwert einstellen, also ob nur genau diese Farbe (0) oder auch ähnliche ausgewählt werden (255 = alle Farben auswählen). Dieses Werkzeug wird bei den Auswahlwerkzeugen näher beschrieben.

Vom Pfad (Umschalt+V)

Erzeugt eine Auswahl aus dem derzeit aktiven Pfad.

Auswahleditor

Öffnet ein neues Fenster, in dem die Auswahl als Graustufen-Bild dargestellt wird und verschiedene Funktionen zur Verfügung gestellt werden, die auch im Menü Auswahl zu finden sind. Von links nach rechts am unteren Fensterrand entsprechen die Schalter den Befehlen : "Alles" , "Aufheben" , "Invertieren" , "In Kanal speichern" , "Nach Pfad" und der ganz rechts entspricht "Auswahl nachziehen" im Menu Bearbeiten.

Ausblenden
Schärfen
Verkleinern...

Die aktive Auswahl lässt sich hiermit um eine selbst zu bestimmende Größe verkleinern. Zu beachten ist hierbei, dass die Pixel die von der Auswahl abgezogen werden, entlang des Formverlaufs der Auswahl abgezogen werden, was Änderungen der Form zur Folge hat ausgenommen bei einem Kreis oder Rechteck.

Vergrößern...

Hiermit lässt sich die aktive Auswahl um eine selbst zu bestimmende Größe vergrößern. In Bezug auf die Form gilt Selbiges wie bei "Verkleinern", nur werden bei einem Rechteck die Ecken abgerundet mit einem Radius der dem zu vergrößernden Wert entspricht.

Rand...
Abgerundetes Rechteck...
Schnelle Maske aktivieren/deaktivieren (Umschalt+Q)
In Kanal speichern
Nach Pfad

Ansicht[Bearbeiten]

Bild[Bearbeiten]

Ebenen[Bearbeiten]

Werkzeuge[Bearbeiten]

Dialoge[Bearbeiten]

Filter[Bearbeiten]

In diesem Menü befinden sich die verschiedenen Filter und Plugins von Gimp. Auch zusätzlich installierte Plugins befinden sich (meistens) hier. Eine genaue Beschreibung der einzelnen Filter finden sie in Band 3.

Script-Fu[Bearbeiten]

In diesem Menü befinden sich die Script-Fus von Gimp. Hierbei handelt es sich um Skripte, welche einfache Arbeitabläufe automatisieren. Erstellt werden Script_Fus mit Hilfe der Skriptsprache Sheme. Näheres zum Erstellen von Script-Fus finden sie in Band 5. Da Scripte den Filtern ähnlich sind, finden sie genauere Beschreibungen der einzelnen Script-Fus in Band 3.

Python-Fu[Bearbeiten]

Auch unter diesem Menüpunkt befinden sich Skripte, welche vom Prinzip den Script-Fus ähnlich sind, jedoch in der Skriptsprache Python geschrieben sind. Genaueres zum erstellen von Python_Fus finden sie in Band 5, genauere Beschreibungen der einzelnen Python-Fus befinden sich in Band 3.