GIMP/ Grundlegende Bildbearbeitung/ Bilder verwalten/ Bilder öffnen und schliessen

Aus Wikibooks
Wechseln zu: Navigation, Suche

Vorbemerkungen[Bearbeiten]

Das Menü Datei ausgeklappt
Datei/Öffnen...: GIMP verbindet sich mit dem Dateimanager (hier Windows Explorer unter Windows 7)

Das Öffnen und Schliessen Bildern ist Grundlage jeder Bildbearbeitung. Technisch gesehen werden natürlich nicht eigentlich Bilder geöffnet oder geschlossen, sondern Dateien, die Bilder enthalten, aber da die Bildbearbeitung per Definition voraussetzt, das das zu bearbeitende Bild wortwörtlich sichtbar ist, hat sich diese abgekürzte Ausdrucksweise durchgesetzt.

Das blosse Öffnen und Schliessen von Bildern ist noch keine Bildbearbeitung, nicht einmal eine rudimentäre. Die Bilder werden ja nur dadurch nicht verändert, also nicht bearbeitet. Deshalb muss man dafür an sich auch kein Bildbearbeitungsprogramm benutzen, und erst recht nicht GIMP. Wer häufiger mit GIMP arbeitet, wird das Programm aber unter Umständen (auch nur) dafür benutzen. In diesem Punkt sind die Geschmäcker verschieden. Manche Benutzer verwenden, wenn sie Bilder nur anschauen und damit nur öffnen und schliessen wollen, bewusst einfachere Programme. Solche (auch kostenfreie oder Open Source) gibt es für alle Betriebssystem in grosser Zahl. Es ist nicht Aufgabe des Buches diese Programme hier aufzuzählen oder gar einzeln vorzustellen. Erwähnt sei, dass Programme, die im Grundsatz nur zum "Anschauen" von z. B. Bildern gemacht sind, auch Viewer heissen. Viewer gibt es keineswegs nur für Bilddateien, sondern z. B. auch für verschiedene Arten von Textdateien. Heutige Viewer für Bilddateien haben allerdings in den allermeisten Fällen, selbst wenn es sich um ein sehr einfaches Programme handelt, auch einige (unter Umständen natürlich aber auch viele) Funktionen zur grundlegenden Bildbearbeitung.

So oder so ist das Öffnen und Schliessen von Bildern Voraussetzung jeder Bildbearbeitung, und deshalb erklärt diese Seite, wie das in GIMP gemacht wird. Es wird nicht jeder Spezialfall erläutert, sondern nur, was für grundlegende Bildbearbeitung unabdingbar ist. Es sei erwähnt, dass auf der Seite, die den Grundaufbau der Menüleiste erklärt, die wesentlichen Optionen fürs Öffnen und Schliessen von Bildern noch einmal kurz zusammengefasst sind. Fürs blosse Öffnen und Schliessen von Bildern braucht man in der Regel nur zwei bis drei Menübefehle, so dass es nicht nötig ist vor diesem Schritt bereits einen Überblick über die Menüleiste zu haben.

Bild öffnen[Bearbeiten]

GIMP mit geöffnetem Bild

Bilder werden meist über die Menüliste geöffnet (daneben gibt es noch die Möglichkeit das über ein Tastaturkürzel zu tun, siehe unten). Alle Befehle zum Öffnen und Schliessen von Bildern befinden sich im Menü Datei, dem ersten von links in der Menüleiste. Es ist auch bei anderen Programmen (etwa Textverarbeitungsprogrammen) üblich die Optionen zum Umgang mit Dateien, wozu insbesondere das Öffnen und Schliessen gehört, im ersten Menü zu haben, und auch dort heisst dieses meistens Datei.

Das Menü enthält 19 Menüpunkte, die aufklappen, sobald das Menü Datei angeklickt wird. Der dritte von oben, Öffnen... , öffnet wie jetzt gewünscht ein Bild. Dazu verbindet sich GIMP mit dem Standard-Dateimanager des verwendeten Betriebssystems. In allen Versionen von Windows ist das fast immer der Windows Explorer; andere Betriebssysteme verwenden andere Dateimanager. Es ist auch möglich einen anderen Dateimanager als vom Betriebssystem vorgesehen als Standard-Dateimanger zu verwenden; die dafür nötigen Konfigurationseinstellungen sind nicht Gegenstand dieses Buches, weil das nichts mit GIMP zu tun hat. In den allermeisten Konstellationen muss sich der Benutzer aber über all das keine Gedanken machen. Das Suchen der gewünschten Bilddatei läuft grundsätzlich so ab, wie auch im Dateimanager Dateien gesucht werden. Es ist zu empfehlen von Anfang an für Bilddateien, die irgendwann mit GIMP bearbeitet werden sollen, einen eigenen Ordner zu erstellen und aussagekräftig zu benennen. Dieser Ratschlag hat an sich nichts mit GIMP zu tun, sondern gilt generell, wenn Dateien für eine bestimmte Verwendung angelegt werden. Das Arbeiten mit GIMP erzeugt relativ viele Dateien, so dass es wichtig ist, die Übersicht von Anfang an zu gewährleisten. Ein zweiter Ratschlag sei gleich angefügt: Da auf heutigen Systemen Speicherplatz zumindest mehrheitlich kaum mehr limitiert ist, ist es sinnvoll, mit GIMP zu bearbeitenden Bilddateien als Kopien in den "GIMP-Ordner" zu legen. Geschehe auch, was wolle: So ist ausgeschlossen, dass die Originaldatei verloren geht.

Hat man die gewünschte Bilddatei gefunden, kann sie einfach durch Doppelklick (bei einigen Betriebssystemen auch nur einfacher Klick) geöffnet werden. Sie wird dann im Bildfenster von GIMP angezeigt. Damit ist der erste Schritt getan!

Bild schliessen[Bearbeiten]

Das Schliessen eines geöffneten Bildes ist denkbar einfach: Im Menü Datei klickt man den drittuntersten Menüpunkt Ansicht schliessen an. Wenn das geöffnete Bild nicht bearbeitet wurde (wovon auf dieser Seite noch ausgegangen wird), schliesst GIMP die Datei sofort ohne Rückfrage. Wenn es noch nicht gespeicherte Änderungen aufgrund von Bearbeitungen gibt, fragt GIMP, wie das heute bei den meisten Programmen der Fall ist, sicherheitshalber noch mit einem aufploppenden Fenster nach, ob diese Änderungen wirklich nicht gespeichert werden sollen. Dass GIMP statt von "Datei schliessen" oder so ähnlich von Ansicht schliessen spricht, liegt daran, dass in GIMP das Speichern von Änderungen etwas komplexer ist als etwa in heutigen Textverarbeitungsprogrammen. Wenn das Bild geschlossen ist, ist das Bildfenster wieder leer, sofern kein (anderes) Bild mehr offen ist.

Mehrere Bilder öffnen und schliessen[Bearbeiten]

obere linke Ecke des Bildfensters bei drei gleichzeitig geöffneten Bildern

Selbstverständlich kann man in GIMP mehrere Bilder öffnen bzw mehrere gleichzeitig geöffnet haben. Dazu wiederholt man einfach Datei/Öffnen... und wählt jeweils das gewünschte Bild aus. Auch das mehrmalige Öffnen desselben Bildes ist natürlich unter GIMP möglich und für gewisse Arbeiten durchaus sinnhaft. GIMP zeigt per Default im Bildfenster immer das zuletzt geöffnete Bild, wenn mehrere geöffnet sind. Es ist sehr einfach ein anderes als das zuletzt geöffnete Bild anzuzeigen: Wenn mehr als ein Bild geöffnet ist, zeigt GIMP nämlich am oberen Ende des Bildfensters automatisch Reiter (einen pro geöffnetes Bild) an, so dass bequem zwischen den geöffneten Bildern gewechselt werden kann. Sogar eine kleine Vorschau wird im Reiter angezeigt, so dass sofort ersichtlich ist, welche Bilder gerade geöffnet sind.

Das Schliessen von Bildern, wenn mehrere geöffnet sind, ist (noch ohne die Variante mit Tastenkürzel) auf zwei verschiedene Weisen grafisch möglich: Einmal hat es direkt im Reiter neben dem Vorschaubild eine kleine, mit x beschriftete Schaltfläche, wodurch das Bild des betreffenden Reiters geschlossen werden kann. Das ist zweckdienlich, wenn man nicht alle von mehreren geöffneten Bildern schliessen will. Das letzte geöffnete Bild kann allerdings nicht so geschlossen werden, da dann kein Reiter mehr da ist. Es ist aber auch möglich alle geöffneten Bilder auf einmal zu schliessen. Das wählt man im Menü Datei den zweituntersten Menüpunkt Alle schliessen. Wenn keine ungespeicherten Änderungen vorliegen, erfolgt das Schliessen aller Bilder sofort ohne Rückfrage; andernfalls fragt GIMP (unter Umständen mehrmals, falls mehrere Bilder ungespeicherte Änderungen haben) sicherheitshalber nach.

Einsatz von Tastenkürzeln[Bearbeiten]

Wie fast alle Aufgaben, kann man auch das Öffnen und Schliessen in GIMP mit Tastenkürzeln machen. Da die (zumindest regelmässigen oder sogar ausschliesslichen) Benutzer dieser Bedienungsart eine Minderheit sind, wird darauf jeweils nur kurz in einem Abschnitt eines Unterkapitels eingegangen. Es ist aber allen Benutzern, gerade auch Einsteigern, zu empfehlen diese Bedienungsart zumindest einmal zu testen. Erwähnt sei, dass Benutzer, die regelmässig mit Tastenkürzel arbeiten und dadurch die wichtigsten Kürzel auswendig kennen, ganz erheblich und messbar schneller arbeiten, als wer das Programm grafisch oder mit Menüs bedient.

Das Öffnen von Bildern erfolgt mit dem Tastenkürzel Ctrl + O. Das Tastenkürzel führt natürlich (nur) bis zur Verbindung mit dem Dateimanager; das zu öffnende Bild muss dann noch gesucht und angewählt werden.

Das Schliessen eines einzelnen (des gerade sichtbaren) Bildes erfolgt mit dem Tastenkürzel Ctrl + W. Wenn es nicht gespeicherte Änderungen in der zu schliessenden Datei gibt, stellt GIMP noch Rückfragen, sonst wird das Bild sofort geschlossen.

Das Schliessen aller geöffneten Bilder erfolgt mit dem Tastenkürzel Shift + Ctrl + W.

GIMP gibt bei allen Menüpunkten (rechts) die Tastenkürzel an, die anstelle der Bedienung verwendet werden können. Dieses Buch hat zudem eine Zusammenstellung der wichtigsten Tastenkürzel, insbesondere aller, die im Buch vorkommen.

Kleine Aufgaben[Bearbeiten]

  • Öffnen Sie ein Bild Ihrer Wahl per Menü und schliessen Sie es per Menü.
  • Öffnen Sie ein Bild ihrer Wahl per Menü und dann ein anderes per Tastenkürzel. Das zweite Bild öffen Sie noch einmal, diesmal per Menü. Dann schliessen Sie eine der beiden Ansichten des zweiten Bildes grafisch direkt im Bildfenster. Schliesslich schliessen Sie die restlichen zwei Bilder gleichzeitig per Menü.