GIMP/ GIMP als Malprogramm

Aus Wikibooks
Wechseln zu: Navigation, Suche
GIMP als Malprogramm

Dieser Teil gehört zum Buch „GIMP“.

Kurzinhalt: Dieser Band enthält Anleitungen zu Bearbeitungsfunktionen und Effekten.

Tutorials fürs Malen [Bearbeiten]

... einen Ballon[Bearbeiten]

  1. Zuerst erstellen wir ein quadratisches Bild und füllen es mit der Farbe, die der Ballon später haben soll. Im nächsten Schritt benutzen wir das Textwerkzeug (T-Taste) und schreiben the gimp in das mittlere Drittel des Bildes. Wollen Sie noch etwas anderes auf den Ballon malen, sollten Sie dies jetzt nachholen. Über die Menüfolge Bild und Sichtbare Ebenen vereinen fügen wir alle Ebenen zu einer einzelnen Ebene zusammen.
    Der Text und die Farbe
  2. Um den Ballon abzurunden, benutzen wir den Filter Auf Objekt abbilden, den Sie über das Menü Filter und Abbilden erreichen. Sie sollten darauf achten, die Option "Transparenter Hintergrund" zu aktivieren.
    Auf Objekt abbilden
  3. Unser Ziel ist es nun, aus der Kugel einen Ballon zu formen. Dazu benutzen wir den Filter Verbiegen. Sie finden den Filter im Menü Filter und Verzerren. Wählen Sie für die Vorschau die Funktion Automatische Vorschau und zusätzlich unter dem Eintrag Kurve für Rand die Option Untere Kurve aus. Wichtig sind weiterhin die beiden Optionen Glättung und Kantenglättung. Wenn soweit alles richtig ist, können Sie nun die Kurve etwa so wie auf dem Bild hinbiegen und auf die Schaltfläche OK klicken.
    Verbiegen
  4. Damit das Ergebnis auch das ganze Bild ausfüllt, wenden wir noch den Menübefehl Bild und Automatisch zuschneiden an. Fertig!!!
    Der fertige Ballon!

... Schaltflächen und Logos für die Web-Site[Bearbeiten]

  1. Eine Schaltlfäche erstellen Sie mit GIMP über das Menü Xtns - Skript-Fu und Schaltflächen.
  2. Wählen Sie im Untermenü von Schaltflächen den Eintrag Rund.... Mit dieser Auswahl erstellen Sie Schaltflächen mit abgerundeten Ecken.
  3. Im Dialogfenster Skript-Fu: Rund stehen Ihnen verschiedene Einstellmöglichkeiten zur Verfügung (z.B. Eingabe eines Textes, Wahl der Schriftart und Schriftgröße sowie die Wahl der Farbe für die Schaltfläche). GIMP legt standardmäßig drei einzelne Bilddateien mit nicht gedrückter, aktiver und gedrückter Schaltfläche an. Falls Sie nur eines dieser Arten benötigen, können Sie die nicht benötigte Variante im Dialogfenster Skript-Fu: Rund deaktiveren.
  4. Mit GIMP ist es nicht nur möglich, Schaltflächen zu erstellen - es stellt auch zahlreiche Skripte zur Verfügung, um Logos zu entwerfen. Unter Xtns - Skript-Fu und Logos finden Sie eine große Auswahl an Vorschlägen für das Layout von Logos. Die Logo-Dialoge enthalten ähnliche Einstellungen wie die Dialoge für das Erstellen von Schaltflächen.

... einen Negativstreifen[Bearbeiten]

  1. Zuerst öffnen wir die Bilder, die unser Negativ zeigen soll, und invertieren deren Farben über die Menüfolge Ebenen - Farben und Invertieren. Durch die Funktion Invertieren werden die Farben "umgedreht" - genauso wie Sie es von einem Negativ kennen.
    Umgedrehte Farben
  2. Allerdings stellt uns das Ergebnis noch nicht zufrieden, da ein Negativ nicht weiß, sondern braun ist. Um das aber zu erreichen, müssen wir diesen Farbton imitieren. Dafür stellen wir in der Farbauswahl eine Farbe ein, die etwa diesen Wert hat (z.B. 9b5b00).
    Die Negativfarbe
  3. Nun legen wir bei jedem Bild eine neue Ebene an, und füllen diese mit der eingestellten Farbe. Zusätzlich stellen wir die Deckkraft der neuen Ebenen auf 85%. Die Einzellbilder sind jetzt fertig und müssen lediglich über die Menüfolge Bild und Bild zusammenfügen zusammengefügt werden, sodass diese jeweils eine Ebene besitzen.
    Das Fertige Negativbild
  4. Kurz vor Abschluss fügen Sie die Bilder zu einem Film zusammen. Für diesen Teil der Arbeit gibt es bereits ein fertiges Plugin, welches uns einige Arbeit abnimmt. Sie finden es unter Menü Filter, Kombinieren und Film. An dieser Stelle wählen wir alle vorhanden Bilder aus und klicken auf die Schaltfläche Hinzufügen. Wir stellen weiterhin im Dialog Film die Farbe auf braun und unter Nummerierung die Farbe auf schwarz ein. Bei Bedarf können Sie noch die Startnummer ändern oder die anderen Einstellungen anpassen. Mit einem Klick auf die Schaltfläche OK erzeugt GIMP einen Film.
    Der Fertige Negativstreifen

... einen Wackelpudding-Klecks[Bearbeiten]

Zeitaufwand: etwa 10-20 Minuten, benoetigte Vorkenntnisse: geringe bis keine

  1. Wir erstellen ein neues Bild mit einer weissen Hintergrundebene, die wir sofort duplizieren. Auf der duplizierten Ebene malen wir die Klecksform mit einer Tusche (als Alternative können Sie die Klecksform mit einem Pinsel oder mit einem Stift malen). Als Farbe benutzen Sie am besten Kirschrot; zu finden ist sie in der Default-Palette. Wichtig ist, dass die Farbe voll gesättigt und vollen Wert hat, sie also weder schwarze noch weisse Anteile aufweist.
    Der grob gemalte Kleks
  2. Im nächsten Schritt zeichen wir den Klecks über die Menüfolge Filter - Weichzeichnen und Gaußscher Weichzeichner weich und verwenden einen grosszügigen Radius. Bei einer Bildgröße von 300x300 Bildpunkten ist 30 ein guter Wert. Wenn Ihr Ergebnis am Ende sehr viele Knicke und Kanten enthält, dann war der Wert für den Radius zu gering - kommt ein Oval heraus, war der Radiuswert zu hoch.
    Der weichgezeichnete Kleks
  3. Zum Einsatz kommt nun das Kurvenwerkzeug, das Sie über Ebenen - Farben und Kurven erreichen. Benutzen Sie an dieser Stelle die Einstellungen aus der Abb. Das Kurvenwerkzeug. Sie erhalten eine schöne, abgerundete Kante und eine ziemlich weiche Form. Je nachdem, wie Sie die Punkte verschieben, können Sie den Fleck durchsichtiger malen. Wird aber die Außenkante zu pixelig, sollten Sie die beiden mittleren Punkte in horizontaler Richtung weiter auseinanderschieben.
    Das Kurvenwerkzeug Nach Anwenden des Kurvenwerkzeuges
  4. Wollen Sie hinterher den Hintergrund ändern oder einen Schatten hinzufuegen, dann ist es praktisch, den weißen Hintergrund loszuwerden. Sie bewerkstelligen das mit Ebenen, Transparenz und Farbe zu Transparenz. (weiss).
  5. Für die Glanzpunkte erstellen wir eine neue Ebene, und zwar in schwarzer Farbe und Ebenenmodus auf Bildschirm. Mit Pinsel oder Sprüdose an die üblichen verdächtigen Stellen die Glanzpunkte grob aufpinseln.
    Grobe Glanzpunkte
  6. Diese Ebene zeichnen wir ebenfalls weich. Wir reduzieren hier allerdings den Wert des Radius um die Hälfte und ändern den Wert auf 15 ab. Je nachdem welche Oberfläche Sie wünschen, ist das Ziel schon erreicht.
    Fertige Glanzpunkte
  7. Wir wollen aber einen glänzenden Wackelpudding-Klecks, was die Glanzlichtebene im Wertewerkzeug auf den Plan ruft. Um dorthin zu gelangen, benutzen Sie die Menüfolge Ebenen, Farben und Werte und ziehen am oberen der beiden Balken die beiden äußeren Punkte zur Mitte hin. Damit ist es kein Problem, die Größe und Schärfe der Glanzpunkte sehr gut anzupassen.
    Das Wertewerkzeug Glanzpunkte
  8. Wer es übertreiben möchte, kann die bisher zurückgelegten Schritte wiederholen, den Wackelpudding-Klecks schattieren, die Farbe schwarz gegen weiß austauschen und die Ebene auf Multiplizieren setzen. Wem auch das nicht ausreicht, der kann dem Klecks noch einen Schlagschatten verpassen.
    Der fertige Klecks
  9. Das ganze eignet sich natürlich auch für andere Objekte, wie z.B. Schriftzüge:
    Wackelpudding-Schrift

... eine Animation[Bearbeiten]

Um kleine Filme mit einer Abfolge von vorgefertigten Bildern zu erstellen, die anschließend als GIF oder MNG für Internetbrowser, oder als MPG-Film für das Handy gespeichert wird, ist mit Gimp keine schwierige Angelegenheit. Die Bilder müssen dazu nur auf verschiedene Ebenen geladen werden und können dann automatisch beim Speichern in ein animiertes GIF umgewandelt werden.

Wir haben ein paar aufeinander folgende Bilder in unserem Verzeichnis auf der Festplatte gespeichert. Die Bilder heißen: Bild-1.png, Bild-2.png, Bild-3.png, Bild-4.png.

Die Bilder sollten die gleichen Abmessungen haben (z.B. 72Pixel×72Pixel ) und die gleiche Hintergrundfarbe haben, damit der Film nicht flackert. Wir laden das erste Bild : Datei, Öffnen. Wir wählen Bild-1.png Wenn das erste Bild geladen ist, dann hat es einen eigenen Rahmen. Das zweite Bild öffnen wir mit der Menüfolge: Datei, Als Ebene öffnen und wählen dann in dem Auswahlfenster das Bild Bild-2.png. Als Ebene öffnen wir auch die restlichen Bilder, welche in die Animation mit einfließen sollen.

Vor dem Speichern ist es sinnvoll, die Animation der Bilder auf den Ebenen zu überprüfen. Das geht mit der Menüfolge Filter, Animation, Animation abspielen.

... ein Gitter[Bearbeiten]

Dieses Tutorial finden Sie im GIMP-Tutorial unter: GIMP/ GIMP als Malprogramm/ Tutorials fürs Malen/ Gitter


Go-up.svg Hoch zu "GIMP - GIMP als Malprogramm"


... ein Argusbild zum Suchen der Unterschiede[Bearbeiten]

Mit der Stempelfunktion lassen sich auch mit SchülerInnen schöne Argusbilder basteln (vgl. [1]). Man entfernt Gegenstände, verändert Farben - verändert häufig kleinere, unauffällige Details und ersetzt sie durch ihre Umgebung. Mit + (oder der Lupe) vergrößert man den sichtbaren Bildausschnitt, mit - verkleinert man ihn. Die Stempelgrösse und Form, für den zu ersetzenden Bildbereich, lässt sich am Schieberegler aus Bild 2 einstellen.

Um nun ein Detail aus dem Bild durch die Umgebung zu ersetzen, klickt man zuerst auf die Fläche mit welcher man später ersetzen will. Zweckmäßig ist es häufig, die Fläche neben dem zu ersetzenden auszuwählen. Danach mit gedrückter CTRL Taste mit Stempel überdecken. Wenn nötig, kann man mit dem Wischfinger noch sichtbare, harte Kanten, die durch das Ersetzen entstanden sind, retuschieren, indem man betroffene Bildbereiche per Drag and Drop (Klicken und Ziehen) verschmiert. Mit Klick auf das Symbol "T" kann man auch Texte einfügen, wie z.B. die Beschriftung auf den Seiten des Lastwagens "GIMP OSS" (vgl. dazu Bild 2 und Bild 4).



Wikibooks-Hinweise
Druckversion des Buches GIMP/ GIMP als Malprogramm
  • Dieses Buch umfasst derzeit etwa DIN-A4-Seiten einschließlich Bilder (Stand: ).
  • Wenn Sie dieses Buch drucken oder die Druckvorschau Ihres Browsers verwenden, ist diese Notiz nicht sichtbar.
  • Zum Drucken klicken Sie in der linken Menüleiste im Abschnitt „Drucken/exportieren“ auf Als PDF herunterladen.
  • Mehr Informationen über Druckversionen siehe Hilfe:Fertigstellen/ PDF-Versionen.
  • Hinweise:
    • Für einen reinen Text-Ausdruck kann man die Bilder-Darstellung im Browser deaktivieren:
      • Internet-Explorer: Extras > Internetoptionen > Erweitert > Bilder anzeigen (Häkchen entfernen und mit OK bestätigen)
      • Mozilla Firefox: Extras > Einstellungen > Inhalt > Grafiken laden (Häkchen entfernen und mit OK bestätigen)
      • Opera: Ansicht > Bilder > Keine Bilder
    • Texte, die in Klappboxen stehen, werden nicht immer ausgedruckt (abhängig von der Definition). Auf jeden Fall müssen sie ausgeklappt sein, wenn sie gedruckt werden sollen.
    • Die Funktion „Als PDF herunterladen“ kann zu Darstellungsfehlern führen.
  • Autorenliste, sofern möglich
CC some rights reserved.svg
Heckert GNU white.svg

Dieser Text ist sowohl unter der „Creative Commons Attribution/Share-Alike“-Lizenz 3.0 als auch GFDL lizenziert.

Eine deutschsprachige Beschreibung für Autoren und Weiternutzer findet man in den Nutzungsbedingungen der Wikimedia Foundation.