GIMP/ Fortgeschrittene Bildbearbeitung

Aus Wikibooks
Wechseln zu: Navigation, Suche
Fortgeschrittene Bildbearbeitung

Dieser Teil gehört zum Buch „GIMP“.

Kurzinhalt: Dieser Band bietet einen Überblick über die Filter und Skripte von GIMP.

Filter [Bearbeiten]

Weichzeichner[Bearbeiten]

Bewegungsunschärfe[Bearbeiten]

Gaußscher Weichzeichner[Bearbeiten]

Der Gaußsche Weichzeichner zeichnet Bilder weich, indem er die Farbwerte benachbarter Pixel miteinander vermittelt. Wie stark die jeweiligen benachbarten Pixel in die Vermittlung einfließen, wird dabei durch eine Gauß'sche Glockenkurve bestimmt. Man hat zwei verschiedene Algorithmen zur Auswahl, die allerdings beide zum selben Ergebnis führen:

  • IIR (infinite impulse response) eignet sich für Fotos
  • RLE (run length encoding) eignet sich besonders für Bilder mit großen einfarbigen Flächen, z.B. Comics

Kachelbarer Weichzeichner[Bearbeiten]

Pixeln[Bearbeiten]

Dieser Weichzeichner tut nicht das, was man unter einem Weichzeichner versteht. Er "verpixelt" ein Bild, wie es gerne zur Unkenntlichmachung von Gesichtern oder Autonummern in Nachrichten und ähnlichem getan wird. In Verbindung mit anderen Filter eignet sich dieser Filter sehr gut zur Erstellung von gitterartigen Mustern: GIMP/_GIMP als Malprogramm/_Tutorials fürs Malen/_Gitter

Selektiver Gaußscher Weichzeichner[Bearbeiten]

Weichzeichnen[Bearbeiten]

Ein sehr einfacher Weichzeichner, der benachbarten Pixel ineinander einfließen lässt.

Farben[Bearbeiten]

Filter, die die Farben eines Bildes beeinflussen.

Abbilden[Bearbeiten]

Alien Map 2[Bearbeiten]

Auf Farbverlauf[Bearbeiten]

Einfärben[Bearbeiten]

Farbbereiche vertauschen[Bearbeiten]

Farben drehen[Bearbeiten]

Farben vertauschen[Bearbeiten]

VG-HG anpassen[Bearbeiten]

Einfärben[Bearbeiten]

Farbe zu Transparenz[Bearbeiten]

Farbraumanalyse[Bearbeiten]

Gibt das Farbspektrum eines Bildes aus (von 000000-FFFFFF)

Filterpaket[Bearbeiten]

Heiß[Bearbeiten]

Kanalmixer[Bearbeiten]

Max RGB[Bearbeiten]

Palette glätten[Bearbeiten]

Randmittelwert[Bearbeiten]

Retinex[Bearbeiten]

Semi-Flatten[Bearbeiten]

Wert invertieren[Bearbeiten]

Zerlegen[Bearbeiten]

Der Befehl Zerlegen ermöglicht, ein Bild in die Komponenten eines Farbprofiles zu zerlegen. Man erreicht ihn über das Menü "Farben - Komponenten - Zerlegen ..." Nach der Auswahl des Farbmodus und dem Anklicken des OK Buttons wird eine Kopie erstellt, bei der die einzelnen Farbanteile als Ebenen im Graumodus angezeigt werden. Eine Möglichkeit ist, diese Bilder zum Erstellen von Auswahlen zu verwenden. Eine weitere kann die Erzeugung einer Druckvorstufe sein.

Zusammensetzen[Bearbeiten]

Rauschen[Bearbeiten]

Kanten finden[Bearbeiten]

Verbessern[Bearbeiten]

Generisch (GIMP 2.4)[Bearbeiten]

Glaß-Effekte[Bearbeiten]

Licht-Effekte[Bearbeiten]

Mit den Lichteffekten bei Gimp kann man, z.B. ein Glitzern oder Supernova(Blitz punkt) erstellen. Man kann dem Bild einen Schlagschatten hinzufügen, der sich auf den Hintergrund des Objekts legt.

Verzerren[Bearbeiten]

Künstlerisch[Bearbeiten]

Abbilden[Bearbeiten]

Render[Bearbeiten]

Web[Bearbeiten]

Animation[Bearbeiten]

Um in GIMP den Animationsfilter verwenden und Animationen erstellen zu können, muss zunächst der Umgang mit und das Konzept hinter Ebenen verstanden werden.

Um eine Animation zu erstellen, genügt die Vorstellung, jede Ebene sei ein Bild der Animation. In etwa wie in einem Daumenkino. Wurden die Ebenen mit den einzelnen Bildern erstellt, ist die Animation eigentlich bereits fertig. Das Resultat kann durch eine Vorschau unter dem Menüpunkt "Filter --> Animation --> Animation abspielen" betrachtet werden.

Wird ein Bild mit mehreren Ebenen als GIF gespeichert, erscheint dieser Dialog.

Um nun aus dem Bild, welches aus mehreren Ebenen besteht eine Animation zu generieren, genügt es, das Bild als gif zu speichern. Es öffnet sich der im rechten Bild gezeigte Dialog. Da das GIF-Format Ebenen lediglich als Animation kennt, bestehen lediglich die Möglichkeiten, die Ebenen zu einem Bild zu kombinieren oder aus den Ebenen eine Animation zu generieren.

Ebenen einer GIF-Animation, können die vorherige Ebene bei einem Übergang ersetzen oder miteinander kombiniert werden.

Im folgenden Dialog können noch einige Einstellungen zur Animation festgelegt werden. U.a. kann hier angegeben werden, ob der Übergang von einer Ebenen zu nächsten durch Ersetzen oder Kombinieren geschehen soll.

Das Ersetzen von Ebenen entspricht dem intuitiveren Vorgehen. Hierbei wird bei einem Übergang eine Ebene durch die nächst höhere Ebene vollständig ersetzt (genau wie bei einem Daumenkino).

Üblicherweise ist es jedoch klüger sich für das Kombinieren von Ebenen zu entscheiden, da bei diesem Verfahren bei einem Übergang nur die Teile einer Ebene durch die nächst höhere ersetzt werden, die von dieser verändert werden. Alle Anteile, die in der nächst höheren Ebene als Transparent markiert sind, werden nicht verändert. Für die Kombination von Ebenen müssen deshalb nicht alle Ebenen als eigenständige Bilder gespeichert werden, sondern lediglich die Veränderung von einem zum nächsten Bild. Dadurch kann die Gesamtgröße der Animation maßgeblich reduziert werden.

Um die Ebenen für die Kombination vorzubereiten bietet GIMP mit dem Animationsfilter eine komfortable Optimierungsfunktion an. Durch Auswahl des Menüpunkts "Filter --> Animation --> Optimieren für GIF" wird ein weiteres GIMP-Dokument angelegt, bei dem bei den höheren Ebenen die Anteile gelöscht (transparent gemacht) wurden, die sich nicht von den Anteilen der darunter liegenden Ebene unterscheiden. Aus diesem GIMP-Dokument kann nun die GIF-Animation erstellt werden.

Die in diesem Abschnitt vorgestellte Technik zur Erstellung einer Animation ist sehr aufwendig. Trotz der Hilfestellung duch GIMP beim Verwalten der Ebenen, bei der Reduktion der Bildgröße durch Kombination und bei dem tatsächlichen Erstellen der Animation, ist es nötig jedes einzelne Bild der Animation selbst zu erzeugen. Will man jedoch eine komplexere Animation erstellen, empfiehlt sich die Verwendung von GAP (GIMP animation package). GAP besteht aus einer Sammlung von Plugins für GIMP, mit denen sich Animationen der Art "Bewege Objekt A von der linken oberen Ecke in die rechte untere Ecke, lasse dieses Objekt anschließend größer werden und letztendlich ausblenden." erstellen lassen.

Kombinieren[Bearbeiten]

Film[Bearbeiten]

Der Filter Film erzeugt einen Filmstreifen und fügt die ausgewählten Bilder in diesen ein.

Tiefenkombination[Bearbeiten]

Viel Spaß[Bearbeiten]

In diesem Menü verbergen sich Filter, welche kaum sinnvoll anwendbar sind, aber durchaus Spaß machen, oder gut aussehen können.

Gee-Schleim[Bearbeiten]

Der Menüpunkt Gee-Schleim öffnet ein Fenster, in welchem ein Ausschnitt des Bildes zu sehen ist. Bewegt man den Mauszeiger, so erzeugt der Filter auf dem Bild Wellen, wie wenn eine zähflüssige Flüssigkeit in eine andere tropft.

Gee-Zoom[Bearbeiten]

Gee-Zoom zeigt einen Ausschnitt des Bildes in einem extra Fenster. Durch Bewegen des Mauszeigers wird der Zoom und andere Eigenschaften verändert und mit Effekten überlagert. Der Filter bringt manchmal sehr schöne Muster hervor.



Bildhelligkeit ändern [Bearbeiten]

Gradationskurven in GIMP 2.4
Gradationskurven in GIMP 2.6

GIMP-Benutzer setzen häufig das Helligkeits- und Kontrastkwerkzeug ein und erzielen damit wenig zufriedenstellende Ergebnisse. Verwunderlich ist das nicht, da das Helligkeits- und Kontrastwerkzeuge die helleren und dunkleren Bildbereiche gleichermaßen verändert. Abhilfe schaffen Sie mit dem Einsatz von Gradationskurven, die es erlauben, für das gesamte Bild individuell die Farbtemperatur, Kontraste und Helligkeit einzustellen.

  1. Gradationskurven erstellen Sie über das Menü Werkzeuge - Farben und Kurven.
  2. GIMP blendet nun ein Dialogfenster mit mehreren Schaltflächen und einer Geraden ein. Uns interessiert einzig das Histogramm, aus dem Sie die Verteilung der Farben und der hellen und dunklen Bildelemente entnehmen können. Über diesem Histogramm liegt eine diagonale Linie mit einem unteren und einem oberen Ende. In der Bildbearbeitung trägt diese Gerade die Bezeichnung Gradationskurve.
  3. Um das Bild aufzuhellen oder abzudunkeln, müssen Sie die Endpunkte der Kurve senkrecht nach oben (das Bild wird heller) oder nach unten (das Bild wird dunkler) schieben. Achten Sie darauf, ein Häkchen vor der Option Vorschau zu setzen, denn damit ist es Ihnen möglich, das Ergebnis Ihrer Änderungen am Bildschirm mitzuverfolgen. Hinweis: GIMP übernimmt die Änderungen erst, wenn Sie auf die Schaltlfäche OK klicken.
  4. Falls Sie mit Ihren Einstellungen nicht zufrieden sind, können Sie mit der Schaltfläche Rücksetzen (GIMP 2.4) oder mit der Schaltfläche Zurücksetzen (GIMP 2.6) die Gradationskurve auf seinen Ursprung zurücksetzen.
  5. Sollten Sie mehrere Bilder mit ähnlicher Hell-Dunkel-Verteilung bearbeiten wollen, empfiehlt es sich, die Werte der Gradationskurve abzuspeichern. Dazu klicken Sie in GIMP 2.4 auf die Schaltfläche Speichern, wählen das Verzeichnis und den Dateinamen Ihrer Gradationskurven-Einstellungen aus und klicken auf Speichern. Um die gespeicherten Einstellungen in anderen Bildern einzusetzen, klicken Sie einfach auf die Schaltfläche Öffnen und wählen aus dem Verzeichnis die entsprechende Datei aus und klicken auf Öffnen.
    GIMP 2.6-Benutzer klicken auf das Plus-Zeichen, das sich im oberen Bereich am rechten Rand des Dialogfensters befindet. Im anschließenden Dialogfenster tragen Sie im Textfeld einen Namen ein. Über die Klappliste gelangen Sie zu der Auswahl der von Ihnen abgespeicherten Einstellungen.

Siehe auch: GIMP/_Tutorials/_Objekte_freistellen#Farbkurven



Bildhorizont ändern [Bearbeiten]

Schräge Bilder gerade rücken[Bearbeiten]

Es gibt zwei Wege schräge Bilder gerade zu rücken. Einerseits kann man die korrektive Rotation verwenden, andererseits als Hilfsmittel mit Messwerkzeug (Abstände und Winkel messen) Winkel und entfernungen messen.png, das die Entfernungen und Winkel zwischen zwei Punkten misst arbeiten. Ergänzend zum Messwerkzeug benutzen wir das Werkzeug Ebene oder Auswahl drehen (Umschalttaste + R) Auswahl drehen.png, um das Bild zu begradigen.

Vorgehensweise: Korrektive Rotation[Bearbeiten]

In Kurzform bedienen wir uns hier dem Gitter (Grid) in der Rotationsvorschau. Bilder folgen noch.

  1. Werkzeug "Drehen(Rotation)" wählen
  2. Ins Bild klicken
  3. In den Werkzeugeigenschaften nun "Korrigierend(Correcting)" und "Bild und Raster(Image + Grid)" bei "Vorschau(Preview)" wählen
  4. nun die Anzahl der Gitterlinien so weit erhöhen/verringern, dass eine Linie eine im Bild vorhandene Linie schneidet
  5. nun das Bild so weit drehen, das die Line aus dem Bild parallel zu einer Gridlinie ausgerichtet ist
  6. "Rotieren(Rotate)" klicken und fertig, das Bild wird nun zurechtgedreht

Vorgehensweise: Messwerkzeug[Bearbeiten]

  1. Ziel ist es, das Ursprungsbild Haus im japanischen Garten zu begradigen.
    Das Ursprungsbild
  2. Es ist unschwer zu erkennen: das Bild ist zu weit nach rechts verdreht. Um den Drehwinkel abschätzen zu können, ziehen Sie eine Hilfslinie ins Bild: Dazu klicken Sie auf das Lineal, halten die linke Maustaste gedrückt und ziehen die Maus nach unten. In unserem Fall sollten Sie die Hilfslinie auf die obere linke Bildecke ablegen, sodass Sie nun eine Markierung der Waagerechten haben.
  3. Wählen Sie das Messwerkzeug (Abstände und Winkel messen) Winkel und entfernungen messen.png, klicken an eine Stelle im Bild und halten die linke Maustaste gedrückt. Sobald Sie den Mauszeiger bewegen, zeichnet GIMP eine Verbindungslinie.
  4. In den Werkzeugeinstellungen des Messwerkzeugs (Abstände und Winkel messen) können Sie einstellen, ob GIMP die Länge und den Winkel nicht nur in der Statuszeile, sondern auch in einem eigenen Infofenster anzeigt.
    Info-Fenster.png
  5. Um das Bild gerade zu rücken, wählen Sie das Werkzeug Ebene oder Auswahl drehen (Umschalttaste + R) Auswahl drehen.png und tragen im folgenden Dialog den im Messwerkzeug ermittelten Winkelwert (z.B. -1.80) ein. Je nach Richtung wählen Sie einen positiven oder negativen Wert des Winkels (negativer Wert: GIMP dreht das Bild im Uhrzeigersinn; positiver Wert: GIMP dreht das Bild gegen den Uhrzeigersinn).
    Drehinformationen.png
  6. Es ist geschafft: Unser Motiv Haus im japanischen Garten ist an der horizontalen Linie bündig ausgerichtet!
    Das fertige Bild


Bilder mit Transparenz versehen [Bearbeiten]

Mit GIMP ist es leicht, Grafiken zu erstellen, deren helle Farben hinter die Hintergrundfarbe rücken sollen (z.B. bei Web-Seiten mit dunklem Hintergrund). Um aber solche transparente Grafiken zu erstellen, müssen Sie bestimmte Bildteile definieren und in einem Alpha-Kanal in der Grafikdatei mitspeichern.

  1. Öffnen Sie eine Grafik, die Sie transparent abspeichern möchten.
  2. Falls Sie ein Graustufen- oder Schwarzweiß-Bild benutzen, müssen Sie es in Farbe umwandeln. Dazu klicken im Menü Bild - Modus auf den Eintrag RGB.
  3. Wählen Sie aus dem Menü Ebene - Transparenz den Eintrag Farbe zu Transparenz.
  4. In der Regel dürfte nichts dagegen sprechen, den Vorschlag von GIMP für die transparente Farbe anzunehmen (standardmäßig schlägt GIMP weiß als transparente Farbe vor). Sie schließen den Dialog mit dem Klick auf OK ab. Im Vorschaufenster sehen Sie ein mit einem Schachbrett vergleichbares Muster, das Ihnen den transparenten Hintergrund anzeigt.
    Farbe zu transparenz.png
  5. Nun können Sie die Grafik abspeichern, wobei Sie nur Dateiformate verwenden sollten, die Transparenzen unterstützen (z.B. Portable Network Graphics-Format). Wenn Sie das Bild in das PNG-Format abspeichern, blendet Ihnen GIMP vor dem Abspeichern ein Dialogfenster ein, in dem Sie Optionen aktivieren oder deaktiveren können. Achten Sie darauf, die Option Farbwerte aus Transparenz speichern auszuwählen. Damit speichern Sie in Ihrem Bild die transparente Farbe mit ab.
    Png-speichern.png


Wikibooks-Hinweise
Druckversion des Buches GIMP/ Fortgeschrittene Bildbearbeitung
  • Dieses Buch umfasst derzeit etwa DIN-A4-Seiten einschließlich Bilder (Stand: ).
  • Wenn Sie dieses Buch drucken oder die Druckvorschau Ihres Browsers verwenden, ist diese Notiz nicht sichtbar.
  • Zum Drucken klicken Sie in der linken Menüleiste im Abschnitt „Drucken/exportieren“ auf Als PDF herunterladen.
  • Mehr Informationen über Druckversionen siehe Hilfe:Fertigstellen/ PDF-Versionen.
  • Hinweise:
    • Für einen reinen Text-Ausdruck kann man die Bilder-Darstellung im Browser deaktivieren:
      • Internet-Explorer: Extras > Internetoptionen > Erweitert > Bilder anzeigen (Häkchen entfernen und mit OK bestätigen)
      • Mozilla Firefox: Extras > Einstellungen > Inhalt > Grafiken laden (Häkchen entfernen und mit OK bestätigen)
      • Opera: Ansicht > Bilder > Keine Bilder
    • Texte, die in Klappboxen stehen, werden nicht immer ausgedruckt (abhängig von der Definition). Auf jeden Fall müssen sie ausgeklappt sein, wenn sie gedruckt werden sollen.
    • Die Funktion „Als PDF herunterladen“ kann zu Darstellungsfehlern führen.
  • Autorenliste, sofern möglich
CC some rights reserved.svg
Heckert GNU white.svg

Dieser Text ist sowohl unter der „Creative Commons Attribution/Share-Alike“-Lizenz 3.0 als auch GFDL lizenziert.

Eine deutschsprachige Beschreibung für Autoren und Weiternutzer findet man in den Nutzungsbedingungen der Wikimedia Foundation.