Blender 3D: FAQ

Aus Wikibooks
Wechseln zu: Navigation, Suche

<< Zurück zu Blender 3D

FAQ (frequently asked questions) zu Blender 3D. Die englischsprachige FAQ finden Sie auf wiki.blender.org.

Inhaltsverzeichnis

Installation[Bearbeiten]

Welche Hardwarevoraussetzungen hat Blender?[Bearbeiten]

Blender benötigt einen schnellen Computer und viel Hauptspeicher (RAM), damit Bilder schnell berechnet werden. Um im 3D-Fenster zügig arbeiten zu können, sollte die Graphikkarte OpenGL fähig sein, Karten mit NVidia-Chipsätzen laufen in der Regel gut. Alle Empfehlungen bezüglich von Hardwarekomponenten sind natürlich nur sehr begrenzte Zeit gültig (März 2008).

Normale Anforderungen:

  • Wenn Sie es nicht so eilig haben und nur Einzelbilder berechnen wollen, kann man mit einem 2 GHz Prozessor und 2 GB RAM schon vernünftig arbeiten. Eine GeForce 7600 reicht auch für gehobene Ansprüche in der Regel bereits aus.

Mittleres System:

  • Ein Dual-Core Prozessor (z.B. Athlon 64 X2 3800+) mit 4 GB RAM und ebenfalls eine GeForce 8600 reicht auch für komplexere Szenen aus, es geht aber natürlich noch erheblich schneller.

Gutes System:

  • Als Prozessor ein QuadCore, z.B. Intel® Core 2 Quad Q9300. 8 GB RAM und z.B. eine GeForce 9600. Damit der Hauptspeicher vollständig genutzt werden kann, benötigen Sie aber ein 64-Bit Betriebssystem und eine 64-Bit Version von Blender. Für die optimale Nutzung von Cycles sollten Sie ein Grafikarte mit NVidia-Chipsatz besitzen.

Beim Starten öffnet sich ein schwarzes Fenster. Dort steht: "Checked for installed Python ... No installed Python found." Fehlt mir irgendetwas?[Bearbeiten]

Blender überprüft, ob ein Interpreter für die Sprache "Python" auf dem Rechner installiert ist. Python braucht man nicht zum normalen Arbeiten mit Blender, alle mitgelieferten Skripte laufen auch ohne Python-Installation.

Will man eigene oder heruntergeladene Python-Skripte zum laufen bekommen, kann man sich unter http://www.python.org/download/ die passende Software herunterladen. Welche Python-Version man braucht, steht in der Meldung nach der Angabe "Compiled with Python" (Blender 2.48a benötigt 2.5.x)

Kann ich Blender unter Windows auch ohne besagtes (Konsolen)-Fenster starten?[Bearbeiten]

Ja, dies geht mit blenderstarter.exe. Diese Datei muss sich dabei im selben Ordner wie Blender befinden und dann statt blender gestartet werden.

Allgemeines[Bearbeiten]

Kann ich ältere Tutorials/Dokumentationen überhaupt für meine Blenderversion benutzen?[Bearbeiten]

v2.48a: Den größten Unterschied in der Bedienung gibt es zwischen den Versionen 2.45 und 2.46. In 2.46 kam ein neues Partikelsystem und der UV Face Select Mode wurde entfernt und befindet sich nun im Edit Mode. Wenn Sie das einführende Tutorial Gus durchgearbeitet haben, sollten Sie in der Lage sein, alle Einstellungsmöglichkeiten in Blender wiederzufinden, auch wenn sich die Position der Buttons verändert haben sollte.

Kann ich Blender auf Deutsch umstellen?[Bearbeiten]

Es gibt zwar eine (lückenhafte) Übersetzung für die Oberfläche, aber alle Tutorials und die gesamte Dokumentation beziehen sich immer auf die englischsprachige Oberfläche. Auch in den deutschen Foren werden i.d.R. die englischsprachigen Fachbegriffe verwendet. Wir empfehlen Ihnen deswegen, nur die Tooltips auf deutsch anzeigen zu lassen. In den Voreinstellung unter Language & Font aktivieren Sie International Fonts. Wählen Sie eine Sprache aus. Direkt unter diesem Menübutton befinden sich drei Schalter. Tooltips - die Kurzhilfen. Buttons - die Schalter. Toolbox - die Werkzeugkiste. Nur wenn die entsprechenden Buttons aktiviert sind, wird auf deutsch umgestellt. Alle deaktivierten Teile werden weiterhin auf englisch angezeigt.

Mein Blender erkennt Python nicht![Bearbeiten]

Blender 2.4X benötigt Python 2.5x. Überprüfen Sie, ob Sie eine andere Version von Python installiert haben. Ggf. müssen Sie im Archivder Python-Website nach einer der älteren 2.5X-Versionen suchen und installieren. [ - Möglicherweise haben Sie zwar die richtige Version, aber eine Variante für anderen/spezielle Prozessoren installiert.

    <->  "Dieses Installationspaket wird auf dieser Plattform nicht unterstützt." 

Diese Fehlermeldung beweist schon, dass Sie eine Prozessorarchitektur installiert haben, die nicht valid ist. (z.B die 64-bit Variante auf einem 32-Bit Betriebssystem). Ähnliches gilt natürlich auch für verschiedene Betriebssysteme.

Wie kann ich zwei Objekte (im Object Mode) miteinander verbinden, sodass ein einziges Objekt bzw. Mesh entsteht?[Bearbeiten]

v.2.49.2: Nur Objekte desselben Typs lassen sich miteinander verbinden. Also nur ein Meshobjekt mit einen anderen Meshobjekt, NURBS mit anderen NURBS etc. Eine Ausnahme bilden die Metaobjekte, die nicht verbunden werden können. Sie befinden sich im ObjektMode und markieren dann alle Objekte, die Sie verbinden wollen und wählen die Funktion Join Objects im Menü Object oder das Tastaturkürzel Strg-J. Bestätigen Sie mit OK. Nähere Informationen darüber, wie diese Aktion mit Blenders Datenstruktur zusammen hängt, finden Sie hier.

Lila Bild?[Bearbeiten]

Wenn beim rendern ein Körper lila erscheint läuft was schief. Dies kann bei falschen Verknüpfungen oder an der Version von Blender liegen.

Fehler: Eine höhere Version von Blender benötigt, weil Features fehlen. Weil deshalb das Bild nicht gerendert werden kann, färbt dieses sich lila.

Grundfunktionen[Bearbeiten]

Wie kann ich die Ansicht so ausrichten, dass sie senkrecht zu meinem Objekt ist?[Bearbeiten]

v2.48a: Entweder über das View->Align View->Allign View to Selected-Menü in der Werkzeugleiste des 3D-Fensters, oder mit Num *.

Wie kann ich ein Objekt auswählen?[Bearbeiten]

v2.48a: Sie wählen grundsätzlich mit Rechtsklick aus. Im Select Menü der Werkzeugleiste des 3D-Fensters finden Sie verschiedene Auswahlmöglichkeiten, z.B. nach Objekttyp, Layer usw. Die Auswahlmöglichkeiten unterscheiden sich je nach Modus, in dem sich das Objekt befindet. Eine Übersicht über die vielfältigen Möglichkeiten finden Sie im Handbuch unter EditMode.

Mehrere Objekte liegen übereinander, wie kann ich das gewünschte Objekt auswählen?[Bearbeiten]

v2.48a: Klicken Sie mit Alt-RMT, wird ein Auswahlmenü mit allen Objekten geöffnet, die sich an dieser Stelle befinden. Häufig ist diese Tastenkombination allerdings schon durch den Fenstermanager (das Betriebssystem) belegt. Dann müssen Sie mehrmals mit der rechten Maustaste klicken, um das richtige Objekt auszuwählen (oder den Fenstermanager umstellen).

Wie kann ich ein Objekt (Material, Bild, Szene) aus einer anderen Datei einfügen?[Bearbeiten]

v2.48a: Das geschieht mit der Append Funktion. Man klickt auf File->Append or Link und wählt dann die andere .blend Datei aus. Man sieht nun in die andere Datei hinein, in der die verschiedenen Datentypen aufgelistet sind (Camera, Object, Texture ...) Nach Klick auf eine Kategorie kann man ein Object auswählen. Siehe Append.

Wie kann ich Einstellungen von einem Objekt auf ein anderes kopieren?[Bearbeiten]

v2.48a: Wählen Sie zunächst das Objekt (die Objekte) aus, die die Eigenschaften bekommen soll, als letztes mit Shift-Auswahl das Objekt, das die gewünschten Eigenschaften hat. Drücken Sie Strg-C und wählen die gewünschten Eigenschaften aus.


Meshbearbeitung[Bearbeiten]

Was ist ein Meshobjekt?[Bearbeiten]

v2.48a: Meshobjekte sind die wichtigsten Bestandteile ihrer Szene. Die meisten sichtbaren Objekte sind üblicherweise sog. Meshobjekte, da sie am besten und flexibelsten zu bearbeiten sind. Meshobjekte [Netzobjekte] bestehen aus einzelnen "Knoten" [Vertices], das sind Punkte im 3D Raum. Zwischen den "Knoten" kann man Verknüfungen (Kanten [Edges]) erzeugen, also virtuelle Seile ziehen. Fertig ist das Netz. In einem 3D Bild würde man das Meshobjekt aber noch nicht sehen können, es fehlen noch die Flächen [Faces]. Zwischen den Verknüpfungen können die Flächen aufgespannt werden. Veränderungen der Geometrie des Meshobjektes betreffen immer nur die Vertices, da diese die Form bestimmen.

Ich habe versehentlich ein neues Objekt im Edit-Mode eingefügt, wie kann ich daraus ein eigenständiges Objekt machen?[Bearbeiten]

v2.48a: Zunächst müssen Sie alle Vertices auswählen, die abgetrennt werden sollen. Häufig hängen die Vertices ja zusammen. Dann wählen Sie zunächst einen der Vertices aus, mit Select linked (Strg-L) wählen Sie alle anhängenden Vertices aus. Genügt das nicht, müssen Sie eine der anderen Auswahlfunktionen einsetzen. Wenn Sie die entsprechenden Vertices ausgewählt haben, drücken Sie P (Separate). Wählen Sie Selected. Um das neu erstellte Objekt auszuwählen, müssen Sie zunächst den Edit Modus verlassen (Tab). Nun können Sie ihr neues Objekt wie üblich auswählen.

Vertices aneinander ausrichten[Bearbeiten]

v2.48a: Wählen Sie die gewünschten Vertices im Edit-Modus aus. Drücken Sie S, gefolgt von der Achse, an der Sie die Vertices ausrichten wollen (X/Y/Z). Durch Eingabe der Zahl 0 richten Sie die Vertices genau aneinander aus. Mit Enter schließen Sie die Aktion ab.

Wie trenne ich Teile meines Objektes ab?[Bearbeiten]

v2.48a: Wenn Sie die entsprechenden Vertices ausgewählt haben, drücken Sie P (Separate). Wählen Sie Selected. Fertig.

Wie kann ich mehrere Objekte auf einmal bearbeiten?[Bearbeiten]

v2.48a: Gar nicht. Sie müssen die Objekte zunächst zu einem verbinden [joinen]. Wählen Sie dazu die Objekte aus, und drücken Strg-J.

Wie kann ich Vertices miteinander verbinden?[Bearbeiten]

v2.48a: Um einzelne Vertices zu verbinden, markieren Sie diese und drücken F. Haben Sie drei oder vier Vertices markiert, wird eine Fläche [Face] erstellt. Wollen Sie mehr als eine Fläche erstellen, also beispielsweise ein Verbindungsstück zwischen zwei Rohren, markieren Sie die entsprechenden Vertices, und benutzen ein Script . Dazu wechseln Sie in das Scripts Window, und wählen Scripts->Mesh->Bridge Faces/Edge-Loops.

Ich habe auf ein Mesh einen Modifier wirken lassen, aber wenn ich das Mesh exportiere, scheinen die Änderungen verloren zu sein?[Bearbeiten]

v2.48a: Sie müssen den Modifier erst "anwenden". Dazu drücken sie einfach auf "Apply". Den Schalter dafür finden sie, eine Zeile weiter unter dem Namen des Modifiers, auf der Rechten Seite.

Animation[Bearbeiten]

Wie animiert man eine Drehung um eine lokale Achse?[Bearbeiten]

v2.48a: Wenn die lokale Achse eines Objektes nicht mehr mit den globalen Achsen übereinstimmt, kann man eine Eigendrehung eines Objektes nicht direkt mit IPO Kurven erreichen. Man geht also folgendermaßen vor:

  • man setzt den 3D-Cursor mit Shift-S auf das Objekt, welches gedreht werden soll und erstellt eine Armature
  • man verläßt den Editmode der Armature
  • man markiert zuerst die Armature, dann das Objekt
  • man drückt Strg-C und wählt Rotation, damit wird die Rotation des Objektes auf die Armature kopiert
  • man fügt einen Copy Rotation Constraint für das Objekt hinzu, Target ist der entsprechende Bone der Armature
  • nun kann man (im Posemode) den Bone um die Lokale X-, Y- oderZ-Achse drehen und animieren, durch den Copy Rotation Constraint folgt das Objekt der Armature.

Ich kann ein Objekt nicht mehr bewegen, nachdem eine IPO Kurve hinzugefügt wurde![Bearbeiten]

v2.41: Dieses Problem tritt auf, wenn ein Partikel Emitter Child des Objektes ist. Nachdem Sie den ersten Key hinzugefügt haben, lässt sich das Parentobjekt nicht mehr bewegen.

  • Benutzen Sie statt der Parent-Child Beziehung einen Copy Location/Rotation Constraint. Diese Lösung ist nicht ganz gleichwertig, da Sie unter Umständen den Partikelemitter im Edit Modus in die richtige Position bringen müssen. Bei statischen Partikeln tritt dieses Problem nicht auf.

Wie verbindet man ein mechanisches Gerät, z.B. einen Roboter, das sich nicht verformen soll, mit einer Armature?[Bearbeiten]

v2.48a: Man erstellt jedes einzelne bewegliche Teil als einzelnes Objekt, und parentet dann an jeweils einen Bone.

  • Bringen Sie die Armature in den Pose-Modus.
  • Wählen Sie das Objekt aus.
  • Wählen Sie zusätzlich einen Bone der Armature aus (mit Shift-RMT).
  • Parenten Sie das Objekt an den Bone (Strg-P->Make Parent to Bone).


Interface[Bearbeiten]

Beim Weight-Painting wird mein Mesh ganz dunkel, ich kann gar nichts mehr erkennen![Bearbeiten]

v2.48a: In Blender werden die Objekte mit OpenGL dargestellt. Öffnen Sie die User Preferences->System & OpenGL. Stellen Sie das dritte Licht an, und wählen Sie die Richtung des Lichtes. Wenn das immer noch nicht genügt, können Sie auch noch die Lichtfarben auf Weiss ändern. Denken Sie daran, Ihre Voreinstellungen mit Strg-U zu sichern.

Material[Bearbeiten]

Wie kann ich ganz vielen Objekten auf einmal ein Material zuweisen?[Bearbeiten]

v2.48a: Man erstellt das Material an einem Objekt. Dann wählt man die gewünschten Objekte aus, das mit dem gewünschten Material als letztes. Strg-L->Material.

Ich habe ein durchsichtiges Objekt, aber der Schatten des Objektes ist trotzdem schwarz?[Bearbeiten]

v2.48a: Auch wenn alle anderen Einstellungen richtig sind, für das schattenempfangende Objekt muss die Option TraShad auf dem Shaders-Panel in den Material-Buttons angestellt sein!


Texturen[Bearbeiten]

Wie kann ich ein Video in einen Teil eines Bildes einbinden, z.B. für einen Fernseher?[Bearbeiten]

v2.48a: Sie können Videos (z.B. AVI) und nummerierte Bildsequenzen als Texturen benutzen.

Wie kann ich die Textur im 3D Fenster sehen?[Bearbeiten]

v2.41: Das geht nur mit UV-Texturen. Alle anderen Texturen ließen sich nur sichtbar machen, wenn Sie die Modelle vielfach unterteilen würden. Allerdings können Sie ab Version 2.42 mit Shift-P eine ausschnittsweise Rendervorschau im 3D Fenster einblenden.

Wieso ist meine Textur verzerrt ?[Bearbeiten]

Wahrscheinlich haben sie im Map-Input Panel eine falsche Einstellungen gewählt. Ziehen sie in diesem Fall das Kapitel über Texturkoordinaten festlegen (Map Input) zu rate.

Bildfehler[Bearbeiten]

Auf meinem Modell treten schwarze Streifen auf, wenn ich SetSmooth anwende.[Bearbeiten]

v2.48a: Das ist das typische Problem mit den verdrehten Flächennormalen. Markieren Sie alle Flächen im Edit Mode und drücken Sie STRG-N, um die Normalen neu zu berechnen. Weitere Informationen finden Sie auf der Seite Subdivision Surfaces.

Bei einer Animation scheint eine Fläche zu flimmern, oder ein Teil der Fläche sieht grieselig aus.[Bearbeiten]

v2.48a: Möglicherweise liegen an dieser Stelle zwei Teile des Meshes direkt übereinander. Benutzen Sie Remove Doubles (Edit Mode) um doppelte Vertices zu entfernen.

In einer eigentlich ebenen Fläche sieht man die Grenze zwischen den Teilflächen, insbesondere bei Anwendung von SetSmooth.[Bearbeiten]

v2.48a: Dafür gibt es mehrere Therapiemöglichkeiten:

  • Beautify fill: Manchmal ist die Unterteilung der Teilflächen ungünstig, dann kann Beautify fill (Alt-F) die Unterteilung evtl. verbessern.
  • Erneutes Unterteilen der entsprechenden Flächen dient ebenfalls einer günstigen Unterteilung der Teilflächen, das kann, muss aber nicht helfen.
  • Einsetzen von Auto Smooth (Objekte glätten).


Rendering (Bildsynthese)[Bearbeiten]

Ich habe YafaRay installiert, aber erhalte Fehlermeldungen sobald ich den Export Script starte[Bearbeiten]

v2.49:

Überprüfen sie, ob sie die Version von YafaRay installiert haben, die auf ihrere Python Version abgestimmt ist. So existieren Builds für Python 2.6 und Python 2.5. Download YafaRay 0.1.x RC3

Löschen sie den alten Export Script aus ihrem Script Ordner. Löschen sie jeglichen Script der einen Namensbestandteil wie "YafaRay" oder "Yafray" besitzt. Ausgenommen davon "yafaray_ui.py" !!


<< Zurück zu Blender 3D