Blender Dokumentation: Das Konzept von Blenders Benutzerschnittstelle

Aus Wikibooks
Zur Navigation springen Zur Suche springen
<<<Zurück
Die Blenderbedienung verstehen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Navigation im dreidimensionalen Raum


Diese Seite bezieht sich auf Blender v2.42


Das Blender Interface[Bearbeiten]

Der Umgang mit Blender gehört sicher zu den anspruchsvollen Anwendungsgebieten im Bereich der Computerprogramme. Gerade der Anfänger ist mit einer Fülle neuer Begriffe und Bedienungstechniken konfrontiert. Diese Einführung in die Funktionen der Benutzeroberfläche von Blender soll Ihnen den Einstieg in die komplexe Materie erleichtern und die wesentlichen Elemente der Benutzeroberfläche vorstellen.


Für das Bedienen von Blender benötigen Sie eine Dreitasten-Maus und eine Tastatur. Im Gegensatz zu vielen anderen Programmen müssen sie in Blender Maus und Tastatur über weite Strecken gleichzeitig bedienen. Das ist am Anfang etwas ungewohnt, besonders in der Koordination der unterschiedlichen Bewegungsabläufe für beide Hände. Während Sie mit der Maus Bewegungen am Bildschirm vollziehen und die drei Tasten bedienen, müssen sie parallel dazu bestimmte Tasten-(kombinationen) auf der Tastatur drücken.


Blender3D FreeTip.gif

Für das effiziente Arbeiten hat sich deshalb eine goldene Regel durchgesetzt: Die rechte Hand bedient die Maus und die linke bleibt auf der Tastatur!


Abbildung 1: Eine 3-Tasten Maus erleichtert die Bedienung.

Natürlich sind alle Funktionen über Menüfelder zugänglich, aber gerade bei immer wieder kehrenden Routinebefehlen bilden Tastaturkürzel eine willkommene Arbeitserleichterung. Im Laufe Ihrer Beschäftigung mit Blender werden Sie einen individuellen Mix zwischen Menübenutzung und Tastaturkürzeln entwickeln.

Sollte ihre Maus nur zwei Tasten besitzen, müssen Sie die mittlere mit Alt-Strg simulieren .

Für Mac user mit einer Eintastenmaus gelten folgende Regeln:

  • bei gedrückter Apfel Taste + Maus können Sie Objekte auswählen
  • durch Alt + Maustaste können Sie die mittlere Maustaste ersetzen
  • wenn Sie die Ansicht scrollen statt drehen wollen müssen Sie Shift + Alt + Maus drücken.


Weiter Infos finden sie im Kapitel Grundfunktionen


Um im Text unnötige Längen zu vermeiden, werden folgende Abkürzungen benutzt.

  • Die Maustasten werden mit LMT (linke Maustaste), MMT (mittlere Maustaste) und RMT (rechte Maustaste) bezeichnet.
  • Sollte ihre Maus ein Mausrad besitzen, bezieht sich MMT auf das Drücken des Rades als wäre es eine Taste, MR bedeutet ‚Mausrad drehen‘.
  • Tasten werden fett hervorgehoben und mit ‚-Taste‘ ergänzt (z.B die T-Taste). Werden Tastenkombinationen benutzt, so ist die Schreibweise Strg W oder Shift Alt A.
  • Num0 bis Num9, Num+ und so weiter beziehen sich auf die Tasten auf dem numerischen Tastenfeld. NumLock sollte immer eingeschaltet sein.
  • Andere Tasten werden mit ihrem Namen benannt, so zum Beispiel Esc, Tab, F1 bis F12.
  • Andere Spezialtasten sind die Pfeiltasten, Hoch, Runter usw.


Mausgesten[Bearbeiten]

Auf einen Teilaspekt der Benutzerschnittstelle soll an dieser Stelle noch hingewiesen werden, da er wenig bekannt ist und bisweilen unabsichtlich in Aktion tritt - die Mausgesten. Wenn Sie mit gedrückter LMT und selektiertem Objekt Bewegungen auf dem Bildschirm vollführen, werden automatisch bestimmte Transformationsmodi aktiviert.

  • Zeichnen Sie einen Strich, kommen Sie in den Verschieben Modus.
  • Zeichnen Sie einen Kreis, kommen Sie in den Rotieren Modus.
  • Zeichnen Sie ein V, kommen sie in den Skalieren Modus.

Die «Treffsicherheit» können sie erhöhen, indem Sie statt des Kreises eine 6 und anstatt des V ein Häkchen zeichnen. Bestätigen sie die Transformation mit LMT oder brechen Sie mit MMT ab. Die Sache funktioniert trotz aller Anstrengungen nicht immer 100%ig.

Das Fenstersystem in Blender[Bearbeiten]

Abbildung 2: Das Fensterkonzept

Hier sehen Sie den Bildschirm, wie er nach dem ersten Start von Blender erscheint. Als Grundeinstellung finden Sie einen drei geteilten Bildschirm, ein «Menü» am oberen Rand, ein großes «3D-Fenster» und das «Button-Fenster» am unteren Bildschirmrand.

Alle Befehle, die Sie in Blender eingeben, sei es mit der Maus oder per Tastatur, beziehen sich immer auf das aktive Fenster, in dem sich die Maus gerade befindet.


3D-Fenster [3D Viewport][Bearbeiten]

Das Kernstück der Blender Oberfläche bildet das 3D-Fenster in der Mitte. Hier können Sie die Objekte, an denen Sie gerade arbeiten, von allen Seiten betrachten, unterschiedliche Ansichten einstellen und die Darstellung der Objekte auf dem Bildschirm ändern. Über die Darstellung hinaus ist hier natürlich auch der Ort, um Objekte zu verändern oder zu modellieren.


Kopfzeile [Window Header][Bearbeiten]

Standardmäßig enthält jedes Fenster eine «Kopfzeile», die entweder oben oder unten im Fenster positioniert ist. Klicken Sie mit RMT auf die Leiste und wählen Top oder Bottom um die Kopfzeile zu positionieren. Mit No Header können Sie die Kopfzeile auch ganz verbergen; das ist aber nur ratsam wenn Sie alle relevanten Tastenkominationen auswendig kennen. Eine verborgenene Kopfzeile wird durch Klicken mit MMT oder RMT in den Fensterrand und Auswahl von Add Header wieder sichtbar gemacht.


Buttonfenster [Buttons Window][Bearbeiten]

Das Fenster am unteren Rand des Bildschirms enthält die meisten Werkzeuge zum Bearbeiten von Objekten, Oberflächen, Texturen, Beleuchtungen und vieles mehr. Während man das 3D-Fenster als Werkbank bezeichnen könnte, so ist das Tastenfenster das Steuerpult für die dazugehörigen Einstellungen.


Abbildung 3: Die Nutzereinstellungen

Nutzereinstellungen [Hauptmenü][Bearbeiten]

Hinter dem Menü am oberen Rand verbirgt sich ein Fenster, in dem Sie Grundeinstellungen für das Programm vornehmen können. Da man solche Grundeinstellungen selten ändert, ist es standardmäßig geschlossen. Sie öffnen das Fenster, indem Sie den Cursor über den unteren Rand des Menüs halten (oder darauf klicken) und ein kleiner Doppelpfeil erscheint. Mit gedrückter LMT können sie die Kante nun nach unten ziehen und der Blick wird auf das Menü freigegeben. Auf die gleiche Weise können Sie das Menü auch wieder schließen.

Abbildung 4: Blenders Fenstertypen


Fenstertypen[Bearbeiten]

Ein 3D-Programm teilt sich in sehr viele unterschiedliche Arbeitsbereiche auf wie z.B. in den zum Modellieren, zum Anlegen von Materialien und Texturen, zum Animieren von Objekten, Laden von Dateien, für Skripte, Video- und Audiobearbeitung usw. Es ist natürlich sinnvoll, nur die aktuell benötigten Informationen auf dem Bildschirm darzustellen und den Rest auszublenden, sonst könnte man bei der Fülle der Informationen leicht den Überblick verlieren. Mit einem Klick auf das Menü in Abbildung 4 öffnet sich ein Popup-Fenster. Dort sind alle Fenstertypen aufgelistet und wenn Sie eines der 16 Icons anklicken, wird das aktuelle Fenster, entsprechend der Auswahl, andere Aspekte darstellen.

Blenders Fenstersystem lässt sich ganz einfach an Ihre Bedürfnisse und Wünsche anpassen.


Neues Fenster hinzufügen[Bearbeiten]

Abbildung 5: Das Teilen-Menü

Durch Teilen eines bestehenden Fensters können Sie ein neues Fenster erstellen. Bewegen sie die Maus an den Rand des Fensters und es erscheint ein kleiner Doppelpfeil. Je nachdem ob Sie den oberen oder seitlichen Rand auswählen, erhalten Sie senkrechte oder horizontale Aufteilungen. Jetzt MMT oder RMT klicken und Split Area auswählen (Abbildung 5). Mit den Bewegungen der Maus können Sie die Position der Trennlinie bestimmen, die Sie per LMT bestätigen oder die Aktion durch RMT bzw. ESC abbrechen. Das neue Fenster startet als eine Kopie mit den Eigenschaften des Originalfensters, aber wie oben beschrieben wurde, können Sie den Fenstertyp ganz leicht Ihren Bedürfnissen anpassen.

Fenster entfernen[Bearbeiten]

Um die Anzahl der Fenster zu reduzieren, klicken Sie auf die Trennlinie zwischen zwei Fenstern mit MMT oder RMT an und wählen Join Areas. Nun wird ein Pfeil angezeigt und das eine Fenster erscheint heller, das andere dunkler. Wenn Sie die Aktion mit LMT abschließen, werden beide Fenster zu einem vereinigt und die Eigenschaften des hellen Fensters übernommen. Wenn die beiden Fenster nicht gleich hoch bzw. breit sind, werden Sie sie nicht vereinen können. Verändern Sie in diesem Fall die Größe eines der beiden Fenster passend.

Fenster im Vollbildmodus[Bearbeiten]

Wenn Sie viele Fenster geöffnet haben, verkleinert sich die Ansicht in einigen Ansichten mitunter dramatisch. Mit dem Menüeintrag View->Maximize Window oder der Tastenkombination Strg-Hoch vergrößern Sie das ausgewählte Fenster auf Bildschirmgröße. Um zum alten Zustand zurückzukehren, verwenden Sie wieder den View->Tile Window Menüeintrag oder Strg-Runter.

Kontexte, Panels und Buttons[Bearbeiten]

Die grafische Oberfläche in Blender wird mit OpenGL gezeichnet. Dies bietet den Vorteil, das man in der farblichen Gestaltung und Anordnung der Bedienelemente sehr viel mehr Freiheiten besitzt als in anderen Programmen. Welche Gestaltungsänderungen Sie vornehmen können, lesen Sie bitte im Unterkapitel «Gestaltungsmöglichkeiten».


Unterschiedliche Kontexte auswählen[Bearbeiten]

Abbildung 6: Zusammenschau aller Kontexte und Subkontexte


  1. Die Kopfzeile des Button-Fensters zeigt nach dem Start von Blender sechs Icons. Jedes Icon steht stellvertretend für ein eigenes Themengebiet (Logic, Script, Shading etc.). Rechts daneben befinden sich -kontextbezogen- die entsprechenden Untermenüs, ebenfalls durch ein kleines Icon dargestellt.
  2. Sie können alternativ auf das Panel-Menü klicken und Ihre Auswahl über die Einträge im Pop-up-Menü tätigen.
  3. Wie in Blender nicht anders zu erwarten, kann man wichtige Themen auch direkt per Tastaturkürzel aufrufen.
F4: logic Align=none F5: material Align=none F6: texture Align=none F7: object Align=none F8: world Align=none F10: render


Panele[Bearbeiten]

In den Panelen [Bedienpaletten, engl. Panels] werden Schaltflächen inhaltlich zu Gruppen zusammengefasst. Um mehr Platz auf der Benutzeroberfläche zu schaffen sind viele Panelen in Tabs (sog. Reitern) organisiert. Ein Klick mit LMT auf die Überschrift in einem Tab schaltet den Reiter um.

Abbildung 7: Panel mit Reitern

Gestaltungsmöglichkeiten[Bearbeiten]

Die Ansichten der Panele und die darin enthaltenen Elemente können in vielerlei Hinsicht verändert werden.

  • MR bzw.MMT rollt (scrollt) die Panele, verschiebt sie zur Seite
  • mit Strg-MR und Strg-MMT vergrößert und verkleinert man die Panele.
  • einzelne Panele können durch LMT auf das Dreieck links in der Panelüberschrift ein- und ausgeklappt werden.
  • Tabs können aus einem Panel ‚herausgelöst‘ werden um ein unabhängiges Panel zu bilden. Dazu klickt man mit LMT auf ihre Überschrift und zieht sie einfach auf einen freien Raum im Buttons Window.
  • In einer ähnlichen Weise können unterschiedliche Panels zu einem einzelnen Panel mit Tabs verschmolzen werden, indem man ein Panel an der im Bereich der Überschrift mit LMT in die Auswahl nimmt, es über ein anderes Panel zieht und dann loslässt, wenn das andere einen hellen Rahmen zeigt.



Buttons[Bearbeiten]

Es gibt eine Reihe von unterschiedlichen Buttons, die in den Panelen angeordnet sind. Obwohl sie einfach aussehen, verbirgt sich dahinter teilweise eine sehr ausgefeilte Funktionalität.


Ausführungsknöpfe [operation buttons][Bearbeiten]

Abbildung 8: Ausführungsbutton

Dies sind Knöpfe die eine Aktion ausführen, wenn sie angeklickt werden (mit LMT auf alle Knöpfe). Sie können durch ihre bräunliche Farbe erkannt werden, sofern Sie das Standard-Farbschema eingestellt haben


Umschaltknöpfe [toggle buttons][Bearbeiten]

Abbildung 9: Umschaltknöpfe

Umschaltknöpfe kommen in verschiedenen Größen und Farben vor (Abbildung 9). Das Anklicken dieser Art von Knöpfen führt zu keiner Aktion. Man schaltet damit einen Zustand an oder aus.Einige Tasten haben auch einen dritten Zustand, der durch eine gelbe Farbe des Textes gekennzeichnet wird (Emit in Abbildung 9). Normalerweise bedeutet der dritte Zustand Negativ und der normale an Zustand bedeutet in dieser Konstellation Positiv.

Auswahlknöpfe [radio buttons][Bearbeiten]

Abbildung 10: Auswahlknöpfe

Auswahlknöpfe sind besondere Gruppen von Optionsfeldern. Nur ein Auswahlknopf in einer gegebenen Gruppe kann gleichzeitig an sein. Ein Beispiel sehen Sie in Abbildung 10: in der Vierergruppe mit Flat, Cube etc. kann immer nur genau einer der vier Buttons aktiv sein (wie bei einem alten Radio). Entsprechendes gilt für die andere markierte Gruppe.

Numerische Knöpfe [number buttons][Bearbeiten]

Numerische Knöpfe dienen, wie der Name schon sagt, der Eingabe von Zahlenwerten (Abbildung 10)

Bedienung der Numerischen Knöpfe[Bearbeiten]

Eingaben mit der Maus

Align=none Um den Wert zu erhöhen klicken Sie mit LMT auf die rechte Seite des Knopfs

Align=none um den Wert zu verringern klicken Sie entsprechend auf die linke Seite.

Align=none Um den Wert schneller zu ändern halten Sie LMT gedrückt und ziehen Sie die Maus nach links oder rechts. Dabei können Sie folgende Einschränkungen vornehmen:

  1. Wenn Sie dabei Strg gedrückt halten wird der Wert in großen Schritten geändert;
  2. wenn Sie Shift halten, wird der Wert in sehr kleinen Schritten geändert;
  3. wenn Sie diese beiden Tasten kombinieren, erhalten Sie einen Mittelwert


Numerische Eingaben über die Tastatur

  1. Wenn Sie in die Mitte des Buttons klicken können Sie Werte über die Tastatur eingeben
  2. Mit Shift LMT können Sie irgendwo in den Button klicken und Werte über die Tastatur eingeben
Eingabemöglichkeiten
Align=none Betätigen Sie Shift-Backspace um den Wert zu löschen;
Align=none Mit Enter oder LMT-Klick außerhalb des Buttons wird der Wert bestätigt.
Align=none Betätigen Sie ESC um die Eingabeaktion abzubrechen und den ursprünglichen Wert wieder herzustellen.
Align=none Weiterhin kann der Wert eines numerischen Knopfs mit Strg C kopiert werden, wenn der Mauszeiger auf den entsprechenden Knopf zeigt. Sobald ein Wert kopiert wurde, kann er mit Strg V auf dieselbe Weise in einen anderen Knopf eingefügt werden.

Einige numerische Knöpfe enthalten einen Schieber anstatt einer Zahl mit seitlichen Dreiecken. Hier gilt die gleiche Vorgehensweise, außer dass das LMT Klicken am linken oder rechten Rand des Schiebers durchgeführt wird, während das Klicken auf den Bezeichner oder die Zahl automatisch in den Tastatureingabemodus führt.


Menüknöpfe [Menu buttons][Bearbeiten]

Menüknöpfe gibt es überall dort, wo Sie etwas aus einer Liste auswählen können. Es gibt statische und dynamische Menüknöpfe;

Abbildung 11: statischer Menüknopf
  • statische werden verwendet, wenn nur bestimmte, vorgegebene Werte aus einer Liste ausgewählt werden sollen, z.B. unterschiedliche Bildformate.


  • Dynamische Menüknöpfe haben einen erweiterten Funktionsumfang. Ein Beispiel für einen solchen Knopf ist in Abbildung 12 zu sehen. Hier können Sie nicht nur aus einer bestehenden Liste Werte auswählen, sondern auch neue Werte der Liste hinzufügen.
Abbildung 12: dynamischer Menüknopf


Die Werkzeugkiste[Bearbeiten]

Abbildung 13: Die Werkzeugkiste während der Anwendung

Indem Sie die Leertaste mit der Maus im 3D Darstellungsfeld drücken ( kontextbezogen) oder die LMT oder die RMT mit einer ruhigen Maus für mehr als eine halbe Sekunde gedrückt halten, öffnen Sie die Werkzeugkiste. Diese enthält sieben Hauptkontexte mit jeweils verschiedenen Untermenüs. Rechts neben jedem Menüpunkt wird auch die Tastenkombination angezeigt, sofern es eine gibt. Die Werkzeugkiste ist mit das wichtigste Bedienelement in Blender. Abbildung 13 zeigt alle Einträge des ersten Kontextes inkl. Untermenüs.

Arbeitsumgebungen [Screens][Bearbeiten]

Abbildung 14: Arbeitsumgebung [Screen] und Szenenauswahl
Abbildung 15: Blenders Arbeitsumgebungen

Wie schon weiter oben angedeutet durchlaufen Sie bei der Bearbeitung Ihrer Projekte viele unterschiedliche Arbeitsabschnitte wie z.B. Modellierung, Animation, Materialarbeiten etc. und es macht durchaus Sinn, jeder dieser Stationen eine eigene Arbeitsumgebung zuzuweisen. So wie ein Maler andere Werkzeuge benötigt als ein Bildhauer, können Sie sich in Blender eine optimale Arbeitsumgebung nach Ihren eigenen Bedürfnissen schaffen, immer abhängig von der jeweiligen Aufgabenstellung. Diese Arbeitsumgebungen werden in Blender Screens genannt. Folgende Arbeitsumgebungen sind vorinstalliert:

Animation Align=none Modell Align=none Material Align=none Sequence Align=none Scripting


Um eine Umgebung direkt auszuwählen öffnen Sie das SCR Menü rechts neben dem Hauptmenü (Abbildung 14). Mit ADD NEW können Sie auch eigene Screens anlegen und benennen. Allerdings stört es den Arbeitsfluss erheblich, wenn man mit der Maus immer über den ganzen Bildschirm fahren muss, nur um einen anderen Screen aufzurufen. Viel einfacher geht dies über Tastaturkürzel. Mit Strg Rechts bzw. Strg Links schalten Sie sich blitzschnell durch die abgespeicherten Screens in alphabetischer Reihenfolge.


Szenen [Scenes][Bearbeiten]

Abbildung 16: Arbeitsumgebung [Screen] und Szenenauswahl

Semantisch liegen die Worte Scenes und Screens eng beieinander, bezeichnen aber vollkommen unterschiedliche Inhalte. Scenes können Sie sich als eine Art Bühne vorstellen, auf der Sie Ihre Objekte platzieren. Bei sehr aufwändigen Modellen oder komplexen Animationen kann es sinnvoll sein, Teilaspekte auf einer eigenen Bühne zu modellieren um die Übersichtlichkeit des Ganzen zu wahren.

Die Auswahl oder das Erstellen einer Szene erledigen Sie mit dem SCE Menüknopf (Abbildung 16).

Beim Erstellen einer neuen Szene kann man zwischen vier verschiedenen Möglichkeiten wählen:

  1. Empty: erstellt eine neue, leere Szene.
  2. Link Objects: erstellt eine neue Szene, wobei die Objekte in beiden Szenen dieselben sind. Änderungen in der einen Szene verändern auch die andere Szene. Neue Objekte werden aber nur in einer Szene hinzugefügt. So können sie z.B. schnell verschiedene Kamerastandpunkte ausprobieren.
  3. Link ObData: die neue Szene wird auf der Basis der aktuellen Szene erstellt. Die Meshes (Objektgitter, also die eigentliche Geometrie der Objekte) und die Materialien sind zwischen den Szenen verlinkt. Das bedeutet, dass Änderungen in der relativen Positionierung der Objekte keine Auswirkung auf die andere Szene haben, ändern Sie aber das Material oder das Mesh, ändern sich die Objekte in allen Szenen.
  4. Full Copy: erzeugt eine vollständige Kopie. Die Szenen sind nicht miteinander verbunden.

Zu der Benutzung von Szenen gibt es eine eigene Seit Szenen.


Links[Bearbeiten]

<<<Zurück

Die Blenderbedienung verstehen

Inhaltsverzeichnis
Glossar
Weiter>>>

Navigation im dreidimensionalen Raum