Blender Dokumentation: Objekte verschieben

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Objekte auswählen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Objekte drehen


Diese Seite bezieht sich auf
Blender v2.47
Archiv-Version(en) verfügbar für:
2.37a

Sie verschieben ein Objekt ohne Einschränkung der Bewegungsrichtung immer bezogen auf die Ansicht, genauer: in der XY-Ebene der View-Koordinaten. Es gibt allerdings eine Vielzahl von Möglichkeiten, die Bewegungsrichtung in einem bestimmten Koordinatenraum durchzuführen, ein Raster zu benutzen oder Objekte an anderen einrasten zu lassen.

Freies Verschieben[Bearbeiten]

  • Drücken Sie G um das Objekt in den Grab-Modus [Bewegungsmodus] zu bringen. Dieser Befehl funktioniert in Blender in fast allen Fenstern und Modi, also nicht nur für Objekte, sondern auch für Vertices, Ipo-Kurven usw. Sie können nun das Objekt durch Bewegen der Maus in der XY-Ebene der View-Koordinaten verschieben.
  • Anstelle der Tastatur können Sie auch das Gesture System benutzen: zeichnen Sie mit gehaltener LMT eine gerade Linie in das 3D-Fenster, wechselt das ausgewählte Objekt in den Grab-Modus.

Die Objekte werden im Grab Modus weiß hervorgehoben dargestellt. LMT oder Enter schließt die Aktion ab, RMT oder Esc bricht die Aktion ab. In der Werkzeugleiste des Fensters wird der Abstand angezeigt, um den verschoben wird.

Um die Genauigkeit der Bewegung zu erhöhen, können Sie die Shift-Taste drücken. Dann wird eine große Mausbewegung in eine kleine Objektbewegung umgesetzt.

Der Ort von Objekten wird auf die Koordinaten 0/0/0 gesetzt, wenn Sie Alt-G drücken. Mit Strg-Z nehmen Sie die letzte Aktion zurück.

Ein Raster verwenden[Bearbeiten]

  • Halten Sie Strg während der Bewegung gedrückt, bewegt sich das Objekt immer eine ganze Anzahl von Blender-Einheiten (Koordinatensystem-Kästchen) relativ zu seiner letzten Position. Der Snap Modus endet, wenn Sie Strg loslassen, daher müssen Sie die Bewegung zuerst bestätigen.
Blender3D FreeDifficulty.gif

Das Objekt rastet gar nicht auf dem Gitter ein

Stimmt. Wenn das Objekt gegenüber dem Gitter verschoben ist, wird es zwar relativ in festen Schritten bewegt, aber nicht unbedingt auf dem Gitter. Sie müssen es zunächst mit Shift-S->Snap to->Grid auf das Gitter einrasten lassen.



  • Gitterabstand und Größe stellen Sie auf dem View Properties-Panel ein (View->View Properties).
  • Mit Shift benutzen Sie die jeweils kleinere Unterteilung des Gitters. Zoomen Sie in die Ansicht hinein, um die jeweils höhere Auflösung zu verwenden.

Einschränken der Bewegungsrichtung[Bearbeiten]

Abbildung 1: Das Translate-Transform Widget
  • Um in einem bestimmten Koordinatenraum zu arbeiten, also nur entlang bestimmter Achsen zu verschieben, eignet sich insbesondere das 3D-Transform Widget. Klicken Sie einfach mit LMT auf eine Pfeilspitze und ziehen Sie mit gehaltener Maustaste in die gewünschte Richtung.


Abbildung 2: Nur entlang der globalen X-Achse verschieben
  • mit der Maus: Um festzulegen, dass die Verschiebungen nur entlang der Achsen des globalen Koordinatensystems verlaufen, wechselt man in den Grab-Modus(Taste G), bewegt das Objekt dann grob entlang der gewünschten Achse und klickt schließlich MMT (Abb. 2). Um diese Fixierung wieder aufzuheben klicken Sie nochmals MMT.

Bei gehaltener MMT können Sie auch zwischen den globalen Achsen wechseln.

  • auf eine Achse: drücken Sie nach dem Wechsel in den Grab Modus eine der Tasten X, Y oder Z. Ein einfacher Tastendruck beschränkt die Bewegung auf die entsprechende globale Achse, so wie es MMT auch tut (Abb. 2). Ein zweiter Tastendruck derselben Taste beschränkt die Bewegung auf die entsprechende lokale, oder die Achse des ausgewählten Koordinatenraums. Der dritte Tastendruck entfernt die Beschränkung der Bewegungsrichtung. Damit man schnell sieht, in welche Richtung die Bewegung erfolgen wird, wird die Achse eingezeichnet.
Abbildung 3: Nur entlang zweier globaler Achsen verschieben (hier nicht X-Achse)
  • auf zwei Achsen: Aktivieren Sie den Grab Modus mit G und drücken Shift-X bzw. Shift-Y oder Shift-Z. Damit wird die Bewegung der jeweils mit Shift gedrückten Achse gesperrt, und auf die zwei übrigen Achsen beschränkt (Abb. 3).


Numerisches Verschieben[Bearbeiten]

  • Nach dem Aktivieren des Grab-Modus können Sie die Verschiebung des Objektes auch numerisch festlegen. Drücken Sie einfach eine Zahl, mit der Tab-Taste wechseln sie die Koordinate. Backspace löscht, Enter übernimmt die Änderungen und Esc bricht den Bewegungsvorgang ab. Der Punkt auf dem Keyboard - nicht der Num-Punkt - ist das Dezimaltrennzeichen.
  • Das aktive Objekt können Sie auch direkt über die Eingabe von Koordinaten positionieren. Öffnen Sie das Transform Properties-Panel (Object->Transform Properties oder N). Füllen Sie dann die entsprechenden Loc-Felder aus (Abb. 4).


Ein Objekt an einem anderen einrasten oder ausrichten[Bearbeiten]

In diesem Abschnitt geht es nur um die Position von Objekten, wenn Sie die Objekte auch noch drehen wollen, verwenden Sie die Technik die im Abschnitt Zwei Objekte aneinander ausrichten beschrieben wird.

  • Ein Objekt auf ein anderes positionieren:
  • Mit Shift-S rufen Sie das Snap-Menü auf (oder verwenden Sie Object->Snap).
  • Wählen Sie das Zielobjekt aus, setzen Sie dann den Cursor darauf (Shift-S->Cursor->Selection), dann das zu bewegende Objekt auswählen und auf den Cursor setzen (Shift-S->Selection->Cursor).
  • Ausgewählte Objekte auf den gemeinsamen Schwerpunkt setzen:
Objekte markieren, Shift-S->Selection->Center.
  • Ausgewählte Objekte an einer Ebene ausrichten:
Alle ausgewählten Objekte können Sie an einer Ebene ausrichten, indem Sie ihre entsprechende Koordinate auf 0 skalieren.
  • Aktivieren Sie die Funktion "Move object centers only" Align=none
  • Skalieren Sie mit S, gefolgt von der gewünschten Ebene (X/Y/Z) und dann einer 0 (null). Bestätigen Sie mit Enter.
Durch den Button "Move object centers only" werden nur die Objektzentren skaliert, die Objekte selber bleiben in ihrer Größe erhalten. Sie sollten nicht vergessen, den Button anschließend wieder auszustellen.
  • Ein Objekt an einer Ecke eines anderen Objektes einrasten lassen:
  • Aktivieren Sie Use Snap or Grid, Snap Mode Center. Align=none
  • Bewegen Sie das Objekt mit gehaltener Strg-Taste. Der Mauscursor wählt die gewünschte Stelle aus.

Snapping-Werkzeug[Bearbeiten]

Abb. 4: Die Snapping-Icons

Das Snapping Werkzeug ist dafür gemacht, Objekte nicht am Objektzentrum eines anderen Objektes, sondern an Vertices (Punkten), Edges (Kanten) oder Faces (Flächen) einrasten zu lassen.

  • Aktivieren Sie die Snapping Funktion mit einem Klick auf das Icon mit dem Magneten in der Werkzeugleiste des 3D-Fensters. Weitere Einstellungsmöglichkeiten sind wählbar.
  • Wählen Sie aus, ob die zu verschiebende Auswahl an den Vertices, Kanten oder Flächen des Zielobjekts einrasten soll.
  • Wählen Sie aus, mit welchem Punkt die zu verschiebende Auswahl am Zielobjekt einrasten soll:
Closest: Dasjenige Vertice, dass dem Zielobjekt am nächsten steht, wird eingerastet.
Center: Das Zentrum der Auswahl wird am Zielobjekt eingerastet.
Median: Der gewichtete Schwerpunkt wird am Zielobjekt eingerastet.
Active: Das aktive Objekt wird am Zielobjekt eingerastet.
  • Wählen Sie die zu verschiebenden Objekte aus, wechseln in den Verschiebe-Modus mit G und bewegen den Mauscursor mit gedrückter Strg -Taste in die Nähe des Zielobjekts. Nicht die Position der Auswahl ist hier entscheidend, sondern die Position des Mauscursors.
  • Mit LMT schließen Sie die Aktion ab.

Objekte vor dem Verschieben schützen[Bearbeiten]

Abbildung 5: Das Transform Properties Panel.
  • Sie können verhindern, dass ein Objekt bewegt werden kann, indem Sie die Schloss-Icons auf dem Transform Properties Panel aktivieren.


<<<Zurück

Objekte auswählen

Inhaltsverzeichnis
Glossar
Weiter>>>

Objekte drehen