Blender Dokumentation: Animationsphasen als Objekte erzeugen

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Objektkopien an Vertices oder Faces erzeugen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Grundlegendes Mesh Modelling


Diese Seite bezieht sich auf
Blender v2.44
Archiv-Version(en) verfügbar für:
2.43

Mit der Funktion DupliFrames können Sie alle Frames einer Animation eines Objekts gleichzeitig anzeigen lassen. Aus diesen Frames lassen sich bei Bedarf auch eigenständige Objekte machen. Dupliframes steht für „DUPLIcation at FRAMES“. Z. B. lassen sich Objekte entlang eines Pfades vervielfältigen, wie Eisenbahnschwellen entlang eines Schienenstrangs oder bei allen anderen, sich regelmäßig wiederholenden Strukturen.

Allerdings lassen sich ähnliche Effekte mit anderen Funktionen wie dem Array-Modifier und Taper-Kurven schneller und mit weniger Aufwand erzeugen. DupliFrames ist in einem bestimmten Bereich aber flexibler, da Sie bei Bedarf jeden einzelnen Frame von Hand einstellen und animieren können.

Bedienung[Bearbeiten]

Abbildung 1: Einstellungen für DupliFrames

DupliFrames zu benutzen ist unkompliziert. Erzeugen Sie eine Animation für Ihr Objekt, und stellen Sie DupliFrames an.

In Abb. 1 sehen Sie die möglichen Einstellungen.

  • DupliFrames: aktiviert die DupliFrames-Funktion.
  • DupSta: Frame, ab dem Objektkopien erzeugt werden sollen.
  • DupEnd: Frame, ab dem keine Objektkopien mehr erzeugt werden sollen.
  • DupOn: Anzahl der Frames, die zusammen eine Gruppe bilden.
  • DupOff: Anzahl der Frames, die nicht dargestellt werden sollen. Damit kann man Lücken zwischen den Objektengruppen erzeugen.
  • No Speed: Dieser Button ist nur für eine Pfadanimation interessant, und nur dann, wenn Sie keinen Path-Constraint benutzen. Normalerweise erfolgt die Animation an einem Pfad entsprechend der Speed-IPO-Kurve des Pfades (sofern die Kurve eine solche besitzt). Mit No Speed wird diese Speed-IPO-Kurve ignoriert, und die Objekte werden gleichmäßig am Pfad verteilt. Statt diesen Button zu benutzen, der nur unter bestimmten Umständen wirksam ist, können Sie auch die Speed-IPO-Kurve des Pfades vernünftig einstellen (IPO-Type->linear, Extend Mode->Extrapolation).


Beispiel für DupliFrames als Modelling-Werkzeug[Bearbeiten]

Abbildung 2: Einen NURBS Circle einfügen

In unserem Beispiel werden wir zunächst einen Ring, und dann eine Kette modellieren.

  • Löschen Sie den Würfel der Standard-Szene und wechseln Sie in die Aufsicht (View->Top).
  • Fügen Sie einen Bezier Circle ein (Add->Curve->Bezier Circle) und wechseln Sie in den Objekt-Modus (Tab).
  • Skalieren Sie den Bezier Circle um den Faktor 3 größer.
  • Wechseln Sie in die Frontansicht (View->Front).
  • Fügen Sie einen Surface Nurbs Circle ein (Add->Surface->Nurbs Circle) und wechseln in den Objekt-Modus.
  • Wählen Sie mit gehaltener Shift-Taste den Bezier Circle aus, und wählen Object->Parent...->Make Parent->Follow Path.
  • Wählen Sie nur den Surface Nurbs Circle aus, und benutzen die Funktion Object->Clear/Apply->Clear Origin.
  • Drehen Sie den Surface Nurbs Circle um 90 Grad.

Ihre Szene sollte jetzt ungefähr wie in Abb. 3 aussehen.

  • Wenn Sie nun Alt-A drücken, sollte sich der zweite Kreis in einer Animation um den ersten Kreis herum bewegen. Brechen Sie mit ESC ab.
Abbildung 3: Bei der Animation mit Alt-A wandert der Kreis entlang des Pfads


Abbildung 4: Die Ausrichtung des NURBS Circle einstellen.
  • Wechseln Sie in das Fenster mit den Object-Buttons (F7) und aktivieren die Einstellung DupliFrames.

Wenn Sie die Objekte in den beschriebenen Ansichten eingefügt haben, steht der Nurbs Circle noch nicht richtig zum Kreis. Mit den Track-Einstellungen korrigieren Sie die Ausrichtung.

  • Stellen Sie Track auf Y, wie in Abbildung 4 gezeigt.

Im Grunde hat Blender eine Animation über 100 Frames gestartet und die Position des Kreises entlang des Pfades in einem Bild dargestellt. Die einzelnen virtuellen Objekte werden nun in drei Schritten in ein zusammenhängendes Objekt zusammengefügt.

Abbildung 5: Der fast fertige Ring
  • Erstellen Sie mit Object->Clear/Apply->Make Duplicates Real reale Objekte aus den virtuellen.
  • Fassen Sie mit Object->Join Objects die Objekte zu einem zusammen.
  • Wechseln Sie in den Edit-Modus (Tab). Alle Vertices sind ausgewählt.
  • Erzeugen Sie mit Surface->Make Segment eine Oberfläche.

Das war auch der Grund, warum ein Nurbs Surface -Objekt verwendet wurde, bei diesen lässt sich leicht eine zusammenhängende Oberfläche erstellen. Ihr Ring sollte jetzt etwa so aussehen wie in Abb. 5.

Aus dem Nurbs Surface-Objekt wird nun ein Meshobjekt gemacht.

  • Wechseln Sie wieder in den Objekt-Modus.
  • Konvertieren Sie mit Object->Convert Object Type in ein Meshobjekt.


Abbildung 6: Skin Faces/Edge-Loops im Make Faces-Menü.

Es bleibt eine Lücke im Modell, die man aber leicht schließen kann.

  • Wechseln Sie in den Edit-Modus.
  • Wählen Sie an den offenen Enden die Vertices aus.
  • Durch den Menübefehl Mesh->Faces->Make Edge/Face erscheint ein Pop-up-Fenster Make Faces. Dort benutzen Sie den Eintrag Skin Faces/Edge-Loops (Abb. 6).

Der Bezierkreis wird nicht mehr benötigt und kann entfernt werden.

Abbildung 7: Den Ring entlang eines Pfades animieren

Das Kettenglied können wir noch weiter verarbeiten, indem wir es an einen Pfad parenten und die Rotation des Rings animieren.

  • Fügen Sie im Object Mode einen Pfad ein Add->Curve->Path.
  • Die einzelnen Vertices des Pfades können Sie beliebig verschieben oder durch Strg-LMT neue Vertices anfügen.
  • Parenten Sie den Ring an den Pfad und aktivieren Sie DupliFrames für den Ring.

Im Augenblick werden noch 100 Kopien entlang des Pfads generiert.

  • Drücken Sie bitte den Button NoSpeed.

Damit wird die Speed-Kurve, die die Geschwindigkeit der Animation bestimmt - und die auf 100 Frames voreingestellt ist - deaktiviert und Sie können unter Pathlen [F9] und DupliEnd [F7] eigene Werte eintragen. Über die IPO-Kurven wird die Rotation des Kettenglieds animiert.

Man kann aber nicht nur die Rotation eines Objekts entlang eines Pfads animieren, sondern auch seine Größe. Die Vorgehensweise ist wie im ersten Beispiel, nur dass wir dieses Mal den Radius des Nurbs-Kreises animieren. Der Vorteil dieser Methode im Gegensatz zu den Einsatzmöglichkeiten der Taper Curves liegt darin, das Sie hier den Radius in allen drei Werten, nämlich x,y und z verändern können und damit wesentlich differenziertere Formen erstellen können.

Abbildung 8: Freiform
<<<Zurück

Objektkopien an Vertices oder Faces erzeugen

Inhaltsverzeichnis
Glossar
Weiter>>>

Grundlegendes Mesh Modelling