Blender Dokumentation: Objekte einfügen, kopieren und löschen

Aus Wikibooks
Wechseln zu: Navigation, Suche
<<<Zurück
Objektzentrum und Pivot-Punkt
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Objekte auswählen


Diese Seite bezieht sich auf
Blender v2.46
Archiv-Version(en) verfügbar für:
2.42a
Abbildung 1: Ein Würfel im Objekt-Modus.

Objekte können auf verschiedene Weisen eingefügt werden:

  • über das Add-Menü in der Werkzeugleiste des User Preferences-Fensters The Blender User Preferences Icon.png, das sich in der Regel am oberen Bildschirmrand befindet.
  • über das Space->Add-Menü.
  • über File->Append aus anderen Blenderdateien (siehe Append).

Blender greift nicht auf die Zwischenablage des Betriebssystems bzw. Fenstermanagers zu. Objekte lassen sich deswegen nicht über Copy in einem Blendfile kopieren und mit Paste in eine andere Datei einfügen.

  • Neue Objekte werden mit ihrem Schwerpunkt am 3D-Cursor eingefügt Blender 3D-cursor.png. Setzen Sie also eventuell vorher den 3D-Cursor auf die gewünschten Koordinaten.
  • Werden Objekte im Objekt-Modus eingefügt (Abb. 1), werden sie an den globalen Koordinaten ausgerichtet, unabhängig von der Ansicht im 3D-Fenster.
  • Objekte werden in den aktiven Layer eingefügt.

Transform-Properties[Bearbeiten]

Das Transform-Properties Panel [TPP] rufen Sie mit N im 3D-Fenster auf. Es zeigt bestimmte Eigenschaften für die ausgewählten Objekte an, dabei hängen die angezeigten Werte zum Teil vom Objekttyp ab.

Abbildung 2: Das Transform Properties Panel für eine Kugel im Objekt-Modus.

Das TPP zeigt für ein Meshobjekt im Objekt-Modus folgende Werte an (Abb. 2):

  • die Ortskoordinaten (Loc)
  • die Drehung (Rot)
  • die Skalierung (Scale)
  • die Größe der Bounding Box (Dim).

Alle Werte beziehen sich auf die globalen Koodinaten des Objektes, für ein Objekt mit Parent also auf die lokalen Koordinaten des Parents.

  • OB: der Name des Objektes
  • Par: der Name eines Parents (sofern vorhanden)
  • Link Scale: bei Änderung eines Scale Wertes im TPP ändern sich die anderen beiden Scale-Koordinaten proportional.
  • Schlüssel-Icons: Damit können Sie diesen Wert gegen eine Veränderung im 3D-Fenster sperren.

Im TPP können Sie die Werte auch direkt verändern.

Objekte vervielfältigen[Bearbeiten]

Objekte werden nicht so kopiert, wie Sie es vielleicht aus anderen Programmen gewohnt sind, sondern dupliziert - also in einem Schritt kopiert und eingefügt.

  • Wählen Sie ein Objekt aus, und drücken Shift-D. Dadurch wird eine Kopie des ausgewählten Objektes erstellt. Die Kopie wird an der selben Stelle positioniert und befindet sich automatisch im Bewegungsmodus.

Es handelt sich um ein neues Objekt, teilt jedoch alle Materialien, Texturen und die IPO (Animationskurven) mit dem Original. Diese Attribute sind mit dem alten und dem neuen Objekt verbunden. So ändert sich das Material des einen Objektes auch, wenn das Material des anderen sich ändert. Sie können anschließend für jedes Objekt ein eigenes Material erstellen, mehr dazu im Abschnitt Materialeinstellungen.

  • Wenn beide Objekte auf dieselben Objektdaten verweisen sollen, verwenden Sie ALT-D zum duplizieren. Bearbeiten Sie dann bspw. das Mesh des einen Objektes, verändert sich das Mesh an allen Objekten.

Eigenschaften zwischen verschiedenen Objekte kopieren[Bearbeiten]

Objekteigenschaften (z.B. Ort, Ausrichtung, Constraints, Modifier usw.) können vom aktiven Objekte auf alle ausgewählten Objekte kopiert werden.

  • Wählen Sie die gewünschten Objekte aus, das zuletzt ausgewählte Objekt ist das aktive Objekt. Mit Object->Copy Attributes... kopieren Sie die auszuwählenden Objekteigenschaften. Sie können anstelle des Menüs auch die Tastenkombination Strg - C verwenden.

Das Mesh und das Material sind keine Eigenschaften des Objektes, und werden deswegen nicht kopiert, sondern verlinkt.

  • Wählen Sie die gewünschten Objekte aus, das zuletzt ausgewählte Objekt ist das aktive Objekt. Mit Object->Make Links... können Sie die gewünschten Eigenschaften des aktiven Objektes mit den ausgewählten Objekten verlinken. Sie können anstelle des Menüs auch die Tastenkombination Strg - L verwenden.

Mehr über die technischen Hintergründe beim Verlinken können Sie auf den Seiten Objekte und Objektdaten, Szenen und Mit Objektbibliotheken arbeiten erfahren.

Objekte löschen[Bearbeiten]

  • Um ein Objekt zu löschen, wählen Sie es aus (Objekte werden in Blender mit der rechten Maustaste ausgewählt) und drücken entweder Entf oder die X-Taste.

Voreinstellungen[Bearbeiten]

Mehrere Einstellungen lassen sich im User Preferences-Fenster unter Edit Methods vornehmen.

  • Duplicate with Object: welche Eigenschaften sollen beim Duplizieren mit Shift-D kopiert werden, welche sollen von den Objekten gemeinsam benutzt werden.
  • Add new objects:
    • Switch to Edit Mode: Objekte wechseln nach dem Einfügen automatisch in den Edit-Modus.
    • Aligned to View: Objekte werden nicht an den globalen Koordinaten ausgerichtet, sondern an der Ansicht im 3D-Fenster.

Wie Material- (einschließlich Textur) oder auch IPO- Eigenschaften auf weitere Objekte kopiert werden können siehe den Abschnitt Materialeinstellungen.



<<<Zurück

Objektzentrum und Pivot-Punkt

Inhaltsverzeichnis
Glossar
Weiter>>>

Objekte auswählen