Blender Dokumentation: Referenz: UV/Image Editor

Aus Wikibooks
Zur Navigation springen Zur Suche springen
<<<Zurück
Suzanne mit UV-Mapping
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
_Paint


Diese Seite bezieht sich auf
Blender v2.42a
Von dieser Seite gibt es eine
aktuellere Version
Abbildung 1: Aufruf des UV/Image Editor Fensters.

Im UV/Image Editor können Sie die UV-Koordinaten eines Meshes bearbeiten, sowie Bild-Dateien betrachten und verändern.

Viele der Funktionen sind nur anwendbar wenn Sie UV-Koordinaten bearbeiten, also ein Mesh in den UV Face Select Modus gebracht und einige Faces ausgewählt haben.

Mit der Werkzeugleiste des Fensters (Abbildung 2) haben Sie Zugriff auf (fast) alle angebotenen Funktionen. Von links nach rechts:

  • Auswahl des Fenstertyps.
  • Mit der dreieckigen Pfeilspitze blenden Sie die Menüs aus bzw. wieder ein.
  • View/Select/Image/UVs Menüs.
  • Mit dem Doppelpfeil wählen Sie ein bereits geladenes Bild aus. Im Feld daneben können Sie den Namen des Bildes ändern. Das "X" löscht die Zuordnung eines Bildes zu den UV-Koordinaten eines Objektes. Es wird nicht das Bild gelöscht.
  • Der Pack Button speichert das Bild in der Datei, sodass Sie die Datei zusammen mit den Texturen weitergeben können. Unpack entfernt das Bild aus der Datei und speichert es auf der Festplatte (sofern nötig).
  • Der Stift ermöglich das Bemalen des Bildes. Drücken Sie anschließend C, um das Paint Werkzeug aufzurufen.
  • Draws image with alpha: berücksichtigt die Transparenzinformationen im Bild und zeigt diese an. Allerdings werden ganz transparente Bereiche in weiß dargestellt. Auf das gerenderte Bild oder die Darstellung im 3D-Fenster hat diese Option keinen Einfluss.
  • Draws only alpha: Zeigt die Transparenz in Graustufeninformationen an, dabei ist Schwarz transparent und Weiß opak. Auf das gerenderte Bild oder die Darstellung im 3D-Fenster hat diese Option keinen Einfluss.
  • Schloss-Icon: Aktualisiert die Darstellung in anderen Fenstern automatisch, z.B. auf einem Mesh.
Abbildung 2: Die Werkzeugleiste des UV/Image Editor Fensters, wenn ein Bild geladen wurde.


View Menü[Bearbeiten]

Abbildung 3: Das View Menü im UV-Editor Fenster.
  • Update Automatically: Änderungen am UV-Layout werden sofort im 3D-Fenster dargestellt. Auch erreichbar mit dem Schloss-Icon in der Titelleiste des UV-Editor Fensters.
  • View-Navigation: Einstellen verschiedener Zoom-Stufen.
  • Draw Shadow Mesh: Auch die im 3D-Fenster nicht ausgewählten Faces werden dargestellt.
  • Draw Faces: Die ausgewählten Flächen werden im UV-Editor gezeichnet.
  • Display Normalized Coordinates: Normalerweise werden die UV-Koordinaten in Pixeln angezeigt, stellt man diese Option an, werden die Koordinaten in einen Wert zwischen 0..1 umgerechnet und so im Properties Panel bzw. beim Verschieben angezeigt.
  • Composite Preview: Wenn Sie Composite-Nodes benutzen und Do Composite im Anim Panel der Render Buttons aktiviert haben, erhalten Sie hiermit eine Vorschau und schränken den zu rendernden Bereich ein (siehe Composite-Nodes).
  • Curves Tool: Zeigt das Curves Werkzeug an. Damit können Sie Farbkorrekturen an Bildern vornehmen (siehe Curves Tool).
  • Paint Tool: Zeigt das Image Paint Panel an. Damit können Sie auf dem Bild malen (siehe UV-Texture Paint).
Abbildung 4: Das Properties Panel im UV-Editor Fenster.
  • Properties: Das Properties Panel zeigt die Koordinaten des ausgewählten UV-Vertex an. Bei mehreren ausgewählten Vertices wird der Median angezeigt. Haben Sie ein Bild geladen, erscheinen die Optionen Anim und Tiles auf dem Properties Panel.
    • Tiles: Mit diesen Reglern können Sie einen Bildausschnitt erzeugen und anzeigen. Mit Shift-LMT wählen Sie den anzuzeigenden Bildausschnitt aus (siehe Abbildung 5).
    • Anim: hat nur Bedeutung in der Gameengine. Damit können Sie die Tiles nacheinander anzeigen lassen.
Abbildung 5: 2x2 Tiles. Mit Shift-LMT wählen Sie den anzuzeigenden Ausschnitt aus.


Select Menü[Bearbeiten]

Abbildung 6: Das Select Menü im UV/Image Editor Fenster.
  • Linked UVs: [verbundene UVs auswählen] arbeitet ähnlich wie Select Linked in der 3D-Ansicht. Diese Funktion wählt alle Vertices aus die mit den derzeit ausgewählten 'verbunden' sind. Im Unterschied zur 3D-Ansicht sind Vertices im UV-Editor implizit verbunden, das heißt sie gelten als verbunden wenn sie höchstens fünf Pixel voneinander entfernt sind. Diese Funktion wird mit Strg-L aufgerufen.
  • Pinned UVs: Alle mit der Pin-Funktion gepinnten Vertices werden ausgewählt.
  • Unlink Selection [Auswahl trennen] entfernt alle UV-Vertices aus der Auswahl die nicht zu ganz ausgewählten Faces gehören. Wie der Name andeutet ist das besonders nützlich um die Auswahl abzutrennen und irgendwohin zu bewegen. Diese Funktion wird mit Alt L aufgerufen.
  • Select/Deselect All: Alle auswählen bzw. Auswahl aufheben.
  • Border Select: Auswahl durch Aufziehen eines Rechteckes wie im 3D-Fenster (B-LMT). B-B-LMT (Auswählen durch aufmalen) funktioniert auch, ist aber nicht im Menü verfügbar.
  • Border Select Pinned: Wählt nur gepinnte Vertices mit Border Select aus.

Es gibt mehrere Auswahlmodi für den UV-Editor. Da ein Vertex im UV-Editor einmal für jedes Face gezeichnet wird, zu der er gehört, ist es manchmal schwer zu sagen ob man den selben Vertex auswählt oder nicht.

  • Stick UVs to Mesh Vertex: RMT wählt nicht nur einen UV-Vertex aus, sondern auch alle anderen, die zum selben Mesh Vertex gehören. Sie können diesen Modus auch verwenden, wenn er nicht im Menü aktiviert ist, indem Sie Strg gedrückt halten während Sie einen Vertex auswählen.
  • Stick Local UVs to Mesh Vertex: arbeitet auf die gleiche Weise, allerdings werden nur Vertices ausgewählt, die 'verbunden' sind, das heißt dass sie maximal fünf Pixel von dem zuerst ausgewählten Vertex entfernt sein dürfen. Sie können diesen Modus auch verwenden, wenn er nicht im Menü aktiviert ist, indem Sie Shift gedrückt halten während Sie einen Vertex auswählen. Voreinstellung ab Version 2.42.
  • Active Face Select: Mit RMT wird ein Face ausgewählt und als aktiv definiert.

Image Menü[Bearbeiten]

Abbildung 7: Image Menü im UV/Image Editor Fenster wenn bereits ein Bild geladen ist.

Ist noch kein Bild geladen, enthält das Menü nur zwei Einträge, Open... und New....

Blender3D FreeTip.gif

Image Browser

Halten Sie Strg gedrückt wenn Sie auf Open... klicken, dann wird das Image Browser Fenster geöffnet und Sie erhalten eine Dateivorschau. Allerdings kann es in Verzeichnissen in denen sich Videos befinden sehr lange dauern, bis Blender die Vorschauen erstellt hat. Bei unbekannten Videocodecs stürzt Blender außerdem manchmal ab, also sollten Sie vor dem Öffnen des Image Browser Fensters unbedingt speichern.


Abbildung 8: Eine UV-Testmap erstellen.

Mit dem Eintrag New... können Sie entweder ein leeres Bild oder eine UV-Testmap (UV Test Grid) erstellen (siehe Abbildung 8).

  • Realtime Texture Mapping: Entweder werden die UV-Koordinaten oder der Reflexionsvektor der Fläche benutzt.
  • Texture Painting: Ermöglicht das Malen auf der Textur. Drücken Sie C um das Paint Werkzeug aufzurufen.
  • Pack Image: Speichert das Bild in der Datei.
  • Reload: Lädt das Bild erneut von der Festplatte, z.B. wenn Sie es in einem Graphikprogramm geändert haben.
  • Replace...: Ersetzt das geladene Bild.
  • Save as...: Speichert das Bild. Der Dateityp ist nicht frei wählbar, sondern entspricht dem Dateityp auf dem Format Panel der Render Buttons (F10).


UVs Menü[Bearbeiten]

Abbildung 9: Das UVs Menü im UV/Image Editor Fenster.
  • Show/Hide Faces: Damit können einzelne Faces im UV-Editor "versteckt" werden, d.h. die Anzeige ausgeschaltet (H). Mit Alt-H werden die Faces wieder angezeigt, mit Shift-H werden die nicht ausgewählten Faces versteckt.
  • Proportional Editing/Falloff: Entspricht den Bearbeitungsfunktionen im 3D-Fenster.
  • Weld: Damit werden beliebige UV-Vertices zusammengelegt. Ähnlich wie "Merge at Center" im 3D-Fenster, allerdings gibt es im UV-Editor keinen "Merge" Befehl, d.h. die UV-Vertices bleiben erhalten.
  • Align: Die ausgewählten UV-Vertices werden in einer Linie (an der X oder Y Achse) angeordnet. Sehr nützlich, um die UV-Map auszurichten.
  • Mirror: Spiegelt an der X- oder Y-Achse.
  • Transform: Die üblichen Bewegungs/Rotations/Skalierungsfunktionen.
  • Stitch: Verschiedene Teile einer UV-Karte können mit V vernäht werden wenn die UV-Vertices am Rand jeweils der selben Mesh Vertex entsprechen. Der Stitch Befehl kann auch unregelmäßige Kanten vernähen, wählen Sie einfach mit Stick UVs to Mesh Vertex die Vertices am Rand aus oder halten Sie beim Auswählen Strg gedrückt um auch die anderen übereinstimmenden Vertices auszuwählen.
  • Limit Stitch: arbeitet auf die selbe Weise. Der Unterschied ist dass nur UVs vernäht werden die innerhalb eines bestimmten Radius liegen. Die maximale Entfernung ist standardmäßig 20 Pixel. Der Vorteil gegenüber Stitch ist in Abbildung 10 klar zu sehen: die UV-Map der Röhre wird nur da vernäht wo es sinnvoll ist.
Abbildung 10: Stitch und Limit Stitch
  • Minimize Stretch: Mit diesem Werkzeug bearbeiten Sie den Unwrap komplexer Meshes. Wenn an einer Stelle viele kleine Faces vorkommen (Nase, Ohren), belegen diese im Unwrap normalerweise nur wenig Platz, die UV Koordinaten werden dort sehr auseinandergezogen. Wählen Sie die UV-Vertices der entsprechenden Region aus und drücken Strg-V. Mit dem Mausrad (MR) können Sie die Stärke des Ausbreitens beeinflussen, LMT schließt die Aktion ab.
  • Pin/Unpin: Um einen Vertex an einer Stelle "festzuhalten", benutzen Sie die Pin Funktion (P). Mit Alt-P lösen Sie den Pin wieder. Gibt es beispielsweise eine Reihe von Vertices die in einer geraden Linie angeordnet sein sollen, wählen Sie die Vertices aus, bringen Sie in die entsprechende Position und pinnen sie. Auch die Größe von Meshabschnitten lässt sich so fixieren, wenn Sie zwei Vertices pinnen und diese skalieren. Gepinnte Vertices werden in rot dargestellt.
  • Unwrap: mit E im UV-Editor Fenster können Sie den gesamten Unwrap neu berechnen lassen. Alle verschobenen und nicht gepinnten Vertices rutschen dann aber wieder in ihre Ausgangsposition zurück.
  • Live Unwrap Transform sollten Sie aktivieren, da dann das Unwrapping bei einer Bewegung der Vertices neu berechnet wird, und Sie direkt die Auswirkungen aus das Mesh beurteilen können. Damit das überhaupt eine Auswirkung hat, müssen Sie aber mindestens zwei Vertices aus dem Meshabschnitt gepinnt haben und einen gepinnten Vertex bewegen. Es wird allerdings nicht der ganze Unwrap neu berechnet, das Setzen von neuen Seams wird bspw. nicht berücksichtigt.
  • Layout Clipped to Image Size: Sie können die Vertices nicht mehr über den Rand des Bildes hinausbewegen.
  • Quads Constrained Rectangular: Die Edges an einem ausgwählten Vertex bilden einen rechten Winkel, sobald der Vertex bewegt wird. Dazu werden auch weitere Vertices verschoben, wenn dies notwendig ist. Sie werden dies in der Regel nicht wollen, da es das gesamte Layout zerreißt.
  • Snap to Pixels: Die UV-Vertices werden an den Pixeln des Bildes ausgerichtet.


Skripte im UVs Menü[Bearbeiten]

Die Nützlichkeit der Skripte verändert sich im Laufe der Blenderversionen stark, da viele Funktionen in das Programm direkt integriert werden. Daher wird hier nur eine Auswahl besprochen.

Abbildung 11: Save UV Face Layout Skript.
  • Save UV Face Layout ...: Mit diesem Script speichern Sie die ausgebreiteten Flächen aus dem UV/Image Editor so, wie sie dort zu sehen sind. Wählen Sie eine ausreichend große Auflösung (Size) und klicken auf OK. Es erscheint ein Save Image Dialog, in dem Sie den Speicherort eintragen können. Das Bild wird mit der Endung ".tga" in diesem Format gespeichert.



<<<Zurück

Suzanne mit UV-Mapping

Inhaltsverzeichnis
Glossar
Weiter>>>

Paint