Suchmaschinenmarketing: Technik

Aus Wikibooks
Wechseln zu: Navigation, Suche

Software ist beim online basierten Suchmaschinenmarketing naturgemäß ein wichtiger Faktor. Beim Account strukturieren, Tracking, Bidding und Reporting können die richtigen Tools die Arbeit erleichtern oder bestimmte Methoden erst ermöglichen.

Manuell[Bearbeiten]

Zum Erstellen, Pflegen und Auswerten gibt es zahlreiche hilfreiche Programme, die …

Excel[Bearbeiten]

Eines der wichtigsten Werkzeuge ist Excel oder andere  Tabellenkalkulationsprogramme, nicht nur zur Auswertung und Reporting sondern auch zum Aufbau der Struktur (AdGroups KeyWords) und Texten.

Die wichtigsten Funktionen:

Autofilter
erlauben Datenzeilen nach Filterkriterien einzuschränken
Um gefilterte Zeilen weiter zu bearbeiten, können diese mit F5 einzeln kopiert werden, ohne die ausgefilterten Zeilen mit zu kopieren.
Transponieren
wandelt Zeilen in Spalten um
Bedingte Formatierung
stellt Werte abhängig von Kriterien (z. B. großer oder kleiner Null) dar (Farbe, Hintergrund).

Die wichtigsten Formeln:

Länge
=LÄNGE(A1) gibt die Zeichenanzahl in einer Zelle zurück. Vor allem eingesetzt, um die Zeichen Längenbeschränkung der Texte zu beachten.
Abschneiden
=LINKS(A1;35) schneidet eine Zeichenkette ab einer definierten Zeichenstelle (hier 35) ab. Zwar erhält man so keine grammatikalisch richtigen Texte, aber schon mal einen Anhaltspunkt, wie viel zu lang ein Text war.
Kleinbuchstaben
=KLEIN(A1) schreibt Zeichenkette in Kleinbuchstaben.
Verketten
=VERKETTEN(A1;"hallo welt";C1) werden Zeichenkette aus Zellen über den  Zellbezug, aber auch direkte Werte, aneinander gereiht. Die alternative Schreibweise mit einem  Et-Zeichen (=D6&"hallo welt"&F6) ist aber meist einfacher zu schreiben.
Hilfreich bei vielen ähnlichen Texten und Struktur.
SVerweis
=SVERWEIS(A1;A10:B20;2;1) durchsucht die erste Spalte einer Matrix (Zellenbereich aus Zeilen und Spalten) senkrecht nach einem Suchbegriff (hier A1) und schreibt den Inhalt einer ausgewählten Spalte der Matrix in die Zelle.
Hilfreich bei der Suche nach doppelten Keywords, Zuordnung von Zielseiten etc.
SummeWenn
=SUMMEWENN(A1:A10;B20;C1:C10) durchsucht einen Bereich (hier A1:A10) nach einem Suchbegriff (hier B20) und summiert die entsprechenden Werte einer Zeile.
Pivot-Tabelle
die Pivot-Tabelle schreibt Übersichtstabellen aus flachen Datensätzen (wie Reportingdaten).

Die Skriptsprache  Visual Basic for Applications ermöglicht es in Excel (in anderen Tabellenkalkulationsprogramme gibt es Ähnliches), weitere selbst definierte Funktionen hinzuzufügen. (VBA in Excel)

Oft müssen Umlaute, Leerzeichen oder URLs ersetzt werden.

Folgendes Beispiel ersetzt kleine Umlaute gegen kleine Umschreibungen.

Sub umlaute()
'
' leerzeichenunderscore Makro
'
    Selection.Replace What:="ä", Replacement:="ae", LookAt:=xlPart, _
        SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
        ReplaceFormat:=False

    Selection.Replace What:="ü", Replacement:="oe", LookAt:=xlPart, _
        SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
        ReplaceFormat:=False

    Selection.Replace What:="ö", Replacement:="oe", LookAt:=xlPart, _
        SearchOrder:=xlByRows, MatchCase:=False, SearchFormat:=False, _
        ReplaceFormat:=False
End Sub


Und die Möglichkeiten sind nach oben offen, es gibt sogar eine Excel-API-Anbindung für Adwords.

Adwordseditor[Bearbeiten]

Der Adwordseditor ist ein Desktopprogramm, mit welchem ausschließlich Google-Kampagnen erstellt werden können. Vor allem die Möglichkeit Kampagnen, Keywords und Texte in großen Mengen einzugeben und zu verändern macht ihn sehr effektiv. Meist kann man in Webapplikationen vom Desktop gewohnte Funktionen schwer ersetzen.

Der Adwordseditor kann

  • Anzeigen und Keywords mit Suchen und Ersetzen verändern
  • Elemente mit Copy and Paste innerhalb des Adwordseditors, aber auch aus anderen Programmen, wie vor allem Excel mit  Copy and Paste, hin und her verschieben.

Weitere[Bearbeiten]

Tracking[Bearbeiten]

Tracking ist eine der wichtigsten Funktionen im SEM. Erst die Zahlen aus einem richtigen und korrekten Tracking ermöglichen es, eine Kampagne richtig Bidding und Struktur optimieren …(?). Dabei bieten zahlreiche Anbieter unterschiedlichste, meist als  Software as a Service, Dienste an. Google und Yahoo selbst bieten für ihre Accounts auch meist kostenlose Trackinglösungen an.

Eine gute Alternative für kleinere und größere (kein keyword-bidding) Accounts ist inzwischen  Piwik mit dem Analytics Campaigns Tracking.