Inkscape/ bw2svg

Aus Wikibooks
Wechseln zu: Navigation, Suche


Navigation: Index —   Schwarzweisszeichnungen vektorisieren und kolorierenBilder mit Graustufen vektorisierenFarbbilder vektorisierenManuell vektorisieren


Bonsai windgepeitschte form.png

Als Ausgangsbild nehmen wir eine einfache Grafik, hier ein Bonsai. Das Ziel ist, den Stamm, den Topf und die Blätter in Inkscape einzufärben, nachdem wir den ganzen Bonsai vektorisiert haben.

Die «Füllung» muss nicht ganz genau passen, es sieht sogar natürlicher aus, wenn noch ein paar weiße Ränder zu sehen sind. Die einfachste Möglichkeit die Einzelteile zu kolorieren ist, die Blätter, den Stamm und den Topf mit einem Malprogramm wie GIMP separat auszufüllen und dann in einem zweiten Schritt in Inkscape einzufärben.

Vorarbeit mit GIMP[Bearbeiten]

Blätter ausgewählt
Blätter schwarz

Öffne die Zeichnung nun in Gimp. Zuerst mit Ctrl + D duplizieren, dann mit dem «Zauberstab», Z, bei gedrückter Umschalttaste auf die Stellen klicken, die nachher Grün gefärbt sein sollen. Bei dieser Zeichnung sind zum Glück keine Löcher in den Einzelteilen, sonst würde der weiße Bereich auch mit ausgewählt. Hätte das Bild weiße Löcher, müsstest du sie mit dem Pinsel separat schließen. Das muss nicht allzu genau ausgeführt werden, es wird nachher sowieso nur zum Ausmalen benutzt. Invertiere die Auswahl mit Ctrl + i und fülle alles mit schwarzer Farbe. Umschalt + B wählt das Füllwerkzeug, mit dem du bei gedrückter Umschalttaste zwei Mal in das Bild klickst.

Nun sind die Blätter Weiß, der Hintergrund ist Schwarz eingefärbt. Für die weitere Verwendung in Inkscape müssen wir das noch invertieren. So wie es jetzt ist, ist es noch nicht brauchbar. Also nichts auswählen mit Umschalt + Ctrl + A und über Ebene > Farben > Invertieren die Farben umkehren. Speichere es als blatt.png, schließe das Bild, dupliziere das Original wieder und wiederhole die Vorgänge mit dem Stamm (stamm.png) und dem Topf (topf.png).

Das Bild blatt.png sollte nun etwa so aussehen wie in der Abbildung rechts. Damit wären wir jetzt so weit, alle weiteren Schritte, wie Einfärben und Vektorisieren in Inkscape auszuführen.

Vektorisieren[Bearbeiten]

Zuerst müssen die Bilder in Inkscape importiert werden. Dies geschieht mit Ctrl + i oder über Datei > Importieren. Beachte, dass es immer noch Bitmaps sind, und somit können sie sich überlagern. Wenn ein Bild von der Zeichenfläche verschwindet, musst du vielleicht ein anderes auf die Seite ziehen, falls es darunter geraten ist.

Import Spacer.gif Vektorisieren

Vektorisiert wird nun mit Umschalt + Alt + B oder über Pfad > Bitmap vektorisieren. Wähle alle Bitmaps nacheinander an und klicke auf OK, die Standardeinstellungen sind für dieses Beispiel gut geeignet (Helligkeitswert mit Schwellwert 0,45). Übrigens, die Originalgrafik brauchen wir später noch! Die alten Pixelgrafiken können/sollen gelöscht werden. Wenn du nicht mehr weißt, welche das sind: Entweder heranzoomen (Ctrl gedrückt halten und das Mausrad drehen) oder schauen, ob weiße Flächen zu sehen sind, die beim Verschieben von anderen Objekten überlagert wurden.

Ändere noch die Größe des Dokuments per Umschalt + Ctrl + D oder über Datei > Dokumenteneinstellungen auf 600×400 Pixel und ziehe alle Objekte auf das Dokument.

Vektorisiert

Nun ändern wir die Farbe der Füllungen. Das geschieht mit Umschalt + Ctrl + F oder über Objekt > Füllung und Kontur ... Die Blätter bekommen die Farbe 5aa046ff (das kannst du direkt in dem Feld «RGBA» eingeben), der Stamm a06400ff und der Topf wird blau mit 325aa0ff.

Eingefärbt

Setze schlussendlich die Transparenz der Farben auf 0,2, damit es mehr nach Wasserfarbe aussieht, und schiebe die Blätter, den Stamm und den Topf auf die richtige Position. Wenn du die Blätter etwas mehr nach unten links verschiebst, den Stamm dafür nach oben rechts, sieht es noch ein wenig natürlicher aus, man nimmt es aber nur unbewusst wahr:

alpha, zurechtgerückt

Vorher-Nachher-Vergleich[Bearbeiten]

Zum Vergrössern bitte auf die Bilder klicken.

Bonsai windgepeitschte form.png Spacer.gif Inkscape-tut-bw-bonsai.svg

Fertig!


Navigation: Index —   Schwarzweisszeichnungen vektorisieren und kolorierenBilder mit Graustufen vektorisierenFarbbilder vektorisierenManuell vektorisieren