Blender Dokumentation/ Druckversion/ UV-Mapping

Aus Wikibooks
Zur Navigation springen Zur Suche springen


Anmerkungen zur Druckversion[Bearbeiten]

Diese Druckversion enthält den jeweils aktuellsten Stand der Dokumentation, da es sich um eine direkte Einbindung der einzelnen Seiten handelt. Dafür ist die Druck-Qualität von Ihrem Browser abhängig, es sollte aber in jedem Fall ein lesbares Ergebnis angezeigt werden. Ich empfehle Ihnen aber nicht in Farbe zu drucken, da das Dokument ca. 26 DINA4 Seiten umfasst.

Die Navigationsleisten mit Vor- und Zurücklinks werden nicht mit ausgedruckt, auch wenn Sie hier angezeigt werden.

UV-Mapping[Bearbeiten]

<<<Zurück
Normal Maps
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
UV-Schnittkanten (Seams) setzen


Diese Seite bezieht sich auf
Blender v2.42
Von dieser Seite gibt es eine
aktuellere Version

Ältere Versionen finden Sie für 2.41, 2.37a

UV-Mapping ist eine Möglichkeit, zweidimensionale Bildtexturen auf dreidimensionale Modelle zu projizieren. Es kann benutzt werden, um Texturen auf willkürliche und komplexe Formen wie menschliche Köpfe oder Tiere anzuwenden. Diese Texturen sind oft gemalte Bilder, die mit Programmen wie Gimp, Photoshop oder Ihrem bevorzugten Bildbearbeitungsprogramm erstellt wurden. Sie können, wenn Sie wollen, jedem Face - also jeder einzelnen Fläche - eines Modells eine eigene Textur verpassen, aber genausogut können Sie auch eine Textur für alle Flächen benutzen. Dazwischen sind natürlich alle Mischformen möglich, z.B. eine Textur für jede Materialgruppe.

Prozedurale Texturen, wie sie in den vorigen Kapiteln vorgestellt wurden, sind eine schöne Möglichkeit um ein Modell zu texturieren. Das beste daran ist, dass sie immer 'passen'. Zweidimensionale Bilder werden nicht immer auf dreidimensionale Formen passen. Prozedurale Texturen zu erzeugen ist relativ einfach und sie sind ein schneller Weg zu guten Ergebnissen.

Es gibt aber auch Fälle, in denen diese Art von Textur nicht gut genug ist. Die Haut auf einem menschlichen Kopf zum Beispiel wird nie genau richtig aussehen, wenn sie prozedural generiert wird. Falten an einem Kopf oder Kratzer an einem Auto erscheinen nicht an zufälligen Stellen, sondern hängen von der Form des Modelles und seiner Verwendung ab. Von Hand gemalte Bilder geben dem Künstler die völlige Kontrolle über das Endergebnis. Anstatt mit ein paar numerischen Schiebereglern herumzuprobieren, können Künstler jeden Punkt auf der Oberfläche kontrollieren. Das bedeutet mehr Arbeit, führt aber am Ende zu besseren Bildern.

Eine UV-Map wird benutzt, um einem Polygon in einem Modell einen Teil eines Bildes zuzuweisen. Jede Vertex eines Polygons bekommt zweidimensionale Koordinaten zugewiesen, die bestimmen, welcher Teil des Bildes für das Polygon verwendet wird. Diese zweidimensionalen Koordinaten heißen UV-Vertices, oder kurz UVs (vgl. XYZ Koordinaten in 3D). Der Vorgang zum Erstellen der UV-Map heißt 'unwrap' (auseinanderfalten), da es einem Auseinanderfalten des Meshes auf eine zweidimensionale Fläche entspricht.

Blender3D FreeTip.gif

UV-Mapping ist auch sehr wichtig für Blenders Game Engine oder jedes andere Spiel. Es ist de facto Standard um einem Modell Texturen zuzuweisen; fast jedes Modell, das man in Spielen findet, benutzt UV-Texturen.


UV-Mapping kann sehr einfach sein (bei einem Würfel), es kann aber auch sehr komplex werden (bei einem Lebewesen). Wir werden zunächst einfache - aber häufige und sehr nützliche - Anwendungsfälle behandeln, am Schluss kommt dann ein komplexeres Beispiel. Der Ablauf ist im Prinzip aber immer der gleiche:

  • Festlegen der Schnittkanten (sog. Seams), an denen die dreidimensionale Oberfläche aufgeschnitten werden soll (bei ganz einfachen Objekten kommt man ohne das aus).
  • Auswahl der Flächen, die die UV-Map erhalten sollen.
  • Laden eines Bildes im UV/Image Editor Fenster.
  • Ausbreiten (sog. Unwrapping) der Flächen im UV/Image Editor.
  • evtl. Nachbearbeiten des Bildes.
  • Anzeigen der UV-Textur im 3D-Fenster und beim Rendern.

Dabei ist das Ausbreiten der Flächen - das sogenannte Unwrapping - der komplizierteste Schritt. Wer einmal versucht hat, die Schale einer Apfelsine auf eine Fläche auszubreiten, kennt die Probleme, die damit verbunden sind. Blender stellt dafür verschiedene fortgeschrittene Werkzeuge bereit.

Auf den nachfolgenden Seiten werden diese Schritte und Werkzeuge ausführlich besprochen, aber zunächst ein Überblick.

Im Überblick[Bearbeiten]

Abbildung 1: Vertices auswählen um die Schnittkanten [Seams] zu markieren.
Abbildung 2: Mit Strg-E Schnittkanten [Seams] markieren.
Abbildung 3: Im UV Face Select Modus mit U abwickeln [unwrappen].
Abbildung 4: Das erste Ergebnis im UV/Image Editor.
Abbildung 5: Das Unwrap Ergebnis im UV-Editor etwas bearbeitet. Das ist hier einfach, weil das Beispiel sehr einfach ist. Normalerweise ist dies der komplizierteste Schritt.
Abbildung 6: Mit dem UVs Menü das Layout exportieren. Oder einfach einen Screenshot machen (Druck/S-Abf). (Damit überspringt man den nächsten Schritt natürlich.)
Abbildung 7: Einige Optionen für den Export einstellen, insbesondere die Bildgröße.
Abbildung 8: Das Bild in einem Graphikprogramm Ihrer Wahl bearbeiten.
Abbildung 9: Das bearbeitete Bild wird dann wieder in Blender geladen.
Abbildung 10: Gus im Leopardenanzug im 3D-Fenster.
Abbildung 11: Zum Rendern erhält Gus die UV gemappte Image Textur.


Links[Bearbeiten]

Die englischsprachige Vorlage des ursprünglichen Textes
Releasenotes zu Version 2.42
What is UV-Mapping?
Greybeards Video Tutorial (englisch)
Ultimate Stitcher (Einen Character bauen und UV-Mappen (deutsch). Sehr ausführliche Hinweise und viele Tips, aber für Fortgeschrittene.)
Creature Tutorial (Teil II Texturierung)


<<<Zurück

Normal Maps

Inhaltsverzeichnis
Glossar
Weiter>>>

UV-Schnittkanten (Seams) setzen


UV-Schnittkanten (Seams) setzen[Bearbeiten]

<<<Zurück
UV-Mapping
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
UV Face Select


Diese Seite bezieht sich auf
Blender v2.42
Von dieser Seite gibt es eine
aktuellere Version

Entscheidend für das Abwickeln eines 3D-Körpers auf eine Fläche ist es, seine Oberfläche vorher an den richtigen Stellen aufzuschneiden. Dabei sollten zwei Bedingungen erfüllt sein:

  1. Die Schnittkanten [Seams] sollten möglichst an unauffälligen Stellen sitzen, die später im Bild nicht prominent zu sehen sind, oder an Stellen, an denen sowieso ein Materialwechsel stattfindet.
  2. Die Flächen sollten in der Flächenprojektion etwa genau so groß sein, wie auf dem 3D Körper. Dazu müssen unter Umständen auch Teilflächen ausgeschnitten werden.

Sie können allerdings auch zunächst an einfach zu markierenden Stellen aufschneiden, und die entscheidenden Stellen später wieder "vernähen".

Die Schnittkanten werden folgendermaßen erstellt:

Im Edit-Modus:

  • Markieren Sie die entsprechenden Vertices und drücken Strg-E->Mark Seam. Zwei Auswahlwerkzeuge sind hier extrem hilfreich:
    1. Vertex Path: Markieren Sie Start- und Endvertex einer Linie. Mit W->Select Vertex Path werden alle Vertices zwischen ihnen ausgewählt.
    2. Edge Loop: Klicken Sie mit Alt-RMT auf eine Kante [Edge]. Blender wählt dann anschließende Kanten aus.

Im UV Face Select Modus:

  • Markieren Sie die entsprechenden Faces. Drücken Sie Strg-E->Mark Border Seam.
  • Edge unter Cursor markieren: Alt-RMT (wenn die Tastenkombination bereits von einem anderen Programm besetzt ist, evtl. auch Strg-Alt-RMT).
  • Seam entlang des kürzesten Weges vom zuletzt markierten Seam setzen: Shift+Alt+RMT.

Wenn die Topologie des Meshes einigermaßen in Ordnung ist, lassen sich die nötigen Seams mit diesen Werkzeugen in kürzester Zeit erstellen. Gelöscht werden Seams mit den gleichen Werkzeugen.


Fläche[Bearbeiten]

Eine Fläche braucht natürlich keine Schnittkanten. Suchen Sie eine Ansicht senkrecht von oben auf die Fläche auf, und unwrappen Sie mit Project from View 1/1.

Würfel / Quader[Bearbeiten]

Der Standard-Unwrap projiziert die Textur auf jede Seite des Würfels (siehe auch UV Face Select). Nahtlos kann die Textur natürlich nur dann aufgebracht werden, wenn Sie an allen vier Seiten kachelbar ist.

Abbildung 1: Schnittkanten an einem Würfel und Abwicklung.

In der Regel werden Sie entscheiden müssen, wie Sie den Würfel abwickeln wollen. Die Seams bringen Sie genauso an, als ob Sie eine Pappschachtel aufschneiden würden, z.B. wie in Abbildung 1.

Dass der Unwrap nicht senkrecht ausgerichtet ist, ist kein Problem. Einfach alle Vertices im UV/Image Editor auswählen und mit R drehen.



Kugel[Bearbeiten]

Für Kugeln braucht man wohl keine Schnittkanten, da diese entweder mit einer "normalen" Textur gemappt werden (Map Input Orco/Sphere), oder mit Project From View.

Den ersten Fall wird man benutzen, wenn man eine Bilddatei hat, die bereits zur Aufbringung auf eine Kugel gedacht ist (Weltkarte). Der zweite Fall ist nützlich, wenn man das Bild einer Kugel auf eine Kugel aufbringen will.

Flasche[Bearbeiten]

Abbildung 2: Schnittkanten an einer Flasche. Die lange Schnittkante wird später an der Seite der Flasche sitzen.
Abbildung 3: Aufgebrachte UV-Testmap. Die Flasche ist von vorne gezeigt, die seitliche Schnittkante sieht man hier nicht.

Bei einer Flasche schneidet man am besten den Boden und das Gewinde ab, und setzt eine Schnittkante an einer Stelle, wo die Textur nicht nahtlos sein muss, z.B. an der Seite. Kleine Regionen behandelt man am besten separat, ob es sich wie hier um ein Gewinde handelt, oder um Hände und Füße, Ohren usw.

Dino-Kopf[Bearbeiten]

Abbildung 4: Naiver Unwrap eines Kopfes.

Ohne Schnittkanten werden organische Formen nicht gut abgewickelt. Ein logischer Ansatz ist es, in Abbildung 4 das Maul separat zu behandeln. Eine gute Topologie erleichtert die Auswahl der entsprechenden Vertices erheblich, mit Alt-RMT und Shift-Alt-RMT lässt sich mit wenigen Klicks ein entsprechender Ring von Vertices im Maul auswählen.


Abbildung 5: Schnittkanten setzen.

Das Innere der Nasenlöcher wird ebenfalls separiert. Die anderen Schnittkanten hängen von der Textur ab, in Abbildung 5 wurde die "Nase" und unter dem Kinn aufgeschnitten.

Abbildung 6: Dieser Unwrap muss nur wenig nachbearbeitet werden.

Das Ergebnis dieses Unwraps ist sehr zufriedenstellend, und muss fast nicht mehr nachbearbeitet werden (Abbildung 6).


Abbildung 7: Spiegelsymmetrische Textur und Mirror-Modifier? Dann muss man fast gar nichts mehr selber machen.

Eine Alternative zu diesem Vorgehen wäre, mit dem Mirror-Modifier zu arbeiten und nur die Hälfte des Modells zu texturieren. Die andere Hälfte der Textur wird spiegelsymmetrisch ergänzt. Eventuell könnte man noch das Innere des Mundes mit Seams markieren, aber der Unwrap ist auch so schon fast perfekt.



Menschlicher Kopf[Bearbeiten]

Abbildung 8: Schnittkanten an einem menschlichen Kopf. Ansicht von vorn. Blend-Datei von [1]
Abbildung 9: Und die Ansicht von hinten rechts.

Die Schnittkanten sind:

  • Der Haaransatz über der Stirn.
  • Mittelscheitel bis zum Hinterhaupt.
  • Unter dem Kinn.
  • Vom Kinn bis zum Brustbein.

Auch hier kommt es natürlich darauf an, dass die Schnittkanten nicht zu sehen sind. Der Mirror-Modifier sollte vor dem UV-Mapping permanent gemacht werden, da das Gesicht vermutlich nicht spiegelsymmetrisch texturiert wird.




Links[Bearbeiten]

UV Mapping Tutorial eines menschlichen Kopfes.
Englischsprachig, aber viele Bilder. Einschließlich Blend-Datei des Kopfes und aller Texturen.
UV Texturierung eines Dinosauriers.
Englischsprachig, nicht für Blender, aber das Prinzip ist das gleiche.
<<<Zurück

UV-Mapping

Inhaltsverzeichnis
Glossar
Weiter>>>

UV Face Select


UV Face Select[Bearbeiten]

<<<Zurück
UV-Schnittkanten (Seams) setzen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Unwrapping-Werkzeuge


Diese Seite bezieht sich auf
Blender v2.41
Von dieser Seite gibt es eine
aktuellere Version

Zum UV-Mapping benutzen Sie zwei Fenster gleichzeitig (dazu die Ansicht splitten). Im 3D-Fenster sehen Sie ihr Objekt. Wechseln Sie im 3D-Fenster in den UV Face Select Modus [Flächenauswahlmodus]. Mit Alt-Z schalten Sie am besten gleich in den Textured Draw Type. Im zweiten Fenster wechseln Sie zum UV/Image Editor. Der UV-Editor erlaubt Ihnen Texturen direkt auf die Faces eines Meshes zu projizieren.

Abbildung 1: Face Select (links) und UV-Editor rechts. Alle Faces des Würfels sind ausgewählt, sie liegen im UV-Editor übereinander. Da die Flächen gleich groß sind, kann man das allerdings nicht erkennen.
Abbildung 2: Die Darstellungsoptionen auf dem UV Calculation Panel.

Ihr Mesh wird jetzt mit Hilfe des Z-Buffers dargestellt. Den Faces sind zunächst noch keine Bilder zugewiesen. Schalten Sie mit F9 in die Editing Buttons. Die Art der Darstellung der Faces können Sie mit den Draw Edges [Kanten zeichnen] und Draw Faces [Flächen zeichnen] Buttons im UV Calculation Panel im Editing Kontext (F9) beeinflussen (Abbildung 2). Wenn Draw Edges aktiv ist, werden alle Faces im 3D-Fenster umrahmt dargestellt. Wenn Draw Faces aktiv ist, werden ausgewählte Faces mit einem leichten Pinkstich dargestellt (so wie in Abbildung 1).

Wenn Sie A im 3D-Fenster drücken, werden alle Faces des Meshs ausgewählt und von gestrichelten Linien umgeben. Sie können Faces auch mit RMT oder der Rahmenauswahl (B) im 3D Fenster auswählen. Wenn Sie Probleme haben die gewünschten Faces auszuwählen, können Sie auch direkt aus dem Face Select Mode in den Edit Mode wechseln und dort mit den bekannten Methoden die gewünschten Faces auswählen. Wechseln Sie dann aus dem Edit Mode zurück in den Face Select Mode, bleiben die entsprechenden Faces ausgewählt.

Blender3D FreeNote.gif

Die Auswahl im Edit Mode wird nur mit der Auswahl im Face Select Mode synchronisiert, wenn Sie im zuletzt genannten Tab drücken und so in den Edit Mode wechseln, sonst nicht. Durch diese Synchronisierung wird Ihre Auswahl im Edit Mode durch die Auswahl überschrieben, die der Face Select Mode vorgibt.


Nur ein Face ist aktiv, das bezieht sich aber nur auf die Anzeige des Bildes im UV/Image Editor (Abbildung 3, rechts). Wie in Blender üblich ist das zuletzt ausgewählte Face das aktive. Sie könnten jetzt für jedes Face einzeln ein Bild zuweisen, indem Sie Face nach Face auswählen und die Bilder mit Image->Open... laden. Dann aktivieren Sie TexFace auf dem Material Panel in den Material Buttons (F5). Oder wählen Sie einige/alle Faces aus (z.B. mit A im 3D-Fenster) und weisen den ausgewählten Faces das gleiche Bild zu.

Sie können die Bilder aller ausgewählten Flächen rotieren bzw. spiegeln, indem Sie im 3D-Fenster R (Rotation 90 Grad im Uhrzeigersinn) bzw. M drücken und UV-coordinates wählen.

Nicht alle Meshes sind so einfach wie ein Würfel. Wenn Sie z.B. eine UV-Sphere mit 1024 Faces mappen, wäre es sehr unpraktisch, alle Faces mit einem eigenen Bild zu belegen. Im UV/Image Editor können Sie die UV-Koordinaten anpassen. Dies kann von Hand geschehen, im Abschnitt Unwrapping-Werkzeuge werden wir sehen, welche Werkzeuge Blender bereitstellt, um auch kompliziertere Meshes einfach auf eine Fläche abzuwickeln.

Abbildung 3: Ein Würfel mit 6 verschiedenen, UV gemappten Bildern.

Weitere Möglichkeiten[Bearbeiten]

  • Mit dem UV-Editor werden jedem Face des Meshs zwei weitere Eigenschaften hinzugefügt:
    1. Vier UV Koordinaten - Diese Koordinaten definieren wie ein Bild oder eine Textur auf das Face projiziert wird. Es sind zweidimensionale Koordinaten, deshalb werden sie UV genannt, um sie von den XYZ Koordinaten zu unterscheiden.
    2. Eine Verknüpfung zu einem Bild - Jedes Face in Blender kann eine Verknüpfung zu einem anderen Bild haben. Die UV-Koordinaten definieren wie dieses Bild auf das Face projiziert wird. Dieses Bild kann gerendert oder in Echtzeit angezeigt werden.
  • Jedes Face kann individuelle Texturkoordinaten und ein individuelles Bild erhalten. Es ist hierzu nicht notwendig Materialindizes zu definieren.
  • UV-Texturen können mit Vertexfarben kombiniert werden, um die Textur heller oder dunkler zu machen oder ihr eine Farbe zu geben.
Abbildung 4: Der Face Select Mode im Menübutton in der Titelleiste des 3D Fensters
  • Ein 3D-Fenster muss im Face Select Mode sein, um dem aktiven Meshobjekt Bilder zuweisen oder UV-Koordinaten ändern zu können.
  • Fügen Sie zuerst ein Meshobjekt in Ihre Szene ein und wechseln Sie dann in den Flächenauswahlmodus indem Sie UV Face Select in Modusmenü auswählen oder F drücken.
  • Ändern Sie ein Fenster zum UV-Editor/Bildfenster indem Sie Shift F10 drücken. Hier können Sie Bilder laden (Image>>Open), die schon geladenen Bilder durchsuchen und noch vieles mehr.
  • Wenn ein Bild im Face Select Mode geladen wird oder Sie ein schon geladenes aus der Liste auswählen bekommen automatisch alle ausgewählten Faces dieses Bild zugewiesen. Sie können das sofort im 3D-Fenster sehen wenn Sie in der texturierten Ansicht sind.


<<<Zurück

UV-Schnittkanten (Seams) setzen

Inhaltsverzeichnis
Glossar
Weiter>>>

Unwrapping-Werkzeuge


Unwrapping-Werkzeuge[Bearbeiten]

<<<Zurück
UV Face Select
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
UV-Koordinaten bearbeiten


Diese Seite bezieht sich auf
Blender v2.42a
Von dieser Seite gibt es eine
aktuellere Version

Eine ältere Version gibt es für 2.41.

Mit den Unwrapping-Werkzeugen wird die Oberfläche eines Körpers auf eine Fläche abgewickelt. Bilder sind grundsätzlich flach, und Texturen lassen sich am einfachsten zeichnen, wenn das flache Bild möglichst unverzerrt auf den Körper aufgebracht wird. Parallele Linien in der Textur sollten auf dem Körper immer noch parallel zueinander sein, rechteckige Flächen immer noch rechteckig. Und natürlich sollte es keine Schnittkanten geben.

Abbildung 1: Nahtlose Textur auf einem Würfel.

An einem Würfel ist das ganze besonders einfach, wenn die Textur nahtlos ist (Abbildung 1). Bei allen anders geformten Körpern ist das nicht so leicht, aber wie man in Abbildung 2 sehen kann, nicht allzu schwierig. Voraussetzung dazu sind zwei Dinge: das Mesh muss einigermaßen in Ordnung sein, also die Flächen möglichst gleichmäßig groß. Und die Schnittkanten müssen stimmen.

Abbildung 2: Textur an einem Kopf.

Die Werkzeuge die zum "Abwickeln" eingesetzt werden, werden auf dieser Seite besprochen.


Unwrap Menü[Bearbeiten]

Abbildung 3: Die Unwrapping Werkzeuge

Die Unwrapping Werzeuge erreichen Sie im Face Select Mode mit U (Abbildung 3), einige Optionen dazu können Sie auf dem UV Calculation Panel einstellen (Abbildung 6).

Abbildung 4: Ein Testgrid erstellen.

Um die Wirkungen des UV-Mapping direkt beurteilen zu können, sollten Sie immer ein Testgrid [Raster] laden, oder es von Blender mit Image->New... erstellen lassen (Abbildung 4).

Die verfügbaren UV Mapping Optionen sind:

Abbildung 5: Cube Projection, Sphere from View, Cylinder from View
  • Cube Projection - kubisches Mapping. Alle Flächen werden so gemappt, als wären sie gleich groß. Ist das nicht der Fall, wird die Textur natürlich stark verzerrt.
  • Cylinder from View, Sphere from View - zylindrisches/kugelförmiges Mapping, vom Mittelpunkt der ausgewählten Faces aus berechnet.
  • Unwrap - Angle Based oder Conformal Unwrap. Die Standardmethode für alle komplexeren Gebilde. Conformal entspricht dem früheren LSCM.
  • Project from View - Die UV-Koordinaten werden so wie im aktuellen 3D-Fenster dargestellt berechnet. Das ist eine sehr schnelle Möglichkeit, Texturen von einem Foto aufzubringen (solange man die Rückseite des Objektes nicht sieht). Positionieren Sie das Objekt so wie auf dem Foto, laden das Bild, mappen From Window. Schon fertig. Mit den verschiedenen Optionen können Sie die Koordinaten auf die gewünschte Bildfläche skalieren. Diese Option entspricht dem früheren From Window und Bounds.
  • Reset 1/8, 1/4, 1/2, 1/1 - Jedes Face erhält die standardmäßigen quadratischen UV-Koordinaten, die dann auf die gewünschte Größe skaliert werden. Diese Option entspricht dem früheren Standard.

Die Bezeichnungen der Vorgängerversion wurden angefügt, damit Sie auch ältere Tutorials nachvollziehen können.

UV Calculation Panel[Bearbeiten]

Im UV Calculation Panel (Abbildung 6) können Sie die Einstellungen für das Mapping und die Darstellung des Meshs im Face Select Mode verändern. Sie finden das Panel in den Editing Buttons (F9), wenn sich das ausgewählte Objekt im UV Face Select Modus befindet.

Abbildung 6: Das UV Calculation Panel in den Editing Buttons.
  • Draw Edges und Draw Faces: aktivieren die Darstellung von Edges und Faces im 3D Fenster während das Mesh im Face Select Mode ist. Ausgewählte Faces werden dann mit einem transparenten Pink (oder der Farbe des Themas) dargestellt, ähnlich wie im Edit Mode.
  • Draw Seams: Die Darstellung der Schnittkanten in Edit Mode und Face Select Mode kann an- oder abgeschaltet werden.
  • Cube Size bzw. Cyl Radius: definieren jeweils die Größe der UV-Map, wenn Sie Cube oder Cylinder verwenden.
  • View Aligns Face: Wenn diese Option aktiv ist, werden Cylindrical und Spherical von der aktuellen Ansicht beeinflusst. Blender geht dann davon aus, dass der Zylinder bzw. die Kugel von vorne sichtbar ist und die Pole in der Ansicht oben und unten sind. Der Zylinder/die Kugel wird dann auf der gegenüberliegenden Seite "aufgeschnitten".
  • Wenn VA Top (View Aligns Top [Ansicht von oben]) aktiv ist geht Blender davon aus dass die aktuelle Ansicht von oben auf das Objekt schaut. Der Schnitt ist dann fast der selbe wie bei View Aligns Face von vorne. Polar ZX und Polar ZY bewirken in diesem Modus noch eine zusätzliche Drehung der Koordinaten.
  • Al Obj: Die UV-Map hängt von der Drehung des Objekts ab.
  • Angle Based / Conformal: Mit diesem Menü wählen Sie die Methode für das allgemeine Unwrapping aus. (Abbildung 8)
Abbildung 7: Option Fill Holes: 1: ohne, 2: mit, 3: der Bereich wird gesondert behandelt.
  • Fill Holes: Die Option Fill Holes verbessert das Unwrapping Ergebnis des Angle Based Unwrapping, wenn Bereiche mit vielen kleinen Flächen vorhanden sind. Das sind z.B. Ohren und Augen an einem Kopfmodell. Das Ergebnis wird allerdings noch besser, wenn Sie solche Bereiche mit Seams markieren und gesondert behandeln. Sie sollten also grundsätzlich mit Fill Holes unwrappen, und dann entscheiden ob Sie die Bereiche besser ausschneiden.


Angle Based/Conformal Unwrapping[Bearbeiten]

Abbildung 8: Auswahlmenü der Unwrapping Methode.

Diese beiden Methoden erlauben es, auch kompliziertere Meshes mit relativ geringem Aufwand abzuwickeln. Dabei liefert Angle Based Unwrapping in der Regel das bessere Ergebnis, so dass Sie die Voreinstellungen übernehmen können. Voraussetzung für vernünftige Ergebnisse ist allerdings, dass Sie die richtigen Schnittkanten gesetzt haben.

Das Ergebnis des Abwickelns muss normalerweise nachbearbeitet werden, wenn auch dank Angle Based Unwrapping nur noch wenig. Dies wird im Abschnitt UV-Koordinaten bearbeiten erläutert.

Abbildung 9: Unbearbeiteter Unwrap eines Kopfmeshes.
Abbildung 10: Das Ergebnis ist auch ohne Nachbearbeitung schon sehr zufriedenstellend, nur an der Kehle gibt es ein Problem.


Links[Bearbeiten]

Releasenotes zu Version 2.42, Angle Based Unwrapping
Releasenotes zu Version 2.34, LSCM

<<<Zurück

UV Face Select

Inhaltsverzeichnis
Glossar
Weiter>>>

UV-Koordinaten bearbeiten


UV-Koordinaten bearbeiten[Bearbeiten]

<<<Zurück
Unwrapping-Werkzeuge
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
UV-Texture Paint


Diese Seite bezieht sich auf
Blender v2.42a
Von dieser Seite gibt es eine
aktuellere Version

Eine ältere Version gibt es für 2.41.

Nachdem Sie ihr Modell abgewickelt (eine der Unwrap-Funktionen angewendet) haben, werden im UV/Image Editor Fenster die im 3D-Fenster ausgewählten Faces dargestellt.

Abbildung 1: Stellen Sie die Textured Ansicht im 3D-Fenster und den Automatic Update im UV/Image Editor an.
Abbildung 2: Die zu einem Vertex im 3D-Fenster gehörenden UV-Vertices (hier vier) können im UV-Editor getrennt werden.

Die Vertices werden repräsentiert durch gelbe (ausgewählte) oder violette (nicht ausgewählte) Punkte, die durch gestrichelte Linien verbunden sind. Im 3D-Fenster gehören alle Vertices - bis auf die an Ecken - zu mehreren Flächen. Im UV-Editor muss man die Flächen trennen können, daher hat jede Fläche ihre eigenen Vertices, die nach dem Unwrap zunächst übereinanderliegen.

In der Voreinstellung wählen Sie die zu einem 3D-Vertex gehörenden UV-Vertices aufeinmal aus, da die Option Stick Local UVs to Mesh Vertex aus dem Select Menü aktiv ist. Diese Option bewirkt, dass Sie alle UV-Vertices, die nicht weiter als 5 Pixel im UV-Editor Fenster voneinander entfernt sind und zu einem 3D-Vertex gehören, gleichzeitig auswählen. Wenn Sie die Vertices trennen möchten, schalten Sie diese Option aus (Abbildung 2).

Zur Bearbeitung der UV-Koordinaten können Sie dieselben Techniken wie im Edit Mode des 3D-Fensters verwenden, also auswählen, bewegen, drehen, skalieren und so weiter. Skalieren und verschieben kann auch auf die X oder Y Achse beschränkt werden, indem Sie X bzw. Y drücken oder auch MMT klicken. Auch das Proportional Editing Tool ist verfügbar und funktioniert so wie bei Meshes im Edit Mode. Vertices im UV-Editor können mit H versteckt und mit Alt H wieder sichtbar gemacht werden, genau wie im Edit Mode.


Abbildung 3: UV Test Grid erstellen.
  • Erstellen (oder laden) Sie ein UV Test Grid (Image Menü->New...->UV Test Grid, siehe Abbildung 3), um das UV Mapping beurteilen zu können.
  • Aktivieren Sie das Echtzeit Update mit dem Schloss im Fensterheader des UV/Image Editor Fensters Blender3D UVRealTimeUpdate.png.
  • Stellen Sie im 3D-Fenster die Textured Ansicht an.

Im wesentlichen müssen Sie nun versuchen, durch geschicktes Anpassen der UV-Koordinaten ihr Mesh flach, ohne große Verzerrungen auszubreiten. Das geht natürlich schon vom Prinzip her nicht perfekt, aber an manchen Stellen sind die Verzerrungen eben weniger sichtbar als an anderen.

Es gibt einige Funktionen die Sie häufiger benötigen werden, diese werden zunächst besprochen.

Häufig benutzte Werkzeuge[Bearbeiten]

  • Um einen Vertex an einer Stelle "festzuhalten", benutzen Sie die Pin Funktion (P). Mit Alt-P lösen Sie den Pin wieder. Gibt es beispielsweise eine Reihe von Vertices die in einer geraden Linie angeordnet sein sollen, wählen Sie die Vertices aus, bringen Sie in die entsprechende Position und pinnen sie. Auch die Größe von Meshabschnitten lässt sich so fixieren, wenn Sie zwei Vertices pinnen und diese skalieren. Gepinnte Vertices werden in rot dargestellt.
  • Live Unwrap Transform aus dem UVs-Menü sollten Sie aktivieren, da dann das Unwrapping bei einer Bewegung der Vertices neu berechnet wird, und Sie direkt die Auswirkungen aus das Mesh beurteilen können. Damit das überhaupt eine Auswirkung hat, müssen Sie aber mindestens zwei Vertices aus dem Meshabschnitt gepinnt haben und einen gepinnten Vertex bewegen. Es wird allerdings nicht der ganze Unwrap neu berechnet, das Setzen von neuen Seams wird bspw. nicht berücksichtigt.
  • Unwrap: mit E im UV-Editor Fenster können Sie den gesamten Unwrap neu berechnen lassen. Alle verschobenen und nicht gepinnten Vertices rutschen dann aber wieder in ihre Ausgangsposition zurück.
  • Rückgängig machen Sie Aktionen im UV-Editor mit Strg-Z.
  • Stitch: Wollen Sie mit Seams getrennte Abschnitte wieder "vernähen", benützen Sie den Stitch Befehl. Wählen Sie die entsprechenden Vertices aus, und drücken Sie V. Stitch fügt nur UV-Vertices zusammen, die zum gleichen 3D-Vertex gehören, beliebige Vertices werden mit Weld (W) zusammengefügt.
Abbildung 4: Minimize Stretch mit unterschiedlicher Stärke.
  • Minimize Stretch: Mit diesem Werkzeug bearbeiten Sie den Unwrap komplexer Meshes. Wenn an einer Stelle viele kleine Faces vorkommen (Nase, Ohren), belegen diese im Unwrap normalerweise nur wenig Platz, die UV Koordinaten werden dort sehr auseinandergezogen. Wählen Sie die UV-Vertices der entsprechenden Region aus und drücken Strg-V. Mit dem Mausrad (MR) können Sie die Stärke des Ausbreitens beeinflussen, LMT schließt die Aktion ab.


Abbildung 5: Save UV Face Layout Skript.
  • Save UV Face Layout ...: Mit diesem Script aus dem UVs Menü speichern Sie die ausgebreiteten Flächen aus dem UV/Image Editor so, wie sie dort zu sehen sind. Wählen Sie eine ausreichend große Auflösung (Size). Das Bild trägt den Namen NameDerBlendDateiNameDesObjekts.tga und wird im Verzeichnis der blend-Datei gespeichert.



Eine Beschreibung der anderen Funktionen finden Sie in der Referenz zum UV/Image Editor.

Tips[Bearbeiten]

Abbildung 6: Vertexfarben passen die Textur an

Einige Tips:

  • Drücken Sie R im 3D-Fenster, es erscheint ein Menü welches Ihnen erlaubt UV-Koordinaten zu drehen.
  • Manchmal ist es notwendig, Bilddateien auf der Festplatte zu verschieben. Danach können Sie die Option Replace... [ersetzen] verwenden um Blender mitzuteilen, wohin Sie das Bild verschoben haben. Blender ersetzt dann automatisch alle veralteten Vorkommen des Bildes (zum Beispiel in Materialien) durch die neue Version.
  • Sie können den Face Select Mode und Vertex Paint auch gleichzeitig verwenden. Dann können nur ausgewählte Faces angemalt werden. Diese Möglichkeit ist besonders nützlich um Faces anzumalen als ob sie keine Vertices teilen würden. Beachten Sie bitte, das Vertexfarben verwendet werden, um Helligkeit oder Farbe der Bilder anzupassen. Allerdings ist es viel einfacher, mit UV-Texture Paint die Image-Textur selbst anzupassen.


Links[Bearbeiten]

Releasenotes zu Version 2.33
Alte Referenz zum Image Window

<<<Zurück

Unwrapping-Werkzeuge

Inhaltsverzeichnis
Glossar
Weiter>>>

UV-Texture Paint


UV-Texture Paint[Bearbeiten]

<<<Zurück
UV-Koordinaten bearbeiten
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
UV-Texturen anzeigen


Diese Seite bezieht sich auf
Blender v2.41
Von dieser Seite gibt es eine
aktuellere Version
Abbildung 1: Texture Paint im UV/Image Editor.

Sobald Sie ein Bild im UV-Editor geladen haben, können Sie es im Texture Paint Modus bearbeiten, das heißt Sie können das Bild in Blender anmalen. Alle Änderungen werden sofort angezeigt, falls sich das Modell in der texturierten Ansicht (Alt-Z) befindet. Damit malen Sie beinahe direkt auf dem Mesh.

Abbildung 2: Mini-Gimp im UV/Image Editor

Im UV/Image Editor Fenster können Sie im View Menü das View Paint Tool aufrufen, es erscheint dann ein Panel, auf dem Sie verschiedene Werkzeuge auswählen können.

  • Brush: mit LMT wird gezeichnet, die Farbe können Sie im Farbfeld einstellen. Der Brush zeichnet erst, wenn die Maus um Stepsize bewegt wird. Dabei wird Stepsize in Prozent des Pinseldurchmessers angegeben.
  • Airbrush: kontinuierlicher Fluss von Farbe (Sprühpistole).
  • Soften: Pinsel mit einfacher Mittlung zwischen benachbarten Pixeln.
  • Aux: Jeder Pinsel speichert seine eigenen Einstellungen, mit den Hilfspinseln können Sie schnell zwischen verschiedenen Einstellungen wechseln.
  • Smear: Verschmieren.
    • Opacity: Blendfaktor für den Farbauftrag.
    • Size: Pinselgröße in Pixeln.
    • Fall: Alle Pinsel haben einen inneren Radius, in dem mit dem Opacity Wert Farbe aufgetragen wird. Bis zum äußeren Radius fällt die Deckkraft linear ab. Das Verhältnis zwischen innerem und äußeren Radius wird durch Fall eingestellt.
  • Clone: Einer der nützlichsten Pinsel. Klont von einem Bild auf ein anderes.
    • Jedes geladene Bild kann als Pinselquelle dienen. Mit den Hoch/Runter Pfeilen kann das Bild ausgewählt werden.
    • Ziehen Sie das Bild an die gewünschte Stelle mit RMT.
    • Kopieren Sie mit LMT.
    • Der Blend-Faktor wird mit dem B Schieberegler eingestellt.
  • Wrap: Wenn Wrap aktiv ist kann man über den Rand der Textur hinausmalen, was nicht mehr passt wird am anderen Ende der Textur aufgemalt. Damit kann man sehr schön nahtlose Texturen erzeugen.

Die bearbeitete Textur wird aber nicht gespeichert bis Sie Blender dazu auffordern. Verwenden Sie dazu das Image Menü im UV-Editor. Die Option Replace wird das Bild speichern und das Original ersetzen, die Option Save öffnet das bekannte 'Datei speichern' Fenster damit Sie die Datei unter einem anderen Namen speichern können.

Wenn Sie im UV-Editor zeichnen kann die Option Draw Shadow Mesh natürlich sehr hilfreich sein damit Sie wissen welchen Teil der Textur Sie gerade anmalen.

Blender3D FreeTip.gif

Mithilfe eines vorinstallierten Plugins können Sie auch das Layout so wie es im UV/Image Editor zu sehen ist speichern, und das Bild in der Bildbearbeitung ihrer Wahl bearbeiten. Dieses Vorgehen ist im Abschnitt Suzanne mit UV-Mapping genauer beschrieben.


Links[Bearbeiten]

Release-Notes zum Image Editor

<<<Zurück

UV-Koordinaten bearbeiten

Inhaltsverzeichnis
Glossar
Weiter>>>

UV-Texturen anzeigen


UV-Texturen anzeigen[Bearbeiten]

<<<Zurück
UV-Texture Paint
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Suzanne mit UV-Mapping


Diese Seite bezieht sich auf
Blender v2.42
Von dieser Seite gibt es eine
aktuellere Version
Abbildung 1: Einstellen des Draw Type.

Die UV-Textur ist die einzige Textur, die man sich im 3D-Fenster anzeigen lassen kann, ohne das Bild vorher rendern zu müssen. Da das Bild auf Wunsch immer direkt neu gezeichnet wird, kann man z.B. mit den integrierten Malwerkzeugen auf dem Bild malen, und gleichzeitig auf dem 3D-Objekt im 3D-Fenster die Auswirkungen des Zeichnens beobachten. Dazu wechseln Sie den Draw Type im 3D-Fenster auf Textured (Alt-Z). Die Vorschau funktioniert aber nur mit einer Textur.

Sie können jedem Face (oder mehreren Faces) eine eigene Textur zuweisen, oder eine Textur für alle Faces benutzen. Jedes Face besitzt aber nur einen Satz von UV-Koordinaten. Sie können also nicht mehrere Texturen mit unterschiedlichen Koordinaten einem Face zuweisen.


Um die Textur rendern zu lassen, gibt es zwei verschiedene Möglichkeiten.

Eine Image-Textur mit UV-Koordinaten benutzen[Bearbeiten]

Abbildung 2: Das zum UV-Mappen genutzte Bild als Image-Textur laden.
Abbildung 3: UV-Mapping auf dem MapInput Panel aktivieren.

Laden Sie das zum UV-Mappen benutzte Bild als normale Image-Textur (Abbildung 2). Schalten Sie dann den Button UV auf dem Map Input Panel in den MaterialButtons (F5) an (Abbildung 3).

Sie müssen das Bild dazu vorher nicht im UV/Image Editor zugewiesen haben. Häufig wird so vorgegangen, dass zunächst ein Bild als Colormap (Bildfarbe) zum Unwrappen benutzt wird, und auf Grundlage der Colormap eine gleichgroße Bumpmap, Specmap, Refmap usw. erstellt wird. Die UV-Koordinaten stellen dann sicher, dass die Texturen alle exakt sitzen.


Abbildung 4: Löschen der UV-Koordinaten.

Die UV-Koordinaten werden mit dem TexFace Button auf dem Mesh Panel in den Editing Buttons (F9) gelöscht (Abbildung 4). Das geht nur für das ganze Objekt auf einmal.

Blender3D FreeDifficulty.gif

Haare (statische Partikel) ignorieren die UV-Textur!

Das ist leider noch ein Mangel der statischen Partikel. Das ist bekannt und soll mit Version 2.43 behoben werden.




Hinweis für Spezialisten die sich wirklich auskennen und genau wissen was sie wollen[Bearbeiten]

Abbildung 4: TexFace Button drücken.

Die alternative, aber nicht so flexible Möglichkeit ist es, den TexFace Button in den Materialeigenschaften zu aktivieren, um die UV-Textur zu rendern. Dann wird die im 3D-Fenster angezeigt Textur auch zum Rendern benutzt (aber nur als Colormap). Diese Möglichkeit bietet sich immer dann an, wenn Sie mehr UV-Texturen als Materialindizes benutzen wollen, oder pro Face texturieren möchten und nur die Farbe benötigen.



<<<Zurück

UV-Texture Paint

Inhaltsverzeichnis
Glossar
Weiter>>>

Suzanne mit UV-Mapping


Suzanne mit UV-Mapping[Bearbeiten]

<<<Zurück
UV-Texturen anzeigen
Inhaltsverzeichnis

Handbuch durchsuchen

Weiter>>>
Referenz: UV/Image Editor


Diese Seite bezieht sich auf
Blender v2.37a
Von dieser Seite gibt es eine
aktuellere Version

Wenn man mit komplexen Modellen wie zum Beispiel Menschen arbeitet wird es schnell offensichtlich, dass gute Werkzeuge gebraucht werden. Seit Blender 2.34 sind einige neue Werkzeuge im Quellcode vorhanden, darunter auch Schnittkanten und die LSCM Unwrap Funktion.

In diesem Tutorial werde ich Ihnen in zwei Anläufen zeigen wie Sie Suzanne eine UV-Map verpassen und dafür die neuen Werkzeuge verwenden.

Schnittkanten [Seams][Bearbeiten]

Durch Schnittkanten kann man ein Mesh in Gruppen von Faces aufteilen. Damit kann man das Mesh ordnen, bevor man mit LSCM die UV-Map erzeugt. Diese Gruppen sind aber keine abgetrennte Einheit, sondern einfach nur eine schnelle Möglichkeit, bestimmte Faces auszuwählen. Schnittkanten erzeugen Sie, indem Sie eine oder mehrere Edges im Edit Mode auswählen, Strg E drücken und dann Mark Seam auswählen. Wenn Sie den Weg durch die Menüs bevorzugen, können Sie im Menü Mesh das Untermenü Edges aufklappen und dort Mark Seams auswählen. Eine dicke durchgezogene Linie wird jetzt in der 3D-Ansicht dargestellt, die die neue Schnittkante darstellt. Sie können die Darstellung der Schnittkanten mit dem Button Draw Seams an- oder abstellen. Sie finden Draw Seams im Editing Kontext (F9), entweder im Mesh Tools 1 Panel, wenn Sie im Edit Mode sind, oder im UV Calculation Panel, wenn Sie im Face Select Mode sind.

Sobald eine durchgehende Schnittkante markiert wurde können Sie im Face Select Mode eine Gruppe von Faces einfach dadurch auswählen, dass Sie ein einzelnes Face dieser Gruppe auswählen und L drücken. Dadurch werden alle miteinander verbundenen Faces, die nicht durch Schnittkanten getrennt werden, ausgewählt. Indem Sie strategische Schnittkanten in ihrem Modell erzeugen, können Sie später gezielt mit diesen Gruppen arbeiten und so Ihre Aufgabe deutlich erleichtern.

Idealerweise sollten Sie überall dort Schnittkanten einfügen, wo die UV-Map geschnitten werden soll. Um zum Beispiel die Arme vom Torso eines Charakters abzutrennen, sollten Sie eine geschlossene Schnittkante an jeder Schulter markieren. Es gibt aber auch Fälle, wo Sie statt einer geschlossenen eine offene Schnittkante verwenden sollten.

Lassen Sie uns ein paar Tests durchführen. Fügen Sie eine Suzanne zu Ihrer Szene hinzu und wählen Sie die komplette vertikale Reihe von Vertices in der Mitte aus. Drücken Sie dann Strg E um die so ausgewählten Edges als Schnittkante zu markieren. Um das zu Testen wechseln Sie in den Face Select Mode, auch hier sollte die Schnittkante sichtbar sein. Wählen Sie ein Face aus und drücken Sie L, jetzt sollte eine Seite des Kopfes ausgewählt sein. Wenn alles ausgewählt wäre, würde das heißen, dass Sie irgendwo eine Edge vergessen hätten. Falls das so ist, wissen Sie, was zu tun ist... Einfach, oder nicht? Das ist der Gedanke dabei.

Abbildung 1: Suzanne mit markierten Schnittkanten

Erzeugen Sie noch ein paar weitere Schnittkanten, versuchen Sie dabei komplexe Bereiche voneinander zu trennen, wie zum Beispiel die Ohren vom Kopf. Wenn Sie die UV-Map erzeugen werden diese Schnittkanten als Schnitte in der Meshoberfläche wie auch in der UV-Map dienen.

Um schnell eine Vertexschleife auszuwählen verwenden Sie am Besten Alt B. Eine interessante Schleife ist die um Suzannes Gesicht, wenn Sie hier eine Schnittkante setzen, können Sie einfach die Vorderseite von der Hinterseite trennen.


Das Mesh auseinanderfalten[Bearbeiten]

Öffnen Sie ein UV-Editor-Fenster neben dem Fenster mit der 3D Ansicht. Wählen Sie dann Ihr Modell aus und wechseln Sie in den Face Select Mode.

Abbildung 2: Die erste UV-Map (die Ohren wurden ausgeblendet)

Wählen Sie alle Faces auf der linken und rechten Seite von Suzannes Kopf aus, auch die Ohren. Wir werden diese Gruppen mit der Sphere Option auseinanderfalten (im 3D-Fenster U drücken), wodurch wir später für LSCM eine gute Ausgangsbasis haben. Wahrscheinlich erhalten Sie ein 'fast' perfektes Ergebnis. Aber vermutlich sind auch ein paar Faces auf der falschen Seite der UV-Map. Das können Sie natürlich schnell von Hand beheben, aber warum sich die Mühe machen wenn Blender das erledigen kann? Drücken Sie im UV-Editor C um den Active Face Select Mode zu aktivieren. Wählen Sie im UV-Editor dann die Flächen um die Ohren herum wie in Abbildung 2 gezeigt. Verlassen Sie diesen Modus wieder mit C und wählen Sie die oberen zentralen Vertices. Die entsprechenden unteren Vertices sind etwas schwieriger, deshalb stellen wie sie erst einmal hintenan. Da Sie jetzt schon einige Vertices ausgewählt haben drücken Sie P. Das ist der Pin Befehl, er wird die ausgewählten Vertices an ihrer Position festhalten, damit 'nichts' Ihr Layout zerstören kann. Aber mehr dazu später.


Abbildung 3: Unzugängliche UV-Vertices auswählen

Jetzt wo Sie die schön auseinandergefalteten Vertices festgepinnt haben, wählen Sie im 3D-Fenster nur die beiden Faces unter dem Kinn aus. Im UV-Editor pinnen Sie dann die zwei Vertices in der Mitte fest, die vorher so schlecht zugänglich waren. Sie haben es fast geschafft.

Jetzt ist es Zeit für ein bisschen LSCM-Magie. Wählen Sie im 3D-Fenster alle Faces aus die mit den beiden unter dem Kinn verbunden sind (L). Diesmal sollten Sie die Ohren nicht auswählen. Die ausgewählten Faces sollten im UV-Editor erscheinen. Drücken Sie jetzt E. Blender fragt zur Sicherheit nochmal nach ob LSCM wirklich ausgeführt werden soll. Wenn Sie die Frage bestätigen werden wundervolle Dinge geschehen. Die nicht festgepinnten Vertices werden so verschoben, dass sich keine Flächen mehr überlappen. (Wenn nicht, dann fehlt wahrscheinlich die offene Schnittkante dem Hinterkopf entlang bis zum Kinn.)

Abbildung 3: LSCM in Aktion

Jetzt sollten Sie etwas Platz für das Gesicht schaffen. Dafür wählen Sie einfach die Vertices am inneren Rand aus und skalieren sie. Der UV-Editor unterstützt auch das Proportional Editing Tool (O) wie Sie es von Meshes kennen. Das ist sehr nützlich um etwas Platz zu schaffen ohne Faces übereinanderzulegen.

Nachdem Sie etwas Platz geschaffen haben wählen Sie in einem 3D-Fenster in der Vorderansicht das Gesicht und mappen es mit der Option From Window. Dann werden Sie die Faces im UV-Editor noch etwas skalieren müssen, das geht wie gewohnt mit S und eventuell X oder Y falls Sie die Skalierung auf eine Achse beschränken wollen.

Jetzt haben Sie die vorderen Faces schön auseinandergefaltet im UV-Editor.


Abbildung 4: Das Gesicht from window gemappt
Blender3D FreeTip.gif

Wenn Sie im 3D-Fenster die ausgewählten Faces abwählen werden Sie sie im UV-Editor nicht mehr sehen, aber Sie können im View Menü des UV-Editors die Option Draw Shadow Mesh aktivieren um sie dennoch darzustellen.


Abbildung 5: Zwei Inseln in der UV-Map


Die Map zusammennähen[Bearbeiten]

Jetzt müssen wir diese zwei 'Inseln' vereinen, dazu verwenden wir die Stitch-Funktion. Aktivieren Sie Stick UVs to Mesh (Strg C) damit Sie automatisch alle Vertices auswählen die zusammengenäht werden müssen. Wählen Sie einen UV-Vertex vom Rand des Gesichts, Sie werden sehen dass auch der entsprechende Vertex in der anderen Insel ausgewählt wird. Vernähen Sie die beiden mit V. Sie werden dadurch zu einem Vertex verschmolzen der mitten zwischen den beiden Ursprungsvertices liegt.

Abbildung 6: Stitch: vorher und nachher

Es wäre etwas umständlich wenn Sie Vertex für Vertex weiterarbeiten würden. Wählen Sie alle UV-Vertices am Rand von Suzannes Gesicht aus, die entsprechenden Vertices auf dem anderen Teil sollten damit auch ausgewählt sein. Dann vernähen Sie sie und pinnen Sie sie fest, aber nur wenn es keine Überlappung gibt. Wenn es Überlappungen gibt pinnen Sie die entsprechenden Vertices nicht fest und fahren mit dem Vernähen fort.


Abbildung 7: ein schlechtes Beispiel einer vernähten UV-Map

Jetzt sind beide Inseln vernäht. Es gibt aber Bereiche wo sich Faces überlappen. Pinnen Sie die 'schönen' Vertices fest und führen Sie LSCM nochmal aus. Drücken Sie einfach E, Sie müssen nichts auswählen. Wenn Sie alles richtig machen sollte jede Ausführung von LSCM weitere Überlappungen entfernen.

Sie können natürlich auch Vertices skalieren oder verschieben bevor Sie LSCM ausführen, aber wählen Sie dafür immer Paare aus um die Symmetrie zu erhalten.


Nochmal, bitte ;-)[Bearbeiten]

Also gut. Wir haben eine ganze Menge Werkzeuge verwendet und eine mehr oder weniger anständige UV-Map erhalten. Wir hätten das aber auch deutlich schneller und einfacher erreichen können.

Die Schnittkanten die ich markiert hatte müssen nicht unbedingt 'geschlossen' sein. Wie ich schon gesagt habe sind sie nur Schnitte in der Oberfläche die Blender dazu benutzt, sie auseinanderzufalten. Wenn wir also schlau genug vorgehen könnten wir die ganze Arbeit mit ein oder zwei LSCM-Schritten erledigen.

Abbildung 8: die überarbeiteten Schnittkanten

Löschen Sie alle Schnittkanten, die Suzie hat (Strg E->Clear Seam). Unser Ansatz ist folgender: wir wollen die gestreckten Teile so gut wie möglich unsichtbar lassen. Wie ein Schönheitschirurg wollen wir keine Beweise für unsere Schnittkanten hinterlassen. Deshalb markiere ich eine Schnittkante von der Mitte des oberen Teils bis unter das Kinn, ohne das Gesicht zu schneiden. Am Einfachsten wählen Sie die betreffenden Edges manuell aus und markieren sie dann als Schnittkante. Beachten Sie dass diese Schnittkante jetzt 'offen' ist, das heißt es ist kein kompletter Schnitt um den ganzen Kopf herum.

Ich habe auch noch eine kurze Schnittkante vom Anfang der vorigen bis in die Nähe der Ohren gezogen, natürlich auf beiden Seiten symmetrisch. Das war alles.

Abbildung 9: die neue UV-Map

Wählen Sie jetzt alle Faces bis auf die Augen aus und falten Sie sie mit LSCM auseinander. Das sieht deutlich besser aus.

Jetzt können wir wie vorhin die Vertices festpinnen und die UV-Map überarbeiten, aber diesmal sollte es deutlich einfacher sein.


Wir kommen zum Ende[Bearbeiten]

Jetzt werden wir die schon erklärten Methoden anwenden um die überlappenden Flächen in Suzannes Gesicht zu korrigieren.

Abbildung 10: ein überarbeitetes Ohr

Versuchen Sie zuerst einmal, die äußeren UV-Vertices der Ohren etwas nach außen zu skalieren und festzupinnen. Wenn Sie dann LSCM anwenden, haben die inneren Vertices mehr Platz und sollten sich auseinanderfalten. Am besten Sie arbeiten sich von außen nach innen vor, immer wieder Platz schaffen und festpinnen. Nach ein paar Schritten sollte die UV-Map schon gut aussehen.

Sie können sich die Sache vereinfachen, wenn Sie ganze Flächen im inneren Ohr auswählen und skalieren. Sie können sogar das ganze Ohr auswählen und um ein paar Grad drehen.

Mit etwas Geduld werden Sie ein fast vollständig gepinntes Ohr erhalten, wo nichts mehr überlappt.

Jetzt gibt es nicht mehr viel zu tun. Wählen Sie die Augen und mappen Sie sie mit LSCM oder From Window. Da die Augen nicht mit dem Rest des Meshes verbunden sind, wird der 'Stitch'-Befehl zum Vernähen nicht wirken. Wenn Sie die Augen also mit dem Rest vereinen wollen, müssen Sie mit dem 'Weld'-Befehl arbeiten. Mir ist es aber lieber wenn die Augen separat sind, da ich sie so einfacher bearbeiten kann, wenn ich die Texturen male.

Wenn Ihr Charakter Augenlider hat, ist es besser sie fast geschlossen zu lassen während Sie die UV-Map erzeugen, dadurch ist es leichter die Texturen dafür zu malen.


Was jetzt?[Bearbeiten]

Abbildung 11: das exportierte UV-Layout

Sobald Sie mit der UV-Map zufrieden sind, können Sie sie exportieren. Dazu rufen Sie aus dem 'UVs'-Menü des UV-Editors das Save UV Face Layout... Script auf, das mit den offiziellen Blenderversionen mitgeliefert wird. Stellen Sie hier den Size-Wert ein, wenn Sie mit der Größe nicht einverstanden sind. Wenn Sie eine sehr große Textur erzeugen wollen, sollten Sie auch noch Wire Size erhöhen. Alles andere können Sie so lassen. Kontrollieren Sie noch einmal dass Suzanne auch wirklich ausgewählt ist und klicken Sie dann auf Export. Dadurch wird eine Targa-Textur mit dem UV-Layout erzeugt, die Sie mit Gimp, Photoshop und anderen Grafikprogrammen öffnen können. Benutzen Sie diese Textur als Referenz um Ihre Texturen zu malen.

Um dieses Bild als Referenz verwenden zu können brauchen Sie ein Grafikprogramm das mit transparenten Ebenen arbeiten kann. In diesem Beispiel verwende ich Gimp, Sie können aber jedes andere Programm verwenden dass Ihnen angemessen erscheint.

Erzeugen Sie ein neues Bild von der Größe der UV-Map und laden Sie diese in eine Ebene. Fügen Sie dann einige neue Ebenen über dieser Referenzebene ein. Ich verwende drei Ebenen mit den Namen Col, Bump und Ref. Später werde ich dadurch drei verschiedene Texturen erhalten, die ich für die Farbe, die Unebenheiten und die Reflektivität verwenden werde. Sie können am Anfang aber auch eine Textur für alles verwenden. Der Vorteil der Trennung liegt darin dass man zum Beispiel die Unebenheiten anpassen kann ohne die Farben zu ändern.

Abbildung 12: Die Ansicht in Gimp

Hier noch ein kleiner Trick von mir: Wählen Sie die Referenzebene aus und führen Sie den Filter > Farben > Farben zu Transparenz-Filter aus. So können Sie den weißen Hintergrund durchsichtig machen und nachher die Referenzebene ganz oben auf den Ebenenstapel legen. Dadurch wird die Referenz immer angezeigt und wird nicht übermalt, außerdem können Sie die Arbeitsebene mit voller Deckkraft anzeigen und sehen genau wie die Farben nachher herauskommen.


Abbildung 12: Die UV-Map als Referenz

Die Farbtextur ist nicht so kompliziert. Diese Farben werden so wie sie sind über das Modell verteilt. Die Texturen für Unebenheit und Reflektivität sind schon etwas komplizierter. Die Bumpmaps sollten von einem mittleren Grau ausgehen, alles was dunkler oder heller ist wird als Unebenheit in die eine oder andere Richtung interpretiert, wobei die Richtung in Blender einfach umgestellt werden kann. Die RefMap geht von schwarz aus, alles was hell ist wird stärker reflektieren.

Sie können so viele Texturen erzeugen wie Sie Texturkanäle in Blender haben, zum Beispiel auch für die Stärke von Spiegelungen, wie Durchscheinend ihr Objekt sein soll (Translucency), welche Selbstleuchtkraft (Emit) und so weiter. Alle diese Texturen werden die selben UV-Koordinaten verwenden wenn Sie die UV Option im Map Input Panel in den Material Buttons aktivieren.

Um die Texturen zu verwenden, die wir erzeugt haben, müssen wir zuerst ein Material erzeugen und ihm dann die richtigen Bildtexturen zuweisen. Gehen Sie sicher dass Sie für jede Textur die UV Option aktivieren und den richtigen Kanal im Map To Panel einstellen. Wenn Sie die Farbtextur als Bumpmap verwenden wird das etwas komisch aussehen. Sie können die Texturfarbe mit der Objektfarbe mischen, wenn Sie das wollen. Ziehen Sie dazu einfach den Col Wert etwas nach unten in Richtung 0.

Sie können Ihre Textur auch noch in den UV-Editor laden, wenn Sie die UV-Koordinaten etwas anpassen wollen, oder auch wenn Sie mit den Blender-internen Zeichenwerkzeugen arbeiten wollen. Um zu Rendern muss die Textur aber nicht extra geladen werden da Sie ja die Texturen im Material zugewiesen haben.

Abbildung 12: Das Ergebnis


Links[Bearbeiten]

Die englischsprachige Vorlage dieses Textes

<<<Zurück

UV-Texturen anzeigen

Inhaltsverzeichnis
Glossar
Weiter>>>

Referenz: UV/Image Editor