Inkscape/ Dateiformate

Aus Wikibooks
Zur Navigation springen Zur Suche springen


Dieses Kapitel soll einen Überblick darüber bieten, was man mit einer fertigen Inkscape-Zeichnung anfangen kann.

Das Menü Datei bietet die Wahl zwischen Speichern und Exportieren.

Speichern[Bearbeiten]

Übersicht über die möglichen Dateiformate[Bearbeiten]

Beim Speichern eines Inkscape-Projekts hat man die Wahl zwischen folgenden Dateiformaten:

  • Inkscape-SVG (*.svg)
  • Kompromiertes Inkscape-SVG (*.svgz)
  • Komprimiertes SVG (*.svgz)
  • Optimiertes SVG (*.svg)
  • Komprimiertes Inkscape-SVG mit Medien (*.zip)
  • Desktop-Schneideplotter (AutoCAD DXF R12) (*.dxf)
  • Desktop-Schneideplotter (AutoCAD DXF R14) (*.dxf)
  • Encapuslated Postscript (*.eps)
  • Erweiterte Metadatei (*.emf)
  • Flash XML-Grafik (*.fxg)
  • GIMP-Palette (*.gpl)
  • HP Graphics Language-Datei (*.hpgl)
  • HTML5-Canvas-Element (*.html)
  • JessyInk, gepackte PDF- oder PNG-Ausgabe (*.zip)
  • LaTeX mit PS Tricks-Makros (*.tex)
  • Ebenen als einzelne SVGs (*.tar)
  • Microsoft XAML (*.xaml)
  • OpenDocument-Zeichnung (*.odg)
  • Portable Document Format (*.pdf)
  • PostScript (*.ps)
  • PovRay (*.pov) (nur Pfade und Formen)
  • Synfig Animation (*.sif)
  • Windows-Metadatei (*.wmf)

Beispiele[Bearbeiten]

SVG-Icon[Bearbeiten]

Um ein kleines Icon, das nur wenige Pixel misst und einen transparenten Hintergrund hat (Beispiel: Exchange Positions of Selected Objects – Selection Order.svg), zu erstellen und als SVG zu speichern, geht man am elegantesten folgendermaßen vor:

  • In der Werkzeugeinstellungsleiste des Auswahlwerkzeugs als Skalierungseinheit „px“ (Pixel) wählen.
  • Die Zeichnung so erstellen, dass sie die gewünschten Dimensionen (in px) hat.
  • Zeichnung auswählen, dann Bearbeiten > Seitengröße auf Auswahlgröße bzw. Umschalt + Strg + R. Die Seite wird dadurch für die Auswahl passend gemacht.
  • Als SVG speichern (jeder SVG-Typ ist geeignet).

Der große Vorzug des Speicherns als SVG liegt darin, dass die Grafik, so klein sie ist, beliebig vergrößert werden kann, ohne unscharf zu werden. Dass die Grafik mit dieser geringen Ausgangsgröße angelegt ist, erlaubt es, sie in Fließtexte wie diesen einzubinden, ohne ihre Größe explizit festsetzen zu müssen.

Zum Vergleich: Ein in Wikimedia-Projekten als Mini(atur) oder Thumb eingebundenes Bild erscheint voreinstellungsmäßig 220 px breit.

Dateigrößen optimieren[Bearbeiten]

Zum Optimieren der Dateigrößen gibt es einige Möglichkeiten – einige sind über die Funktionen und Menüs von Inkscape realisierbar, einige in Handarbeit (am Quelltext). Einige dieser Möglichkeiten sind quasi verlustfrei, manche sind praktisch nicht zu bemerken, manche gehen mit mehr oder weniger deutlich bemerkbaren Verlusten einher.
Somit lässt sich die Dateigröße, ohne dass sich für den jeweiligen Verwendungszweck Nachteile ergeben, teilweise noch erheblich verringern – bevor sie z.B. auf einer Internet-Seite veröffentlicht und dort tausende Male heruntergeladen wird...

Es gibt Programme die SVGs optimieren: (Teilweise verlustbehaftet)

Beachte, dass ein optimieren im Allgemeinen keinen neuupload auf Wikimedia rechtfertigt, ein ausführlicherer Essay ist dazu in Englisch auf Commons unter c:User:JoKalliauer/Optimization#When_is_optimizing/validating_files_undesired? zu finden. Das optimieren "fremder" SVGs sollte behutsam gemacht werden, da für den Nutzer relevante Bearbeitungsdaten ev. vorhanden sind.

„verlustfrei“[Bearbeiten]

  • anstatt als „Inkscape SVG“ als „Plain SVG“ speichern
  • entfernen unbenutzter Definitionen („Datei“ → „leere Defs Aufräumen“ bzw. bei neueren Versionen "Dokument säubern")
  • entfernen nicht benötigter Attribute (oft wird z.B. für nicht vorhandene Linien („stroke:none;“) noch Dicke, Enden, Verhalten bei Überdeckung und vieles andere festgelegt)
  • Kommentare entfernen (z.B. <!-- Created with Inkscape (http://www.inkscape.org/) -->)
  • komprimiert speichern („Komprimiertes SVG“ im Speichern unter… Dialog. Die verlustfreie Zip-Komprimierung lässt sich u.U. mit speziellen Datenkompressionsprogrammen noch weiter optimieren)
  • optimiertes speichern („Optimierte Inkscape-SVG“ im Speichern unter… Dialog. Die Dateigröße wird verringert und für die Verwendung mit Scriptsprachen aufbereitet, eine Kompression findet nicht statt )
  • https://jakearchibald.github.io/svgomg/
  • c:User:Quibik/Cleaning_up_SVG_files_manually#Removing_unnecessary_content

Komplexität verringern[Bearbeiten]

  • Punkte entfernen (Strg+L)
  • verdeckte Strukturen entfernen
  • Runden von Koordinaten
  • Als "Optimiertes SVG" speichern, mit der Einstellung "Anzahl der signifikanten Stellen für Koordinaten" (ab 5 Stellen praktisch verlustfrei)
  • https://jakearchibald.github.io/svgomg/
    • Round/rewrite paths
    • Round/rewrite transforms

Exportieren[Bearbeiten]

Der Dialog PNG-Bild exportieren

Inkscape kann Vektorgrafiken auch in Rastergrafiken verwandeln, die dann als PNG-Datei (*.png) gespeichert werden. PNG (für Portable Network Graphics) ist heute – noch vor JPEG und GIF – das meistverwendete verlustfreie Grafikformat im Internet.

Bereiche, die nicht von Objekten bedeckt sind, werden im PNG transparent dargestellt. Wenn dies nicht erwünscht ist, kann man die Zeichnung vor dem Exportieren z. B. mit einem weißen Rechteck unterlegen.

Der Dialog Inkscape icons document export.svg PNG-Bild exportieren wird über Datei > PNG-Bild exportieren… oder Umschalt + Strg + E aufgerufen.

In diesem Dialog können folgende Parameter eingestellt werden:

Exportbereich
Legt fest, was genau exportiert werden soll:
  • Seite: Exportiert die gesamte Seite mitsamt der darauf befindlichen Objekte. Objekte, die über den Seitenrand hinausreichen, werden abgeschnitten. Form und Größe der Seite können unter Datei > Dokumenteinstellungen… > Seitengröße frei gewählt werden.
  • Zeichnung: Export der gesamten Zeichnung mit allen Objekten, aus denen sie besteht. Die Objekte reichen hierbei bis an den Rand; falls aus ästhetischen Gründen ein (scheinbar) nicht mit Objekten bedeckter Randstreifen (Padding) verbleiben soll, so muss in die Zeichnung ein entsprechender Abstandhalter (etwa in Form eines kontur- und füllungslosen Rechtecks) aufgenommen werden.
  • Auswahl: Export der Auswahl. Auch bei dieser Option reichen die Objekte bis an den Rand.
  • Benutzerdefiniert: Export aller Objekte, die in einem über die Eingabefelder (x0, y0 usw.) zu definierenden Rechteck liegen.
Bildgröße
Erlaubt es, Größe und Auflösung der zu erstellenden PNG-Grafik festzulegen.
Dateiname
Zeigt Verzeichnis und Namen der zu erstellenden PNG-Datei an. Inkscape schlägt selbst einen Namen vor, den man, um die Datei später leichter identifizieren zu können, aber immer durch einen selbst gewählten Namen ersetzen sollte. Der neue Name kann direkt ins Eingabefenster eingegeben werden. Mit dem Schalter Exportieren als… kann ein Kontextmenü aufgerufen werden, das es erlaubt, in der Verzeichnisstruktur des Computers zu navigieren; der Dateiname kann auch hier eingegeben werden.

Wichtig: Die PNG-Datei wird erst durch Auswahl des Schalters Exportieren erstellt. Mit Hilfe des Schalters Exportieren als… kann man der zu erstellenden Datei lediglich einen Namen und ein Verzeichnis zuweisen; dies allein ist jedoch noch kein Export.

Falls nur ein einziges Bild exportiert werden soll, kann das Kontrollkästchen „Schließen wenn fertig“ markiert werden.

Die Zusatzoptionen im Dialog

Durch Aufklappen des Bereichs „Fortgeschritten“ werden fünf weitere Parameter zugänglich:

Interlacing verwenden
Interlacing ist ein spezielles Speicherverfahren, das beim Laden einer Rastergrafik den schnellen Aufbau eines Vorschaubildes in voller Größe ermöglicht.
Bittiefe
Beim Parameter Bittiefe (engl. bit depth) kann zwischen den Optionen Grey_1, Gray_2, Gray_4, Gray_8, Gray_16, GrayAlpha_8, GrayAlpha_16, RGBA_8 (= Voreinstellung) und RGBA_16 gewählt werden.
Kompression
Bietet die Wahl zwischen den Optionen Z_No_COMPRESSION, Z_BEST_SPEED, 2, 3, 4, 5, Z_DEFAULT_COMPRESSION (= Voreinstellung), 7, 8 und Z_BEST_COMPRESSION.
pHYs-dpi
Erlaubt die Steuerung der physikalischen Pixeldichte. Voreinstellung ist 0.
Kantenglättung
Unter Kantenglättung (engl. antialiasing) versteht man bestimmte Verfahren zur Vermeidung ungleichmäßiger und damit hässlicher Verpixelungen von Kanten. Bei diesem Parameter hat man die Wahl zwischen CAIRO_ANTIALIAS_NONE, CAIRO_ANTIALIAS_FAST, CAIRO_ANTIALIAS_GOOD (= Voreinstellung) und CAIRO_ANTIALIAS_BEST.