Inkscape/ Seite, Hilfslinien und Seitengitter

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


Seite (engl. page), Hilfslinien (guides, guide lines) und Seitengitter (grids) sind Hilfsmittel in Inkscape, die insbesondere beim präzisen Konstruieren die Arbeit beschleunigen und erleichtern können.

Die Seite hat darüber hinaus auch eine grundlegende Funktion für die Erzeugung von SVG-Dateien.

Seite, Hilfslinien und Seitengitter können sowohl separat als auch gleichzeitig verwendet werden.

Seite[Bearbeiten]

Die Seite

Als „Seite“ wird in Inkscape das mit einem Schatten unterlegte virtuelle Papierblatt bezeichnet, das voreinstellungsmäßig in jedem neu erzeugten Dokument erscheint (Abbildung).

Funktionen der Seite[Bearbeiten]

Je nachdem, was man mit Inkscape vorhat, erfüllt die Seite zwei grundlegend unterschiedliche Funktionen:

Erstellung einer SVG-Datei[Bearbeiten]

Wenn das Ziel die Erstellung einer SVG-Datei ist, die z. B. in die Wikimedia Commons bzw. ins Web hochgeladen werden soll, so ist die Seite buchstäblich der Träger der Zeichnung. Ihre Form und Größe bestimmt die Form und Größe der SVG-Grafik. Teile der Zeichnung, die sich nicht auf der Seite befinden, werden nicht Teil der SVG-Datei.

Alle übrigen Verwendungen[Bearbeiten]

Bei allen anderen Verwendungen (etwa wenn die Zeichnung im Inkscape-SVG-Format archiviert oder als PNG-Datei exportiert werden soll) ist die Seite nicht wirklich Träger der Zeichnung (die virtuell endlose Leinwand ist der Träger), sondern ein reines Hilfsmittel. Zeichnungen können dann auf, oberhalb, neben oder unterhalb der Seite oder über den Seitenrand hinweg erstellt werden.

Hilfsfunktionen der Seite[Bearbeiten]

Neben ihrer oben genannten Hauptfunktion hat die Seite viele Hilfsfunktionen, darunter die folgenden:

  • Sie bietet Orientierung für die Größe und Proportion der zu erstellenden Zeichnung.
  • Sie erlaubt schnelle Orientierung auf der Leinwand, denn durch Auswählen von Inkscape icons zoom fit page.svg bzw. 5 rückt die Seite groß ins Zentrum des Bearbeitungsfensters.
Dieser Befehl funktioniert übrigens selbst dann, wenn die Seite ausgeblendet ist; freilich rückt dann nicht die Seite als solche ins Bild, sondern nur die Objekte, die sich in ihrem Bereich befinden.
  • An ihr ist das Koordinatensystem ausgerichtet: Die obere linke Ecke der Seite markiert sowohl auf der x- als auch auf der y-Achse den Nullpunkt.
Hilfreich ist das schnelle Auffinden des Nullpunkts etwa dann, wenn man Muster verwendet. Der Muster-Anfasser, mit dem man die Größe und Orientierung eines Musters steuern kann, wird am Nullpunkt eingefügt.
  • Sie erlaubt an ihren vier Rändern Einrasten.
  • Sie erlaubt das Ausrichten von Objekten an ihren Rändern und an ihrer Mitte.
  • Sie erlaubt bequemes PNG-Exportieren aller Zeichnungen, die sich auf der Seite befinden (durch Wahl des Exportbereichs „Seite“).

Seite nach Bedarf einstellen[Bearbeiten]

Unter Datei > Dokumenteinstellungen (Document Settings Icon.svg, Umschalt + Strg + D) können das Format (A4, US Letter u. v. a. m., auch benutzerdefiniert) und die Orientierung (Hochformat, Querformat) der Seite verändert werden. Durch Deaktivieren von Rand der Seite anzeigen kann die Seite auch ausgeblendet werden.

Enorm praktisch ist bei manchen Anwendungen auch die Funktion Bearbeiten > Seitengröße auf Auswahlgröße (Umschalt + Strg + R).

Außer für die Erstellung von PNG-Dateien ist die Seite nicht wirklich erforderlich – nicht einmal fürs Drucken. Viele Benutzer blenden sie, wenn sie ein neues Projekt starten, routinemäßig aus.

Hilfslinien[Bearbeiten]

Einige horizontale, vertikale und gedrehte Hilfslinien mit ihren Achsenpunkten

Hilfslinien sind temporär verwendete Geraden, die in beliebiger Zahl an beliebiger Position in beliebiger Drehrichtung platziert werden können. Eine klassische Anwendung finden Hilfslinien beim perspektivischen Zeichnen mit Axonometrien oder mit Fluchtpunkten.

Es empfiehlt sich, bei der Verwendung von Hilfslinien die Lineale sichtbar geschaltet zu haben (Ansicht > Anzeigen > Lineale bzw. Strg + R).

Funktion
Pfade und Objekte können an Hilfslinien ausgerichtet werden. Diese Ausrichtung kann entweder nach Augenmaß erfolgen oder – unterstützt durch die Einrastfunktion – präzise.

Alternativ ist ein Ausrichten von Pfaden und Objekten auch mit den Optionen des Dialogs Ausrichten und verteilen möglich.

Hilfslinie erzeugen
Mit Ansicht > Anzeigen/Ausblenden > Lineale die Lineale anzeigen lassen. Unter beiden Linealen sind Hilfslinien „verborgen“, die mit dem Mauszeiger nun in unbegrenzter Zahl darunter „hervorgezogen“ werden können: MouseClickLeft.svg auf eines der Lineale, Taste aber gedrückt halten, Mauszeiger aus dem Lineal heraus- und ins Bearbeitungsfenster führen. Dadurch wird eine Hilfslinie auf die Leinwand gezogen. Horizontale Hilfslinien holt man sich von oben, vertikale von links.
Falls Hilfslinien an den vier Rändern der Seite gewünscht werden, so erzeugt man diese ganz schnell mit Bearbeiten > Hilfslinien an Seitenrändern erstellen.
Umwandlung eines Pfades (rechts) in Hilfslinien (links); anders als hier der Deutlichkeit wegen dargestellt, verschwindet das ursprüngliche Objekt tatsächlich ganz.
Objekte zu Hilfslinien
Daneben bietet Inkscape eine sehr interessante weitere Methode zur Erzeugung von Hilfslinien. Die Software ist auch in der Lage, die geraden Kanten beliebiger Objekte in Hilfslinien zu verwandeln (Abbildung). Dafür wählt man das Objekt (bzw. die Objekte) aus und wählt im Menü den Befehl Objekt > Objekte zu Hilfslinien. Bei Formobjekten wie z. B. Polyedern oder Sternen funktioniert das nur, wenn diese mit Objekt zu Pfad vorher in Pfade umgewandelt werden. Falls dies unterbleibt, wählt Inkscape für die zu erstellenden Hilfslinien die Ränder des Objektrahmens aus.


Messwerkzeug zu Hilfslinien (der rote Pfeil zeigt die Mauszugbewegung)
Messwerkzeug zu Hilfslinien
Eine weitere interessante Methode zur Erstellung von Hilfslinien bietet das Messwerkzeug. Dafür spannt man das Werkzeug per MouseDragLeft.svg in beliebiger Richtung (an Objekten oder auf der leeren Leinwand) auf und wählt dann Inkscape icons guides.svg In Hilfslinien umwandeln. Außer an der aufgespannten Geraden erscheinen Hilfslinien dann mindestens auch an den vier Seiten der Messstrecke (Abbildung).
Hilfslinie drehen
Jede Hilfslinie kommt mit einem Achsenpunkt, kenntlich an einem kleinen roten Kreis. Um eine Hilfslinie zu drehen, den Achsenpunkt beliebig platzieren, Umschalt drücken und gedrückt halten (dann erscheint, sobald man die Hilfslinie mit dem Mauszeiger berührt, ein Drehsymbol), Hilfslinie an einem beliebigen Punkt greifen und drehen.
Um eine Hilfslinie in Inkrementen von 15 Grad oder genau in die Waagerechte oder Senkrechte zu drehen, zusätzlich Strg gedrückt halten.
Hilfslinien einrastfähig machen
Einrastfähige Punkte anderer Inkscape-Objekte können an Hilfslinien einrasten, wenn entweder im Einrast-Kontrollschalter-Balken der Schalter Inkscape icons guides.svg aktiviert ist oder unter Datei > Dokumenteinstellungen > Einrasten (auch Umschalt + Strg + D) das Einrasten an Hilfslinien erlaubt wurde.
Hilfslinien-Achsenpunkte einrasten lassen
Wenn die Einrastfunktion aktiviert ist, rasten auch die Achsenpunkte von Hilfslinien ein.
Hilfslinien sperren
Um zu verhindern, dass Hilfslinien versehentlich verändert werden, kann man sie temporär sperren: Bearbeiten > Hilfslinien sperren. Dieselbe Funktion hat das kleine Schloss-Symbol oben links zwischen den beiden Linealen.
Hilfslinien einblenden/ausblenden
Ansicht > Hilfslinien deaktivieren/aktivieren. Hilfslinien sind übrigens nur am Bildschirm sichtbar und werden weder gedruckt noch exportiert.
Einzelne Hilfslinien ganz entfernen
Verschiedene Methoden: 1. Hilfslinie greifen und in beliebiger Richtung aus dem Arbeitsfeld herausziehen. 2. Hilfslinie mit dem Mauszeiger berühren, Löschen drücken.
Alle Hilfslinien ganz entfernen
Bearbeiten > Hilfslinien löschen.
Farbe der Hilfslinien verändern
Per Voreinstellung sind Hilfslinien blau bzw. (während sie bewegt werden) rot. Die Einstellungen für die Farbe und einige andere Parameter findet man unter Dokument > Eigenschaften > Hilfslinien.

Seitengitter[Bearbeiten]

Das Voreinstellungs-Seitengitter
Ein axonometrisches Gitter

Ein Seitengitter ist die Inkscape-Entsprechung von Karo- bzw. Millimeterpapier, bietet aber einige Möglichkeiten, die über die von Papier weit hinausgehen.

Seitengitter an-/ausschalten
Ansicht > Seitengitter aktivieren/deaktivieren.
Einstellungen für das Seitengitter verändern
Dokument > Eigenschaften > Seitengitter. Einstellbar sind hier u. a. die Linienabstände und die Linienfarben. Gitter, denen der Benutzer bestimmte Eigenschaften gegeben hat, können hier auch gespeichert und später erneut aufgerufen werden.
Rechtwinkliges oder axonometrisches Gitter
Das Gitter kann derzeit (Version 1.0.1) nicht frei, d. h. mit beliebigen Winkeln, gestaltet werden. (Einen gewissen Ersatz bietet unter Umständen ein selbst gebautes Koordinatengitter.) Zur Wahl stehen bei den Seitengittern aber immerhin die beiden Optionen „rechtwinklig“ und „axonometrisch“. Ein axonometrisches Gitter ist, wie der Name sagt, für Axonometrien nützlich. Aufgerufen wird es so: Dokument > Eigenschaften > Seitengitter: aktuelles Gitter entfernen; die Option „rechtwinkliges Gitter“ durch „axonometrisches Gitter“ ersetzen, „neu“ wählen, beliebig modifizieren.
Verwendung
Seitengitter können je nach Bedarf entweder nach Augenmaß oder präzise verwendet werden. Präzise Verwendung setzt Aktivierung der Einrastfunktion voraus.
Seitengitter einrastfähig machen
Einrastfähige Punkte anderer Inkscape-Objekte können an den Schnittpunkten von Seitengittern einrasten, wenn entweder im Einrast-Kontrollschalter-Balken der Schalter Inkscape icons grid rectangular.svg aktiviert ist oder unter Datei > Dokumenteinstellungen > Einrasten (auch Umschalt + Strg + D) das Einrasten an Seitengittern erlaubt wurde.