Inkscape/ Objekte

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


1 = drei Formobjekte, 2 = ein Textobjekt, 3 = ein Pfadeffekt-generiertes Objekt, 4 = ein Pfad (Ansicht jeweils im Knotenmodus)

In diesem Handbuch wird, wenn nötig, am Eingang der Kapitel jeweils ausdrücklich geklärt, wie der Begriff im nachfolgenden Text gemeint ist.

Begriffsbestimmung[Bearbeiten]

Objekte im weiteren Sinne[Bearbeiten]

Im weiteren Sinne ist ein Objekt ein Element – z. B. eine Linie, ein Kreis oder ein Rechteck – das individuell gestaltet werden kann, etwa durch eine eigene Füllfarbe, Konturfarbe und/oder Konturbreite, die von der anderer Elemente abweichen kann. Eine Zeichnung besteht meist aus vielen Objekten.

Diese kleine Inkscape-Zeichnung z. B. – Inkscape icons edit nodes.svg – besteht aus fünf Objekten i. w. S. (drei Quadraten, einem Dreieck und einer Bogenlinie).

Objekte im engeren Sinne[Bearbeiten]

In einem engeren Sinne wird jedes Objekt als „Objekt“ bezeichnet, das kein Pfad ist. Während Pfade Knoten haben, haben Objekte i. e. S. keine Knoten, sondern Anfasser (Abbildung). Anders als Pfade haben Objekte i. e. S. keine Richtung, und mit Ausnahme von Spiralen und manchen Pfadeffekt-generierten Objekten sind Objekte i. e. S. immer geschlossen.

Bei Objekten i. e. S. lassen sich verschiedene Typen unterscheiden (Auswahl):

  • Formobjekte: Objekte, die mit dem Rechteck-, dem Ellipsen-, dem Stern-, dem 3D-Box- oder dem Spiralwerkzeug erstellt werden
  • Textobjekte: Objekte, die mit dem Textwerkzeug erstellt werden
  • Objekte, die aus Pfadeffekten entstehen

Um die Probe zu machen, ob ein Element ein Objekt oder ein Pfad ist, ruft man das Knotenwerkzeug auf, wählt das Element aus und prüft, ob Knoten oder Anfasser sichtbar werden. Falls weder das eine noch das andere der Fall ist, liegt dies vermutlich daran, dass mehrere Elemente kombiniert wurden. Also versucht man die Kombination mit Pfad > Zerlegen in ihre Einzelteile aufzubrechen und nur eines der kombinierten Elemente auszuwählen. Spätestens jetzt sollten sich entweder Knoten oder Anfasser zeigen.

Objekte im weiteren Sinne[Bearbeiten]

Merkmale[Bearbeiten]

Objekte i. w. S. haben unter anderem folgende Merkmale:

Objektrahmen, Koordinaten, Maße und Drehachse[Bearbeiten]

Objektrahmen an verschiedenen Objekten und Pfaden

Jedes Objekte i. w. S. hat einen Objektrahmen (engl. object's frame, boundary box), der allerdings nur angezeigt wird, wenn das Objekt ausgewählt ist. Der Objektrahmen wird als gestricheltes Rechteck dargestellt, welches das Objekt unabhängig von dessen Form ganz umschließt (Abbildung).

Dieses Objekt hat auf einer Millimeterskala die Koordinaten 20 (X) und 30 (Y), sowie die Maße 200 (Breite) und 50 (Höhe).

Die obere linke Ecke des Objektrahmens bestimmt die zwei Koordinaten (X, Y), die jedes Objekt besitzt. Die Nullkoordinaten befinden sich auf der Leinwand an der Position, an der – falls sie angezeigt wird – auch die obere linke Ecke der Seite liegt (vgl. Abbildung).

Weiterhin hat jedes Objekt Maße, nämlich eine Breite und eine Höhe. Ausschlaggebend sind hierfür die Maße seines Objektrahmens.

Benutzer haben die Wahl, Koordinaten und Maße in cm, in, pt, pc, mm oder px darstellen zu lassen bzw. einzugeben. Darüber hinaus ist auch eine Eingabe von Prozentzahlen möglich.

Die Länge des Umrisses eines Objekts kann ganz einfach bestimmt werden, in dem man das Messwerkzeug aufruft und mit dem Mauszeiger das Objekt berührt. Ein kleines Pop-up zeigt dann, neben anderen Maßen, die Umrisslänge an.

Jedes Objekt hat überdies eine Drehachse, die voreinstellungsmäßig im Mittelpunkt des Objektrahmens liegt, im Drehmodus aber beliebig verschoben werden kann.

Stapelanordnung[Bearbeiten]

Stapelanordnung. Beachte die Veränderungen des roten Kreises, der hier (jeweils vom Ausgangszustand ganz links) herunter- bzw. heraufgebracht wird.
Was ist das?[Bearbeiten]

Jedes Objekt hat – über die vorgenannten Merkmale hinaus – auch eine einzigartige Lage in der dritten Dimension (Z). Diese Schichtung aller Objekte wird als „Stapelanordnung“ (engl. z-order, stacking order) bezeichnet. Früher erstellte Objekte liegen voreinstellungsmäßig tiefer als später erstellte. Wenn zwei Objekte sich überschneiden, so verdeckt das höher liegende an den Überschneidungen das tiefer liegenden. Eine Rolle spielt die Lage auch bei den Boole-Operationen.

In Inkscape gibt es auch einen Funktionsbereich Ebene, in dem Objekte auf übereinander geschichteten virtuellen Folien platziert werden können. Die Stapelanordnung hat damit nicht direkt zu tun und existiert auch, wenn nur eine einzige Ebene vorhanden ist.

Stapelanordnung verändern[Bearbeiten]

Inkscape bietet verschiedene Werkzeuge an, mit denen die Stapelanordnung eines oder mehrerer ausgewählter Objekte verändert werden kann:

Operation: Ausgewählte Objekte… Menübefehl Auswahlwerkzeug:
Werkzeugeinstellungsleiste
Tasten
…ganz nach unten bringen Objekt > Nach ganz unten absenken Inkscape icons selection bottom.svg Ende
…eine Stufe tiefer bringen Objekt > Absenken Inkscape icons selection lower.svg Bild↓
…eine Stufe höher bringen Objekt > Anheben Inkscape icons selection raise.svg Bild↑
…ganz nach oben bringen Objekt > Ganz nach oben anheben Inkscape icons selection top.svg Pos1

Füllung und Kontur[Bearbeiten]

1 = Füllung und Kontur, 2 = nur Füllung, 3 = nur Kontur, 4 = weder Füllung noch Kontur
Füllung
(engl. filling) Objekte i. w. S. sind die kleinsten Einheiten, die eine Füllung haben können. Die Füllung füllt die Fläche aus, die vom Pfadumriss begrenzt wird (Abbildung, 1, 2).
Kontur
(engl. stroke) Objekte i. w. S. sind auch die kleinsten Einheiten, die eine Kontur haben können. Die Kontur bildet den Pfadumriss ab, hat – anders als dieser – aber eine einstellbare Breite und eine beliebig auszuwählende sichtbare Farbe (1, 3).

Wie Beispiel 4 in der Abbildung zeigt, sind Füllung und Kontur nicht zwingend notwendig. Ein Objekt kann auch ganz ohne sie existieren; nur ist es dann freilich nicht sichtbar.

Füllung und Kontur lassen sich am schnellsten mit Hilfe der Farbpalette (unterhalb des Arbeitsfensters) und der Farbanzeige in der Statusleiste (ganz unten links) steuern.

Für eine Feinsteuerung braucht man den Dialog Füllung und Kontur, der am einfachsten mit Inkscape icons dialog fill and stroke.svg (Befehlsleiste) aufgerufen wird.

Mischmodus, Unschärfe und Deckkraft[Bearbeiten]

links: Veränderung der Schärfe, rechts: Veränderung der Deckkraft

Drei weitere Parameter, die bei allen Objekten i. w. S. vorliegen, sind die folgenden:

Mischmodus
Der Mischmodus (engl. blend mode) eines Objekts bestimmt, wie seine Füllungs- und Konturfarben sich verhalten, wenn es ein anderes Objekt überdeckt. Voreinstellungsmäßig ist das bedeckende Objekt gänzlich opak; seine Farbe wird von der des verdeckten Objekts nicht beeinflusst. Wenn dagegen eine andere Einstellung gewählt, verhält das bedeckende sich wie ein Farbfilter. Welcher Effekt eintrifft, hängt von der Wahl des Mischmodus ab.
Unschärfe
Vorstellungsmäßig haben Objekte eine Unschärfe (blur) von 0 %, das heißt, ihre Ränder sind vollkommen scharf. U. a. im Dialog Füllung und Kontur kann dieser Wert heraufgesetzt werden. Möglich sind Werte zwischen 0 und 100. Wie sehr die Veränderung der Schärfe das Erscheinungsbild eines Objekts verändert, hängt u. a. von seiner Form und Größe ab.
Deckkraft
Voreinstellungsmäßig haben Objekte eine Deckkraft (opacity) von 100 %, das heißt, sie sind nicht im Mindesten durchsichtig. U. a. im Dialog Füllung und Kontur kann dieser Wert herabgesetzt werden. Möglich sind Werte zwischen 100 und 0. Bei 0 wird das Objekt vollständig durchsichtig, also unsichtbar.

Operationen[Bearbeiten]

Übersicht[Bearbeiten]

Das Menü Objekt bietet Zugang zu folgenden Operationen:

Objekte gruppieren engl. group
Ausschneidepfad clip, clipping Siehe Abschnitt Ausschneidepfad im Kapitel Schneiden und vereinigen.
Maske mask, masking Siehe Abschnitt Maske im Kapitel Schneiden und vereinigen.
Muster Pattern Siehe Kapitel Muster.
Objekte zu Knotenmarkierung objects to marker Siehe Abschnitt Knotenmarkierungen im Kapitel Füllung und Kontur.
Objekte zu Hilfslinien objects to guides Siehe Abschnitt Hilfslinien im Kapitel Seite, Hilfslinien und Seitengitter.
Stapelanordnung verändern (Objekte anheben oder absenken) raise, lower Siehe Abschnitt Stapelanordnung verändern im Kapitel Inkscape/ Transformation.
Objekte umkehren oder um 90 ° drehen flip, rotate Siehe Abschnitt Drehen und Spiegeln im Kapitel Auswahlwerkzeug.
Alles einblenden unhide all
Alle entsperren unlock all

Über Dialoge (Kontextmenüs) sind darüber hinaus u. a. folgende Objekt-bezogene Operationen möglich:

  • Objekt ausblenden (engl. hide)
  • Objekt sperren (lock)

Gruppieren[Bearbeiten]

Durch Gruppieren können mehrere Objekte temporär so zusammengefasst werden, als handle es sich um ein einziges Objekt. Die wichtigste Wirkung von Gruppieren ist, dass durch Anklicken eines individuellen Gruppenmitglieds stets die ganze Gruppe ausgewählt wird.

Gruppieren hat darüber hinaus folgende Wirkungen:

  • Die gruppierten Objekte behalten die meisten ihrer ursprünglichen Merkmale: ihre Form, Farbe, Größe und Position (X- und Y-Koordinanten). Dies unterscheidet Gruppieren von Vereinigung oder Kombinieren, wo Füllung und Kontur der Objekte durch die Operation gleichgemacht werden.
In diesem Beispiel werden die beiden grünen Kreise gruppiert (2) und wieder entgruppiert (3). Beachte die Veränderung in der Schichtung (Stapelanordnung) der fünf Kreise.
  • In der Stapelanordnung rücken tiefer liegende Objekte durch das Gruppieren direkt unter das oberste Objekt der Gruppe. Diese Änderung der Stapelanordnung ist dauerhaft und wird durch Entgruppieren nicht rückgängig gemacht (Abbildung).

Die gruppierten Objekte können einfach wieder voneinander getrennt werden. Dies unterscheidet Gruppieren von Vereinigung.

Objekte gruppieren
(engl. to group) Um Objekte zu gruppieren, wählt man sie aus und wählt Objekt > Gruppieren bzw. Inkscape icons object group.svg bzw. drückt Strg + G.
Gruppe betreten
Auch wenn Objekte gruppiert sind, kann man auf ihre individuellen Mitglieder zugreifen. Man muss die Gruppe dafür „betreten“ (enter group). Dafür gibt es drei Methoden:
  • MouseClickLeft.svg×2 auf die Gruppe
  • MouseClickRight.svg auf die Gruppe, im Kontextmenü Gruppe … betreten auswählen
  • MouseClickLeft.svg auf die Gruppe, dann Strg + Enter
Eine Gruppe nicht zu entgruppieren, sondern zu betreten, empfiehlt sich beispielsweise bei der Bearbeitung von Klon-Elternteilen. Durch Entgruppieren verlieren diese nämlich ihre Elternfunktion mit der Folge, dass die Klone unumkehrbar verwaisen. Das Betreten einer Gruppe erlaubt:
Einer Gruppe neue Mitglieder hinzuzufügen, ist auf dem Betretwege nicht möglich. Umgehen kann man dieses Problem jedoch durch Benutzung des Dialogs Objekte. Um zu einer Gruppe ein neues Objekt hinzuzufügen, erzeugt man zunächst das Objekt – an der gewünschten Position – und verschiebt es im Dialog Objekte dann mit Drag&Drop in die Gruppe (Stapelanordnung beachten).
Gruppe verlassen
Um eine betretene Gruppe wieder zu verlassen (exit group), wählt man eine der drei folgenden Methoden:
  • MouseClickLeft.svg×2 auf einen beliebigen Punkt außerhalb der Gruppe
  • MouseClickRight.svg auf die Gruppe, im Kontextmenü Zum übergeordneten Objekt gehen auswählen
  • MouseClickLeft.svg auf die Gruppe, dann Strg + Rück
Einzelnes Gruppenmitglied auswählen
Auch ohne eine Gruppe zu betreten, kann innerhalb einer Gruppe ein Objekt ausgewählt werden: Strg + MouseClickLeft.svg auf das Objekt. Durch Festhalten von Umschalt kann man auch weitere Objekte ausgewählt werden.
Einzelnes Objekt aus der Gruppe herauslösen
Um aus einer Gruppe ein individuelles Objekt so herauszulösen, dass die Gruppe zwar noch bestehen bleibt, dieses Objekt ihr aber nicht mehr angehört (pop selected objects out of group), markiert man das betreffende Objekt und wählt eine der beiden folgenden Methoden:
  • Objekt > Gewählte Objekte aus Gruppe herauslösen
  • MouseClickRight.svg, im Kontextmenür Auswahl aus Gruppe herauslösen auswählen
Um das Objekt auswählen zu können, muss man entweder die Gruppe betreten oder das Objekt mit Strg + MouseClickLeft.svg auswählen.
Gruppierung aufheben
Um sämtliche Objekte, die zu einer Gruppe zusammengefasst sind, wieder freizugeben (ungroup), wählt man die Gruppe aus und wählt entweder Objekt > Gruppierung aufheben oder Inkscape icons object ungroup.svg oder drückt wahlweise Strg + U oder Umschalt + Strg + G.
Group Hierarchy.png

Gruppen sind hierarchisch organisiert. Bestehende Gruppen bleiben auch dann erhalten, wenn sie zu neuen, größeren Gruppen zusammengefasst werden. Infolgedessen umfasst das Aufheben von Gruppierungen eventuell mehrere Schritte (Abbildung).

Objekt ausblenden[Bearbeiten]

→ Siehe auch: Kapitel Ausblenden und löschen

Inkscape ermöglicht es, Objekte temporär unsichtbar zu machen („ausblenden“). Ausgeblendete Objekte sind nicht nur unsichtbar, sondern können auch nicht ausgewählt werden.

Objekt ausblenden
Um ein Objekt auszublenden, wählt man es aus und markiert im Dialog Objekteigenschaften das Kontrollkästchen Ausblenden.
Objekt einblenden
Um ein ausgeblendetes Objekt wieder einzublenden, hat man verschiedene Möglichkeiten: 1. Im Dialog Objekteigenschaften ins Feld Kennung den Namen des Objekts eingeben, dann das Kontrollkästchen Ausblenden demarkieren. 2. In der Objektliste im Dialog Objekte nach dem ausgeblendeten Objekt suchen und das Icon Inkscape Eye Shut Icon.png anklicken, was damit durch Inkscape Eye Open Icon.png ersetzt wird. 3. Alle Objekte einblenden.
Alle Objekte einblenden
Objekt > Alles einblenden.

Objekt sperren[Bearbeiten]

Diese Operation geht nicht ganz so weit wie die vorgenannte. Gesperrte Objekte können ebenfalls nicht ausgewählt werden, bleiben aber sichtbar.

Objekt sperren
Um ein Objekt zu sperren, wählt man es aus und markiert im Dialog Objekteigenschaften das Kontrollkästchen Sperren.
Objekt entsperren
Um ein gesperrtes Objekt zu entsperren, hat man verschiedene Möglichkeiten: 1. Im Dialog Objekteigenschaften ins Feld Kennung den Namen des Objekts eingeben, dann das Kontrollkästchen Sperren demarkieren. 2. In der Objektliste im Dialog Objekte nach dem ausgeblendeten Objekt suchen und das Icon Inkscape icons object locked.svg anklicken, was damit durch Inkscape icons object unlocked.svg ersetzt wird. 3. Alle Objekte entsperren.
Alle Objekte entsperren
Objekt > Alle entsperren.

Dialoge[Bearbeiten]

Füllung und Kontur[Bearbeiten]

Der Dialog Inkscape icons dialog fill and stroke.svg Füllung und Kontur bietet sehr umfangreiche Optionen für die Farb- und Formgestaltung von Objektfüllungen und -konturen.

Einzelheiten im Kapitel Füllung und Kontur.

Objekte[Bearbeiten]

Object Dialogue.png

Dieser Dialog enthält eine vollständige Liste aller in einem Dokument enthaltenen Ebenen, Objektgruppen und Einzelobjekte. Höher liegende Ebenen bzw. in der Stapelanordnung höher liegende Objektgruppen und Objekten werden weiter oben angezeigt, tiefer liegende weiter unten.

Mit den Schaltern ► und ▼ können untergeordnete Gliederungsebenen aus- und eingeklappt werden.

Hauptfunktion des Dialogs ist die Verwaltung der Objekte. Er ermöglicht es beispielsweise, zu Gruppen neue Mitglieder hinzuzufügen, ohne die Gruppierung aufzuheben.

Folgende Parameter werden angezeigt und können zum Teil bearbeitet werden:

Sichtbarkeit (S)
Inkscape icons object visible.svg Eingeblendete Elemente werden angezeigt, Inkscape Eye Shut Icon.png ausgeblendete sind unsichtbar und können auch nicht ausgewählt werden.
Sperren (L)
Inkscape icons object unlocked.svg Nicht gesperrte Elemente können ausgewählt und bearbeitet werden, Inkscape icons object locked.svg bei gesperrten ist beides nicht möglich.
Typ (T)
Inkscape icons dialog layers.svg Ebene, Objects Dialogue Group Icon.png Gruppe, Objects Dialogue Object Icon.png Objekt.
Ausgeschnitten/Maskiert (M)
Ausgeschnittene Objekte sind durch Inkscape icons path cut.svg gekennzeichnet, maskierte durch Inkscape icons path difference.svg .
Pfadumrissfarbe (F)
Voreinstellungsmäßig wird der Pfadumriss im Knotenmodus rot dargestellt. Falls gewünscht, kann hier für ein individuelles Objekt eine andere Farbe gewählt werden.
Name
Der Name der Ebene, der Objektgruppe oder des Objekts. Falls dieser geändert werden soll, so benutzt man dafür den Dialog Objekteigenschaften.

Auch die folgenden Ebenen- und Objektparameter können im Dialog Objekte abgerufen oder neu festgesetzt werden:

Ebenen und Stapelanordnung
Sowohl durch Drag&Drop als auch durch Verwendung von Object Dialogue Arrow Icons.png kann die Reihenfolge und damit die Lage aller in der Liste aufgeführten Elemente verändert werden. Mit dem Ebenenschalter links neben den Pfeilen kann die Liste so zusammengeklappt werden, dass nur noch die Ebenen angezeigt werden.
Mischmodus
Mischmodus eines Objekts.
Unschärfe
Schärfe eines Objekts.
Deckkraft
Deckkraft eines Objekts.

Tipp: Wenn im Falle einer komplexen Zeichnung die Liste sehr umfangreich und unübersichtlich ist, kann man Objekte, auf die man im Dialog Objekte womöglich wiederholt zugreifen möchte, temporär auf einer separaten Ebene unterbringen, wo sie dann sehr viel leichter auffindbar sind.

Objekteigenschaften[Bearbeiten]

Object Properties Dialogue Extended.png

Der Dialog Objekteigenschaften (engl. object properties) erlaubt es, individuellen Objekten verschiedene weitere Informationen hinzuzufügen. Aufgerufen wird dieser Dialog mit Objekt > Objekteigenschaften… oder Umschalt + Strg + O.

Dieser Dialog ist im Web besonders schlecht dokumentiert, sodass man hier weitgehend auf Ausprobieren angewiesen ist. Die folgenden Angaben enthalten gewisse Unsicherheiten. Falls du mehr weißt, bist du herzlich eingeladen, den Text entsprechend zu ergänzen.

Im Dialog können u. a. folgende Parameter festgelegt bzw. verändert werden:

Kennung
(engl. ID) Ein beliebiger Name, den man dem Objekt geben möchte. Er sollte so sprechend sein, dass man auch später wieder weiß, welches Objekt gemeint ist (Beispiele: „Quadrat“, „Hintergrund“, „gelber Pfeil“, „Überschrift“). Voreinstellungsmäßig erscheinen hier Namen wie z. B. rect10 (Rechteckwerkzeug), path12 (Ellipsen-, Stern-, Spiral-, Zeichen-, Malwerkzeug), g14 (3D-Box-Werkzeug) oder text16 (Textwerkzeug).
Beschriftung
(label) Es scheint Konvention zu sein, hier auf jeden Fall eine Angabe zu machen, und zwar in Kleinschreibung und mit vorangestelltem # (z. B. #rect10, #roter_kreis).
Titel
(title)
Beschreibung
(description) Offenbar eine Möglichkeit, eine ausführlichere Beschreibung des Objekts einzugeben, die als Gedächtnisstütze verwendet werden kann.
Ausblenden
(hide) Ein ausgeblendetes Objekt wird auf der Leinwand nicht gezeigt. Um es wieder einzublenden, gibt man entweder hier im Dialog den Namen des Objekts ein oder sucht es im Dialog Objekte oder wählt Objekt > Alles anzeigen.
Sperren
(lock) Gesperrte Objekte können auf der Leinwand nicht ausgewählt und also auch nicht bearbeitet werden.
Seitenverhältnis beibehalten
(preserve ratio)

Im unteren Teil des Dialogs können auch Parameter für Interaktivität festgelegt werden.

Wichtig: Alle Eingaben werden erst durch Drücken des Schalters Setzen (set) wirksam.

Es kann nur jeweils ein Objekt zur Zeit behandelt werden. Um im Dialog Objekteigenschaften ein Objekt anzuzeigen, wählt man es entweder auf der Leinwand aus oder gibt im Dialog im Feld Kennung seinen Namen ein; im letztgenannten Fall wird es dann auf der Leinwand automatisch ausgewählt.

Symbole[Bearbeiten]

Symbols Dialogue.png

Inkscape stellt eine kleine Bibliothek von fertigen Objekten zur Verfügung, die über den Dialog Paint Servers Icon.png Symbole abgerufen werden können. Auch ist es möglich, der Sammlung eigene Schöpfungen hinzuzufügen, die dann wahlweise nur im jeweiligen Dokument oder für alle Dokumente zur Verfügung stehen.

Aufgerufen wird der Dialog Symbole über Objekt > Symbole… oder Umschalt + Strg + Y.

Falls er nicht angezeigt wird, könnte das daran liegen, dass man in einem anderen geöffneten Inkscape-Fenster Änderungen an den Symbolsammlungen vorgenommen hat, die noch nicht gespeichert wurden.

Vorhandene Symbolsammlungen[Bearbeiten]

Folgende Sammlungen stellt Inkscape bereits zur Verfügung:

  • AIGA-Symbolzeichen: Eine Sammlung von Icons rund um die Themen Mobilität und Reisen (Abbildung, 1)
  • Flussdiagrammformen (2)
  • Kartensymbole des United States National Park Service (3)
  • Logische Symbole (4)
  • Sprechblasen (5)

Die Symbole können per Drag&Drop auf die Leinwand gezogen werden. Technisch handelt es sich zumeist um kombinierte Pfade. Durch Pfad > Zerlegen können diese bei Bedarf in ihre Bestandteile aufgelöst und dann beliebig weiterbearbeitet werden.

Eigene Symbole erzeugen[Bearbeiten]

Den Sammlungen eine eigene Arbeit hinzuzufügen, umfasst folgende Schritte:

  • Zeichnung, falls sie mehrere Objekte umfasst, mit Pfad > Kombinieren kombinieren.
  • Dem neuen Objekt im Dialog Objekteigenschaften eine Kennung und Beschriftung geben. Es wird dadurch später leichter auffindbar.
  • Als Sammlung, in die das Objekt aufgenommen werden soll, „Aktuelles Dokument“ auswählen.
  • Objekt markieren und mit Add Symbol to Collection.png in die Sammlung schaffen.

Mit Remove Symbol from Collection.png kann es bei Bedarf aus der Sammlung wieder entfernt werden.

Eigene Sammlung anlegen[Bearbeiten]

Um eine persönliche Sammlung anzulegen, die eine eigene Bezeichnung erhält, schafft man die hierfür bestimmten Objekte erst einmal in die Sammlung „Aktuelles Dokument“ und geht dann weiter so vor:

  • Datei > Dokumenteinstellungen… > Metadaten.
  • Unter Titel den Namen der neuen Sammlung eingeben (z. B. „Meine eigenen Symbole“); Fenster schließen.
  • Datei > Speichern unter….
  • Ordner Inkscape / share / inkscape suchen, in dem sich voreinstellungsmäßig bereits Ordner wie extensions, icons, keys, palettes und templates befinden. Dort einen neuen Ordner „symbols“ anlegen und die Datei darin speichern (z. B. als „Meine eigenen Symbole“).
  • Inkscape schließen. Beim Wiederaufruf von Inkscape erscheint im Dialog Symbole jetzt auch die neu angelegte Sammlung.

Farbgebungsarten[Bearbeiten]

Dialog Paint Servers.png

Der Dialog Paint Servers Icon.png Farbgebungsarten (engl. Paint Servers), der über Objekte > Farbgebungsarten… aufgerufen wird, bietet weitere Möglichkeiten, den Füllungen oder Konturen ausgewählter Objekte Farben, Farbverläufe oder Muster zuzuweisen.

Der erste der sehr wenigen Vorteile des Dialogs Farbgebungsarten gegenüber dem Dialog Füllung und Kontur, der grundlegend dasselbe leistet (aber sehr viel mehr kann), besteht darin, dass er weitaus übersichtlicher ist und kein Hin- und Herschalten zwischen einfachen Farben, Farbverläufen und Mustern erfordert. Der zweite ist der, dass er einige Muster enthält, die im Dialog Füllung und Kontur fehlen.

Der Dialog Farbgebungsarten bietet nur zwei Parameter:

Farbgebungsart
Bietet die Wahl zwischen den vier Optionen Alle Farbgebungsarten, Aktuelles Dokument (alle im aktuellen Dokument verwendeten Farbverläufe und Muster), Hatches (Schraffuren und Ähnliches) und Patterns (Muster).
Ändern
Bestimmt, welchem Teil des ausgewählten Objekts (Füllung oder Kontur) die Farbe, der Farbverlauf oder das Muster zugewiesen wird.

Selektoren und CSS[Bearbeiten]

Dialog Selectors and CSS.png

Der Dialog Selectors and CSS icon.png Selektoren und CSS wird über Objekt > Selektoren und CSS… aufgerufen und zeigt CSS-Eigenschaften des ausgewählten Objekts an bzw. erlaubt deren Steuerung. Im oberen Fenster werden die Eigenschaften angezeigt, das untere kann, wenn mehrere Objekte bearbeitet werden sollen, eine Liste der Objekte anzeigen.

Transformation[Bearbeiten]

Der Dialog Inkscape icons dialog transform.svg Transformation unterstützt Operationen wie das Verschieben, Vergrößern, Verkleinern, Drehen und Scheren von Objekten. Er wird über Objekt > Transformation… oder über Umschalt + Strg + M aufgerufen.

Ausrichten und verteilen[Bearbeiten]

Der Dialog Inkscape icons dialog align and distribute.svg Ausrichten und verteilen ermöglicht es unter anderem, Objekte in geraden Reihen auszurichten oder gleichmäßig zu verteilen. Der Aufruf des Dialogs erfolgt über Objekt > Ausrichten und verteilen… oder Inkscape icons dialog align and distribute.svg (Befehlsleiste) oder Umschalt + Strg + A.

Anordnen[Bearbeiten]

Der Dialog Inkscape icons dialog rows and columns.svg Anordnen erlaubt es, Objekte in tabellenähnlichen Gittern oder in Ellipsen bzw. Kreisen anzuordnen. Aufgerufen wird der Dialog über Objekt > Anordnen….

Prototyp[Bearbeiten]

Im Menü Objekte wird ein Dialog Prototyp angekündigt. In der Version 1.0.1 ist ein solcher Dialog aber noch nicht implementiert.