Inkscape/ Rechteckwerkzeug

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


Terminologie: A = Skalieranfasser, B = Rundungsanfasser, C = Fadenkreuz zum Verschieben des Rechteckobjekts

Mit dem Inkscape icons draw rectangle.svg Rechteckwerkzeug können Quadrate und andere Rechtecke gezeichnet werden. Neben dem Ellipsen-, dem Stern-, dem 3D-Box- und dem Spiralwerkzeug ist das Rechteckwerkzeug eines der Werkzeuge, mit denen Formobjekte erzeugt werden können.

Das Rechteckwerkzeug ist auch für Anfänger leicht zu bedienen und eignet sich gut für den Einstieg in Inkscape.

Für das perspektivisch genaue Zeichnen von Quadraten siehe das Kapitel Quadrate.

Um das Werkzeug aufzurufen, wählt man in der Werkzeugleiste Inkscape icons draw rectangle.svg oder drückt R.

Operationen[Bearbeiten]

Konstruktion eines Rechtecks mit Hilfe des Rechteckwerkzeugs
Rechteck zeichnen
Um ein Rechteck zu zeichnen, ruft man das Rechteckwerkzeug auf und führt einen MouseDragLeft.svg Mauszug von einer Ecke des zu erzeugenden Rechtecks zur gegenüberliegenden Ecke aus (Abbildung). Dabei ist es egal, ob MouseDragLeft.svg von oben links nach unten rechts oder in irgendeiner anderen Richtung durchgeführt wird.
Troubleshooting: Falls das Rechteck nicht sichtbar ist, könnte das daran liegen, dass vergessen wurde, das Rechteckwerkzeug aufzurufen, oder dass das neu erzeugte Rechteck weder Füllungs- noch Konturfarbe besitzt. Im letztgenannten Fall versucht man, das unsichtbare Objekt entweder mit „Gummiband“ oder mit Bearbeiten > Alles auswählen auszuwählen und irgendeine Farbe in der Palette am unteren Bildschirmrand anzuklicken, um ihm eine Füllung zu geben.
Quadrat zeichnen
Wenn man beim Zeichnen eines Quadrats nicht nach Augenmaß, sondern ganz genau vorgehen will, so erzeugt man es mit Strg + MouseDragLeft.svg.
Tipp: Das Festhalten von Strg unterstützt nicht nur das Konstruieren von Quadraten, sondern auch von anderen Rechtecken mit ganzzahligem Seitenverhältnis.
Konstruktion eines Rechtecks von seinem Mittelpunkt her
Rechteck oder Quadrat nicht von der Ecke, sondern vom Mittelpunkt her zeichnen
Voreinstellungsmäßig werden Rechtecke von einer Ecke zur gegenüberliegenden erzeugt. Mit Umschalt + MouseDragLeft.svg kann man ein Rechteck von seinem Mittelpunkt her zeichnen. Wenn man zusätzlich Strg gedrückt hält, entsteht ein Quadrat.
Objekt auswählen
Nicht ausgewählte Objekte (auch Objekte, die gar keine Rechtecke sind) können, wenn das Rechteckwerkzeug aktiv ist, durch MouseClickLeft.svg ausgewählt werden. Bei gruppierten Objekten wird nicht – wie beim Auswahlwerkzeug – die ganze Gruppe, sondern nur das angeklickte Objekt ausgewählt.
Bei festgehaltenem Umschalt können durch MouseClickLeft.svg auch mehrere Objekte in Folge ausgewählt werden. Skalier- und Rundungsanfasser erscheinen jedoch nur, wenn ein einzelnes Rechteckobjekt ausgewählt wurde. Esc oder MouseClickLeft.svg auf die Leinwand hebt die Auswahl wieder auf.
Rechteck verschieben
Um ein Rechteck zu verschieben, greift man sein Fadenkreuz mit dem Mauszeiger und zieht dieses händisch an die gewünschte Position. Das Fadenkreuz wird nur angezeigt, solange das Rechteckwerkzeug aktiv ist. Für weitere mögliche Verschiebeoperationen siehe den Abschnitt Verschieben im Kapitel Transformation.


Objekte, die mit dem Rechtwerkzeug erzeugt wurden, behalten ihre Anfasser auch nach Transformationen.
Bei der Verwendung des Rechteckwerkzeugs bleiben rechte Winkel auch erhalten, wenn sie nach Drehen skaliert werden (oberes Beispiel), während bei der Verwendung des Auswahlwerkzeugs Verzerrungen auftreten können (unteres Beispiel).
Rechteck skalieren
Um ein Rechteck größer, kleiner, höher, flacher, breiter oder schmaler zu machen (zu „skalieren“) greift man einen der beiden quadratischen Skalieranfasser mit dem Mauszeiger und zieht diesen an die gewünschte Position. Die Skalieranfasser werden nur angezeigt, solange das Rechteckwerkzeug aktiv ist. Für weitere mögliche Skalieroperationen siehe den Abschnitt Skalieren im Kapitel Transformation.
Alternativ kann ein Rechteck bei aktivem Rechteckwerkzeug auch skaliert werden, indem man die gewünschten Maße in die Eingabefelder B(reite) und H(öhe) der Werkzeugeinstellungsleiste eingibt.


Verschiedene Einstellungen mit den Rundungsanfassern
Ecken abrunden
Die Objekte, die mit dem Rechteckwerkzeug gezeichnet würden, haben voreinstellungsmäßig spitze Ecken. Die beiden runden Abrundungsanfasser in der oberen rechten Ecke des Rechtecks erlauben es, alle vier Ecken des Rechtecks abzurunden. Operationen mit den Abrundungsanfassern sind nur möglich, wenn das Rechteckwerkzeug aktiv ist.
  • Um beide Rundungsanfasser gleichzeitig zu bewegen, hält man, während man nur einen von beiden verschiebt, Strg gedrückt.
  • Strg + MouseClickLeft.svg auf einen der beiden Rundungsanfasser überträgt den Radius des geklickten Anfassers auf den nicht geklickten.
Alternativ kann man die Ecken auch abrunden, indem man die gewünschten Rundungsmaße (Radien) in die Eingabefelder Rx und Ry der Werkzeugeinstellungsleiste eingibt.
Anmerkung: Eine separates Abrunden einzelner Ecken ist mit dem Rechteckwerkzeug nicht möglich. Fortgeschrittene können dafür unter anderem den Pfadeffekt Ecken (Abrunden/Fasen) verwenden.
Tipp: Damit der Radius abgerundeter Ecken bei einem späteren Skalieren des Rechtecks angepasst wird, muss man in der Einstellungsleiste des Auswahlwerkzeugs den Schalter Inkscape icons transform affect rounded corners.svg aktivieren.
Abgerundete Ecken spitz machen
Durch Druck auf den Schalter Sharp Corner Icon.svg in der Werkzeugeinstellungsleiste oder Umschalt + MouseClickLeft.svg auf einen der Rundungsanfasser macht man die abgerundeten Ecken eines Rechtecks wieder spitz. Alternativ kann man auch die Rundungsanfasser in ihre Ecke zurückschieben oder die beiden Radien auf Null setzen.

Optionen[Bearbeiten]

Rectangle Tool Settings.png

Die Einstellungsleiste des Rechteckwerkzeugs umfasst folgende Bedienelemente:

B
Breite des Rechtecks
H
Höhe des Rechtecks
Rx
Horizontaler Radius einer abgerundeten Ecke
Ry
Vertikaler Radius einer abgerundeten Ecke
Einheiten
Maßeinheit für alle vorgenannten Eingabefelder
Sharp Corner Icon.svg Spitze Ecken
Setzt die Werte in den Eingabefeldern Rx und Ry auf Null, sodass die Ecken des Rechtecks, die vorher vielleicht abgerundet waren, auf jeden Fall spitz sind.

Allgemeine Einstellungen[Bearbeiten]

Preferences Rectangle Tool.png

Unter Bearbeiten > Einstellungen… > Werkzeuge > Formen > Rechteck (Preferences Icon.svg, Umschalt + Strg + P) kann man einige allgemeine Einstellungen für das Rechteckwerkzeug vornehmen:

Zuletzt benutzter Stil
Wenn diese Option aktiviert ist, werden voreinstellungsmäßig die Stilmerkmale (Eckrundung, Füllung, Kontur) übernommen, die dem davor erstellten Rechteck zugewiesen wurden.
Stilvorgaben für dieses Werkzeug
Wenn diese Option aktiviert ist, werden neuen Rechtecken immer dieselben Stilmerkmale zugewiesen. Durch Auswahl eines wunschgemäß formatierten Rechtecks und Klicken von Aus Auswahl übernehmen kann man diese Voreinstellungs-Stilmerkmale neu festlegen.
Umwandlung zu Hilfslinien nutzt Objektkanten anstelle von Objektrahmen
Dieses Kontrollkästchen, das voreinstellungsmäßig markiert ist, steuert die Methode, mit der Rechtecke benutzt werden können, um Hilfslinien zu erzeugen (Objekt > Objekte zu Hilfslinien oder Umschalt + G). Wenn das Kontrollkästchen markiert ist, folgen die neuen Hilfslinien auf jeden Fall den Kanten des Rechtecks, auch wenn diese gedreht oder geschert sind.

Alternativen[Bearbeiten]

Diese Rechtecke wurden nicht mit dem Rechteckwerkzeug, sondern mit dem Zeichenwerkzeug (1) bzw. mit dem Sternwerkzeug (2–4) gezeichnet.

Alternativ können Rechtecke auch mit dem Zeichen-, dem Mal- und dem Sternwerkzeug erstellt werden.

Die Verwendung des Zeichenwerkzeugs kann beispielsweise dann zweckmäßig sein, wenn…

  • das Rechteck etwas unregelmäßig erscheinen soll (Abbildung, 1, unten)
  • die Kontur nur über drei Seiten reichen soll (1, oben)

Die Verwendung des Sternwerkzeugs bietet sich an, wenn…

  • bestimmte Verformungen gewünscht sind, etwa konkav bzw. konvex geformte oder geknickte Seiten (2, 3)
  • dem Rechteck ein diagonal ausgerichtetes Farbverlaufsnetz zugewiesen werden soll (4); rechtwinklig oder radial ausgerichtete Netze sind auch bei Objekten möglich, die mit dem Rechteckwerkzeug erstellt wurden.