Inkscape/ Auswählen

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


Ein ausgewähltes Objekt auf der Leinwand
Ein ausgewähltes Objekt in der Liste des Dialogs Objekte
Zwei ausgewählte Knoten auf der Leinwand

Damit eine bestimmte Ebene, ein bestimmtes Objekt, ein bestimmter Pfad und ein bestimmter Knoten bearbeitet werden kann, muss der Benutzer Inkscape mitteilen, welche Ebene, welches Objekt, welcher Pfad, welcher Knoten bearbeitet werden soll. Diese Operation des Aufrufens, Markierens oder Kennzeichnens wird als Auswählen bezeichnet.

Die entgegengesetzte Operation, die Aufhebung einer Auswahl, bezeichnen wir in diesem Buch als Demarkieren.

Dass ein Element „ausgewählt“ ist, wird auf der Leinwand an einer Auswahlmarkierung kenntlich. Bei ausgewählten Objekten erscheint ein Auswahlrahmen, ausgewählte Knoten sind an einer besonderen Einfärbung zu erkennen. In Dialoglisten sind ausgewählte Ebenen, Objekte usw. durch farbliche Hervorhebung gekennzeichnet.

Auswahlfähige Elemente[Bearbeiten]

Auswahlfähig sind u. a.:

Werkzeuge[Bearbeiten]

Die Befehle und Kontrollen für die hier behandelten und erwähnten Operationen sind in Inkscape über mehrere Orte verteilt:

Objekte[Bearbeiten]

Objekte auswählen[Bearbeiten]

Wichtig: Auswählen eines Objekts oder mehrerer Objekte führt grundsätzlich dazu, dass eine bereits bestehende Auswahl aufgehoben wird. Falls dies verhindert werden soll, hält man beim Hinzufügen zusätzlicher Objekte Umschalt gedrückt.

Die in diesem Abschnitt beschriebenen Auswahloperationen können dann in beliebiger Folge miteinander verbunden werden:

Ein einzelnes Objekt auswählen
MouseClickLeft.svg auf das Objekt.
Form- (Rechtecke, Ellipsen, Sterne usw.) und Textobjekte können alternativ auch mit dem jeweiligen Werkzeug ausgewählt werden (Werkzeug aufrufen und MouseClickLeft.svg auf das Objekt).
Verdecktes Objekt auswählen
Manchmal sollen Objekte ausgewählt werden, die entweder vollständig von einem anderen Objekt verdeckt sind, oder so weit verdeckt sind, dass man sie nur schwer anklicken kann. Verdeckendes Objekt auswählen, dann Alt + MouseClickLeft.svg auf das verdeckende Objekt, und zwar irgendwo im Überschneidungsbereich beider Objekte. Das verdeckende Objekt wird dadurch wieder demarkiert.
Einzelnes Objekt auswählen, das einer Gruppe angehört
Wenn man ein Objekt auszuwählen versucht, dass durch Objekt > Gruppieren bzw. Strg + G mit anderen Objekten zu einer Gruppe zusammengefasst wurde, wird normalerweise die ganze Gruppe markiert. Anstatt die Gruppierung aufzuheben, kann man die Gruppe auch betreten. Zu diesem Zweck wählt man das betreffende Einzelobjekt durch Strg + MouseClickLeft.svg oder Umschalt + Strg + MouseClickLeft.svg aus. Mehr zum Thema Betreten im Kapitel Objekte.
Einzelne Objekte nacheinander in der Reihenfolge der Stapelanordnung auswählen
Unabhängig davon, ob der Funktionsbereich Ebenen verwendet wird oder nicht, hat jedes Objekt innerhalb einer Ebene eine individuelle Lage in der Stapelanordnung, was man schon daran sehen kann, dass später erstellte Objekte früher erstellte, wenn Überschneidungen bestehen, zum Teil oder ganz verdecken. Durch Drücken von Tab kann man nacheinander alle Objekte in der Reihenfolge ihrer Stapelanordnung auswählen. Wenn für diese Vorgehensweise kein Startobjekt markiert wurde, beginnt Inkscape beim untersten Objekt. Um die Reihenfolge umzukehren, hält man Umschalt gedrückt.
„Gummiband“-Auswahl
Mehrere Objekte mit „Gummiband“ auswählen
Wenn die Objekte in einem Bereich liegen, der als Rechteck beschrieben werden kann, und alle Objekte in diesem Rechteck ausgewählt werden sollen, zieht man mit dem Mauszeiger ein „Gummiband“ um die Objekte (Abbildung). Um die Operation noch während der Durchführung abzubrechen, bringt man entweder das „Gummiband“ auf seinen Ursprung zurück oder drückt Esc.
Tipp: Gummibandauswahl empfiehlt sich auch zum Auswählen eines Objekts, das versehentlich ohne Füllung und Kontur erstellt wurde, sodass es auf der Leinwand unsichtbar ist und seine Position nur grob geschätzt werden kann.
Mehrere Objekte mit Mauszug auswählen
Bei gedrücktem Alt + MouseClickLeft.svg den Mauszeiger über alle Objekte ziehen, die ausgewählt werden soll. Der Mauszeiger hinterlässt dabei temporär eine rote Spur. Falls die Mausbewegung bei einem Objekt beginnen soll, das bereits ausgewählt ist, verhindert zusätzliches Drücken von Umschalt, dass das erste Objekt vom Mauszeiger mitgezogen wird.
Das Gleiche auswählen
Der Menübefehl Bearbeiten > Das Gleiche auswählen erlaubt es, einer Auswahl alle Objekte hinzuzufügen, die mit dem bereits ausgewählten Objekt hinsichtlich eines bestimmten Kriteriums übereinstimmen. Die möglichen Kriterien sind:
  • Füllung und Kontur
  • Füllfarbe
  • Konturfarbe
  • Konturstil (wählt dann z. B. auch alle Objekte aus, die dieselbe Konturbreite haben, selbst wenn die Konturfarbe nicht übereinstimmt)
  • Objekttyp (Umschalt + Alt + A; wählt dann z. B. alle Rechtecke, alle Textobjekte oder alle Pfade aus)
Alle Objekte auswählen
Select All Icon.png oder Bearbeiten > Alles auswählen oder Strg + A. Durch diesen Befehl werden alle Objekte auf der aktiven Ebene ausgewählt. Wenn alles auf allen Ebenen ausgewählt werden soll, Select All on All Layers Icon.png oder Bearbeiten > Alles auf allen Ebenen auswählen aufrufen oder Strg + Alt + A drücken.

Objekte demarkieren oder Auswahl umkehren[Bearbeiten]

Alle Objekt demarkieren
Unselect All Icon.png oder Esc oder MouseClickLeft.svg irgendwo auf die Leinwand, wo sich kein Objekt befindet. Wenn man nicht ins Leere, sondern auf ein Objekt klickt, wird dieses ausgewählt; alle anderen werden demarkiert.
Ein einzelnes Objekt demarkieren
Wenn von mehreren ausgewählten Objekten nur eines demarkiert werden soll, Umschalt + MouseClickLeft.svg auf das zu demarkierende Objekt.
Auswahl umkehren
Um auf der ausgewählten Ebene alle ausgewählten Objekte zu demarkieren und dafür alle nicht ausgewählten Objekte auszuwählen, ! drücken. Wenn die Auswahl auf allen (sichtbaren und nicht gesperrten) Ebenen umgekehrt werden soll, zusätzlich Alt gedrückt halten.

Auswahlmodi[Bearbeiten]

Inkscape sieht für Auswahlen insgesamt drei verschiedene Modi vor, zwischen denen durch erneutes Anklicken der Auswahl oder Strg + S reihum gewechselt werden kann:

1 = Skaliermodus; 2 = Drehmodus
Skalier- und Drehmodus bei mehreren markierten Objekten
Skaliermodus
Voreinstellungsmäßig, d. h. durch einmaliges Auswählen (etwa durch einmaligen MouseClickLeft.svg), werden Objekte in den Skaliermodus versetzt. Jedes markierte Objekt ist dann mit einem eigenen gestrichelten rechteckigen Objektrahmen umgeben; in ihrer Gesamtheit wird die Auswahl von acht schwarzen Doppelpfeilen flankiert, die auf die Auswahl hin- und davon wegweisen (Abbildung, 1).
In diesem Modus kann die Auswahl verschoben, vergrößert, verkleinert, gedehnt und gestaucht werden. Mehr dazu in den Abschnitten Verschieben und Maßstab des Kapitels Transformation.
Drehmodus
Um ein ausgewähltes Objekt in den Drehmodus zu versetzen, muss es erneut angeklickt werden; mehrere gleichzeitig ausgewählte Objekte bringt man in den Drehmodus, indem man eines von ihnen ein zweites Mal anklickt. Im Drehmodus verlaufen die Doppelpfeile parallel zum Außenrand der Auswahl und schmiegen sich um deren vier Ecken. Zusätzlich wird ein Fadenkreis angezeigt, dass den Drehpunkt des Objekts markiert (2); voreinstellungsmäßig wird der Drehpunkt (der auch verschoben werden kann) auf den Mittelpunkt gesetzt.
In diesem Modus kann die Auswahl verschoben, gedreht und geschert werden. Mehr dazu in den Abschnitten Verschieben, Drehen und Scheren des Kapitels Transformation.
Ausrichtmodus
Dieser Modus ist nur zugänglich, wenn im Dialog Ausrichten und verteilen der Schalter Align and Distribute Icons - Activate Handlers.png aktiv ist. Auswahlen, die aus mehreren Objekten bestehen, können in diesem Modus in einer Reihe ausgerichtet werden. Einzelheiten im Abschnitt Ausrichten des Kapitels Ordnen.

Informationen über den Auswahlzustand abrufen[Bearbeiten]

Welche Objekte gerade ausgewählt sind, wird auf der Leinwand durch den Auswahlrahmen direkt angezeigt. Inkscape bietet aber auch an anderen Stellen Informationen:

Benachrichtigungsfeld der Statusleiste
Zeigt eine Informationen über Anzahl und Typen der ausgewählten Objekte.
Dialog Objekte
Ausgewählte Objekte sind in der Liste des Dialogs farblich hervorgehoben.
Dialog Objekteigenschaften
Falls genau ein Objekt ausgewählt ist, so wird es in diesem Dialog angezeigt.

Knoten[Bearbeiten]

Das Auswählen von Pfadknoten folgt in vielerlei Hinsicht denselben Prinzipien wie das Auswählen von Objekten. Für eine ausführliche Behandlung des Themas siehe den Abschnitt Knoten markieren und demarkieren im Kapitel Inkscape/ Knotenwerkzeug.

Allgemeine Einstellungen[Bearbeiten]

Select Preferences.png

In den Inkscape-Einstellungen, die über Bearbeiten > Einstellungen > Verhalten > Auswählen oder Umschalt + Strg + P aufgerufen werden können, können fürs Auswählen die Grundeinstellungen bearbeitet werden (siehe Abbildung).