Inkscape/ Schneiden

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


In diesem Kapitel über Schneiden und Vereinen geht es um die Verwendung von Schneidepfaden und Masken sowie um die sogenannten Boole-Operationen: Vereinigung, Differenz, Überschneidung, Exklusiv-Oder, Division und Pfad zerschneiden.

Mit Ausnahme von Vereinigen dienen die meisten dieser Operationen dazu, einen Pfad mit Hilfe eines anderen Pfades zurechtzuschneiden. Mit dem Radierer ist auch direktes Schneiden per Mauszug (Freihand-Schneiden) möglich.

Boole-Operationen[Bearbeiten]

Von links nach rechts: Vereinigung, Differenz, Überschneidung, Exklusiv-Oder, Division, Pfad zerschneiden

Im Menü Pfad sind sechs Boole-Operationen zu finden:

  • Vereinigung (engl. union)
  • Differenz (difference)
  • Überschneidung (intersection)
  • Exklusiv-Oder (Ausschluss; exclusion)
  • Division (division)
  • Pfad zerschneiden (path cut)

Mit der ersten können mehrere Pfade vereinigt werden; bei den übrigen fünf wird ein Pfad wie ein Ausstechförmchen benutzt, um einen zweiten Pfad zu zerschneiden.

Anders als etwa die Befehle Pfad > Kombinieren und Objekt Gruppieren können Boole-Operationen (außer durch Strg + Z) nicht wieder rückgängig gemacht werden.

Path - Union Significance.png
Inkscape icons path union.svg Vereinigung
Vereinigt zwei oder mehr Pfade zu einem einzigen (Abbildung). Beide Pfade markieren, dann Pfad > Vereinigung oder Strg + +.


Path - Union Cases.png
Die höher liegenden Pfade nehmen Füllung und Kontur des zuunterst liegenden an (Abbildung). Da zwei Pfade in Inkscape normalerweise immer auf unterschiedlicher Höhe liegen, gilt dies auch dann, wenn sie sich nicht überschneiden. Mit Inkscape icons selection bottom.svg oder Ende kann man einen Pfad nach unten schaffen.


Differenzen: Mutige können auch einmal probieren, mit drei und mehr Pfaden gleichzeitig zu arbeiten. Die Autorin dieser Seite hat für sich nicht klären können, ob das Ergebnis in manchen Fällen auf einem Fehler der Inkscape-Entwickler basiert oder einfach schwer zu verstehen ist.
Inkscape icons path difference.svg Differenz
Der oben liegende Pfad schneidet als „Ausstechförmchen“ in den unten liegenden Pfad, wobei die ausgestochene Fläche verschwindet und nur der nicht ausgestochene Rest übrig bleibt. Diese Operation ist besonders dann nützlich, wenn man in eine Fläche ein wie auch immer geformtes Loch stanzen oder von der Fläche Stücke abzuschneiden will. Pfad > Differenz oder Strg + -. Der neu erzeugte Pfad erhält dieselbe Füllung und Kontur, wie der zuunterst liegende Originalpfad hatte.
Boole-Schneiden ist keineswegs nur mit Formobjekten, sondern mit jedem beliebigen Objekt bzw. Pfad möglich. Auch Freihand-Schneiden wird unterstützt. Dafür erzeugt man entweder ein Freihand-Objekt (etwa mit dem Mal- oder mit dem Kalligrafiewerkzeug) und schneidet damit per Inkscape icons path difference.svg, oder ruft den Radierer auf, wählt den Modus Inkscape icons path difference.svg und führt den Schnitt direkt per MouseDragLeft.svg durch:
Boolean Difference Cutting with Calligraphy Object Vs with Eraser.png


Vergleich Überschneidung und Exklusiv-Oder
Inkscape icons path intersection.svg Überschneidung
Was allen markierten Pfaden gemeinsam ist, bleibt, der Rest verschwindet. Pfad > Überschneidung oder Strg + *. Der neu erzeugte Pfad erhält dieselbe Füllung und Kontur, wie der zuunterst liegende Originalpfad hatte. Es dürfen mehr als zwei Pfade gleichzeitig verwendet werden.
Inkscape icons path exclusion.svg Exklusiv-Oder (Ausschluss)
Umkehrung von Inkscape icons path intersection.svg: Was allen markierten Pfaden gemeinsam ist, verschwindet, der Rest bleibt. Pfad > Exklusiv-Oder (Ausschluss) oder Strg + ^. Der neu erzeugte Pfad erhält dieselbe Füllung und Kontur, wie der zuunterst liegende Originalpfad hatte. Es dürfen mehr als zwei Pfade gleichzeitig verwendet werden.


Wenn mit Division oder Pfad zerschneiden mehr als zwei Pfade gleichzeitig bearbeitet werden, so verwendet Inkscape nur die beiden zuunterst liegenden; die übrigen verschwinden.
Inkscape icons path division.svg Division
Wenn sowohl die Differenz als auch die Überschneidung behalten werden soll: Der höher liegende Pfad schneidet als „Ausstechförmchen“ in den zuunterst liegenden Pfad hinein und teilt ihn in zwei separate Pfade auf. Pfad > Division oder Strg + /.
Inkscape icons path cut.svg Pfad zerschneiden
Die einzige Boole-Operation, mit der nur Konturen zerschnitten werden können: Der höher liegende Pfad schneidet als „Ausstechförmchen“ in den zuunterst liegenden Pfad hinein und teilt ihn in zwei separate Pfade auf. Pfad > Pfad zerschneiden oder Strg + Alt + /.
Wenn ein Pfad mit Kontur und Füllung zerschnitten wird, so verschwindet die Füllung durch die Operation. Dasselbe passiert, wenn man (vielleicht versehentlich) einen Pfad mit Füllung, aber ohne sichtbare Kontur zerschneidet. Um die – nun zerschnittene – Kontur anzuzeigen, versucht man, die neu entstanden (auf der Leinwand aber unsichtbaren) Pfade zu markieren, und setzt die Konturbreite auf einen Wert >0. Alternativ kann man sie auch durch Markieren und Aufruf des Knotenwerkzeugs anzeigen, wobei freilich Inkscape icons show path outline.svg aktiv sein muss.

Ausschneidepfad[Bearbeiten]

Die Operationen, die mit Ausschneidepfaden (engl. clip) vorgenommen werden können, ähneln der Boole-Operation Überschneidung.

In beiden Fällen wird das in der Stapelanordnung höher liegende Objekt – der Ausschneidepfad –, als „Ausstechform“ verwendet, um von dem tiefer liegenden virtuell ein Stück abzuschneiden. Sowohl der Ausschneidepfad als auch der nicht ausgeschnittene Rest des unteren Elements verschwinden dabei; nur der ausgeschnittene Teil des unteren Elements bleibt sichtbar.

Zwischen beiden Operationen bestehen jedoch wichtige Unterschiede:

  • Während Überschneidung von Objekten tatsächlich Teile abschneidet, werden diese bei der Verwendung einer Ausschneideform lediglich ausgeblendet. Sie sind weiterhin vorhanden und können weiterhin bearbeitet und bei Bedarf auch wieder sichtbar gemacht werden.
Der Objektrahmen enthält allerdings nur den sichtbaren Teil.
  • Während Überschneidung nur auf vektorielle Elemente wie Pfade und Objekte angewendet werden kann, können mit einer Ausschneideform darüber hinaus z. B. auch importierte Rastergrafiken geschnitten werden.
1 = Original: der halb transparente schwarze Kreis bedeckt den Stern; 2 = Überschneidung; 3 = Ausschneidepfad

Manchmal führen beide Operationen zu unterschiedlichen Ergebnissen:

  • Während abgeschnittene Konturen bei Überschneidung nach dem Zurechtstutzen wieder vervollständigt werden, geschieht dies bei der Verendung eines Ausschneidepfades nicht (Abbildung, obere Beispiele).
  • Während Unschärfe nach der Operation Überschneidung neu berechnet und wieder vervollständigt wird, vermag ein Ausschneidepfad harte „Schnitte“ durch Unschärfebereiche zu führen (untere Beispiele).
Ausschneidepfad anwenden
Sicherstellen, dass der Ausschneidepfad das zu „schneidende“ Objekt oder Bild bedeckt und nicht umgekehrt; beide Elemente auswählen; Objekt > Ausschneidepfad > Setzen.
Es ist auch möglich, mit einem Ausschneidepfad mehrere Elemente gleichzeitig zu behandeln.
Wählt man statt Setzen die Option Umgekehrt setzen (LPE), so bleibt nicht der bedeckte Teil des unten liegenden Elements, sondern dessen nicht bedeckter Rest sichtbar.
Ausgeblendete Teile wieder sichtbar machen
Um den Ausschneidepfad und die ausgeblendeten Teile wieder sichtbar zu machen, markiert man das Objekt und wählt Objekt > Ausschneidepfad > Freigeben wählt.
Freihand-Schneiden mit einem Kalligrafieobjekt und mit dem Radierer. Beachte den Unterschied!
Freihand-Schneiden
Auch Freihand-Schneiden ist mit Ausschneidepfaden möglich. Dafür erzeugt man entweder ein Freihand-Objekt (etwa mit dem Mal- oder mit dem Kalligrafiewerkzeug) und schneidet damit per Ausschneidepfad, oder ruft den Radierer auf, wählt den Modus Inkscape icons path intersection.svg und führt den Schnitt direkt per MouseDragLeft.svg durch. Wie die Abbildung zeigt, definiert die handgezogene Linie im erstgenannten Fall die Fläche, die sichtbar bleibt, während sie im letztgenannten Fall bestimmt, was unsichtbar gemacht wird.

Falls man Objekte, die mit einem Ausschneidepfad bearbeitet wurden, später mit dem Knotenwerkzeug bearbeiten möchte, so kann man dort in den Werkzeugeinstellungsliste die Option Nodes - Show Clip Path.png Ausschneidepfade zeigen aktivieren, um auf die – sonst unsichtbaren – Knoten bzw. Anfasser des Ausschneidepfades zuzugreifen. Dessen Pfadumrisse werden in dieser Ansicht grün (statt wie normal rot) dargestellt.

Maske[Bearbeiten]

0 = vorher, 1 = nach Anwendung eines Ausschneidepfads, 2 = nach Anwendung einer Maske

Die Verwendung einer Maske gleicht weitgehend der eines Ausschneidepfades. Der einzige Unterschied besteht darin, dass hier durch Verwendung unterschiedlicher Helligkeitsstufen unterschiedliche Transparenzstufen erreicht werden.

Allgemeine Einstellungen[Bearbeiten]

Clip and Mask Preferences.png

In den Inkscape-Einstellungen, die über Bearbeiten > Einstellungen > Verhalten > Ausschneidepfade und Masken oder Umschalt + Strg + P aufgerufen werden können, können für diese beiden Funktion die Grundeinstellungen bearbeitet werden (siehe Abbildung).