Inkscape/ Farben

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


Farbpaletten (Beispiel: MunsellChart) können beliebig groß auch im Dialog Farbfelder-Palette aufgerufen werden.

Farben (einfache Farben) bilden in Inkscape – neben Farbverläufen und Mustern – eine Klasse der Flächengestaltungsmittel. Farben können sowohl für Füllungen als auch für Konturen verwendet werden.

Farbverläufe und Muster basieren auf zwei oder mehr Farben.

Der Begriff „Objekte“ wird in diesem Kapitel in seinem weiteren Sinne gebraucht und schließt Pfade mit ein.

Übersicht: Farbzuweisung und Farbmodifikation[Bearbeiten]

Wenn mehrere Objekte gleichzeitig ausgewählt sind (0), erhalten sie durch Farbzuweisung alle dieselbe Farbe (1). Farbmodifikation dagegen erlaubt es, Farbindividualität aufrechtzuerhalten (2).

Ein Objekt kann seine Füll- und Konturfarben auf vier grundlegend unterschiedlichen Wegen erhalten:

Voreinstellungsfarbzuweisung
Alle Werkzeuge, die zur Erzeugung neuer Objekte benutzt werden können, können so eingestellt werden, dass die damit erzeugten Objekte von Anfang an eine bestimmte Füll- und Konturfarbe haben. Dies gilt für die folgenden Werkzeuge:
Farbzuweisung
Um ausgewählten Objekten eine neue einfache Farbe zuzuweisen, können folgende Mittel verwendet werden:
Farbmodifikation
Der Unterschied zwischen Farbmodifikation und Farbzuweisung besteht darin, dass die erstere es erlaubt, die Farben farblich unterschiedlicher Objekte in einer einzigen Operation so zu bearbeiten, dass die Objekte auch danach noch unterschiedliche Farben haben (Abbildung, 2). Farbmodifikation erlaubt es sogar, farblich einheitliche Objekte in einer einzigen Operation so zu bearbeiten, dass sie sich danach farblich voneinander unterscheiden.
Farbmodifikationen können mit folgenden Mitteln durchgeführt werden:
Nachzeichnen („Durchpausen“)
Klone, denen die Füll- und/oder Kontureigenschaft „undefiniert“ zugewiesen wurde, können dazu gebracht werden, die Farben von Objekten oder Rastergrafiken zu übernehmen, die sie bedecken. Voraussetzung ist, dass die Klone entweder durch Kachelung oder mit dem Spraywerkzeug erzeugt wurden.

Farbzuweisung[Bearbeiten]

Farbpalette[Bearbeiten]

Das am einfachsten zu benutzende Mittel zur Farbzuweisung ist die Palette, die voreinstellungsmäßig am unteren Rand des Bearbeitungsfensters angezeigt wird. Um sie ein- und auszublenden, wählt man Ansicht > Anzeigen/Ausblenden > Palette oder Umschalt + Alt + P.

Palette auswählen[Bearbeiten]

Die Voreinstellungspalette

In Version 1.0.1 stehen 24 Paletten zur Auswahl (Schalter ◄ rechts neben der Palette drücken), von denen Gnome HIG für Anfänger vielleicht die am besten geeignete ist, weil sie eine gute Farbbandbreite bietet, ohne – wie die Voreinstellungspalette (Abbildung) – gescrollt werden zu müssen. Hier einige Paletten im Bild:

Zu den wenigen Paletten, die auch eine größere Anzahl von unsatten Farben enthalten, zählen die Voreinstellungspalette und das leider ebenfalls recht unübersichtliche MunsellChart.

Für die Arbeit mit Farbverläufen und für Spezialanwendungen bietet Inkscape einige Spezialpaletten, die scheinbar keine Stufen haben:

Eigene Palette erzeugen[Bearbeiten]

Eine benutzerdefinierte Farbpalette. Im Bearbeitungsfenster sind die Quellfarben dargestellt. Beachte, dass die Farben in der Palette nicht in der Reihenfolge der Matrix erscheinen.

Um eine eigene, benutzerdefinierte Palette zu erzeugen, geht man folgendermaßen vor:

  • Neues Dokument erzeugen.
  • Für jede Farbe, die in der neuen Palette erscheinen soll, ein Rechteck oder Quadrat erzeugen, das die Farbe als Füllung enthält. Die Rechtecke sollten – wie Felder auf einem Schachbrett – als Matrix und ohne Zwischenräume angeordnet sein.
  • Alle Rechtecke auswählen, Bearbeiten > Seitengröße auf Auswahlgröße (Umschalt + Strg + R).
  • Dokument als GIMP-Palette (.gpl) speichern, an einen Ort, an dem die Datei leicht wiederzufinden ist (z. B. aufs Desktop).
  • Auf der Festplatte den Ordner suchen, in dem die Voreinstellungspaletten gespeichert sind (möglicherweise etwas wie: Inkscape > share > inkscape > palettes). Das neue .gpl in diesen Ordner kopieren (das mag Administratorenrechte voraussetzen).
  • Inkscape schließen und neu starten. Die neue Palette sollte nun in der Liste der verfügbaren Paletten erscheinen und aufrufbar sein.


Paletteneinstellungen[Bearbeiten]

Verschiedene Einstellungen (Palette: Gnome HIG): 1 = Breite: Mittel, 2 = Breite: Breit, 3 = Breite: Breiter, 4 = Umbrechen, 5 = Rand: Fest, 6 = Rand: Breit

Im obersten Teil der Auswahlliste für die Paletten befindet sich eine kleine Liste von Parametern, mit denen die Form die Palette gesteuert werden kann:

Größe
Bei Paletten mit sehr vielen Farbfeldern kann man die Option klein oder winzig wählen, um nicht so viel scrollen zu müssen. Bei Paletten mit relativ wenigen Farbfeldern bleibt die Veränderung dieses Parameters ohne Folgen.
Breite
Erlaubt es, die Breite der einzelnen Farbfelder einzustellen (Abbildung, 1–3).
Rand
Voreinstellungsmäßig grenzen Farbfelder direkt aneinander. Die Option Fest erzeugt einen schwarzen Rand (5), Breit zusätzlich einen weißen Abstand (6).
Umbrechen
Voreinstellungsmäßig wird die Palette seitlich gescrollt. Durch Markieren dieses Kontrollkästchens wird die Palette umgebrochen und ein kleiner senkrechter Rollbalken erscheint (4).

Dialog Füllung und Kontur[Bearbeiten]

Der Dialog Inkscape icons dialog fill and stroke.svg Füllung und Kontur erlaubt es, aus HSL-, RGB-, HSV-, CMYK-Komponenten oder aus einem Farbrad beliebige Farben selbst zu komponieren. Auch die Deckkraft kann gesteuert werden.

Dialog Farbfelder-Palette[Bearbeiten]

Der Dialog Farbfelder-Palette mit der Inkscape-Voreinstellungspalette

Wer mit der normalen Palette nicht gut zurechtkommt, weil sie ihm zu klein ist, kann sie mit Hilfe des Dialogs Farbfelder-Palette (engl. swatches) deutlich größer darstellen. Bei extrem großen Paletten kann allerdings selbst bei dieser Darstellungsweise Scrollen erforderlich werden.

Der Dialog wird mit Ansicht > Farbfelderpalette oder Umschalt + Strg + W aufgerufen. Um eine Palette auszuwählen oder die Anzeigeeinstellungen des Dialogs zu steuern, klickt man das kleine Symbol ◄ oben rechts im Dialog an.

Dialog Farbgebungsarten[Bearbeiten]

Der Dialog Paint Servers Icon.png Farbgebungsarten erlaubt es, einfache Farben (ebenso wie Farbverläufe und Muster) aus externen Ressourcen zu importieren.

Farbpipette[Bearbeiten]

Die Farbpipette erlaubt es, der Füllung oder Kontur von ausgewählten Objekten eine Farbe zuzuweisen, die direkt auf der Leinwand einem beliebigen anderen Objekt oder sogar einer importierten Rastergrafik entnommen wird.

Farbmodifikation[Bearbeiten]

Modellierwerkzeug[Bearbeiten]

Das Modellierwerkzeug hat zwei spezielle Modi, in denen die Farben ausgewählter Objekte verändert werden können:

  • Inkscape icons object tweak paint.svg Objekte bemalen erlaubt es, Objekte mit der Voreinstellungsfarbe des Werkzeugs so einzufärben, dass die neue Farbe sich, je nach eingestellter Kraft und nach Zahl der Bearbeitungswiederholungen, immer mehr gegen die ursprüngliche Farbe durchsetzt.
  • Inkscape icons object tweak jitter color.svg Farbe verrauschen erlaubt es, die ursprüngliche Farbe zufällig zu verändern. Die Operation wird meist verwendet, um innerhalb einer Anzahl von Objekten von ursprünglich einheitlicher Farbe eine gewisse Farbbandbreite zu erzeugen.

Erweiterungen > Farbe[Bearbeiten]

Im Menü stehen unter Erweiterungen > Farbe folgende Befehle und Dialoge zur Auswahl (die Operationen werden entweder auf die ausgewählten oder, wenn kein Objekt ausgewählt ist, auf alle Objekte angewendet):

Alle auflisten
Liefert eine Liste aller im Dokument verwendeten Farben (als Hexadezimal-Code)
Benutzerdefiniert…
Ermöglicht es, auf jeden Farbkanal (Rot, Grün, Blau) eine eigene mathematische Funktion anzuwenden. Einzelheiten auf der Hilfeseite des Dialogs.
Blau entfernen, Grün entfernen, Rot entfernen
Setzt den Farbkanal (Blau, Grün, Rot) auf Null.
Extensions - Color - Remove RGB.png
Dunkler, Weniger Helligkeit
Setzt die Helligkeit auf einen niedrigeren Wert.
Heller, Mehr Helligkeit
Setzt die Helligkeit auf einen niedrigeren Wert.

Vgl. HSL anpassen…

Extensions - Color - Darker&Lighter.png
Entsättigen
Entsättigt die Farben ohne Rücksicht auf den Farbton (1).
Graustufen
Entsättigt die Farben mit Rücksicht auf den Farbton (2).
Schwarz-Weiß
Setzt die Farben auf Schwarz-Weiß, wobei ein Grenzwert angegeben werden kann (3).
Extensions - Color - Desaturate ShadesOfGray BlackNWhite.png
Farbe ersetzen…
Erlaubt es, eine Farbe durch eine andere zu ersetzen.
Replace Color.png
HSL anpassen…
Erlaubt es, Farbton, Sättigung und Helligkeit zu steuern.
Adjust HSL.png
Mehr Farbe, Weniger Farbe
Erlaubt es, den Farbton (Hue) zu verändern. Vgl. HSL anpassen…
Extensions - Color - Change Hue.png
Mehr Sättigung, Weniger Sättigung
Erlaubt es, die Sättigung zu verändern. Vgl. HSL anpassen…
Extensions - Color - Change Saturation.png
Negativ
Verwandelt die Farben in ihr Negativ (1).
RGB-Tonne
Verwandelt die Farben in ihre Komplementärfarben (RGB barrel, 2).
Extensions - Color - Negative RGBBarrel.png
Zufallsänderung
Extensions - Color - Randomize.png

Filter > Farbe[Bearbeiten]

Im Menü Filter finden sich unter Farbe einige weitere Dialoge und Befehle, mit denen die Farben ausgewählter Objekte verändert werden können. Dabei handelt es sich durchweg um komplexe Operationen, die vor allem für Fortgeschrittene von Interesse sein dürften. Für Einzelheiten siehe das Kapitel Filter/ Farbe.