Inkscape/ Ebenen

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


Voreinstellungsmäßig befinden alle Objekte, die man für eine Inkscape-Zeichnung erstellt, sich auf ein und derselben Ebene. Auch dass sie einander überschneiden und dann teils über-, teils untereinander liegen können (Stapelanordung), ändert an der Tatsache, dass sie auf einer einzigen Ebene liegen, nichts.

Eine mit Inkscape gezeichnete Landschaft

Ebenen (engl. layers) kann man sich wie übereinandergeschichtete transparente Folien vorstellen, von denen jede einen Teil der Zeichnung aufnimmt: bei einer Landschaftszeichnung die erste, unterste Ebene zum Beispiel den Himmel, die zweite, darüberliegende den Landschaftshintergrund, die dritte weiter vorne liegende Landschaftsteile usw.

Die Verwendung von Ebenen empfiehlt sich bei komplexen, vielteiligen Zeichnungen meist eher als bei einfachen, die nur aus wenigen Objekten und/oder Pfaden bestehen.

Kontrollen für die Ebenen befindet sich an drei Orten:

  • in der Statuszeile
  • in den Dialogen Ebenen und Objekte
  • im Menü

Der Begriff Objekte wird in diesem Kapitel in seinem weiteren Sinne verwendet, schließt also Pfade mit ein.

Wann Ebenen hilfreich sind[Bearbeiten]

Die Verwendung von mehreren Ebenen kann viele Vorteile haben. Einige Beispiele:

  • Falls ganze Bilderserien erstellt werden sollen, etwa für ein Manga, erleichtert das Aufgliedern der Zeichnung in Ebenen das Wiederverwenden von Zeichnungsteilen.
  • Da individuelle Ebenen leicht, mit einem einzigen Klick, ein- und ausgeblendet werden können, eignen Ebenen sich gut, um zum Beispiel Zeichenvorlagen aufzunehmen, die in der fertigen Zeichnung nicht mehr erscheinen sollen.
  • Da individuelle Ebenen leicht, mit einem einzigen Klick, gesperrt und entsperrt werden können, eignen sie sich gut, um bereits fertiggestellte Teile der Zeichnung vor versehentlicher Bearbeitung oder versehentlichem Verschieben zu schützen.
  • Oft sollen bestimmte Operationen (z. B. Steuerung der Schärfe oder der Transparenz) auf mehrere Objekte gleichzeitig angewendet werden. Anstatt diese immer wieder auszuwählen oder anstatt sie dauerhaft zu gruppieren, kann man sie auch auf einer eigenen Ebene zusammenfassen und dann jederzeit ganz einfach auf sie zugreifen.

Ebenen-Architektur[Bearbeiten]

Drei Ebenen, eine davon mit Unterebene

Ebenen sind in einem zweifachen Sinne hierarchisch organisiert:

  • Sie sind übereinandergestapelt angeordnet.
  • Ebenen können Unterebenen haben, die wiederum selbst Unterebenen haben können usw. Unterebenen liegen stets unter ihrer übergeordneten Ebene (Abbildung: Light Blue Layer).
Der größte Vorteil der Verwendung von Unterebenen besteht darin, dass diese bei einer Änderung der Ebenenordnung gemeinsam mit ihrer übergeordneten Ebene verschoben werden können.

Benutzung[Bearbeiten]

Der Dialog Ebenen
Dialog Ebenen aufrufen
Der Dialog Ebenen kann durch Ebene > Ebenen… oder Inkscape icons dialog layers.svg (Befehlsleiste) oder Umschalt + Strg + L aufgerufen werden.
Welche Ebene ist ausgewählt?
Es kann immer nur eine Ebene zur Zeit ausgewählt sein. Um zu ermitteln, welche Ebene ausgewählt ist, kann man an verschiedenen Orten nachschauen:
  • in der Statuszeile, wo sie im Ebenen-Auswahlfeld links neben den Statusmeldungen angezeigt wird.
  • im Dialog Ebenen und im Dialog Objekte, wo sie jeweils mit einem blauen Balken gekennzeichnet ist.
Ebene auswählen
Um eine Ebene auszuwählen, kann man…
  • die Ebene im Ebenen-Dialog anklicken.
  • die Ebene im Ebenen-Auswahlfeld in der Statuszeile auswählen.
  • den Menübefehl Ebene > Inkscape icons layer previous.svg Zur darüberliegenden Ebene umschalten (Strg + Bild↑) benutzen.
  • den Menübefehl Ebene > Inkscape icons layer next.svgZur darunterliegenden Ebene umschalten (Strg + Bild↓) benutzen.
Ebene umbenennen
Wenn Ebenen verwendet werden, kann es die Übersichtlichkeit erhöhen, wenn diese nicht ihre Voreinstellungsnamen Ebene 1, Ebene 2 usw., sondern deskriptive Namen wie Himmel, Hintergrund, Pflanzen, Tiere tragen. Um eine Ebene umzubenennen, wählt man die Ebene aus und klickt entweder auf ihren Namen im Ebenen-Dialog oder wählt Ebene > Ebene umbenennen…. Alternativ kann man im Ebenen-Dialog durch MouseClickRight.svg auf die Ebene auch ein Kontextmenü aufrufen, in dem man dann Ebene umbenennen… auswählt.
Neue Ebene erstellen
Eine neue Ebene kann auf zweierlei Wegen erzeugt werden:
  • Im Ebenen-Dialog auf das Zeichen „+“ (Eine neue Ebene anlegen) klicken.
  • Ebene > Ebene hinzufügen…
In beiden Fällen wird ein kleiner Dialog aufgerufen, in dem man für die neue Ebene einen Namen angeben und im Auswahlfeld Position auswählen kann, ob die Ebene a. über der aktuellen Ebene, b. unter der aktuellen Ebene oder c. als Unterebene unter der aktuellen Ebene angelegt werden soll.
Ebene duplizieren
Um eine Ebene mitsamt all ihren Unterebenen und Objekten zu duplizieren, wählt man die Ebene aus und wählt entweder Ebene > Aktuelle Ebene duplizieren oder ruft für sie im Ebenen-Dialog per MouseClickRight.svg das Kontextmenü auf und wählt darin Aktuelle Ebene duplizieren.
Das Duplikat erhält denselben Namen wie das Original, aber mit dem Zusatz Kopie, und wird direkt über dem Original eingefügt.
Ebene löschen
Um eine Ebene samt Unterebenen und allen darauf befindlichen Objekten zu löschen, wählt man die Ebene aus und…
  • klickt im Ebenen-Dialog das Zeichen „-“ (Die aktuelle Ebene löschen) an.
  • führt im Ebenen-Dialog einen MouseClickRight.svg auf die Ebene aus und wählt im Kontextmenü, das nun erscheint, die Option Aktuelle Ebene löschen aus.
  • Ebene > Aktuelle Ebene löschen.
Ebene anheben oder senken
Es gibt verschiedene Möglichkeiten, eine ausgewählte Ebene anzuheben oder zu senken:
  • Ebene im Ebenen-Dialog mit der Maus per Drag&Drop an die gewünschte Stelle ziehen.
  • Ebene im Ebenen-Dialog mit den Pfeilsymbolen an die gewünschte Stelle verrücken.
  • Ebene > Inkscape icons layer raise.svg Ebene anheben oder Umschalt + Strg + Bild↑.
  • Ebene > Inkscape icons layer top.svg Ebene ganz nach oben oder Umschalt + Strg + Pos1.
  • Ebene > Inkscape icons layer lower.svg Ebene senken oder Umschalt + Strg + Bild↓.
  • Ebene > Inkscape icons layer bottom.svg Ebene ganz nach unten oder Umschalt + Strg + Ende.
Unterebenen werden automatisch mitgezogen.
  • Möglich sind Veränderungen der Ebenenanordnung auch über den Dialog Objekte (siehe weiter unten).
Alle Objekte auf der ausgewählten Ebene auswählen
Select All Icon.png (Einstellungsleiste des Auswahlwerkzeugs) oder Bearbeiten > Alles auswählen oder Strg + A.
Objekte von einer Ebene auf eine andere verschieben
Die umständlichste Methode, Objekte von einer Ebene auf eine andere zu versetzen, besteht darin, sie per Kopieren und Einfügen herüberzuschaffen. Wesentlich eleganter sind folgende Vorgehensweisen, die alle voraussetzen, dass die zu verschiebenden Objekte ausgewählt sind:
  • Ebene > Inkscape icons selection move to layer above.svg Auswahl zur darüberliegenden Ebene verschieben oder Umschalt + Bild↑
  • Ebene > Inkscape icons selection move to layer below.svg Auswahl zur darunterliegenden Ebene verschieben oder Umschalt + Bild↓
  • Ebene > Layers - Move Selection to a Different Layer Icon.svg Auswahl zu einer anderen Ebene verschieben, Ebene auswählen
  • Möglich ist ein Verschieben von Objekten auch über den Dialog Objekte (siehe weiter unten).
Ebene aus- und einblenden
Um eine Ebene unsichtbar zu machen, wählt man sie aus und klickt entweder im Ebenendialog oder in der Statusleiste auf das Symbol Inkscape icons object visible.svg, das sich dadurch in Inkscape icons object hidden.svg verwandelt. Um die Ebene wieder einzublenden, klickt man das Augensymbol erneut an.
Ebene sperren und entsperren
Um zu verhindern, dass die auf einer Ebene befindlichen Objekte versehentlich bearbeitet werden, kann man die ganze Ebene sperren. Dafür wählt man die Ebene aus und klickt entweder im Ebenendialog oder in der Statusleiste auf das Symbol Inkscape icons object unlocked.svg, das sich dadurch in Inkscape icons object locked.svg verwandelt. Um die Ebene wieder zu entsperren, klickt man das Schlosssymbol erneut an.
Layers in Dialog Objects.png
Verwaltung von Ebenen im Dialog Objekte
Grundsätzlich können Ebenen und die darauf befindlichen Objekte auch über den Dialog Objekte verwaltet werden.