Inkscape/ Knotenwerkzeug

Aus Wikibooks
Zur Navigation springen Zur Suche springen

Werkzeuge: Auswahlwerkzeug | Knotenwerkzeug | Rechteckwerkzeug | Ellipsenwerkzeug | Sternwerkzeug | 3D-Box-Werkzeug | Spiralwerkzeug | Zeichenwerkzeug | Malwerkzeug | Kalligrafiewerkzeug | Textwerkzeug | Farbverlaufswerkzeug | Verlaufsnetz | Farbpipette | Farbeimer | Modellierwerkzeug | Spraywerkzeug | Radierer | Objektverbinder | Zoomwerkzeug | Messwerkzeug

Operationen: Auswählen | Kopieren und klonen | Transformieren | Ordnen | Messen | Schneiden | Füllung und Kontur gestalten | Mischen | Filtern | Pfadeffekte anwenden | Ausblenden und löschen

Elemente: Objekte | Pfade | Striche und Linien | Quadrate | Würfel | Kreise | Farben | Farbverläufe | Muster | Text

Hilfsmittel: Leinwand | Seite, Hilfslinien und Seitengitter | Einrasten | Ebenen

Inkscape Logo.svg

Inkscape Handbuch

Startseite


Terminologie: 1 = Knoten, 1a = Endknoten, 2 = (Bézier-)Anfasser, 3 = Pfadumriss (auch: Pfadumrandung), 4 = ein (Pfad-)Segment, 5 = Kontur, 6 = Füllung, 7 = Objektrahmen
Bézierpfad und Spiropfad im Vergleich

Mit dem Knotenwerkzeug Inkscape icons edit nodes.svg können die Knoten eines Pfades bearbeitet werden. Das Knotenwerkzeug ist eines der wichtigsten und am meisten benutzten Werkzeuge in Inkscape.

Aufruf des Knotenwerkzeugs bringt Inkscape in den Knotenmodus. Bei ausgewählten Pfaden können im Knotenmodus – über Füllung und Kontur hinaus – Pfadumriss, Knoten und Bézieranfasser angezeigt werden. Bei ausgewählten Objekten dagegen wird – über Objektanfasser, Füllung und Kontur hinaus – auch je ein Fadenkreuz angezeigt, das den Mittelpunkt des Objekts markiert und als Anfasser genutzt werden kann, um das Objekt mit dem Mauszeiger auf der Leinwand zu verschieben.

Operationen[Bearbeiten]

Die Werkzeugeinstellungen für das Knotenwerkzeug.

Die mit dem Knotenwerkzeug möglichen Operationen im Einzelnen:

Knotenwerkzeug aufrufen[Bearbeiten]

Um das Knotenwerkzeug aufzurufen, markiert man den zu bearbeitenden Pfad. Wenn mehrere Pfade gleichzeitig bearbeitet werden sollen, markiert man diese alle gleichzeitig. Dann entweder Inkscape icons edit nodes.svg in der Werkzeugleiste anklicken oder F2 oder n drücken.

Objekte und Konturen in Pfade umwandeln[Bearbeiten]

To Path.png

Inkscape-Objekte (z. B. Formen, die mit dem Rechteck-, dem Ellipsen- oder dem Textwerkzeug erzeugt werden) können, weil sie keine Knoten haben, mit dem Knotenwerkzeug nur eingeschränkt bearbeitet werden.

Objekt in Pfad umwandeln
Um bei der Bearbeitung eines Objekts die Möglichkeiten des Knotenwerkzeugs voll ausschöpfen zu können, muss man es in einen Pfad umwandeln. Das erfolgt durch Markieren des Objekts und entweder Pfad > Objekt in Pfad umwandeln oder Nodes - Object to Path.png oder Umschalt + Strg + C.
Der Befehl kann für Objekte mit Kontur und Füllung ebenso verwendet werden wie für solche Objekte, bei denen eines davon fehlt. Weder Kontur noch Füllung werden verändert.
Kontur in Pfad umwandeln
Objekt markieren und entweder Pfad > Kontur in Pfad umwandeln oder Nodes - Stroke to Path.png oder Strg + Alt + C. Dieser Befehl hat unterschiedliche Auswirkungen, je nachdem, worauf er angewendet wird:
1. Hauptanwendung ist die Umwandlung von Objekten oder Pfaden, die nur aus einer Kontur bestehen und keine Füllung haben (siehe Abbildung am Beginn dieses Abschnitts, 2a). Die Kontur wird in diesem Fall in zwei Sub-Pfade umgewandelt, die den Innen- und den Außenrand der bisherigen Kontur repräsentieren (2b).
2. Bei Objekten, die nur aus einer Füllung bestehen und keine Kontur haben, hat der Befehl dieselbe Wirkung wie „Objekt in Pfad umwandeln“.
3. Bei Objekten, die Kontur und Füllung haben, wird beides getrennt behandelt, d. h. man erhält einen Pfad, der die ehemalige Kontur enthält, und einen darunter liegenden zweiten Pfad, der die Füllung enthält.

Anders als „Objekt in Pfad verwandeln“ kann „Kontur in Pfad verwandeln“ nicht nur auf Objektkonturen, sondern auch auf Pfade angewendet werden. In beiden Fällen kann nach der Umwandlung die Breite der Kontur nicht mehr mit dem Dialog Kontur und Füllung, sondern nur noch durch Manipulation der Knoten verändert werden. Die Konturfarbe verwandelt sich in die Füllungsfarbe.

Falls die Kontur besondere Merkmale hatte, etwa eine besondere Strichlinie (z. B. gestrichelt, gepunktet) oder besondere Knotenmarkierungen (z. B. eine Pfeilspitze), so werden diese in ihre Einzelteile zerlegt.

Beide Befehle – „Objekt in Pfad verwandeln“ und „Kontur in Pfad verwandeln“ – können auf mehrere Objekte bzw. Pfade gleichzeitig angewendet werden.

Der Mauszeiger[Bearbeiten]

Der Mauszeiger wird, wenn das Knotenwerkzeug aktiv ist, als schwarze Pfeilspitze dargestellt. Wenn er einen nicht markierten Pfad berührt, wird der Pfadumriss kurze Zeit rot dargestellt, und zwar auch dann, wenn Nodes - Show Path.png nicht aktiviert ist. Einzelheiten können unter Bearbeiten > Einstellungen > Werkzeuge > Knoten (Umschalt+Strg+P) eingestellt werden.

Angezeigte Knotengröße steuern[Bearbeiten]

Wem die Knoten zu klein oder zu groß dargestellt sind, der kann ihre Größe unter Bearbeiten > Einstellungen > Benutzeroberfläche (Preferences Icon.svg oder Umschalt + Strg + P) mit dem Schieberegler Anfassergröße verändern. Voreinstellung ist 3.

Knoten markieren und demarkieren[Bearbeiten]

Unmarkierte Knoten werden mit grauer Füllung Nodes - Cusp Node.png dargestellt. Rote Füllung Nodes - Cusp Node Red.png zeigt an, dass der Mauszeiger über dem Knoten schwebt. Die Rotfärbung ist besonders hilfreich, wenn zwei Knoten nahe beieinander liegen, sodass man sichergehen will, nicht versehentlich den falschen Knoten zu markieren.

Das Markieren und Demarkieren erfolgt beim Knotenwerkzeug im Großen und Ganzen ähnlich wie beim Markierungswerkzeug, wobei markierte Knoten mit schwarzer Füllung Nodes - Cusp Node Black.png dargestellt werden. Es ist möglich, Knoten in mehreren Pfaden gleichzeitig zu markieren.

Knoten markieren[Bearbeiten]

Einzelnen Knoten markieren
MouseClickLeft.svg auf den Knoten. Alternative: Mauszeiger über dem Knoten schweben lassen und Mausrad↑ oder Bild↑.
Zwei Knoten markieren, die direkte Pfadnachbarn sind
MouseClickLeft.svg auf das dazwischen liegende Pfadsegment.
Alle Knoten der markierten Pfade markieren
Strg + A.
Der Wenn nach Aufruf des Knotenwerkzeugs der Mauszeiger, bei gedrückter linker Maustaste, über die Leinwand gezogen wird (hier in Richtung des grauen Pfeils), sind nach Loslassen der Maustaste alle Knoten markiert, die sichtbar innerhalb des durch diese Mausbewegung erzeugten schwarzen Rahmens liegen.
Mehrere beieinanderliegende Knoten markieren
Mit dem Mauszeiger einen „Gummibandrahmen“ über die Knoten ziehen (Abbildung rechts).
Mehrere verstreut liegende Knoten markieren
MouseClickLeft.svg auf den ersten Knoten, Umschalt + MouseClickLeft.svg auf jeden weiteren Knoten. Diese Methode empfiehlt sich immer dann, wenn die vorausgehende nicht möglich ist, weil zwischen den zu markierenden Knoten auch solche liegen, die unmarkiert bleiben sollen.
Mehrere oder alle Knoten eines Pfades schrittweise markieren
Wiederholtes Mausrad↑ oder Bild↑ über den Knoten, bei dem das Markieren beginnen soll. Voreinstellungsmäßig werden die Knoten in der Reihenfolge ihrer jeweiligen räumlichen Entfernung vom Startknoten markiert (also unabhängig von ihrer Reihenfolge auf dem Pfad). Wenn sie in der Reihenfolge ihrer Pfadnachbarschaft markiert werden sollen, drückt man gleichzeitig Strg.

Markierung entfernen[Bearbeiten]

Alle markierten Knoten demarkieren
MouseClickLeft.svg irgendwo aufs Arbeitsblatt, wo sich kein Knoten befindet.
Einzelnen Knoten demarkieren
Mauszeiger über dem Knoten schweben lassen und Mausrad↓ oder Bild↓.
Von mehreren markierten Knoten nur einen demarkieren
Umschalt + MouseClickLeft.svg auf den Knoten, von dem die Markierung entfernt werden soll.
Von mehreren markierten Knoten nur zwei demarkieren, die direkte Pfadnachbarn sind
Umschalt + MouseClickLeft.svg auf das zwischen den beiden Knoten liegende Pfadsegment.
Alle Knoten bis auf einen demarkieren
MouseClickLeft.svg auf den Knoten, der markiert bleiben/werden soll.
Mehrere oder alle Knoten eines Pfades schrittweise demarkieren
Wiederholtes Mausrad↓ oder Bild↓ über dem Knoten, bei dem das Demarkieren beginnen soll. Voreinstellungsmäßig werden die Knoten in der Reihenfolge ihrer jeweiligen räumlichen Entfernung vom Startknoten demarkiert (also unabhängig von ihrer Reihenfolge auf dem Pfad). Wenn sie in der Reihenfolge ihrer Pfadnachbarschaft demarkiert werden sollen, drückt man gleichzeitig Strg.

Markierung verschieben oder umkehren[Bearbeiten]

Markierung von einem Knoten auf den nachfolgenden Knoten verschieben
Wenn ein Knoten markiert ist, bewirkt Drücken von Tab, dass dieser Knoten demarkiert wird und stattdessen der im Pfad nachfolgende Knoten markiert wird.
Markierung von einem Knoten auf den vorausgehenden Knoten verschieben
Wenn ein Knoten markiert ist, bewirkt Drücken von Umschalt + Tab, dass dieser Knoten demarkiert wird und stattdessen der im Pfad vorausgehende Knoten markiert wird.
Markierung umkehren
Um alle markierten Knoten der markierten Pfade zu demarkieren und gleichzeitig alle unmarkierten Knoten zu markieren, ! drücken. Dieser Befehl wird nur auf Pfade angewendet, in denen von vornherein mindestens ein Knoten markiert war.

Knoten verschieben, drehen, ausrichten und verteilen[Bearbeiten]

Einfache Operationen[Bearbeiten]

Knoten mit dem Mauszeiger verschieben
Die einfachste Methode, einen Knoten zu verschieben, besteht darin, ihn mit dem Mauszeiger zu greifen und an den gewünschten Platz zu ziehen. Wenn man mehrere Knoten markiert und einen davon verschiebt, werden alle markierten Knoten gleichzeitig verschoben.
Knoten mit dem Mauszeiger genau waagerecht/senkrecht verschieben
Wie vor, dabei Strg gedrückt halten.
Knoten an den Achsen seiner Bézieranfasser verschieben
Um einen Knoten genau an den Achsen seiner Bézieranfasser oder im rechten Winkel dazu zu verschieben, Strg + Alt festhalten.
Knoten mit den Cursortasten verschieben
Markierte Knoten (auch mehrere Knoten gleichzeitig) können mit , , und schrittweise um je 2 SVG-Pixel verschoben werden. Durch Festhalten zusätzlicher Tasten kann die Schrittgröße verändert werden: Umschalt – 20 SVG-Pixel, Alt – 2 Bildschirm-Pixel, Umschalt + Alt – 20 Bildschirm-Pixel.
Knoten einrasten lassen
Wen man dies entsprechend gestattet hat, sind Knoten in der Lage, an einrastfähigen Positionen, etwa an Hilfslinien und an einem Seite, Seitengitter, einzurasten. Um das Einrasten temporär zu verhindern, hält man die Leertaste gedrückt.
Knoten per Zuweisung neuer Koordinaten verschieben
Wenn man einen Knoten an eine ganz bestimmte Koordinate verschieben will, markiert man ihn und gibt in den Eingabefeldern Nodes - Y Coordinate of Selection.png Nodes - Y Coordinate of Selection.png Nodes - Coordinate Unit.png den gewünschten Zielort ein. Wenn man mehrere Knoten gleichzeitig markiert, bezeichnet die Koordinate den Mittelpunkt dieser Knotengruppe.

Gruppenoperationen[Bearbeiten]

Knoten zusammenschieben oder auseinanderziehen
Um zwei oder mehr Knoten näher zum gemeinsamen Mittelpunkt zu schieben, die Knoten markieren und < gedrückt halten. Gedrückthalten von > bewirkt das Gegenteil.
Nodes - Manipulations with Groups of Nodes.png
Knoten mit Nodes - Show Handles.png als Gruppe verschieben, strecken, stauchen, drehen oder scheren
Wenn dieser Schalter aktiviert ist, können markierte Knoten so behandelt werden, als wären sie die Knoten eines mit dem Auswahlwerkzeug markierten Pfads oder Objekts. Sie können damit nicht nur gemeinsam verschoben (Abbildung rechts, 1), sondern auch proportionstreu auseinandergezogen bzw. zusammengeschoben (2) und als Gruppe gedreht bzw. geschert (3) werden.
Knoten mit Inkscape icons dialog align and distribute.svg ausrichten und verteilen
Wenn man, während das Knotenwerkzeug aktiv ist, gleichzeitig den Dialog Ausrichten und verteilen (Umschalt + Strg + A) geöffnet hat, so erscheinen darin vier Optionen, die in diesem Dialog in Verbindung mit anderen Werkzeugen nicht vorkommen:
Nodes - Align Nodes Horizontally.png Markierte Knoten horizontal ausrichten
Nodes - Align Nodes Vertically.png Markierte Knoten vertikal ausrichten
Nodes - Spread Nodes Evenly Horizontally.png Markierte Knoten horizontal gleichmäßig verteilen
Nodes - Spread Nodes Evenly Vertically.png Markierte Knoten vertikal gleichmäßig verteilen
Anmerkung: Indem man die beiden letztgenannten Optionen direkt nacheinander wählt, kann man Knoten auch diagonal bzw. in beliebig geneigter Folge ausrichten.
Nodes - Sculpting Nodes.png
Form-Modus
Dieser spezielle Modus des Knotenwerkzeugs setzt voraus, dass die zu bearbeitenden Knoten alle markiert sind. Dann wird, bei festgehaltenem Alt, einer der markierten Knoten mit dem Mauszeiger gegriffen und beliebig verschoben. Im Form-Modus folgen die übrigen markierten Knoten dem gegriffenen Knoten, und zwar umso mehr, je näher sie am gegriffenen Knoten liegt (Abbildung rechts).

Der Form-Modus (engl. sculpt mode, scuplting) bietet eine Vielzahl von hochinteressanten Anwendungsmöglichkeiten, die hier nicht einmal angedeutet werden können. Interessierte finden Dokumentation im englischsprachigen Web.

Knotentyp wählen[Bearbeiten]

Node Types.png
Der Unterschied zwischen glatten Knoten (1) und auto-glatten Knoten (2) wird offensichtlich, wenn man den Knoten an eine andere Position versetzt. Beachte die Veränderung der Bézieranfasser.

Zur bequemeren Handhabung gibt es in Inkscape vier verschiedene Knotenarten.

Spitze Knoten
(engl. cusp nodes) Standardknoten, die man, weil sie Universalisten sind, routinemäßig verwendet, solange man die anderen noch nicht studiert hat. Spitze Knoten werden als Raute Nodes - Cusp Node.png dargestellt. Die beiden Bézieranfasser (was das ist, wird im folgenden Abschnitt erklärt) sind an spitzen Knoten voneinander unabhängig und können in jedem Winkel zueinander stehen (Bild rechts, 1). Spitze Knoten sind die einzigen Knoten, mit denen man in einen Pfad einen scharfen Knick bekommt.
Um einen Knoten in einen spitzen Knoten zu verwandeln, Knoten markieren und entweder Nodes - Cusp Node (2).png auswählen oder Umschalt + C drücken. Erneutes Klicken von Nodes - Cusp Node (2).png bzw. erneutes Drücken von Umschalt + C begradigt die Pfadsegmente, die sich an beiden Seiten des Knotens anschließen.
Glatte Knoten
(smooth nodes) Werden als Quadrat Nodes - Smooth Node.png dargestellt. Die Anfasser bilden einen 180-Grad-Winkel, was zur Folge hat, dass der Pfad hier keinen sichtbare Knick bilden kann (2).
Um einen Knoten in einen glatten Knoten zu verwandeln, Knoten markieren und Nodes - Smooth Node (2).png auswählen oder Umschalt + S drücken.
Symmetrische Knoten
(symmetric nodes) Werden ebenfalls als Quadrat Nodes - Smooth Node.png dargestellt. Die Anfasser bilden einen 180-Grad-Winkel und sind gleich lang (3); sie bleiben auch dann gleich lang, wenn einer der beiden Anfasser verändert wird.
Um einen Knoten in einen symmetrischen Knoten zu verwandeln, Knoten markieren und Nodes - Symmetrical Node.png auswählen oder Umschalt + Y drücken.
Auto-glatte Knoten
(auto-smooth nodes) Werden als Kreis Nodes - Auto Smooth Node.png dargestellt (4). Auto-glatte Knoten sind glatte Knoten, auch dann glatt bleiben, wenn die Position des Knotens verändert wird.
Um einen Knoten in einen auto-glatten Knoten zu verwandeln, Knoten markieren und Nodes - Auto Smooth Node (2).png auswählen oder Umschalt + A drücken.


Segmente krümmen und begradigen[Bearbeiten]

Innerhalb eines Pfadsegments können durch direktes Verformen oder durch Benutzung der Anfasser unterschiedlichste Formen erzeugt werden. In manchen Fällen (1, 2, 3) verbleiben einer oder beide Anfasser im Knoten und treten gar nicht heraus.

Segment direkt bearbeiten[Bearbeiten]

Die einfachste Methode, ein gerades Segment zu krümmen oder ein bereits gewölbtes Segment weiter zu verformen, besteht darin, den Pfadumriss innerhalb dieses Segments mit dem Mauszeiger zu greifen und direkt dahin zu ziehen, wo man den Umriss haben möchte. Die Möglichkeiten direkter Verformung sind allerdings begrenzt; Formen wie 5 und 6 rechts in der Abbildung können praktisch nur mit Hilfe der (Bézier-)Anfasser erzeugt werden.

Anfasser handhaben[Bearbeiten]

Anders als Knoten können Anfasser nicht markiert werden. Sie können, wenn man das erlaubt hat, aber einrasten, etwa an Hilfslinien.

Voraussetzung der Verwendung der (Bézier-)Anfasser ist, dass die Option Nodes - Show Bezier Handles.png aktiv ist.

Anfasser sichtbar machen
Wenn Anfasser trotz Aktivierung von Nodes - Show Bezier Handles.png unsichtbar sind, so kann das verschiedene Gründe haben:
1. Weder der zugehörige Knoten noch einer der beiden im Pfadverlauf benachbarten Knoten sind markiert. Therapie: Knoten markieren.
2. Das Pfadsegment liegt zwischen zwei spitzen Knoten und ist gerade. Therapie: Die Knoten markieren und Nodes - Curve Segment.png oder Umschalt + U. Durch Nodes - Straighten Segment.png bringt man die Anfasser im Gegenteil wieder zum Verschwinden.
3. Der Anfasser steckt im Knoten. Therapie: Das Pfadsegment auf der Knotenseite, wo ein Anfasser erscheinen soll, mit dem Mauszeiger ein bisschen bewegen.
Anfasser genau waagerecht oder senkrecht stellen
Wenn man beim Verschieben eines Anfassers Strg gedrückt hält, kann man den Anfasser in Inkrementen von 15 Grad präzise ausrichten, also z. B. genau senkrecht oder genau waagerecht stellen.
Winkel zwischen einem Anfasserpaar konstant halten
Wenn man einen Anfasser mit dem Mauszeiger dreht und dabei Umschalt gedrückt hält, dreht der andere Anfasser sich so mit, dass der Winkel zwischen beiden Anfassern unverändert bleibt.
Nur den Winkel, nicht aber die Länge eines Anfassers ändern
Beim Bewegen des Anfassers Alt gedrückt halten.
Anfasserpaar kontrolliert gemeinsam drehen
Knoten markieren. Für eine Drehung gegen den Uhrzeigersinn [ drücken. Für die Gegenrichtung ]. Die Drehung erfolgt nicht kontinuierlich, sondern in Inkrementen von 15 Grad.
Einen Anfasser kontrolliert drehen
Wie vor, aber: Wenn der weiter links gelegene Anfasser gedreht werden soll, zusätzlich die linke Strg-Taste gedrückt halten, für den weiter rechts gelegenen Anfasser die rechte Strg-Taste.
Nur die Länge, nicht aber den Winkel eines Anfasserpaares ändern
Knoten (nur einen) markieren. Zum Verlängern der Anfasser . oder > gedrückt halten; zum Kürzen , oder < gedrückt halten.
Nur die Länge, nicht aber den Winkel eines Anfassers ändern
Wie vor, aber: Wenn der weiter links gelegene Anfasser verändert werden soll, zusätzlich die linke Strg-Taste gedrückt halten, für den weiter rechts gelegenen Anfasser die rechte Strg-Taste.

Segmente begradigen[Bearbeiten]

Gewölbtes Segment begradigen
Beide Knoten, die das Segment abschließen, markieren und Nodes - Straighten Segment.png wählen (Umschalt + L). Wenn mehrere Segmente gleichzeitig begradigt werden sollen, markiert man alle Knoten, die an diese Segmente angrenzen.
Etwas umständlicher kann man ein Segment auch begradigen, indem man beide Anfasser mit dem Mauszeiger in ihre Knoten zurücksteckt.

Troubleshooting[Bearbeiten]

Wenn der Pfad mit dem Mal- oder Zeichenwerkzeug (etwa versehentlich) nicht im Bézier-, sondern im Spiromodus erzeugt wurde, ist ein Verformen der Pfadsegmente nicht möglich.

Knoten hinzufügen und löschen[Bearbeiten]

An einer bestimmten Stelle einen neuen Knoten hinzufügen
Doppelklick oder Strg + Alt + MouseClickLeft.svg auf die entsprechende Stelle des Pfadumrisses.
Nodes - New Nodes.png
In einem Pfadsegment einen oder mehrere Knoten in gleichmäßigen Abständen hinzufügen
Durch Markierung zweier benachbarter Knoten ein Pfadsegment auswählen. Inkscape icons node add.svg klicken oder Einfügen drücken. Je öfter man klickt, umso mehr Knoten werden hinzugefügt (vgl. Abbildung rechts, in der die markierten Knoten blau hervorgehoben sind).
Für die Funktion der Optionen „Knoten einfügen bei min X“, „...bei max X“, „...bei min Y“ und „...bei max Y“ hat die Autorin dieser Seite keine Dokumentation finden können.
Knoten löschen
Um einen oder mehrere Knoten zu löschen, diese(n) zunächst markieren; dann entweder Löschen oder Rück oder Inkscape icons node delete.svg.
Alternative: Strg + Alt + MouseClickLeft.svg auf den Knoten.
Wenn der Knoten gelöscht werden solle, ohne dass die Anfasser der direkt benachbarten Knoten verändert werden, benutzt man stattdessen Strg + Rück oder Strg + Löschen.


Knoten miteinander verbinden und voneinander lösen[Bearbeiten]

Zwei Endknoten miteinander verbinden
Durch Markieren von zwei Endknoten und Auswählen von Nodes - Connect End Nodes.png kann man zwei Endknoten miteinander verbinden (Umschalt + J). Dabei ist es egal, ob die beiden Endknoten demselben Pfad oder zwei unterschiedlichen Pfaden angehören. Im letztgenannten Fall werden die beiden Pfade zu einem einzigen vereinigt, der sich genau in der Mitte befindet.
Zwei Endknoten durch ein neues Segment verbinden
Wie vor, allerdings werden die beiden Knoten nicht verschmolzen, sondern verbleiben an ihren ursprünglichen Positionen, werden aber durch ein Pfadsegment miteinander verbunden. Beide Endknoten markieren und Nodes - Connect End Nodes Through Segment.png auswählen.
Wenn mehr als zwei Endknoten markiert sind, so versucht Inkscape, daraus selbstständig Paare zu bilden.
Pfad an einem Knoten auftrennen
Um einen Knoten so zweizuteilen, dass der Pfad dazwischen unterbrochen wird, den Knoten markieren und Nodes - Split Path.png auswählen (Umschalt + B). Trotz der Unterbrechung bleibt der Pfad ein einziger Pfad. Falls er mehr als nur einmal unterbrochen ist, kann er allerdings keine Füllung aufnehmen.
Um einen unterbrochenen Pfad in zwei selbstständige Pfade zu zerlegen, Pfad > Pfad zerlegen (Umschalt + Strg + K) wählen.
Pfad zwischen zwei Knoten auftrennen
Wie vor, allerdings wird nicht ein Knoten zweigeteilt, sondern das Segment zwischen zwei Knoten wird geöffnet. Die beiden Knoten markieren und Nodes - Open Path.png auswählen.

Pfade vereinigen und zerteilen[Bearbeiten]

Nodes - Reorganize Path.png
Zwei Pfade vereinigen
Um zwei Pfade zu einem einzigen zu machen, markiert man in jedem der beiden Pfade mindestens einen Endknoten und wählt dann (wie im vorausgegangenen Abschnitt dargestellt) entweder Nodes - Connect End Nodes.png oder Nodes - Connect End Nodes Through Segment.png (Vgl. Abbildung rechts, 1–3).
Einen Pfad in zwei unabhängige Pfade zerteilen
Wenn der Pfad (wie 3 in der Abbildung rechts) geschlossen ist, muss er an zwei Stellen getrennt werden; bei einem offenen Pfad genügt eine einzige Trennstelle. Trennstelle(n) markieren und entweder Nodes - Split Path.png oder Nodes - Open Path.png wählen (4–5). Obwohl der Pfad danach bereits zweigeteilt aussieht, handelt es sich technisch immer noch um einen einzigen Pfad (5). Um diesen tatsächlich in zwei Pfade aufzuteilen, markiert man ihn und wählt Pfad > Zerlegen oder Umschalt + Strg + K (6). Erst dann können beide Pfade getrennt bearbeitet werden (7).

Pfade verformen[Bearbeiten]

Ein Verformen von Pfaden ist nicht nur im Knotenmodus möglich, sondern auch mit dem Modellierwerkzeug und durch Pfadeffekte.

Das Modellierwerkzeug erlaubt es unter anderem…

  • Teile von Pfaden in beliebige Richtungen zu schubsen
  • Teile von Pfaden zu schrumpfen oder zu vergrößern
  • Teile von Pfaden zum Mauszeiger hinzuziehen oder vom Mauszeiger wegzustoßen

Das Modellierwerkzeug wird meist verwendet, um den Details einer grundlegend vollständige Zeichnung einen letzten Touch zu geben.

Für Pfadeffekte siehe das gleichnamige Kapitel.

Bézieranfasser und Pfade zeigen[Bearbeiten]

Knoten sind, wenn das Knotenwerkzeug aktiv ist, immer sichtbar. Andere Elemente können wahlweise angezeigt oder unsichtbar gemacht werden:

Bézieranfasser zeigen
Nodes - Show Bezier Handles.png macht die Bézieranfasser der markierten Knoten sichtbar oder unsichtbar.
Auswahlanfasser zeigen
Wenn mehrere Knoten gleichzeitig markiert sind, macht Nodes - Show Handles.png den Auswahlanfasser sichtbar oder unsichtbar, mit dessen Hilfe die Auswahl – genau wie eine Auswahl von Pfaden und/oder Objekten bei aufgerufenem Auswahlwerkzeug – verschoben, gestreckt, gestaucht, gedreht oder geschert werden kann.
Pfade zeigen
Nodes - Show Path.png macht die (voreinstellungsmäßig roten) Pfadumrisse der markierten Pfade sichtbar oder unsichtbar.
Nodes - Show Clip Path Example.png
Ausschneidepfade zeigen
Nodes - Show Clip Path.png macht die Ausschneidepfade der markierten Objekte sichtbar (Bild rechts: die grüne Linie zeigt an, wo der Ausschneidepfad liegt). Diese Option ist nur im Kontext der Benutzung von Objekt > Ausschneidepfad von Bedeutung, und auch nur dann, wenn zum Ausschneiden nicht ein Objekt, sondern ein Pfad verwendet wurde.
Masken zeigen
Nodes - Show Mask Path.png macht die Masken der markierten Objekte sichtbar. Diese Option ist nur im Kontext der Benutzung von Objekt > Maske von Bedeutung, und auch nur dann, wenn als Maske nicht ein Objekt, sondern ein Pfad verwendet wurde.

Musteranfasser zeigen[Bearbeiten]

Wenn mit Mustern gearbeitet wird und ein Muster bearbeitet (z. B. seine Orientierung verändert) werden soll, muss, um den Musteranfasser sichtbar zu machen, ebenfalls der Knotenmodus aufgerufen werden. Der Anfasser eines ausgewählten Musters erscheint voreinstellungsmäßig an der Nullkoordinate der Leinwand, also dort, wo die linke obere Ecke der Seite liegt bzw. liegen würde.

Parameter eines Pfadeffekts bearbeiten[Bearbeiten]

Wenn ein Pfad mit einem Pfadeffekt bearbeitet wurde und die Parameter des Effekts mit dem Knotenwerkzeug direkt auf der Leinwand verändert werden können (Beispiele: Biegen, Hüllenverformung, Muster entlang Pfad), so kann man auf die Parameter durch wiederholtes Drücken von Nodes - Show Next Path Effect Parameter.png hintereinanderweg zugreifen. Welcher Parameter jeweils bearbeitet werden kann, wird unten in der Statusleiste angezeigt.

Einstellungen[Bearbeiten]

Werkzeugeinstellungen[Bearbeiten]

Nodes - Preferences (German).png

Die allgemeinen Einstellungen für das Knotenwerkzeug können unter Bearbeiten > Einstellungen > Werkzeuge > Knoten (Umschalt+Strg+P) verändert werden.

Auswahlmarkierung anzeigen
Hier kann man entscheiden, ob ausgewählte Objekte (wie beim Auswahlwerkzeug) optisch hervorgehoben werden sollen.
Farbverlaufsbearbeitung aktiviert
Hier kann man entscheiden, ob ausgewählte Objekte einen Farbverlaufsanfasser anzeigen oder nicht.

Pfadumriss:

Farbauswahl
Voreinstellungsmäßig werden Pfadumrisse rot dargestellt. Falls das, etwa auf einem roten Hintergrund, dysfunktional ist, kann man hier jede beliebige andere Farbe einstellen.
Umriss zeigen
Zeigt Umriss aller Pfade an, nicht nur von unsichtbaren Pfaden.
Umriss beim Ziehen von Knoten aktualisieren
Aktualisiert den Umriss beim Ziehen oder Transformieren der Knoten. Wenn die Funktion deaktiviert ist, wird der Pfad erst aktualisiert, wenn die Aktion abgeschlossen ist.
Pfad beim Ziehen von Knoten aktualisieren
Aktualisiert Pfade beim Ziehen oder Transformieren von Knoten. Wenn die Funktion deaktiviert ist, wird der Pfad erst aktualisiert, wenn die Aktion abgeschlossen ist.
Nodes - Path Direction.png
Zeige die Pfadrichtung an Außenlinie
Wenn diese Option gewählt und Nodes - Show Path.png aktiv ist, erscheinen an den einzelnen Segmenten des Pfadumrisses kleine Pfeile, die anzeigen, in welche Richtung der Pfad verläuft. Hilfreich ist die Funktion u. a. dann, wenn die Kontur, wie in der Abbildung rechts, besondere Endmarkierungen (z. B. eine Pfeilspitze) erhalten soll.
Zeige temporär Pfadumrandung
Wenn die Maus über den Pfad bewegt wird, wird dessen Umriss kurz angezeigt.
Zeige temporär Umrandung für ausgewählte Pfade
Zeigt, wenn der Pfad zum Bearbeiten ausgewählt wurde, temporär seinen Umriss an.
Anzeigedauer
Dauer der Anzeige des Pfadumrisses bei Mauszeigerberührung, in Millisekunden.

Einstellungen bearbeiten:

Zeige Anfasser für einzelne Knoten
Anfasser anzeigen, wenn nur ein einzelner Knoten ausgewählt ist.
Knoten löschen, Form beibehalten
Verschieben des Anfassers zum nächsten benachbarten Knoten, damit der bearbeitete Pfad der Originalform ähnelt; um das entgegengesetzte Verhalten zu erzwingen, beim Löschen Strg gedrückt halten.

Lehrgrafiken erstellen[Bearbeiten]

Path Effects - Show Handles.png

Mit dem Pfadeffekt Anfasser zeigen kann man Pfade in Objekte mit permanent sichtbaren Pfadumrissen, Knoten und Bézieranfassern umwandeln. Viele Grafiken auf dieser Seite sind mit diesem Mittel erstellt worden.